source: projects/specs/trunk/lib/libt/libtool/libtool-vl.spec @ 12020

Revision 12020, 20.3 KB checked in by tomop, 5 years ago (diff)

update toolchain

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gcc_version 8.2.0
4
5Summary: The GNU Portable Library Tool
6Summary(ja): GNU ポータブルライブラリツール
7Name:    libtool
8Version: 2.4.6
9Release: 3%{?_dist_release}
10License: GPLv2+ and LGPLv2+ and GFDL
11Group:   Development/Tools
12URL:     http://www.gnu.org/software/libtool/
13
14Source:  http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
15Patch0:  libtool-2.4.6-rpath.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18Requires(post):  /sbin/install-info
19Requires(preun): /sbin/install-info
20
21BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo, help2man
22Requires: autoconf >= 2.58, automake >= 1.4
23# make sure we can configure all supported langs
24BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran
25#BuildRequires: gcc-java
26# /usr/bin/libtool includes paths within gcc's versioned directories
27# Libtool must be rebuilt whenever a new upstream gcc is built
28Requires: gcc = %{gcc_version}
29
30Requires: autoconf >= 2.50, automake >= 1.4p1, m4, perl
31Requires: libtool-ltdl = %{version}-%{release}, mktemp
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37GNU Libtool is a set of shell scripts which automatically configure UNIX and
38UNIX-like systems to generically build shared libraries. Libtool provides a
39consistent, portable interface which simplifies the process of using shared
40libraries.
41
42If you are developing programs which will use shared libraries, but do not use
43the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
44should install the libtool package.
45
46The libtool package also includes all files needed to integrate the GNU
47Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
48(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
49and GNU Automake).
50
51This package includes a modification from the original GNU Libtool to allow
52support for multi-architecture systems, such as the AMD64 Opteron and the Intel
5364-bit Xeon.
54
55%description -l ja
56GNU Libtoolは、UNIX及びUNIXライクなアーキテクチャで共有ライブラリを汎用的
57にビルドするための設定を自動化するシェルスクリプトのセットです。libtoolは、
58共有ライブラリを利用する工程を単純化する首尾一貫した移植可能なインターフェー
59スを提供します。
60
61もし、GNU Autotools (GNU Autoconf および GNU Automake) を使わずに共有ライ
62ブラリを利用するプログラムを開発するなら、libtool パッケージをインストール
63する必要があります。
64
65このパッケージの Libtool は、AMD64 や Intel EM64T などのマルチアーキテクチャ
66システムをサポートするために、オリジナルのGNU Libtoolから変更が施されています。
67
68
69%package ltdl
70Summary:  Runtime libraries for GNU Libtool Dynamic Module Loader
71Summary(ja): GNU Libtool ダイナミックモジュールローダのランタイムライブラリ
72Group:    System Environment/Libraries
73Provides: libtool-libs = %{version}-%{release}
74Obsoletes: libtool-libs < 1.5.20
75License:  LGPL
76Requires(post):  /sbin/ldconfig
77Requires(postun):  /sbin/ldconfig
78
79
80%description ltdl
81The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
82library that provides a consistent, portable interface which simplifies the
83process of using dynamic modules.
84
85These runtime libraries are needed by programs that link directly to the
86system-installed ltdl libraries; they are not needed by software built using the
87rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
88
89%description -l ja ltdl
90libtool-ltdl パッケージにはGNU Libtool 動的モジュールローダのランタイムライ
91ブラリが含まれています。GNU Libtool 動的モジュールローダは、動的モジュールを
92利用する工程を単純化する首尾一貫した移植可能なインターフェースを提供します。
93
94
95%package ltdl-devel
96Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
97Summary(ja): GNU Libtool ダイナミックモジュールローダを使った開発に必要なファイル群
98Group:    Development/Libraries
99Requires: libtool-ltdl = %{version}-%{release}
100License:  LGPL
101
102
103%description ltdl-devel
104Static libraries and header files for development with ltdl.
105
106%description -l ja ltdl-devel
107ltdlを使った開発に必要なスタティックライブラリおよびヘッダファイル
108
109
110## to build compat32 for x86_64 architecture support
111%package -n compat32-%{name}-ltdl
112Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
113Group: System Environment/Libraries
114%description -n compat32-%{name}-ltdl
115The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
116library that provides a consistent, portable interface which simplifies the
117process of using dynamic modules.
118
119%package -n compat32-%{name}-ltdl-devel
120Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
121Group: Development/Libraries
122Requires: compat32-%{name}-ltdl = %{version}-%{release}
123%description -n compat32-%{name}-ltdl-devel
124Static libraries and header files for development with ltdl.
125
126
127%prep
128%setup -q
129%patch0 -p1
130
131
132%build
133
134autoreconf -v
135
136export CC=gcc
137export CXX=g++
138export F77=gfortran
139export CFLAGS="$RPM_OPT_FLAGS -fPIC"
140# dumb redhat-rpm-config replaces config.{sub,guess} with ancient ones in %%configure, use ./configure instead:
141./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
142# build not smp safe:
143make #%{?_smp_mflags}
144
145
146#check
147#make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
148
149
150%install
151rm -rf %{buildroot}
152make install DESTDIR=$RPM_BUILD_ROOT
153rm -f %{buildroot}%{_infodir}/dir
154rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
155
156
157%clean
158rm -rf %{buildroot}
159
160
161%post
162/sbin/install-info %{_infodir}/libtool.info.gz %{_infodir}/dir || :
163
164%preun
165if [ "$1" = 0 ]; then
166   /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
167fi
168
169%post ltdl -p /sbin/ldconfig
170
171%postun ltdl -p /sbin/ldconfig
172
173%post -n compat32-%{name}-ltdl
174/sbin/ldconfig
175
176%postun -n compat32-%{name}-ltdl
177/sbin/ldconfig
178
179
180%files
181%defattr(-,root,root)
182%license COPYING
183%doc AUTHORS NEWS README THANKS TODO ChangeLog
184%{_bindir}/libtool
185%{_bindir}/libtoolize
186%{_datadir}/aclocal/*.m4
187%{_datadir}/libtool
188%{_infodir}/libtool.info*.gz
189%{_mandir}/man1/libtool.1.gz
190%{_mandir}/man1/libtoolize.1.gz
191
192%files ltdl
193%defattr(-,root,root)
194%doc libltdl/COPYING.LIB libltdl/README
195%{_libdir}/libltdl.so.*
196
197%files ltdl-devel
198%defattr(-,root,root)
199%{_libdir}/libltdl.so
200%{_includedir}/ltdl.h
201%{_includedir}/libltdl/*
202
203%if %{build_compat32}
204## to build compat32 for x86_64 architecture support
205%files -n compat32-%{name}-ltdl
206%defattr(-,root,root)
207%{_libdir}/libltdl.so.*
208
209%files -n compat32-%{name}-ltdl-devel
210%defattr(-,root,root)
211%{_libdir}/libltdl.so
212%endif
213
214
215%changelog
216* Mon Jan 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-3
217- rebuilt with gcc-8.2.0.
218
219* Sun Jun 26 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
220- rebuild with gcc-5.4.0
221
222* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-1
223- new upstream release
224- update Patch0 (libtool-2.4.6-rpath.patch)
225
226* Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-4
227- rebuild with gcc-4.8.2-1
228
229* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-3
230- rebuild with gcc-4.8.1-2
231
232* Mon Sep 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-2
233- rebuild with gcc-4.8.1
234- add BuildRequires: help2man
235
236* Sat Dec 03 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-1
237- new upstream release
238
239* Mon Nov 28 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4-2
240- rebuilt with gcc-4.6.2
241
242* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4-1
243- new upstream release
244- update Patch0
245
246* Sun Mar 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6b-2
247- rebuilt with gcc-4.4.5
248
249* Sat Feb 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2.6b-1
250- new upstream release
251
252* Mon Jan 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6a-4
253- rebuilt with gcc-4.4.3-1 (w/o gcc-java)
254
255* Tue May 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-3
256- remove comment before compat32 scriptlet to avoid scriptlet failure.
257
258* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.6a-2
259- removed %%if !%%{build_compat32} case condition
260
261* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-1
262- update to 2.2.6a
263- remove libltdl static library
264
265* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.26-3
266- updated to 1.5.26, importing changes from Fedora 1.5.26-2
267- new versioning policy; spec in UTF-8
268- define gcc_version to 4.1.2 for Vine
269
270* Wed May 30 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl4
271- rebuilt with gcc-4.1.2-0vl10 (gcc -dumpversion begets 4.1.2, not 4.1.3)
272
273* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl3
274- remove BuildRequires: libstdc++3-devel
275- add Requres: libtool-ltdl instead of libtool-libs
276
277* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl2
278- rebuilt with gcc4 (F77=gfortran now)
279- import Patch2 and Patch3 from FC6 1.5.22-6.1
280
281  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
282  - detect gcc path at runtime instead of requiring one specific version
283
284  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
285  - miscellaneous upstream fixes
286
287* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl1
288- new upstream release
289
290* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl4
291- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
292- changed '%postun -p /sbin/ldconfig' to '%postun' and /sbin/ldconfig command
293
294* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl3
295- added compat32-* packages for x86_64 architecture support
296
297* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl2
298- add Japanese Summaries and descriptions
299
300* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl1
301- new upstream release
302
303* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.18-3vl1
304- updated to 1.5.18 based on Fedora package
305  * Sun Feb  6 2005 Daniel Reed <djr@redhat.com> 1.5.12.multilib2-3.4.3
306  - update to the 1.5.12 bugfix release
307  - Makes use of $datarootdir, which is necessary for Autoconf >= 2.60.
308  - Correctly skip hppa, x86_64, and s390* in tests/demo-nopic.test.
309  - Interpret `include' statements in toplevel ld.so.conf file.
310  - While "parsing" /etc/ld.so.conf, skip comments.
311  - add dependency on gcc version; /usr/bin/libtool hardcodes paths into
312    gcc's internal directories
313  - replace "libtool-libs" with "libtool-ltdl" and "libtool-ltdl-devel"
314  * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.5.10-1
315  - update to the 1.5.10 bugfix release
316    - obsoletes libtool-1.4-nonneg.patch
317    - obsoletes libtool-1.5-libtool.m4-x86_64.patch
318    - obsoletes libtool-1.4.2-multilib.patch
319    - obsoletes libtool-1.4.2-demo.patch
320    - obsoletes libtool-1.5-testfailure.patch
321  * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> - 1.5.6-2
322  - compile libltdl.a PIC
323
324* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-0vl2
325- rebuild with gcc-3.3.5
326
327* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-0vl1
328- new upstream release
329
330* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.5.2-2vl1
331- merged with fedora-1.5.2-2
332  * Mon Jan 26 2004 Jens Petersen <petersen@redhat.com> - 1.5.2-1
333  - update to 1.5.2 bugfix release
334  - update libtool-1.5-libtool.m4-x86_64.patch
335  - nolonger need libtool-1.5-mktemp.patch, libtool-1.5-expsym-linux.patch,
336    libtool-1.5-readonlysym.patch, libtool-1.5-relink-libdir-order-91110.patch,
337    libtool-1.5-AC_PROG_LD_GNU-quote-v-97608.patch and libtool-1.5-nostdlib.patch
338
339  * Tue Oct 28 2003 Jens Petersen <petersen@redhat.com> - 1.5-8
340  - update libtool-1.4.2-multilib.patch to also deal with powerpc64 (#103316)
341    [Joe Orton]
342
343* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-5vl1
344- merged with rawhide 1.5-5
345  * Mon Dec 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.3-2vl2
346  - based on 1.4.3-2 from Rawhide and built for Vine Linux
347  - added BuildPreReq: automake14
348
349* Thu Jul 17 2003 Jens Petersen <petersen@redhat.com> - 1.5-5
350- bring back libtool-1.4.2-demo.patch to disable nopic tests on amd64
351  and s390x again
352
353* Tue Jul 15 2003 Owen Taylor <otaylor@redhat.com>
354- Fix misapplied chunk for expsym-linux patch
355
356* Tue Jul  8 2003 Jens Petersen <petersen@redhat.com> - 1.5-4
357- remove the quotes around LD in AC_PROG_LD_GNU (#97608)
358  [reported by twaugh]
359- use -nostdlib also when linking with g++ and non-GNU ld in
360  _LT_AC_LANG_CXX_CONFIG [reported by fnasser, patch by aoliva]
361- use %%configure with CC and CXX set
362
363* Thu Jun 12 2003 Jens Petersen <petersen@redhat.com> - 1.5-3
364- don't use %%configure since target options caused libtool to assume
365  i386-redhat-linux-gcc instead of gcc for CC (reported by Joe Orton)
366- add libtool-1.5-relink-libdir-order-91110.patch to fix order of lib dirs
367  searched when relinking (#91110) [patch from Joe Orton]
368
369* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
370- rebuilt
371
372* Thu May  1 2003 Jens Petersen <petersen@redhat.com> - 1.5-1
373- update to 1.5
374- no longer override config.{guess,sub} for rpmbuild %%configure,
375  redhat-rpm-config owns those now
376- update and rename libtool-1.4.2-s390_x86_64.patch to
377  libtool-1.5-libtool.m4-x86_64.patch since s390 now included
378- buildrequire autoconf and automake, no longer automake14
379- skip make check on s390 temporarily
380- no longer skip demo-nopic.test on x86_64, s390 and s390x
381- from Owen Taylor
382  - add libtool-1.4.2-expsym-linux.patch (#55607) [from James Henstridge]
383  - add quoting in mktemp patch
384  - add libtool-1.5-readonlysym.patch
385  - add libtool-1.5-testfailure.patch workaround
386  - relink patch no longer needed
387
388* Sat Feb 08 2003 Florian La Roche <Florian.LaRoche@redhat.de> - 1.4.3-5
389- add config.guess and config.sub, otherwise old versions of
390  these files can creep into /usr/share/libtool/
391
392* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
393- rebuilt
394
395* Mon Jan 13 2003 Jens Petersen <petersen@redhat.com> 1.4.3-3
396- fix mktemp to work when running mktemp fails (#76602)
397  [reported by (Oron Peled)]
398- remove info dir file, don't exclude it
399- fix typo in -libs description (#79619)
400- use buildroot instead of RPM_BUILD_ROOT
401
402* Tue Jan 07 2003 Karsten Hopp <karsten@redhat.de> 1.4.3-2.2
403- use lib64 on s390x, too.
404
405* Thu Dec  5 2002 Jens Petersen <petersen@redhat.com>
406- add comment to explain why we use an old Automake for building
407- buildrequire automake14
408
409* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com>
410- add --without check build option to allow disabling of "make check"
411- exclude info dir file rather than removing
412
413* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com> 1.4.3-2
414- define SED in ltmain.sh for historic ltconfig files
415- define macro AUTOTOOLS to hold automake-1.4 and aclocal-1.4, and use it
416- leave old missing file for now
417- general spec file cleanup
418  - don't copy install files to demo nor mess with installed ltdl files
419  - don't need to run make in doc
420  - force removal of info dir file
421  - don't need to create install prefix dir
422  - don't bother gzipping info files ourselves
423
424* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 1.4.3-1
425- update to 1.4.3
426- remove obsolete patches (test-quote, dup-deps, libtoolize-configure.ac)
427- apply the multilib patch to just the original config files
428- update x86_64/s390 patch and just apply to original config files
429- use automake-1.4 in "make check" for demo-make.test to pass!
430- remove info dir file that is not installed
431- make autoreconf update missing
432
433* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com>  1.4.2-12.2
434- Added s390x and x64_64 support.
435
436* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.4.2-12.1
437- rebuild
438
439* Fri Sep 13 2002 Nalin Dahyabhai <nalin@redhat.com>
440- patch to find the proper libdir on multilib boxes
441 
442* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 1.4.2-12
443- don't include demo in doc, specially now that we "make check" (#71609)
444
445* Tue Aug 13 2002 Jens Petersen <petersen@redhat.com> 1.4.2-11
446- don't hardcode "configure.in" in libtoolize (#70864)
447  [reported by bastiaan@webcriminals.com]
448- make check, but not on ia64
449
450* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.4.2-10
451- automated rebuild
452
453* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.4.2-9
454- automated rebuild
455
456* Fri Apr 26 2002 Jens Petersen <petersen@redhat.com> 1.4.2-8
457- add old patch from aoliva to fix relinking when installing into a buildroot
458- backport dup-deps fix from cvs stable branch
459
460* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 1.4.2-7
461- run ldconfig in postin and postun
462
463* Thu Feb 28 2002 Jens Petersen <petersen@redhat.com> 1.4.2-6
464- rebuild in new environment
465
466* Tue Feb 12 2002 Jens Petersen <petersen@redhat.com> 1.4.2-5
467- revert filemagic and archive-shared patches following cvs (#54887)
468- don't change "&& test" to "-a" in ltmain.in
469
470* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.4.2-4
471- automated rebuild
472
473* Mon Dec  3 2001 Jens Petersen <petersen@redhat.com> 1.4.2-3
474- test quoting patch should be on ltmain.in not ltmain.sh (#53276)
475- use file_magic for Linux ELF (#54887)
476- allow link against an archive when building a shared library (#54887)
477- include ltdl.m4 in manifest (#56671)
478
479* Wed Oct 24 2001 Jens Petersen <petersen@redhat.com> 1.4.2-2
480- added URL to spec
481
482* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.4.2-1
483- 1.4.2 - sync up with autoconf...
484
485* Thu Jul  5 2001 Bernhard Rosenkraenzer <bero@redhat.de> 1.4-8
486- extend s390 patch to 2 more files
487- s/Copyright/License/
488
489* Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
490- add s390 patch for deplibs_check_method=pass_all
491
492* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
493- add patches from Tim Waugh #42724
494
495* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
496- add patches from cvs mainline
497
498* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
499- fix a "test" bug in ltmain.sh
500
501* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
502- disable the post commands to modify /usr/share/doc/
503
504* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
505- Require automake 1.4p1
506
507* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
508- update to libtool 1.4
509- adjust or remove patches
510
511* Thu Jul 13 2000 Elliot Lee <sopwith@redhat.com>
512- Fix recognition of ^0[0-9]+$ as a non-negative integer.
513
514* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
515- automatic rebuild
516
517* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
518- patch to use mktemp to create the tempdir
519- use %%configure after defining __libtoolize to /bin/true
520
521* Mon Jul  3 2000 Matt Wilson <msw@redhat.com>
522- subpackage libltdl into libtool-libs
523
524* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
525- running libtoolize on the libtool source tree ain't right :)
526
527* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
528- FHS packaging.
529
530* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
531- update to 1.3.5.
532
533* Fri Mar  3 2000 Jeff Johnson <jbj@redhat.com>
534- add prereqs for m4 and perl inorder to run autoconf/automake.
535
536* Mon Feb 28 2000 Jeff Johnson <jbj@redhat.com>
537- functional /usr/doc/libtool-*/demo by end-user %post procedure (#9719).
538
539* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
540- update to 1.3.4.
541
542* Mon Dec  6 1999 Jeff Johnson <jbj@redhat.com>
543- change from noarch to per-arch in order to package libltdl.a (#7493).
544
545* Thu Jul 15 1999 Jeff Johnson <jbj@redhat.com>
546- update to 1.3.3.
547
548* Mon Jun 14 1999 Jeff Johnson <jbj@redhat.com>
549- update to 1.3.2.
550
551* Tue May 11 1999 Jeff Johnson <jbj@redhat.com>
552- explicitly disable per-arch libraries (#2210)
553- undo hard links and remove zero length file (#2689)
554
555* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
556- update to 1.3.
557
558* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
559- disable the --cache-file passing to ltconfig; this breaks the older
560  ltconfig scripts found around.
561
562* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
563- auto rebuild in the new build environment (release 2)
564
565* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
566- update to 1.2f
567
568* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
569- completed arm patch
570- added patch to make it more arm-friendly
571- upgrade to version 1.2d
572
573* Thu May 07 1998 Donnie Barnes <djb@redhat.com>
574- fixed busted group
575
576* Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
577- Update to 1.0h
578- added install-info support
579
580* Tue Nov 25 1997 Elliot Lee <sopwith@redhat.com>
581- Update to 1.0f
582- BuildRoot it
583- Make it a noarch package
Note: See TracBrowser for help on using the repository browser.