source: projects/specs/trunk/lib/libt/libtool/libtool-vl.spec @ 10250

Revision 10250, 20.1 KB checked in by Takemikaduchi, 8 years ago (diff)

binutils-2.26,gcc-4.9.3,glibc-2.23

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gcc_version 4.9.3
4
5Summary: The GNU Portable Library Tool
6Summary(ja): GNU ポータブルライブラリツール
7Name:    libtool
8Version: 2.4.6
9Release: 1%{?_dist_release}
10License: GPLv2+ and LGPLv2+ and GFDL
11Group:   Development/Tools
12URL:     http://www.gnu.org/software/libtool/
13
14Source:  http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
15Patch0:  libtool-2.4.6-rpath.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18Requires(post):  /sbin/install-info
19Requires(preun): /sbin/install-info
20
21BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo, help2man
22Requires: autoconf >= 2.58, automake >= 1.4
23# make sure we can configure all supported langs
24BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran
25#BuildRequires: gcc-java
26# /usr/bin/libtool includes paths within gcc's versioned directories
27# Libtool must be rebuilt whenever a new upstream gcc is built
28Requires: gcc = %{gcc_version}
29
30Requires: autoconf >= 2.50, automake >= 1.4p1, m4, perl
31Requires: libtool-ltdl = %{version}-%{release}, mktemp
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37GNU Libtool is a set of shell scripts which automatically configure UNIX and
38UNIX-like systems to generically build shared libraries. Libtool provides a
39consistent, portable interface which simplifies the process of using shared
40libraries.
41
42If you are developing programs which will use shared libraries, but do not use
43the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
44should install the libtool package.
45
46The libtool package also includes all files needed to integrate the GNU
47Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
48(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
49and GNU Automake).
50
51This package includes a modification from the original GNU Libtool to allow
52support for multi-architecture systems, such as the AMD64 Opteron and the Intel
5364-bit Xeon.
54
55%description -l ja
56GNU Libtoolは、UNIX及びUNIXライクなアーキテクチャで共有ライブラリを汎用的
57にビルドするための設定を自動化するシェルスクリプトのセットです。libtoolは、
58共有ライブラリを利用する工程を単純化する首尾一貫した移植可能なインターフェー
59スを提供します。
60
61もし、GNU Autotools (GNU Autoconf および GNU Automake) を使わずに共有ライ
62ブラリを利用するプログラムを開発するなら、libtool パッケージをインストール
63する必要があります。
64
65このパッケージの Libtool は、AMD64 や Intel EM64T などのマルチアーキテクチャ
66システムをサポートするために、オリジナルのGNU Libtoolから変更が施されています。
67
68
69%package ltdl
70Summary:  Runtime libraries for GNU Libtool Dynamic Module Loader
71Summary(ja): GNU Libtool ダイナミックモジュールローダのランタイムライブラリ
72Group:    System Environment/Libraries
73Provides: libtool-libs = %{version}-%{release}
74Obsoletes: libtool-libs < 1.5.20
75License:  LGPL
76Requires(post):  /sbin/ldconfig
77Requires(postun):  /sbin/ldconfig
78
79
80%description ltdl
81The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
82library that provides a consistent, portable interface which simplifies the
83process of using dynamic modules.
84
85These runtime libraries are needed by programs that link directly to the
86system-installed ltdl libraries; they are not needed by software built using the
87rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
88
89%description -l ja ltdl
90libtool-ltdl パッケージにはGNU Libtool 動的モジュールローダのランタイムライ
91ブラリが含まれています。GNU Libtool 動的モジュールローダは、動的モジュールを
92利用する工程を単純化する首尾一貫した移植可能なインターフェースを提供します。
93
94
95%package ltdl-devel
96Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
97Summary(ja): GNU Libtool ダイナミックモジュールローダを使った開発に必要なファイル群
98Group:    Development/Libraries
99Requires: libtool-ltdl = %{version}-%{release}
100License:  LGPL
101
102
103%description ltdl-devel
104Static libraries and header files for development with ltdl.
105
106%description -l ja ltdl-devel
107ltdlを使った開発に必要なスタティックライブラリおよびヘッダファイル
108
109
110## to build compat32 for x86_64 architecture support
111%package -n compat32-%{name}-ltdl
112Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
113Group: System Environment/Libraries
114%description -n compat32-%{name}-ltdl
115The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
116library that provides a consistent, portable interface which simplifies the
117process of using dynamic modules.
118
119%package -n compat32-%{name}-ltdl-devel
120Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
121Group: Development/Libraries
122Requires: compat32-%{name}-ltdl = %{version}-%{release}
123%description -n compat32-%{name}-ltdl-devel
124Static libraries and header files for development with ltdl.
125
126
127%prep
128%setup -q
129%patch0 -p1
130
131
132%build
133
134autoreconf -v
135
136export CC=gcc
137export CXX=g++
138export F77=gfortran
139export CFLAGS="$RPM_OPT_FLAGS -fPIC"
140# dumb redhat-rpm-config replaces config.{sub,guess} with ancient ones in %%configure, use ./configure instead:
141./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
142# build not smp safe:
143make #%{?_smp_mflags}
144
145
146#check
147#make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
148
149
150%install
151rm -rf %{buildroot}
152make install DESTDIR=$RPM_BUILD_ROOT
153rm -f %{buildroot}%{_infodir}/dir
154rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
155
156
157%clean
158rm -rf %{buildroot}
159
160
161%post
162/sbin/install-info %{_infodir}/libtool.info.gz %{_infodir}/dir || :
163
164%preun
165if [ "$1" = 0 ]; then
166   /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
167fi
168
169%post ltdl -p /sbin/ldconfig
170
171%postun ltdl -p /sbin/ldconfig
172
173%post -n compat32-%{name}-ltdl
174/sbin/ldconfig
175
176%postun -n compat32-%{name}-ltdl
177/sbin/ldconfig
178
179
180%files
181%defattr(-,root,root)
182%doc AUTHORS COPYING NEWS README THANKS TODO ChangeLog
183%{_bindir}/libtool
184%{_bindir}/libtoolize
185%{_datadir}/aclocal/*.m4
186%{_datadir}/libtool
187%{_infodir}/libtool.info*.gz
188%{_mandir}/man1/libtool.1.gz
189%{_mandir}/man1/libtoolize.1.gz
190
191%files ltdl
192%defattr(-,root,root)
193%doc libltdl/COPYING.LIB libltdl/README
194%{_libdir}/libltdl.so.*
195
196%files ltdl-devel
197%defattr(-,root,root)
198%{_libdir}/libltdl.so
199%{_includedir}/ltdl.h
200%{_includedir}/libltdl/*
201
202%if %{build_compat32}
203## to build compat32 for x86_64 architecture support
204%files -n compat32-%{name}-ltdl
205%defattr(-,root,root)
206%{_libdir}/libltdl.so.*
207
208%files -n compat32-%{name}-ltdl-devel
209%defattr(-,root,root)
210%{_libdir}/libltdl.so
211%endif
212
213
214%changelog
215* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-1
216- new upstream release
217- update Patch0 (libtool-2.4.6-rpath.patch)
218
219* Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-4
220- rebuild with gcc-4.8.2-1
221
222* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-3
223- rebuild with gcc-4.8.1-2
224
225* Mon Sep 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-2
226- rebuild with gcc-4.8.1
227- add BuildRequires: help2man
228
229* Sat Dec 03 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-1
230- new upstream release
231
232* Mon Nov 28 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4-2
233- rebuilt with gcc-4.6.2
234
235* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4-1
236- new upstream release
237- update Patch0
238
239* Sun Mar 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6b-2
240- rebuilt with gcc-4.4.5
241
242* Sat Feb 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2.6b-1
243- new upstream release
244
245* Mon Jan 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6a-4
246- rebuilt with gcc-4.4.3-1 (w/o gcc-java)
247
248* Tue May 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-3
249- remove comment before compat32 scriptlet to avoid scriptlet failure.
250
251* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.6a-2
252- removed %%if !%%{build_compat32} case condition
253
254* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-1
255- update to 2.2.6a
256- remove libltdl static library
257
258* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.26-3
259- updated to 1.5.26, importing changes from Fedora 1.5.26-2
260- new versioning policy; spec in UTF-8
261- define gcc_version to 4.1.2 for Vine
262
263* Wed May 30 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl4
264- rebuilt with gcc-4.1.2-0vl10 (gcc -dumpversion begets 4.1.2, not 4.1.3)
265
266* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl3
267- remove BuildRequires: libstdc++3-devel
268- add Requres: libtool-ltdl instead of libtool-libs
269
270* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl2
271- rebuilt with gcc4 (F77=gfortran now)
272- import Patch2 and Patch3 from FC6 1.5.22-6.1
273
274  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
275  - detect gcc path at runtime instead of requiring one specific version
276
277  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
278  - miscellaneous upstream fixes
279
280* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl1
281- new upstream release
282
283* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl4
284- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
285- changed '%postun -p /sbin/ldconfig' to '%postun' and /sbin/ldconfig command
286
287* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl3
288- added compat32-* packages for x86_64 architecture support
289
290* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl2
291- add Japanese Summaries and descriptions
292
293* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl1
294- new upstream release
295
296* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.18-3vl1
297- updated to 1.5.18 based on Fedora package
298  * Sun Feb  6 2005 Daniel Reed <djr@redhat.com> 1.5.12.multilib2-3.4.3
299  - update to the 1.5.12 bugfix release
300  - Makes use of $datarootdir, which is necessary for Autoconf >= 2.60.
301  - Correctly skip hppa, x86_64, and s390* in tests/demo-nopic.test.
302  - Interpret `include' statements in toplevel ld.so.conf file.
303  - While "parsing" /etc/ld.so.conf, skip comments.
304  - add dependency on gcc version; /usr/bin/libtool hardcodes paths into
305    gcc's internal directories
306  - replace "libtool-libs" with "libtool-ltdl" and "libtool-ltdl-devel"
307  * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.5.10-1
308  - update to the 1.5.10 bugfix release
309    - obsoletes libtool-1.4-nonneg.patch
310    - obsoletes libtool-1.5-libtool.m4-x86_64.patch
311    - obsoletes libtool-1.4.2-multilib.patch
312    - obsoletes libtool-1.4.2-demo.patch
313    - obsoletes libtool-1.5-testfailure.patch
314  * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> - 1.5.6-2
315  - compile libltdl.a PIC
316
317* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-0vl2
318- rebuild with gcc-3.3.5
319
320* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-0vl1
321- new upstream release
322
323* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.5.2-2vl1
324- merged with fedora-1.5.2-2
325  * Mon Jan 26 2004 Jens Petersen <petersen@redhat.com> - 1.5.2-1
326  - update to 1.5.2 bugfix release
327  - update libtool-1.5-libtool.m4-x86_64.patch
328  - nolonger need libtool-1.5-mktemp.patch, libtool-1.5-expsym-linux.patch,
329    libtool-1.5-readonlysym.patch, libtool-1.5-relink-libdir-order-91110.patch,
330    libtool-1.5-AC_PROG_LD_GNU-quote-v-97608.patch and libtool-1.5-nostdlib.patch
331
332  * Tue Oct 28 2003 Jens Petersen <petersen@redhat.com> - 1.5-8
333  - update libtool-1.4.2-multilib.patch to also deal with powerpc64 (#103316)
334    [Joe Orton]
335
336* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-5vl1
337- merged with rawhide 1.5-5
338  * Mon Dec 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.3-2vl2
339  - based on 1.4.3-2 from Rawhide and built for Vine Linux
340  - added BuildPreReq: automake14
341
342* Thu Jul 17 2003 Jens Petersen <petersen@redhat.com> - 1.5-5
343- bring back libtool-1.4.2-demo.patch to disable nopic tests on amd64
344  and s390x again
345
346* Tue Jul 15 2003 Owen Taylor <otaylor@redhat.com>
347- Fix misapplied chunk for expsym-linux patch
348
349* Tue Jul  8 2003 Jens Petersen <petersen@redhat.com> - 1.5-4
350- remove the quotes around LD in AC_PROG_LD_GNU (#97608)
351  [reported by twaugh]
352- use -nostdlib also when linking with g++ and non-GNU ld in
353  _LT_AC_LANG_CXX_CONFIG [reported by fnasser, patch by aoliva]
354- use %%configure with CC and CXX set
355
356* Thu Jun 12 2003 Jens Petersen <petersen@redhat.com> - 1.5-3
357- don't use %%configure since target options caused libtool to assume
358  i386-redhat-linux-gcc instead of gcc for CC (reported by Joe Orton)
359- add libtool-1.5-relink-libdir-order-91110.patch to fix order of lib dirs
360  searched when relinking (#91110) [patch from Joe Orton]
361
362* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
363- rebuilt
364
365* Thu May  1 2003 Jens Petersen <petersen@redhat.com> - 1.5-1
366- update to 1.5
367- no longer override config.{guess,sub} for rpmbuild %%configure,
368  redhat-rpm-config owns those now
369- update and rename libtool-1.4.2-s390_x86_64.patch to
370  libtool-1.5-libtool.m4-x86_64.patch since s390 now included
371- buildrequire autoconf and automake, no longer automake14
372- skip make check on s390 temporarily
373- no longer skip demo-nopic.test on x86_64, s390 and s390x
374- from Owen Taylor
375  - add libtool-1.4.2-expsym-linux.patch (#55607) [from James Henstridge]
376  - add quoting in mktemp patch
377  - add libtool-1.5-readonlysym.patch
378  - add libtool-1.5-testfailure.patch workaround
379  - relink patch no longer needed
380
381* Sat Feb 08 2003 Florian La Roche <Florian.LaRoche@redhat.de> - 1.4.3-5
382- add config.guess and config.sub, otherwise old versions of
383  these files can creep into /usr/share/libtool/
384
385* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
386- rebuilt
387
388* Mon Jan 13 2003 Jens Petersen <petersen@redhat.com> 1.4.3-3
389- fix mktemp to work when running mktemp fails (#76602)
390  [reported by (Oron Peled)]
391- remove info dir file, don't exclude it
392- fix typo in -libs description (#79619)
393- use buildroot instead of RPM_BUILD_ROOT
394
395* Tue Jan 07 2003 Karsten Hopp <karsten@redhat.de> 1.4.3-2.2
396- use lib64 on s390x, too.
397
398* Thu Dec  5 2002 Jens Petersen <petersen@redhat.com>
399- add comment to explain why we use an old Automake for building
400- buildrequire automake14
401
402* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com>
403- add --without check build option to allow disabling of "make check"
404- exclude info dir file rather than removing
405
406* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com> 1.4.3-2
407- define SED in ltmain.sh for historic ltconfig files
408- define macro AUTOTOOLS to hold automake-1.4 and aclocal-1.4, and use it
409- leave old missing file for now
410- general spec file cleanup
411  - don't copy install files to demo nor mess with installed ltdl files
412  - don't need to run make in doc
413  - force removal of info dir file
414  - don't need to create install prefix dir
415  - don't bother gzipping info files ourselves
416
417* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 1.4.3-1
418- update to 1.4.3
419- remove obsolete patches (test-quote, dup-deps, libtoolize-configure.ac)
420- apply the multilib patch to just the original config files
421- update x86_64/s390 patch and just apply to original config files
422- use automake-1.4 in "make check" for demo-make.test to pass!
423- remove info dir file that is not installed
424- make autoreconf update missing
425
426* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com>  1.4.2-12.2
427- Added s390x and x64_64 support.
428
429* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.4.2-12.1
430- rebuild
431
432* Fri Sep 13 2002 Nalin Dahyabhai <nalin@redhat.com>
433- patch to find the proper libdir on multilib boxes
434 
435* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 1.4.2-12
436- don't include demo in doc, specially now that we "make check" (#71609)
437
438* Tue Aug 13 2002 Jens Petersen <petersen@redhat.com> 1.4.2-11
439- don't hardcode "configure.in" in libtoolize (#70864)
440  [reported by bastiaan@webcriminals.com]
441- make check, but not on ia64
442
443* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.4.2-10
444- automated rebuild
445
446* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.4.2-9
447- automated rebuild
448
449* Fri Apr 26 2002 Jens Petersen <petersen@redhat.com> 1.4.2-8
450- add old patch from aoliva to fix relinking when installing into a buildroot
451- backport dup-deps fix from cvs stable branch
452
453* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 1.4.2-7
454- run ldconfig in postin and postun
455
456* Thu Feb 28 2002 Jens Petersen <petersen@redhat.com> 1.4.2-6
457- rebuild in new environment
458
459* Tue Feb 12 2002 Jens Petersen <petersen@redhat.com> 1.4.2-5
460- revert filemagic and archive-shared patches following cvs (#54887)
461- don't change "&& test" to "-a" in ltmain.in
462
463* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.4.2-4
464- automated rebuild
465
466* Mon Dec  3 2001 Jens Petersen <petersen@redhat.com> 1.4.2-3
467- test quoting patch should be on ltmain.in not ltmain.sh (#53276)
468- use file_magic for Linux ELF (#54887)
469- allow link against an archive when building a shared library (#54887)
470- include ltdl.m4 in manifest (#56671)
471
472* Wed Oct 24 2001 Jens Petersen <petersen@redhat.com> 1.4.2-2
473- added URL to spec
474
475* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.4.2-1
476- 1.4.2 - sync up with autoconf...
477
478* Thu Jul  5 2001 Bernhard Rosenkraenzer <bero@redhat.de> 1.4-8
479- extend s390 patch to 2 more files
480- s/Copyright/License/
481
482* Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
483- add s390 patch for deplibs_check_method=pass_all
484
485* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
486- add patches from Tim Waugh #42724
487
488* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
489- add patches from cvs mainline
490
491* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
492- fix a "test" bug in ltmain.sh
493
494* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
495- disable the post commands to modify /usr/share/doc/
496
497* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
498- Require automake 1.4p1
499
500* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
501- update to libtool 1.4
502- adjust or remove patches
503
504* Thu Jul 13 2000 Elliot Lee <sopwith@redhat.com>
505- Fix recognition of ^0[0-9]+$ as a non-negative integer.
506
507* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
508- automatic rebuild
509
510* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
511- patch to use mktemp to create the tempdir
512- use %%configure after defining __libtoolize to /bin/true
513
514* Mon Jul  3 2000 Matt Wilson <msw@redhat.com>
515- subpackage libltdl into libtool-libs
516
517* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
518- running libtoolize on the libtool source tree ain't right :)
519
520* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
521- FHS packaging.
522
523* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
524- update to 1.3.5.
525
526* Fri Mar  3 2000 Jeff Johnson <jbj@redhat.com>
527- add prereqs for m4 and perl inorder to run autoconf/automake.
528
529* Mon Feb 28 2000 Jeff Johnson <jbj@redhat.com>
530- functional /usr/doc/libtool-*/demo by end-user %post procedure (#9719).
531
532* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
533- update to 1.3.4.
534
535* Mon Dec  6 1999 Jeff Johnson <jbj@redhat.com>
536- change from noarch to per-arch in order to package libltdl.a (#7493).
537
538* Thu Jul 15 1999 Jeff Johnson <jbj@redhat.com>
539- update to 1.3.3.
540
541* Mon Jun 14 1999 Jeff Johnson <jbj@redhat.com>
542- update to 1.3.2.
543
544* Tue May 11 1999 Jeff Johnson <jbj@redhat.com>
545- explicitly disable per-arch libraries (#2210)
546- undo hard links and remove zero length file (#2689)
547
548* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
549- update to 1.3.
550
551* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
552- disable the --cache-file passing to ltconfig; this breaks the older
553  ltconfig scripts found around.
554
555* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
556- auto rebuild in the new build environment (release 2)
557
558* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
559- update to 1.2f
560
561* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
562- completed arm patch
563- added patch to make it more arm-friendly
564- upgrade to version 1.2d
565
566* Thu May 07 1998 Donnie Barnes <djb@redhat.com>
567- fixed busted group
568
569* Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
570- Update to 1.0h
571- added install-info support
572
573* Tue Nov 25 1997 Elliot Lee <sopwith@redhat.com>
574- Update to 1.0f
575- BuildRoot it
576- Make it a noarch package
Note: See TracBrowser for help on using the repository browser.