source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 6676

Revision 6676, 11.6 KB checked in by iwamoto, 12 years ago (diff)

libtiff: new upstream release 4.0.2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.2
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: zlib-devel libjpeg-devel
14%define LIBVER %(echo %{version} | cut -f-2 -d.)
15%ifarch x86_64
16Provides: libtiff.so.4()(64bit)
17%else
18Provides: libtiff.so.4
19%endif
20Obsoletes: libtiff4
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: daisuke, iwamoto
25
26%description
27The libtiff package contains a library of functions for manipulating
28TIFF (Tagged Image File Format) image format files.  TIFF is a widely
29used file format for bitmapped images.  TIFF files usually end in the
30.tif extension and they are often quite large.
31
32The libtiff package should be installed if you need to manipulate TIFF
33format image files.
34
35%description -l ja
36libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
37扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
38広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
39拡張子が使われ,サイズは概して大きめです.
40
41TIFF 形式の画像ファイルを扱う必要があるならば,
42libtiff パッケージを是非インストールして下さい.
43
44
45%package devel
46Summary: Development tools for programs which will use the libtiff library.
47Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
48Group: Development/Libraries
49Requires: libtiff = %{version}
50
51
52%description devel
53This package contains the header files and static libraries for
54developing programs which will manipulate TIFF format image files
55using the libtiff library.
56
57If you need to develop programs which will manipulate TIFF format
58image files, you should install this package.  You'll also need to
59install the libtiff package.
60
61#'
62%description devel -l ja
63このパッケージには,libtiff ライブラリを使って TIFF 形式の
64画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
65スタティックライブラリが収められています.
66
67TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
68このパッケージをインストールして下さい.libtiff パッケージも同時に
69インストールする必要があります.
70
71## to build compat32 for x86_64 architecture support
72%package -n compat32-%{name}
73Summary: A library of functions for manipulating TIFF format image files.
74Group: System Environment/Libraries
75Requires: %{name} = %{version}
76Provides: libtiff.so.4
77Obsoletes: compat32-libtiff4
78%description -n compat32-%{name}
79The libtiff package contains a library of functions for manipulating
80TIFF (Tagged Image File Format) image format files.  TIFF is a widely
81used file format for bitmapped images.  TIFF files usually end in the
82.tif extension and they are often quite large.
83
84The libtiff package should be installed if you need to manipulate TIFF
85format image files.
86
87%package -n compat32-%{name}-devel
88Summary: Development tools for programs which will use the libtiff library.
89Group: Development/Libraries
90Requires: compat32-%{name} = %{version}
91Requires: %{name}-devel = %{version}
92%description -n compat32-%{name}-devel
93This package contains the header files and static libraries for
94developing programs which will manipulate TIFF format image files
95using the libtiff library.
96
97If you need to develop programs which will manipulate TIFF format
98image files, you should install this package.  You'll also need to
99install the libtiff package.
100
101#'
102%prep
103%setup -q -n tiff-%{version}
104
105%build
106%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
107%__make %{?_smp_mflags}
108%__make clean
109
110
111%install
112rm -fr $RPM_BUILD_ROOT
113%makeinstall
114rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
115
116ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
117
118rm $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
119
120
121%post -p /sbin/ldconfig
122
123%postun -p /sbin/ldconfig
124
125%if %{build_compat32}
126%post -n compat32-%{name} -p /sbin/ldconfig
127%postun -n compat32-%{name} -p /sbin/ldconfig
128%endif
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%files
134%defattr(-,root,root)
135%doc COPYRIGHT README RELEASE-DATE VERSION
136%{_bindir}/*
137%{_libdir}/libtiff*.so.*
138%{_mandir}/man1/*
139
140
141%files devel
142%defattr(-,root,root)
143%doc TODO html ChangeLog
144%{_includedir}/*
145%{_libdir}/libtiff*.so
146%{_libdir}/libtiff*.a
147%{_libdir}/pkgconfig/*.pc
148%{_mandir}/man3/*
149
150## to build compat32 for x86_64 architecture support
151%if %{build_compat32}
152%files -n compat32-%{name}
153%defattr(-,root,root)
154%{_libdir}/libtiff.so.*
155
156%files -n compat32-%{name}-devel
157%defattr(-,root,root)
158%{_libdir}/libtiff.so
159%{_libdir}/libtiff.a
160%endif
161
162
163%changelog
164* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
165- new upstream release with security fixes (CVE-2012-2088, 2113)
166- drop patch1 (is included in new release)
167
168* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
169- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
170
171* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
172- fix R: for compat32 package
173
174* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
175- add libtiff.so.4 for compatibility
176- add pkgconfig file
177
178* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
179- new upstream release
180- add patch1 to fix CVE-2012-1173
181
182* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
183- new upstream release
184- drop all patches (are included in new release)
185- remove if-endif for Vine 4.x
186- add Vendor/Distri tags
187
188* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
189- add some patches from RHEL6 3.9.4-1.el6_0.3
190 - fix for CVE-2011-0192 (Patch11)
191 - fix for CVE-2011-1167 (Patch12)
192 - fix for CVE-2009-5022 (Patch13)
193
194* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
195- rebuilt with rpm-4.8.1-3
196
197* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
198- new upstream release
199- add patch4-10 from fedora
200
201* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
202- new upstream release
203- remove BC: freeglut-devel
204- add patch1,2,4,5 from fedora
205- drop obsolete patches
206
207* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
208- change if-endif to make both i386 and compat32 packages
209
210* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
211- add patch5 for fix CVE-2009-2347 (Integer Overflow)
212
213* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
214- add patch4 for fix lzw underflow security issue
215- add if branch Vine4/5 in devel files section (*.la are included or not)
216
217* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
218- removed *.la
219- spec in utf-8
220
221* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
222- fix changelog typo (3.8.4 -> 3.8.2)
223- new versioning policy
224- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
225
226* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
227- fix libdir in libtiff.la
228- add BuildConflicts: freeglut-devel
229
230* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
231- rebuilt without glut-devel
232
233* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
234- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
235
236* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
237- new upstream release
238- remove obsolete patches
239- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
240- delete duped docs
241- add --disable-cxx to configure option
242- add *.la to devel package
243
244* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
245- added compat32-* packages for x86_64 architecture support
246- added --with-jpeg-lib-dir=%{_libdir} to configure
247
248* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
249- new upstream release
250- remove obsolete patches
251- cleanup specs
252
253* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
254- rebuild for Vine3.1
255
256* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
257- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
258- update URL
259
260* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
261- build for Vine2.6
262
263* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
264- fix changelog: proper name
265
266* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
267- add symlink to shared lib by running ldconfig at compile time
268
269* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
270- add patch8-13 from Fedora Core
271--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
272--- fix some integer and buffer overflows (#134853, #134848)
273- add patch14 from SUSE LINUX
274--* Wed Oct 20 2004 - meissner@suse.de
275--- Do not crash if we are using unsupported codecs (like OJPEG).
276
277* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
278- rebuild with new toolchains
279- to use License instead of Copyright
280
281* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
282- 3.5.7-6vl1
283- based on 3.5.7-6 from Rawhide
284
285* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
286- 3.5.5-8vl1
287- based on 3.5.5-8 from Rawhide
288- added Japanese summary and description
289
290* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
291- rebuild
292
293* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
294- added a tiff-to-ps.fpi filter for printing
295
296* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
297- automatic rebuild
298
299* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
300- apply Peter Skarpetis's fix for the 32-bit conversion
301
302* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
303- make man pages non-executable (#12811)
304
305* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
306- remove CVS repo info from data directories
307
308* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
309- fix build rooting
310- fix syntax error in configure script
311- move man pages to %{_mandir}
312
313* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
314- rebuild for an errata release
315
316* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
317- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
318
319* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
320- fix fax2ps swapping height and width in the bounding box
321
322* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
323- move man pages from devel package to the regular one
324- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
325  of libtiff)
326- fix fax2ps breakage (bug #8345)
327
328* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
329- set MANDIR=man3 to make multifunction man pages friendlier
330
331* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
332- fix URLs
333
334* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
335- link shared library against libjpeg and libz
336
337* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
338- enable zip and jpeg codecs
339- change defattr in normal package to 0755
340- add defattr to -devel package
341
342* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
343- update to 3.5.4
344
345* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
346- auto rebuild in the new build environment (release 6)
347
348* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
349- build for glibc 2.1
350
351* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
352- translations modified for de
353
354* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
355- rebuilt against fixed jpeg libs (libjpeg-6b)
356
357* Thu May 07 1998 Prospector System <bugs@redhat.com>
358- translations modified for de, fr, tr
359
360* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
361- new version to replace the one from libgr
362- patched for glibc
363- added shlib support
Note: See TracBrowser for help on using the repository browser.