source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 7116

Revision 7116, 11.7 KB checked in by iwamoto, 11 years ago (diff)

update: libtiff 4.0.3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.3
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: zlib-devel libjpeg-devel
14%define LIBVER %(echo %{version} | cut -f-2 -d.)
15%ifarch x86_64
16Provides: libtiff.so.4()(64bit)
17%else
18Provides: libtiff.so.4
19%endif
20Obsoletes: libtiff4
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: daisuke, iwamoto
25
26%description
27The libtiff package contains a library of functions for manipulating
28TIFF (Tagged Image File Format) image format files.  TIFF is a widely
29used file format for bitmapped images.  TIFF files usually end in the
30.tif extension and they are often quite large.
31
32The libtiff package should be installed if you need to manipulate TIFF
33format image files.
34
35%description -l ja
36libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
37扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
38広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
39拡張子が使われ,サイズは概して大きめです.
40
41TIFF 形式の画像ファイルを扱う必要があるならば,
42libtiff パッケージを是非インストールして下さい.
43
44
45%package devel
46Summary: Development tools for programs which will use the libtiff library.
47Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
48Group: Development/Libraries
49Requires: libtiff = %{version}
50
51
52%description devel
53This package contains the header files and static libraries for
54developing programs which will manipulate TIFF format image files
55using the libtiff library.
56
57If you need to develop programs which will manipulate TIFF format
58image files, you should install this package.  You'll also need to
59install the libtiff package.
60
61#'
62%description devel -l ja
63このパッケージには,libtiff ライブラリを使って TIFF 形式の
64画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
65スタティックライブラリが収められています.
66
67TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
68このパッケージをインストールして下さい.libtiff パッケージも同時に
69インストールする必要があります.
70
71## to build compat32 for x86_64 architecture support
72%package -n compat32-%{name}
73Summary: A library of functions for manipulating TIFF format image files.
74Group: System Environment/Libraries
75Requires: %{name} = %{version}
76Provides: libtiff.so.4
77Obsoletes: compat32-libtiff4
78%description -n compat32-%{name}
79The libtiff package contains a library of functions for manipulating
80TIFF (Tagged Image File Format) image format files.  TIFF is a widely
81used file format for bitmapped images.  TIFF files usually end in the
82.tif extension and they are often quite large.
83
84The libtiff package should be installed if you need to manipulate TIFF
85format image files.
86
87%package -n compat32-%{name}-devel
88Summary: Development tools for programs which will use the libtiff library.
89Group: Development/Libraries
90Requires: compat32-%{name} = %{version}
91Requires: %{name}-devel = %{version}
92%description -n compat32-%{name}-devel
93This package contains the header files and static libraries for
94developing programs which will manipulate TIFF format image files
95using the libtiff library.
96
97If you need to develop programs which will manipulate TIFF format
98image files, you should install this package.  You'll also need to
99install the libtiff package.
100
101#'
102%prep
103%setup -q -n tiff-%{version}
104
105%build
106%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
107%__make %{?_smp_mflags}
108%__make clean
109
110
111%install
112rm -fr $RPM_BUILD_ROOT
113%makeinstall
114rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
115
116ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
117
118rm $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
119
120
121%post -p /sbin/ldconfig
122
123%postun -p /sbin/ldconfig
124
125%if %{build_compat32}
126%post -n compat32-%{name} -p /sbin/ldconfig
127%postun -n compat32-%{name} -p /sbin/ldconfig
128%endif
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%files
134%defattr(-,root,root)
135%doc COPYRIGHT README RELEASE-DATE VERSION
136%{_bindir}/*
137%{_libdir}/libtiff*.so.*
138%{_mandir}/man1/*
139
140%files devel
141%defattr(-,root,root)
142%doc TODO html ChangeLog
143%{_includedir}/*
144%{_libdir}/libtiff*.so
145%{_libdir}/pkgconfig/*.pc
146%{_mandir}/man3/*
147
148## to build compat32 for x86_64 architecture support
149%if %{build_compat32}
150%files -n compat32-%{name}
151%defattr(-,root,root)
152%{_libdir}/libtiff.so.*
153
154%files -n compat32-%{name}-devel
155%defattr(-,root,root)
156%{_libdir}/libtiff.so
157%endif
158
159
160%changelog
161* Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
162- new upstream release with security fix (CVE-2012-4447)
163- drop *.a files from -devel packages
164
165* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
166- new upstream release with security fixes (CVE-2012-2088, 2113)
167- drop patch1 (is included in new release)
168
169* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
170- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
171
172* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
173- fix R: for compat32 package
174
175* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
176- add libtiff.so.4 for compatibility
177- add pkgconfig file
178
179* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
180- new upstream release
181- add patch1 to fix CVE-2012-1173
182
183* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
184- new upstream release
185- drop all patches (are included in new release)
186- remove if-endif for Vine 4.x
187- add Vendor/Distri tags
188
189* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
190- add some patches from RHEL6 3.9.4-1.el6_0.3
191 - fix for CVE-2011-0192 (Patch11)
192 - fix for CVE-2011-1167 (Patch12)
193 - fix for CVE-2009-5022 (Patch13)
194
195* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
196- rebuilt with rpm-4.8.1-3
197
198* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
199- new upstream release
200- add patch4-10 from fedora
201
202* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
203- new upstream release
204- remove BC: freeglut-devel
205- add patch1,2,4,5 from fedora
206- drop obsolete patches
207
208* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
209- change if-endif to make both i386 and compat32 packages
210
211* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
212- add patch5 for fix CVE-2009-2347 (Integer Overflow)
213
214* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
215- add patch4 for fix lzw underflow security issue
216- add if branch Vine4/5 in devel files section (*.la are included or not)
217
218* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
219- removed *.la
220- spec in utf-8
221
222* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
223- fix changelog typo (3.8.4 -> 3.8.2)
224- new versioning policy
225- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
226
227* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
228- fix libdir in libtiff.la
229- add BuildConflicts: freeglut-devel
230
231* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
232- rebuilt without glut-devel
233
234* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
235- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
236
237* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
238- new upstream release
239- remove obsolete patches
240- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
241- delete duped docs
242- add --disable-cxx to configure option
243- add *.la to devel package
244
245* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
246- added compat32-* packages for x86_64 architecture support
247- added --with-jpeg-lib-dir=%{_libdir} to configure
248
249* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
250- new upstream release
251- remove obsolete patches
252- cleanup specs
253
254* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
255- rebuild for Vine3.1
256
257* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
258- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
259- update URL
260
261* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
262- build for Vine2.6
263
264* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
265- fix changelog: proper name
266
267* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
268- add symlink to shared lib by running ldconfig at compile time
269
270* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
271- add patch8-13 from Fedora Core
272--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
273--- fix some integer and buffer overflows (#134853, #134848)
274- add patch14 from SUSE LINUX
275--* Wed Oct 20 2004 - meissner@suse.de
276--- Do not crash if we are using unsupported codecs (like OJPEG).
277
278* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
279- rebuild with new toolchains
280- to use License instead of Copyright
281
282* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
283- 3.5.7-6vl1
284- based on 3.5.7-6 from Rawhide
285
286* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
287- 3.5.5-8vl1
288- based on 3.5.5-8 from Rawhide
289- added Japanese summary and description
290
291* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
292- rebuild
293
294* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
295- added a tiff-to-ps.fpi filter for printing
296
297* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
298- automatic rebuild
299
300* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
301- apply Peter Skarpetis's fix for the 32-bit conversion
302
303* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
304- make man pages non-executable (#12811)
305
306* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
307- remove CVS repo info from data directories
308
309* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
310- fix build rooting
311- fix syntax error in configure script
312- move man pages to %{_mandir}
313
314* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
315- rebuild for an errata release
316
317* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
318- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
319
320* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
321- fix fax2ps swapping height and width in the bounding box
322
323* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
324- move man pages from devel package to the regular one
325- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
326  of libtiff)
327- fix fax2ps breakage (bug #8345)
328
329* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
330- set MANDIR=man3 to make multifunction man pages friendlier
331
332* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
333- fix URLs
334
335* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
336- link shared library against libjpeg and libz
337
338* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
339- enable zip and jpeg codecs
340- change defattr in normal package to 0755
341- add defattr to -devel package
342
343* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
344- update to 3.5.4
345
346* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
347- auto rebuild in the new build environment (release 6)
348
349* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
350- build for glibc 2.1
351
352* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
353- translations modified for de
354
355* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
356- rebuilt against fixed jpeg libs (libjpeg-6b)
357
358* Thu May 07 1998 Prospector System <bugs@redhat.com>
359- translations modified for de, fr, tr
360
361* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
362- new version to replace the one from libgr
363- patched for glibc
364- added shlib support
Note: See TracBrowser for help on using the repository browser.