source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 11276

Revision 11276, 12.9 KB checked in by tomop, 6 years ago (diff)

libtiff-4.0.9-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.9
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11
12URL: http://www.simplesystems.org/libtiff/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: zlib-devel libjpeg-devel
15%define LIBVER %(echo %{version} | cut -f-2 -d.)
16%ifarch x86_64
17Provides: libtiff.so.4()(64bit)
18%else
19Provides: libtiff.so.4
20%endif
21Obsoletes: libtiff4
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, iwamoto
26
27Patch0: libtiff-am-version.patch
28Patch1: libtiff-make-check.patch
29
30Patch1000: libtiff-CVE-2017-9935.patch
31
32%description
33The libtiff package contains a library of functions for manipulating
34TIFF (Tagged Image File Format) image format files.  TIFF is a widely
35used file format for bitmapped images.  TIFF files usually end in the
36.tif extension and they are often quite large.
37
38The libtiff package should be installed if you need to manipulate TIFF
39format image files.
40
41%description -l ja
42libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
43扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
44広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
45拡張子が使われ,サイズは概して大きめです.
46
47TIFF 形式の画像ファイルを扱う必要があるならば,
48libtiff パッケージを是非インストールして下さい.
49
50
51%package devel
52Summary: Development tools for programs which will use the libtiff library.
53Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
54Group: Development/Libraries
55Requires: libtiff = %{version}
56
57
58%description devel
59This package contains the header files and static libraries for
60developing programs which will manipulate TIFF format image files
61using the libtiff library.
62
63If you need to develop programs which will manipulate TIFF format
64image files, you should install this package.  You'll also need to
65install the libtiff package.
66
67#'
68%description devel -l ja
69このパッケージには,libtiff ライブラリを使って TIFF 形式の
70画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
71スタティックライブラリが収められています.
72
73TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
74このパッケージをインストールして下さい.libtiff パッケージも同時に
75インストールする必要があります.
76
77## to build compat32 for x86_64 architecture support
78%package -n compat32-%{name}
79Summary: A library of functions for manipulating TIFF format image files.
80Group: System Environment/Libraries
81Requires: %{name} = %{version}
82Provides: libtiff.so.4
83Obsoletes: compat32-libtiff4
84%description -n compat32-%{name}
85The libtiff package contains a library of functions for manipulating
86TIFF (Tagged Image File Format) image format files.  TIFF is a widely
87used file format for bitmapped images.  TIFF files usually end in the
88.tif extension and they are often quite large.
89
90The libtiff package should be installed if you need to manipulate TIFF
91format image files.
92
93%package -n compat32-%{name}-devel
94Summary: Development tools for programs which will use the libtiff library.
95Group: Development/Libraries
96Requires: compat32-%{name} = %{version}
97Requires: %{name}-devel = %{version}
98%description -n compat32-%{name}-devel
99This package contains the header files and static libraries for
100developing programs which will manipulate TIFF format image files
101using the libtiff library.
102
103If you need to develop programs which will manipulate TIFF format
104image files, you should install this package.  You'll also need to
105install the libtiff package.
106
107#'
108%prep
109%setup -q -n tiff-%{version}
110
111%patch0 -p1
112%patch1 -p1
113
114%patch1000 -p1
115
116# Use build system's libtool.m4, not the one in the package.
117rm -f libtool.m4
118
119libtoolize --force  --copy
120aclocal -I . -I m4
121automake --add-missing --copy
122autoconf
123autoheader
124
125%build
126export CFLAGS="%{optflags} -fno-strict-aliasing"
127%configure \
128  --enable-ld-version-script \
129  --with-jpeg-lib-dir=%{_libdir} \
130  --disable-cxx
131%__make %{?_smp_mflags}
132%__make clean
133
134%install
135rm -fr $RPM_BUILD_ROOT
136%makeinstall
137rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
138
139ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
140
141rm $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
142
143
144%post -p /sbin/ldconfig
145
146%postun -p /sbin/ldconfig
147
148%if %{build_compat32}
149%post -n compat32-%{name} -p /sbin/ldconfig
150%postun -n compat32-%{name} -p /sbin/ldconfig
151%endif
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%files
157%defattr(-,root,root)
158%doc COPYRIGHT README RELEASE-DATE VERSION
159%{_bindir}/*
160%{_libdir}/libtiff*.so.*
161%{_mandir}/man1/*
162
163%files devel
164%defattr(-,root,root)
165%doc TODO html ChangeLog
166%{_includedir}/*
167%{_libdir}/libtiff*.so
168%{_libdir}/pkgconfig/*.pc
169%{_mandir}/man3/*
170
171## to build compat32 for x86_64 architecture support
172%if %{build_compat32}
173%files -n compat32-%{name}
174%defattr(-,root,root)
175%{_libdir}/libtiff.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-,root,root)
179%{_libdir}/libtiff.so
180%endif
181
182
183%changelog
184* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
185- updated to 4.0.9.
186- added Patch1000 to fix CVE-2017-9935.
187
188* Sat Jun  3 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 4.0.8-1
189- update to 4.0.8
190- drop patches; upstream fixed
191 - HylaFAX patch (Patch2)
192 - CVE patches (Patch3..16)
193
194* Sat May  6 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
195- imported patches from rawhide.
196    - fixed CVE-2017-759{2,3,4,5,6,7,8,9}, CVE-2017-760{0,1,2}
197    - fixed CVE-2016-1026{6,7,8,9}, CVE-2016-1027{0,1,2}
198
199* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
200- new upstream release.
201- drooped patch1-11: fixed in upstream.
202
203* Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
204- add patch1-11 from fc21 to fix security issues
205
206* Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
207- new upstream release with security fix (CVE-2012-4447)
208- drop *.a files from -devel packages
209
210* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
211- new upstream release with security fixes (CVE-2012-2088, 2113)
212- drop patch1 (is included in new release)
213
214* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
215- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
216
217* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
218- fix R: for compat32 package
219
220* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
221- add libtiff.so.4 for compatibility
222- add pkgconfig file
223
224* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
225- new upstream release
226- add patch1 to fix CVE-2012-1173
227
228* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
229- new upstream release
230- drop all patches (are included in new release)
231- remove if-endif for Vine 4.x
232- add Vendor/Distri tags
233
234* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
235- add some patches from RHEL6 3.9.4-1.el6_0.3
236 - fix for CVE-2011-0192 (Patch11)
237 - fix for CVE-2011-1167 (Patch12)
238 - fix for CVE-2009-5022 (Patch13)
239
240* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
241- rebuilt with rpm-4.8.1-3
242
243* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
244- new upstream release
245- add patch4-10 from fedora
246
247* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
248- new upstream release
249- remove BC: freeglut-devel
250- add patch1,2,4,5 from fedora
251- drop obsolete patches
252
253* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
254- change if-endif to make both i386 and compat32 packages
255
256* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
257- add patch5 for fix CVE-2009-2347 (Integer Overflow)
258
259* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
260- add patch4 for fix lzw underflow security issue
261- add if branch Vine4/5 in devel files section (*.la are included or not)
262
263* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
264- removed *.la
265- spec in utf-8
266
267* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
268- fix changelog typo (3.8.4 -> 3.8.2)
269- new versioning policy
270- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
271
272* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
273- fix libdir in libtiff.la
274- add BuildConflicts: freeglut-devel
275
276* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
277- rebuilt without glut-devel
278
279* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
280- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
281
282* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
283- new upstream release
284- remove obsolete patches
285- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
286- delete duped docs
287- add --disable-cxx to configure option
288- add *.la to devel package
289
290* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
291- added compat32-* packages for x86_64 architecture support
292- added --with-jpeg-lib-dir=%{_libdir} to configure
293
294* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
295- new upstream release
296- remove obsolete patches
297- cleanup specs
298
299* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
300- rebuild for Vine3.1
301
302* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
303- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
304- update URL
305
306* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
307- build for Vine2.6
308
309* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
310- fix changelog: proper name
311
312* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
313- add symlink to shared lib by running ldconfig at compile time
314
315* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
316- add patch8-13 from Fedora Core
317--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
318--- fix some integer and buffer overflows (#134853, #134848)
319- add patch14 from SUSE LINUX
320--* Wed Oct 20 2004 - meissner@suse.de
321--- Do not crash if we are using unsupported codecs (like OJPEG).
322
323* Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
324- rebuild with new toolchains
325- to use License instead of Copyright
326
327* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
328- 3.5.7-6vl1
329- based on 3.5.7-6 from Rawhide
330
331* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
332- 3.5.5-8vl1
333- based on 3.5.5-8 from Rawhide
334- added Japanese summary and description
335
336* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
337- rebuild
338
339* Mon Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
340- added a tiff-to-ps.fpi filter for printing
341
342* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
343- automatic rebuild
344
345* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
346- apply Peter Skarpetis's fix for the 32-bit conversion
347
348* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
349- make man pages non-executable (#12811)
350
351* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
352- remove CVS repo info from data directories
353
354* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
355- fix build rooting
356- fix syntax error in configure script
357- move man pages to %{_mandir}
358
359* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
360- rebuild for an errata release
361
362* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
363- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
364
365* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
366- fix fax2ps swapping height and width in the bounding box
367
368* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
369- move man pages from devel package to the regular one
370- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
371  of libtiff)
372- fix fax2ps breakage (bug #8345)
373
374* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
375- set MANDIR=man3 to make multifunction man pages friendlier
376
377* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
378- fix URLs
379
380* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
381- link shared library against libjpeg and libz
382
383* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
384- enable zip and jpeg codecs
385- change defattr in normal package to 0755
386- add defattr to -devel package
387
388* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
389- update to 3.5.4
390
391* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
392- auto rebuild in the new build environment (release 6)
393
394* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
395- build for glibc 2.1
396
397* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
398- translations modified for de
399
400* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
401- rebuilt against fixed jpeg libs (libjpeg-6b)
402
403* Thu May 07 1998 Prospector System <bugs@redhat.com>
404- translations modified for de, fr, tr
405
406* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
407- new version to replace the one from libgr
408- patched for glibc
409- added shlib support
Note: See TracBrowser for help on using the repository browser.