source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 11102

Revision 11102, 12.7 KB checked in by iwaim, 7 years ago (diff)

libtiff 4.0.8-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.8
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11
12URL: http://www.simplesystems.org/libtiff/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: zlib-devel libjpeg-devel
15%define LIBVER %(echo %{version} | cut -f-2 -d.)
16%ifarch x86_64
17Provides: libtiff.so.4()(64bit)
18%else
19Provides: libtiff.so.4
20%endif
21Obsoletes: libtiff4
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, iwamoto
26
27Patch0: libtiff-am-version.patch
28Patch1: libtiff-make-check.patch
29
30%description
31The libtiff package contains a library of functions for manipulating
32TIFF (Tagged Image File Format) image format files.  TIFF is a widely
33used file format for bitmapped images.  TIFF files usually end in the
34.tif extension and they are often quite large.
35
36The libtiff package should be installed if you need to manipulate TIFF
37format image files.
38
39%description -l ja
40libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
41扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
42広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
43拡張子が使われ,サイズは概して大きめです.
44
45TIFF 形式の画像ファイルを扱う必要があるならば,
46libtiff パッケージを是非インストールして下さい.
47
48
49%package devel
50Summary: Development tools for programs which will use the libtiff library.
51Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
52Group: Development/Libraries
53Requires: libtiff = %{version}
54
55
56%description devel
57This package contains the header files and static libraries for
58developing programs which will manipulate TIFF format image files
59using the libtiff library.
60
61If you need to develop programs which will manipulate TIFF format
62image files, you should install this package.  You'll also need to
63install the libtiff package.
64
65#'
66%description devel -l ja
67このパッケージには,libtiff ライブラリを使って TIFF 形式の
68画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
69スタティックライブラリが収められています.
70
71TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
72このパッケージをインストールして下さい.libtiff パッケージも同時に
73インストールする必要があります.
74
75## to build compat32 for x86_64 architecture support
76%package -n compat32-%{name}
77Summary: A library of functions for manipulating TIFF format image files.
78Group: System Environment/Libraries
79Requires: %{name} = %{version}
80Provides: libtiff.so.4
81Obsoletes: compat32-libtiff4
82%description -n compat32-%{name}
83The libtiff package contains a library of functions for manipulating
84TIFF (Tagged Image File Format) image format files.  TIFF is a widely
85used file format for bitmapped images.  TIFF files usually end in the
86.tif extension and they are often quite large.
87
88The libtiff package should be installed if you need to manipulate TIFF
89format image files.
90
91%package -n compat32-%{name}-devel
92Summary: Development tools for programs which will use the libtiff library.
93Group: Development/Libraries
94Requires: compat32-%{name} = %{version}
95Requires: %{name}-devel = %{version}
96%description -n compat32-%{name}-devel
97This package contains the header files and static libraries for
98developing programs which will manipulate TIFF format image files
99using the libtiff library.
100
101If you need to develop programs which will manipulate TIFF format
102image files, you should install this package.  You'll also need to
103install the libtiff package.
104
105#'
106%prep
107%setup -q -n tiff-%{version}
108
109%patch0 -p1
110%patch1 -p1
111
112# Use build system's libtool.m4, not the one in the package.
113rm -f libtool.m4
114
115libtoolize --force  --copy
116aclocal -I . -I m4
117automake --add-missing --copy
118autoconf
119autoheader
120
121%build
122export CFLAGS="%{optflags} -fno-strict-aliasing"
123%configure \
124  --enable-ld-version-script \
125  --with-jpeg-lib-dir=%{_libdir} \
126  --disable-cxx
127%__make %{?_smp_mflags}
128%__make clean
129
130%install
131rm -fr $RPM_BUILD_ROOT
132%makeinstall
133rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
134
135ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
136
137rm $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
138
139
140%post -p /sbin/ldconfig
141
142%postun -p /sbin/ldconfig
143
144%if %{build_compat32}
145%post -n compat32-%{name} -p /sbin/ldconfig
146%postun -n compat32-%{name} -p /sbin/ldconfig
147%endif
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%files
153%defattr(-,root,root)
154%doc COPYRIGHT README RELEASE-DATE VERSION
155%{_bindir}/*
156%{_libdir}/libtiff*.so.*
157%{_mandir}/man1/*
158
159%files devel
160%defattr(-,root,root)
161%doc TODO html ChangeLog
162%{_includedir}/*
163%{_libdir}/libtiff*.so
164%{_libdir}/pkgconfig/*.pc
165%{_mandir}/man3/*
166
167## to build compat32 for x86_64 architecture support
168%if %{build_compat32}
169%files -n compat32-%{name}
170%defattr(-,root,root)
171%{_libdir}/libtiff.so.*
172
173%files -n compat32-%{name}-devel
174%defattr(-,root,root)
175%{_libdir}/libtiff.so
176%endif
177
178
179%changelog
180* Sat Jun  3 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 4.0.8-1
181- update to 4.0.8
182- drop patches; upstream fixed
183 - HylaFAX patch (Patch2)
184 - CVE patches (Patch3..16)
185
186* Sat May  6 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
187- imported patches from rawhide.
188    - fixed CVE-2017-759{2,3,4,5,6,7,8,9}, CVE-2017-760{0,1,2}
189    - fixed CVE-2016-1026{6,7,8,9}, CVE-2016-1027{0,1,2}
190
191* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
192- new upstream release.
193- drooped patch1-11: fixed in upstream.
194
195* Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
196- add patch1-11 from fc21 to fix security issues
197
198* Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
199- new upstream release with security fix (CVE-2012-4447)
200- drop *.a files from -devel packages
201
202* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
203- new upstream release with security fixes (CVE-2012-2088, 2113)
204- drop patch1 (is included in new release)
205
206* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
207- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
208
209* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
210- fix R: for compat32 package
211
212* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
213- add libtiff.so.4 for compatibility
214- add pkgconfig file
215
216* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
217- new upstream release
218- add patch1 to fix CVE-2012-1173
219
220* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
221- new upstream release
222- drop all patches (are included in new release)
223- remove if-endif for Vine 4.x
224- add Vendor/Distri tags
225
226* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
227- add some patches from RHEL6 3.9.4-1.el6_0.3
228 - fix for CVE-2011-0192 (Patch11)
229 - fix for CVE-2011-1167 (Patch12)
230 - fix for CVE-2009-5022 (Patch13)
231
232* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
233- rebuilt with rpm-4.8.1-3
234
235* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
236- new upstream release
237- add patch4-10 from fedora
238
239* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
240- new upstream release
241- remove BC: freeglut-devel
242- add patch1,2,4,5 from fedora
243- drop obsolete patches
244
245* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
246- change if-endif to make both i386 and compat32 packages
247
248* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
249- add patch5 for fix CVE-2009-2347 (Integer Overflow)
250
251* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
252- add patch4 for fix lzw underflow security issue
253- add if branch Vine4/5 in devel files section (*.la are included or not)
254
255* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
256- removed *.la
257- spec in utf-8
258
259* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
260- fix changelog typo (3.8.4 -> 3.8.2)
261- new versioning policy
262- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
263
264* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
265- fix libdir in libtiff.la
266- add BuildConflicts: freeglut-devel
267
268* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
269- rebuilt without glut-devel
270
271* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
272- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
273
274* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
275- new upstream release
276- remove obsolete patches
277- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
278- delete duped docs
279- add --disable-cxx to configure option
280- add *.la to devel package
281
282* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
283- added compat32-* packages for x86_64 architecture support
284- added --with-jpeg-lib-dir=%{_libdir} to configure
285
286* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
287- new upstream release
288- remove obsolete patches
289- cleanup specs
290
291* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
292- rebuild for Vine3.1
293
294* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
295- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
296- update URL
297
298* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
299- build for Vine2.6
300
301* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
302- fix changelog: proper name
303
304* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
305- add symlink to shared lib by running ldconfig at compile time
306
307* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
308- add patch8-13 from Fedora Core
309--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
310--- fix some integer and buffer overflows (#134853, #134848)
311- add patch14 from SUSE LINUX
312--* Wed Oct 20 2004 - meissner@suse.de
313--- Do not crash if we are using unsupported codecs (like OJPEG).
314
315* Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
316- rebuild with new toolchains
317- to use License instead of Copyright
318
319* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
320- 3.5.7-6vl1
321- based on 3.5.7-6 from Rawhide
322
323* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
324- 3.5.5-8vl1
325- based on 3.5.5-8 from Rawhide
326- added Japanese summary and description
327
328* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
329- rebuild
330
331* Mon Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
332- added a tiff-to-ps.fpi filter for printing
333
334* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
335- automatic rebuild
336
337* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
338- apply Peter Skarpetis's fix for the 32-bit conversion
339
340* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
341- make man pages non-executable (#12811)
342
343* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
344- remove CVS repo info from data directories
345
346* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
347- fix build rooting
348- fix syntax error in configure script
349- move man pages to %{_mandir}
350
351* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
352- rebuild for an errata release
353
354* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
355- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
356
357* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
358- fix fax2ps swapping height and width in the bounding box
359
360* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
361- move man pages from devel package to the regular one
362- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
363  of libtiff)
364- fix fax2ps breakage (bug #8345)
365
366* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
367- set MANDIR=man3 to make multifunction man pages friendlier
368
369* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
370- fix URLs
371
372* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
373- link shared library against libjpeg and libz
374
375* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
376- enable zip and jpeg codecs
377- change defattr in normal package to 0755
378- add defattr to -devel package
379
380* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
381- update to 3.5.4
382
383* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
384- auto rebuild in the new build environment (release 6)
385
386* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
387- build for glibc 2.1
388
389* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
390- translations modified for de
391
392* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
393- rebuilt against fixed jpeg libs (libjpeg-6b)
394
395* Thu May 07 1998 Prospector System <bugs@redhat.com>
396- translations modified for de, fr, tr
397
398* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
399- new version to replace the one from libgr
400- patched for glibc
401- added shlib support
Note: See TracBrowser for help on using the repository browser.