source: projects/specs/trunk/lib/libs/libssh2/libssh2-vl.spec @ 7180

Revision 7180, 4.9 KB checked in by daisuke, 11 years ago (diff)

libssh2

  • update to 1.4.2
  • add compat32 package
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A library implementing the SSH2 protocol
4Summary(ja):    SSH2 プロトコルを実装するためのライブラリ
5Name:           libssh2
6Version:        1.4.2
7Release:        1%{?_dist_release}
8
9Group:          System Environment/Libraries
10License:        BSD
11URL:            http://www.libssh2.org/
12Source0:        http://downloads.sourceforge.net/libssh2/%{name}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  openssl-devel
16BuildRequires:  zlib-devel   
17
18%description
19libssh2 is a library implementing the SSH2 protocol as defined by
20Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
21SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
22SECSH-DHGEX(04), and SECSH-NUMBERS(10).
23
24
25%package        devel
26Summary:        Development files for %{name}
27Summary(ja):    %{name} の開発ファイル
28Group:          Development/Libraries
29Requires:       %{name} = %{version}-%{release}
30
31%description    devel
32The %{name}-devel package contains libraries and header files for
33developing applications that use %{name}.
34
35%package        docs
36Summary:        Documentation for %{name}
37Summary(ja):    %{name} のドキュメント
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40
41%description    docs
42The %{name}-docs package contains man pages and examples for
43developing applications that use %{name}.
44
45## to build compat32 for x86_64 architecture support
46%package -n compat32-%{name}
47Summary: A library implementing the SSH2 protocol
48Summary(ja): SSH2 プロトコルを実装するためのライブラリ
49Group: System Environment/Libraries
50
51%description -n compat32-%{name}
52libssh2 is a library implementing the SSH2 protocol as defined by
53Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
54SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
55SECSH-DHGEX(04), and SECSH-NUMBERS(10).
56
57
58%prep
59%setup -q
60
61# make sure things are UTF-8...
62for i in ChangeLog NEWS ; do
63    iconv --from=ISO-8859-1 --to=UTF-8 $i > new
64    mv new $i
65done
66
67%build
68%configure --disable-static --enable-shared
69
70make %{?_smp_mflags}
71
72
73%install
74rm -rf %{buildroot}
75
76make install DESTDIR=%{buildroot} INSTALL="install -p"
77find %{buildroot} -name '*.la' -exec rm -f {} +
78
79# clean things up a bit for packaging
80( cd example && make clean )
81rm -rf example/simple/.deps
82find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
83
84%check
85(cd tests && make check)
86
87%clean
88rm -rf %{buildroot}
89
90
91%post -p /sbin/ldconfig
92
93%postun -p /sbin/ldconfig
94
95%post -n compat32-%{name} -p /sbin/ldconfig
96
97%postun -n compat32-%{name} -p /sbin/ldconfig
98
99
100%files
101%defattr(-,root,root,-)
102%doc AUTHORS ChangeLog COPYING README NEWS
103%{_libdir}/*.so.*
104
105%files docs
106%defattr(-,root,root,-)
107%doc COPYING HACKING example/
108%{_mandir}/man?/*
109
110%files devel
111%defattr(-,root,root,-)
112%doc COPYING
113%{_includedir}/*
114%{_libdir}/*.so
115%{_libdir}/pkgconfig/libssh2.pc
116
117%if %{build_compat32}
118%files -n compat32-%{name}
119%defattr(-,root,root,-)
120%{_libdir}/*.so.*
121%endif
122
123%changelog
124* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
125- new upstream reelase
126- add compat32 package
127
128* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
129- new upstream release
130- fix %%files
131
132* Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
133- initial build for Vine Linux
134
135* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
136- rebuilt with new openssl
137
138* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
140
141* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
143
144* Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
145- update to 1.0
146
147* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
148- rebuild with new openssl
149
150* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
151- Autorebuild for GCC 4.3
152
153* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
154- rebuild for new openssl...
155
156* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
157- bump
158
159* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
160- add INSTALL arg to make install vs env. var
161
162* Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
163- run tests; don't package test
164
165* Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
166- split docs into -docs (they seemed... large.)
167
168* Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
169- update to 0.18
170
171* Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
172- update to 0.17
173- many spec file changes
174
175* Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
176- Fix release tag
177- Move manpages to -devel package
178- Add Examples dir to -devel package
179
180* Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
181- Initial build
Note: See TracBrowser for help on using the repository browser.