source: projects/specs/trunk/lib/libs/libssh2/libssh2-vl.spec @ 10048

Revision 10048, 5.0 KB checked in by iwamoto, 8 years ago (diff)

libssh2: update to 1.7.0

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A library implementing the SSH2 protocol
4Summary(ja):    SSH2 プロトコルを実装するためのライブラリ
5Name:           libssh2
6Version:        1.7.0
7Release:        1%{?_dist_release}
8
9Group:          System Environment/Libraries
10License:        BSD
11URL:            http://www.libssh2.org/
12Source0:        http://downloads.sourceforge.net/libssh2/%{name}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  openssl-devel
16BuildRequires:  zlib-devel   
17
18%description
19libssh2 is a library implementing the SSH2 protocol as defined by
20Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
21SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
22SECSH-DHGEX(04), and SECSH-NUMBERS(10).
23
24
25%package        devel
26Summary:        Development files for %{name}
27Summary(ja):    %{name} の開発ファイル
28Group:          Development/Libraries
29Requires:       %{name} = %{version}-%{release}
30
31%description    devel
32The %{name}-devel package contains libraries and header files for
33developing applications that use %{name}.
34
35%package        docs
36Summary:        Documentation for %{name}
37Summary(ja):    %{name} のドキュメント
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40
41%description    docs
42The %{name}-docs package contains man pages and examples for
43developing applications that use %{name}.
44
45## to build compat32 for x86_64 architecture support
46%package -n compat32-%{name}
47Summary: A library implementing the SSH2 protocol
48Summary(ja): SSH2 プロトコルを実装するためのライブラリ
49Group: System Environment/Libraries
50
51%description -n compat32-%{name}
52libssh2 is a library implementing the SSH2 protocol as defined by
53Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
54SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
55SECSH-DHGEX(04), and SECSH-NUMBERS(10).
56
57
58%prep
59%setup -q
60
61# make sure things are UTF-8...
62for i in ChangeLog NEWS ; do
63    iconv --from=ISO-8859-1 --to=UTF-8 $i > new
64    mv new $i
65done
66
67%build
68%configure --disable-static --enable-shared
69
70make %{?_smp_mflags}
71
72%install
73rm -rf %{buildroot}
74
75make install DESTDIR=%{buildroot} INSTALL="install -p"
76find %{buildroot} -name '*.la' -exec rm -f {} +
77
78# clean things up a bit for packaging
79( cd example && make clean )
80rm -rf example/simple/.deps
81find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
82
83%check
84(cd tests && make check)
85
86%clean
87rm -rf %{buildroot}
88
89
90%post -p /sbin/ldconfig
91
92%postun -p /sbin/ldconfig
93
94%post -n compat32-%{name} -p /sbin/ldconfig
95
96%postun -n compat32-%{name} -p /sbin/ldconfig
97
98
99%files
100%defattr(-,root,root,-)
101%doc AUTHORS ChangeLog COPYING README NEWS
102%{_libdir}/*.so.*
103
104%files docs
105%defattr(-,root,root,-)
106%doc COPYING example/ docs/HACKING
107%{_mandir}/man?/*
108
109%files devel
110%defattr(-,root,root,-)
111%doc COPYING
112%{_includedir}/*
113%{_libdir}/*.so
114%{_libdir}/pkgconfig/libssh2.pc
115
116%if %{build_compat32}
117%files -n compat32-%{name}
118%defattr(-,root,root,-)
119%{_libdir}/*.so.*
120%endif
121
122%changelog
123* Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-1
124- new upstream release with security fixes
125
126* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
127- new upstream reelase
128- add compat32 package
129
130* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
131- new upstream release
132- fix %%files
133
134* Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
135- initial build for Vine Linux
136
137* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
138- rebuilt with new openssl
139
140* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
142
143* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
145
146* Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
147- update to 1.0
148
149* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
150- rebuild with new openssl
151
152* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
153- Autorebuild for GCC 4.3
154
155* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
156- rebuild for new openssl...
157
158* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
159- bump
160
161* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
162- add INSTALL arg to make install vs env. var
163
164* Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
165- run tests; don't package test
166
167* Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
168- split docs into -docs (they seemed... large.)
169
170* Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
171- update to 0.18
172
173* Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
174- update to 0.17
175- many spec file changes
176
177* Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
178- Fix release tag
179- Move manpages to -devel package
180- Add Examples dir to -devel package
181
182* Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
183- Initial build
Note: See TracBrowser for help on using the repository browser.