source: projects/specs/trunk/lib/libs/libssh/libssh-vl.spec @ 12447

Revision 12447, 4.7 KB checked in by tomop, 4 years ago (diff)

libssh-0.9.4-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A library implementing the SSH2 protocol
4Summary(ja):    SSH2プロトコルを実装するためのライブラリ
5Name:           libssh
6Version:        0.9.4
7Release:        2%{?_dist_release}
8Group:          System Environment/Libraries
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        LGPLv2+
13URL:            https://www.libssh.org/
14%global         shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
15Source0:        https://www.libssh.org/files/%{shortver}/%{name}-%{version}.tar.xz
16
17# security fix
18# Nothing so far.
19# Patch100:             libssh-0.4.8-pkgconfig.patch
20Patch1000:      CVE-2020-16135-1.patch
21Patch1001:      CVE-2020-16135-2.patch
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-root
24
25BuildRequires:  openssl-devel
26BuildRequires:  zlib-devel
27BuildRequires:  cmake
28
29%description
30The SSH library with
31- Full C library functions for manipulating a client-side SSH connection
32- Fully configurable sessions
33- Support for AES-128,AES-192,AES-256,blowfish, in cbc mode
34- use multiple SSH connections in a same process, at same time.
35- usable SFTP implementation
36- Public key and password authentication
37
38%package devel
39Summary:         Development files for %{name}
40Summary(ja):     %{name} の開発ファイル
41Group:           Development/Libraries
42Requires:        %{name} = %{version}-%{release}
43Requires:        pkgconfig
44
45%description devel
46The %{name}-devel package contains libraries and header files for
47developing applications that use %{name}.
48
49%package -n compat32-%{name}
50Summary:        A library implementing the SSH2 protocol
51Summary(ja):    SSH2プロトコルを実装するためのライブラリ
52Group:          System Environment/Libraries
53
54%description -n compat32-%{name}
55The SSH library with
56- Full C library functions for manipulating a client-side SSH connection
57- Fully configurable sessions
58- Support for AES-128,AES-192,AES-256,blowfish, in cbc mode
59- use multiple SSH connections in a same process, at same time.
60- usable SFTP implementation
61- Public key and password authentication
62
63%prep
64%setup -q
65%autopatch -p1
66
67%build
68mkdir -p %{_target_platform}
69pushd %{_target_platform}
70%cmake ..
71popd
72
73make %{?_smp_mflags} -C %{_target_platform}
74
75#configure --disable-static --enable-shared
76#make # doesn't build with %{?_smp_mflags}
77
78%install
79[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
80
81make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -p /sbin/ldconfig
87
88%postun -p /sbin/ldconfig
89
90%files
91%defattr(-,root,root,-)
92%license COPYING
93%doc AUTHORS ChangeLog README
94%{_libdir}/*.so.*
95
96%files devel
97%defattr(-,root,root,-)
98%{_includedir}/*
99%{_libdir}/*.so
100%{_libdir}/pkgconfig/%{name}*.pc
101%dir %{_libdir}/cmake/
102%{_libdir}/cmake/libssh/
103
104%if %{build_compat32}
105%files -n compat32-%{name}
106%{_libdir}/*.so.*
107%endif
108
109%changelog
110* Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.4-2
111- added Patch1000 and 1001 to fix CVE-2020-16135.
112
113* Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.4-1
114- new upstream release.
115
116* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.3-1
117- new upstream release.
118- dropped Patch0: fixed in upstream.
119
120* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.5-1
121- new upstream release.
122- built with openssl-1.1.1.
123- added cmake support.
124- added a sub-package 'compat32-libssh'.
125
126* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-2
127- rebuilt with openssl 1.0.2g
128
129* Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-1
130- new upstream release with security fixes
131
132* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.8-3
133- add Patch100 (libssh-0.4.8-pkgconfig.patch)
134
135* Mon Dec  3 2012 IWAI, Masaharu <iwai@alib.jp> 0.4.8-2
136- SECURITY FIX:
137 - add patches from Debian libssh 0.4.5-3+squeeze1
138  - CVE-2012-4559.patch (Patch10)
139  - CVE-2012-4561.patch (Patch11)
140  - CVE-2012-4562.patch (Patch12)
141 - add patch based Red Hat BTS #871614
142  - CVE-2012-4560.patch (Patch13)
143
144* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.8-1
145- new upstream release
146
147* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.4-1
148- new upstream release
149
150* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.1-1
151- new upstream release
152
153* Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2-1
154- initial build for Vine Linux
155
156* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.2-4
157- rebuilt with new openssl
158
159* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-3
160- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
161
162* Tue Jun 02 2009 Jan F. Chadima <jchadima@redhat.com> - 0.2-2
163- Small changes during review
164
165* Mon Jun 01 2009 Jan F. Chadima <jchadima@redhat.com> - 0.2-1
166- Initial build
Note: See TracBrowser for help on using the repository browser.