source: projects/specs/trunk/lib/libs/libssh/libssh-vl.spec @ 12373

Revision 12373, 4.5 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

dhcp-4.1.ESV.R16-1

libssh-0.9.4-1

orc-0.4.31-1

rpcbind-1.2.5-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A library implementing the SSH2 protocol
4Summary(ja):    SSH2プロトコルを実装するためのライブラリ
5Name:           libssh
6Version:        0.9.4
7Release:        1%{?_dist_release}
8Group:          System Environment/Libraries
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        LGPLv2+
13URL:            https://www.libssh.org/
14%global         shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
15Source0:        https://www.libssh.org/files/%{shortver}/%{name}-%{version}.tar.xz
16
17# security fix
18# Nothing so far.
19# Patch100:             libssh-0.4.8-pkgconfig.patch
20
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
24BuildRequires:  openssl-devel
25BuildRequires:  zlib-devel
26BuildRequires:  cmake
27
28%description
29The SSH library with
30- Full C library functions for manipulating a client-side SSH connection
31- Fully configurable sessions
32- Support for AES-128,AES-192,AES-256,blowfish, in cbc mode
33- use multiple SSH connections in a same process, at same time.
34- usable SFTP implementation
35- Public key and password authentication
36
37%package devel
38Summary:         Development files for %{name}
39Summary(ja):     %{name} の開発ファイル
40Group:           Development/Libraries
41Requires:        %{name} = %{version}-%{release}
42Requires:        pkgconfig
43
44%description devel
45The %{name}-devel package contains libraries and header files for
46developing applications that use %{name}.
47
48%package -n compat32-%{name}
49Summary:        A library implementing the SSH2 protocol
50Summary(ja):    SSH2プロトコルを実装するためのライブラリ
51Group:          System Environment/Libraries
52
53%description -n compat32-%{name}
54The SSH library with
55- Full C library functions for manipulating a client-side SSH connection
56- Fully configurable sessions
57- Support for AES-128,AES-192,AES-256,blowfish, in cbc mode
58- use multiple SSH connections in a same process, at same time.
59- usable SFTP implementation
60- Public key and password authentication
61
62%prep
63%setup -q
64
65%build
66mkdir -p %{_target_platform}
67pushd %{_target_platform}
68%cmake ..
69popd
70
71make %{?_smp_mflags} -C %{_target_platform}
72
73#configure --disable-static --enable-shared
74#make # doesn't build with %{?_smp_mflags}
75
76%install
77[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
78
79make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(-,root,root,-)
90%license COPYING
91%doc AUTHORS ChangeLog README
92%{_libdir}/*.so.*
93
94%files devel
95%defattr(-,root,root,-)
96%{_includedir}/*
97%{_libdir}/*.so
98%{_libdir}/pkgconfig/%{name}*.pc
99%dir %{_libdir}/cmake/
100%{_libdir}/cmake/libssh/
101
102%if %{build_compat32}
103%files -n compat32-%{name}
104%{_libdir}/*.so.*
105%endif
106
107%changelog
108* Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.4-1
109- new upstream release.
110
111* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.3-1
112- new upstream release.
113- dropped Patch0: fixed in upstream.
114
115* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.5-1
116- new upstream release.
117- built with openssl-1.1.1.
118- added cmake support.
119- added a sub-package 'compat32-libssh'.
120
121* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-2
122- rebuilt with openssl 1.0.2g
123
124* Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-1
125- new upstream release with security fixes
126
127* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.8-3
128- add Patch100 (libssh-0.4.8-pkgconfig.patch)
129
130* Mon Dec  3 2012 IWAI, Masaharu <iwai@alib.jp> 0.4.8-2
131- SECURITY FIX:
132 - add patches from Debian libssh 0.4.5-3+squeeze1
133  - CVE-2012-4559.patch (Patch10)
134  - CVE-2012-4561.patch (Patch11)
135  - CVE-2012-4562.patch (Patch12)
136 - add patch based Red Hat BTS #871614
137  - CVE-2012-4560.patch (Patch13)
138
139* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.8-1
140- new upstream release
141
142* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.4-1
143- new upstream release
144
145* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.1-1
146- new upstream release
147
148* Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2-1
149- initial build for Vine Linux
150
151* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.2-4
152- rebuilt with new openssl
153
154* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-3
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
156
157* Tue Jun 02 2009 Jan F. Chadima <jchadima@redhat.com> - 0.2-2
158- Small changes during review
159
160* Mon Jun 01 2009 Jan F. Chadima <jchadima@redhat.com> - 0.2-1
161- Initial build
Note: See TracBrowser for help on using the repository browser.