source: projects/specs/trunk/lib/libs/libsndfile/libsndfile-vl.spec @ 7638

Revision 7638, 6.5 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define OCT_SITE_D %{_datadir}/octave/site/m
3
4Summary: A library to handle various audio file formats.
5Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
6Name: libsndfile
7Version: 1.0.25
8Release: 1%{?_dist_release}
9Source: http://www.mega-nerd.com/libsndfile/%{name}-%{version}.tar.gz
10License: LGPL
11Group: System Environment/Libraries
12URL: http://www.mega-nerd.com/libsndfile/
13
14# security fix
15# Patch100: libsndfile-1.0.16_CVE-2007-4974.patch
16# Patch110: libsndfile-1.0.20_fix-dev-by-zero.patch
17Patch100: libsndfile-1.0.21_CVE-2011-2696.patch
18
19Requires: alsa-lib
20BuildRequires: alsa-lib-devel
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27libsndfile is a C library for reading and writing sound files such as
28AIFF, AU and WAV files through one standard interface. It can currently
29read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
30point WAV files and a number of compressed formats.
31
32%description -l ja
33libsndfile is a C library for reading and writing sound files such as
34AIFF, AU and WAV files through one standard interface. It can currently
35read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
36point WAV files and a number of compressed formats.
37
38
39%package devel
40Summary: Libraries, includes, etc to develop libsndfile applications
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43
44%description devel
45Libraries, include files, etc you can use to develop libsndfile applications.
46
47%description devel -l ja
48Libraries, include files, etc you can use to develop libsndfile applications.
49
50
51# compat32
52%package -n compat32-%{name}
53Summary: A library to handle various audio file formats.
54Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
55Group: System Environment/Libraries
56
57%description -n compat32-%{name}
58libsndfile is a C library for reading and writing sound files such as
59AIFF, AU and WAV files through one standard interface. It can currently
60read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
61point WAV files and a number of compressed formats.
62
63%description -n compat32-%{name} -l ja
64libsndfile is a C library for reading and writing sound files such as
65AIFF, AU and WAV files through one standard interface. It can currently
66read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
67point WAV files and a number of compressed formats.
68
69
70%package -n compat32-%{name}-devel
71Summary: Libraries, includes, etc to develop libsndfile applications
72Group: Development/Libraries
73Requires: compat32-%{name} = %{version}-%{release}
74Requires: %{name}-devel = %{version}-%{release}
75
76%description -n compat32-%{name}-devel
77Libraries, include files, etc you can use to develop libsndfile applications.
78
79%description -n compat32-%{name}-devel -l ja
80Libraries, include files, etc you can use to develop libsndfile applications.
81
82
83%prep
84%setup -q
85
86# security fix
87# %patch100 -p1 -b .CVE-2007-4974
88# %patch110 -p0 -b .dev-by-zero
89%patch100 -p1 -b .CVE-2011-2696
90
91%build
92%configure --disable-sqlite --disable-external-libs --disable-octave
93%__make %{?_smp_mflags}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97# htmldir=$RPM_BUILD_ROOT\$\(htmldocdir\) libsndfile1-dev
98%makeinstall \
99  htmldir=$RPM_BUILD_ROOT%{_datadir}/doc/libsndfile1-dev
100
101rm -rf html
102cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile1-dev html
103rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile1-dev
104
105rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post -p /sbin/ldconfig
111
112%postun -p /sbin/ldconfig
113
114%post -n compat32-%{name} -p /sbin/ldconfig
115
116%postun -n compat32-%{name} -p /sbin/ldconfig
117
118
119%files
120%defattr(-,root,root)
121%doc AUTHORS COPYING ChangeLog INSTALL NEWS README html
122%{_libdir}/libsndfile.so.*
123%{_bindir}/*
124%{_mandir}/man1/*
125# %{_datadir}/octave/site/m/*
126
127%files devel
128%defattr(-,root,root)
129%{_libdir}/libsndfile.so
130%{_includedir}/*
131%{_libdir}/pkgconfig/sndfile.pc
132
133# compat32
134%if %{build_compat32}
135%files -n compat32-%{name}
136%defattr(-,root,root)
137%{_libdir}/libsndfile.so.*
138
139%files -n compat32-%{name}-devel
140%defattr(-,root,root)
141%{_libdir}/libsndfile.so
142%{_libdir}/pkgconfig/sndfile.pc
143%endif
144
145
146%changelog
147* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.25-1
148- new upstream release
149
150* Sun Jul 31 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-3
151- change spec filename (-vl)
152
153* Sat Jul 30 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-2
154- add patch100 for fix CVE-2011-2696 (IOF) from debian, thanks.
155
156* Wed Sep 22 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.21-1
157- new upstream release
158- built with rpm-4.8.1-1
159
160* Mon Jun  1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.20-1vl5
161- new upstream release with security fix (CVE-2009-1788, 1791)
162- add patch110 to fix devide by 0 issues
163- drop patch100 (is included in new release)
164- change configure option to fix new release
165- revome "TODO" file from file list
166
167* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.17-3
168- added compat32 package for x86_64 arch support
169
170* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.17-2
171- spec in utf-8
172- remove static lib
173
174* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.17-1vl5
175- applied new versioning policy
176- removed lib*.la file from devel package
177
178* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl2
179- rebuild for VineSeed
180
181* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl1
182- new upstream release
183
184* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.16-0vl3.1
185- add patch100 for fix CVE-2007-4974 (PCM Data Handling Buffer Overflow)
186- built for VinePlus 4.x
187
188* Fri Nov 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.16-0vl3
189- add BuildRequires: alsa-lib-devel
190- add '--disable-sqlite --disable-flac' options to %%configure
191
192* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl2
193- rebuilt for VineSeed Plus
194
195* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl1
196- new upstream release
197- fixed Japanese summary
198
199* Wed Feb 08 2006 Atsushi SHICHI <ats7@a.email.ne.jp> 1.0.13-1vl1
200- initial build for VinePlus/3.0
201- modified spec file
202
203* Sun May 15 2005 Erik de Castro Lopo <erikd@mega-nerd.com>
204- Add html files to the files section.
205
206* Tue Sep 16 2003 Erik de Castro Lopo <erikd@mega-nerd.com>
207- Apply corrections from Andrew Schultz.
208
209* Mon Oct 21 2002 Erik de Castro Lopo <erikd@mega-nerd.com>
210- Force installation of sndfile.pc file.
211
212* Thu Jul 6 2000 Josh Green <jgreen@users.sourceforge.net>
213- Created libsndfile.spec.in
214
215
216# end of file
Note: See TracBrowser for help on using the repository browser.