source: projects/specs/trunk/lib/libs/libsndfile/libsndfile-vl.spec @ 12278

Revision 12278, 8.1 KB checked in by tomop, 5 years ago (diff)

updated 8 packages

apr-1.7.0-1

busybox-1.30.1-1

file-5.37-1

libgsf-1.14.46-1

libsndfile-1.0.28-2

subversion-1.12.2-1

uClibc-ng-1.0.32-1

wireshark-3.0.5-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A library to handle various audio file formats.
4Summary(ja):    さまざまなフォーマットの音声ファイルを扱うライブラリ
5Name:           libsndfile
6Version:        1.0.28
7Release:        2%{?_dist_release}
8
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        LGPLv2+ and GPLv2+ and BSD
13Group:          System Environment/Libraries
14URL:            http://www.mega-nerd.com/libsndfile/
15
16Source0:        http://www.mega-nerd.com/libsndfile/files/%{name}-%{version}.tar.gz
17
18Patch0:         %{name}-1.0.25-system-gsm.patch
19Patch1:         libsndfile-1.0.25-zerodivfix.patch
20
21# security fix
22Patch100:       CVE-2017-8365.patch
23Patch101:       CVE-2017-8363.patch
24Patch102:       CVE-2017-8362.patch
25Patch103:       CVE-2017-6892.patch
26Patch104:       CVE-2019-3832.patch
27Patch105:       binheader-heapoverflow.patch
28Patch106:       fix_rf64_arm.patch
29Patch107:       fix_typos.patch
30Patch108:       a-ulaw-fix-multiple-buffer-overflows-432.patch
31Patch109:       double64_init-Check-psf-sf.channels-against-upper-bo.patch
32Patch110:       src-wav.c-Fix-heap-read-overflow.patch
33Patch111:       Check-MAX_CHANNELS-in-sndfile-deinterleave.patch
34
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37BuildRequires:  alsa-lib-devel
38BuildRequires:  flac-devel
39BuildRequires:  libogg-devel
40BuildRequires:  libvorbis-devel
41BuildRequires:  pkgconfig
42BuildRequires:  sqlite3-devel
43BuildRequires:  gsm-devel
44
45
46%description
47libsndfile is a C library for reading and writing sound files such as
48AIFF, AU and WAV files through one standard interface. It can currently
49read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
50point WAV files and a number of compressed formats.
51
52
53%package devel
54Summary: Libraries, includes, etc to develop libsndfile applications
55Summary(ja): libsndfile アプリケーションを開発するためのファイル集
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58Requires: pkgconfig
59
60%description devel
61Libraries, include files, etc you can use to develop libsndfile applications.
62
63
64# compat32
65%package -n compat32-%{name}
66Summary: A library to handle various audio file formats.
67Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
68Group: System Environment/Libraries
69
70%description -n compat32-%{name}
71libsndfile is a C library for reading and writing sound files such as
72AIFF, AU and WAV files through one standard interface. It can currently
73read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
74point WAV files and a number of compressed formats.
75
76
77%package -n compat32-%{name}-devel
78Summary: Libraries, includes, etc to develop libsndfile applications
79Summary(ja): libsndfile アプリケーションを開発するためのファイル集
80Group: Development/Libraries
81Requires: compat32-%{name} = %{version}-%{release}
82Requires: compat32-pkgconfig
83Requires: %{name}-devel = %{version}-%{release}
84
85%description -n compat32-%{name}-devel
86Libraries, include files, etc you can use to develop libsndfile applications.
87
88
89%prep
90%autosetup -p1
91
92rm -r src/GSM610 ; autoreconf -I M4 -fiv # for system-gsm patch
93
94%build
95%configure \
96        --disable-dependency-tracking \
97        --enable-sqlite \
98        --enable-alsa \
99        --enable-largefile \
100        --disable-static
101
102# Get rid of rpath
103sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
104sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
105
106make %{?_smp_mflags}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110make install DESTDIR=$RPM_BUILD_ROOT
111
112rm -rf html
113cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile html
114rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile
115
116rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
117
118
119# fix multilib issues
120%if %{__isa_bits} == 64
121%define wordsize 64
122%else
123%define wordsize 32
124%endif
125
126mv $RPM_BUILD_ROOT%{_includedir}/sndfile.h \
127   $RPM_BUILD_ROOT%{_includedir}/sndfile-%{wordsize}.h
128
129cat > $RPM_BUILD_ROOT%{_includedir}/sndfile.h <<EOF
130#include <bits/wordsize.h>
131
132#if __WORDSIZE == 32
133# include "sndfile-32.h"
134#elif __WORDSIZE == 64
135# include "sndfile-64.h"
136#else
137# error "unexpected value for __WORDSIZE macro"
138#endif
139EOF
140
141%check
142LD_LIBRARY_PATH=$PWD/src/.libs make check
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post -p /sbin/ldconfig
148
149%postun -p /sbin/ldconfig
150
151%if %{build_compat32}
152%post -n compat32-%{name} -p /sbin/ldconfig
153
154%postun -n compat32-%{name} -p /sbin/ldconfig
155%endif
156
157%files
158%defattr(-,root,root)
159%license COPYING
160%doc AUTHORS ChangeLog NEWS README*
161%{_libdir}/libsndfile.so.*
162%{_bindir}/*
163%{_mandir}/man1/*
164
165%files devel
166%defattr(-,root,root)
167%doc html/*
168%{_libdir}/libsndfile.so
169%{_includedir}/sndfile.h
170%{_includedir}/sndfile.hh
171%{_includedir}/sndfile-%{wordsize}.h
172%{_libdir}/pkgconfig/sndfile.pc
173
174# compat32
175%if %{build_compat32}
176%files -n compat32-%{name}
177%defattr(-,root,root)
178%{_libdir}/libsndfile.so.*
179
180%files -n compat32-%{name}-devel
181%defattr(-,root,root)
182%{_includedir}/sndfile-%{wordsize}.h
183%{_libdir}/libsndfile.so
184%{_libdir}/pkgconfig/sndfile.pc
185%endif
186
187
188%changelog
189* Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.28-2
190- removed a comment in %%postun script.
191
192* Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.28-1
193- new upstream release.
194- dropped Patch100-101.
195- imported Patch100-111 from debian.
196
197* Wed Feb 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.25-2
198- added Patch0, 1 and 101 from Fedora
199  * Tue Jan 13 2015 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-14
200  - fix CVE-2014-9496: 2 buffer overruns in sd2_parse_rsrc_fork (#1178840)
201  - division by zero leading to denial of service in psf_fwrite (#1177254)
202  * Sat Nov 12 2011 Ville Skyttä <ville.skytta@iki.fi> - 1.0.25-2
203  - Patch to use system libgsm instead of a bundled copy.
204- added BR: flac-devel, libogg-devel, libvorbis-devel, pkgconfig,
205  sqlite3-devel and gsm-devel
206
207* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.25-1
208- new upstream release
209
210* Sun Jul 31 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-3
211- change spec filename (-vl)
212
213* Sat Jul 30 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-2
214- add patch100 for fix CVE-2011-2696 (IOF) from debian, thanks.
215
216* Wed Sep 22 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.21-1
217- new upstream release
218- built with rpm-4.8.1-1
219
220* Mon Jun  1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.20-1vl5
221- new upstream release with security fix (CVE-2009-1788, 1791)
222- add patch110 to fix devide by 0 issues
223- drop patch100 (is included in new release)
224- change configure option to fix new release
225- revome "TODO" file from file list
226
227* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.17-3
228- added compat32 package for x86_64 arch support
229
230* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.17-2
231- spec in utf-8
232- remove static lib
233
234* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.17-1vl5
235- applied new versioning policy
236- removed lib*.la file from devel package
237
238* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl2
239- rebuild for VineSeed
240
241* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl1
242- new upstream release
243
244* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.16-0vl3.1
245- add patch100 for fix CVE-2007-4974 (PCM Data Handling Buffer Overflow)
246- built for VinePlus 4.x
247
248* Fri Nov 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.16-0vl3
249- add BuildRequires: alsa-lib-devel
250- add '--disable-sqlite --disable-flac' options to %%configure
251
252* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl2
253- rebuilt for VineSeed Plus
254
255* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl1
256- new upstream release
257- fixed Japanese summary
258
259* Wed Feb 08 2006 Atsushi SHICHI <ats7@a.email.ne.jp> 1.0.13-1vl1
260- initial build for VinePlus/3.0
261- modified spec file
262
263* Sun May 15 2005 Erik de Castro Lopo <erikd@mega-nerd.com>
264- Add html files to the files section.
265
266* Tue Sep 16 2003 Erik de Castro Lopo <erikd@mega-nerd.com>
267- Apply corrections from Andrew Schultz.
268
269* Mon Oct 21 2002 Erik de Castro Lopo <erikd@mega-nerd.com>
270- Force installation of sndfile.pc file.
271
272* Thu Jul 6 2000 Josh Green <jgreen@users.sourceforge.net>
273- Created libsndfile.spec.in
274
275
276# end of file
Note: See TracBrowser for help on using the repository browser.