source: projects/specs/trunk/lib/libs/libsndfile/libsndfile-vl.spec @ 1870

Revision 1870, 6.1 KB checked in by shaolin, 14 years ago (diff)
  • libsndfile: rebuilt w/ rpm-4.8.1-1
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define OCT_SITE_D %{_datadir}/octave/site/m
3
4Summary: A library to handle various audio file formats.
5Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
6Name: libsndfile
7Version: 1.0.21
8Release: 1%{?_dist_release}
9Source: http://www.mega-nerd.com/libsndfile/%{name}-%{version}.tar.gz
10License: LGPL
11Group: System Environment/Libraries
12URL: http://www.mega-nerd.com/libsndfile/
13
14# security fix
15# Patch100: libsndfile-1.0.16_CVE-2007-4974.patch
16# Patch110: libsndfile-1.0.20_fix-dev-by-zero.patch
17
18Requires: alsa-lib
19BuildRequires: alsa-lib-devel
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26libsndfile is a C library for reading and writing sound files such as
27AIFF, AU and WAV files through one standard interface. It can currently
28read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
29point WAV files and a number of compressed formats.
30
31%description -l ja
32libsndfile is a C library for reading and writing sound files such as
33AIFF, AU and WAV files through one standard interface. It can currently
34read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
35point WAV files and a number of compressed formats.
36
37
38%package devel
39Summary: Libraries, includes, etc to develop libsndfile applications
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44Libraries, include files, etc you can use to develop libsndfile applications.
45
46%description devel -l ja
47Libraries, include files, etc you can use to develop libsndfile applications.
48
49
50# compat32
51%package -n compat32-%{name}
52Summary: A library to handle various audio file formats.
53Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
54Group: System Environment/Libraries
55
56%description -n compat32-%{name}
57libsndfile is a C library for reading and writing sound files such as
58AIFF, AU and WAV files through one standard interface. It can currently
59read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
60point WAV files and a number of compressed formats.
61
62%description -n compat32-%{name} -l ja
63libsndfile is a C library for reading and writing sound files such as
64AIFF, AU and WAV files through one standard interface. It can currently
65read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
66point WAV files and a number of compressed formats.
67
68
69%package -n compat32-%{name}-devel
70Summary: Libraries, includes, etc to develop libsndfile applications
71Group: Development/Libraries
72Requires: compat32-%{name} = %{version}-%{release}
73Requires: %{name}-devel = %{version}-%{release}
74
75%description -n compat32-%{name}-devel
76Libraries, include files, etc you can use to develop libsndfile applications.
77
78%description -n compat32-%{name}-devel -l ja
79Libraries, include files, etc you can use to develop libsndfile applications.
80
81
82%prep
83%setup -q
84
85# security fix
86# %patch100 -p1 -b .CVE-2007-4974
87# %patch110 -p0 -b .dev-by-zero
88
89%build
90%configure --disable-sqlite --disable-external-libs --disable-octave
91%__make %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95# htmldir=$RPM_BUILD_ROOT\$\(htmldocdir\) libsndfile1-dev
96%makeinstall \
97  htmldir=$RPM_BUILD_ROOT%{_datadir}/doc/libsndfile1-dev
98
99rm -rf html
100cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile1-dev html
101rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile1-dev
102
103rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109
110%postun -p /sbin/ldconfig
111
112%post -n compat32-%{name} -p /sbin/ldconfig
113
114%postun -n compat32-%{name} -p /sbin/ldconfig
115
116
117%files
118%defattr(-,root,root)
119%doc AUTHORS COPYING ChangeLog INSTALL NEWS README html
120%{_libdir}/libsndfile.so.*
121%{_bindir}/*
122%{_mandir}/man1/*
123# %{_datadir}/octave/site/m/*
124
125%files devel
126%defattr(-,root,root)
127%{_libdir}/libsndfile.so
128%{_includedir}/*
129%{_libdir}/pkgconfig/sndfile.pc
130
131# compat32
132%if %{build_compat32}
133%files -n compat32-%{name}
134%defattr(-,root,root)
135%{_libdir}/libsndfile.so.*
136
137%files -n compat32-%{name}-devel
138%defattr(-,root,root)
139%{_libdir}/libsndfile.so
140%{_libdir}/pkgconfig/sndfile.pc
141%endif
142
143
144%changelog
145* Wed Sep 22 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.21-1
146- new upstream release
147- built with rpm-4.8.1-1
148
149* Mon Jun  1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.20-1vl5
150- new upstream release with security fix (CVE-2009-1788, 1791)
151- add patch110 to fix devide by 0 issues
152- drop patch100 (is included in new release)
153- change configure option to fix new release
154- revome "TODO" file from file list
155
156* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.17-3
157- added compat32 package for x86_64 arch support
158
159* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.17-2
160- spec in utf-8
161- remove static lib
162
163* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.17-1vl5
164- applied new versioning policy
165- removed lib*.la file from devel package
166
167* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl2
168- rebuild for VineSeed
169
170* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl1
171- new upstream release
172
173* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.16-0vl3.1
174- add patch100 for fix CVE-2007-4974 (PCM Data Handling Buffer Overflow)
175- built for VinePlus 4.x
176
177* Fri Nov 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.16-0vl3
178- add BuildRequires: alsa-lib-devel
179- add '--disable-sqlite --disable-flac' options to %%configure
180
181* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl2
182- rebuilt for VineSeed Plus
183
184* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl1
185- new upstream release
186- fixed Japanese summary
187
188* Wed Feb 08 2006 Atsushi SHICHI <ats7@a.email.ne.jp> 1.0.13-1vl1
189- initial build for VinePlus/3.0
190- modified spec file
191
192* Sun May 15 2005 Erik de Castro Lopo <erikd@mega-nerd.com>
193- Add html files to the files section.
194
195* Tue Sep 16 2003 Erik de Castro Lopo <erikd@mega-nerd.com>
196- Apply corrections from Andrew Schultz.
197
198* Mon Oct 21 2002 Erik de Castro Lopo <erikd@mega-nerd.com>
199- Force installation of sndfile.pc file.
200
201* Thu Jul 6 2000 Josh Green <jgreen@users.sourceforge.net>
202- Created libsndfile.spec.in
203
204
205# end of file
Note: See TracBrowser for help on using the repository browser.