source: projects/specs/trunk/lib/libs/libsndfile/libsndfile-vl.spec @ 12277

Revision 12277, 8.0 KB checked in by tomop, 5 years ago (diff)

updated 22 packages

Cython-0.29.13-1

alsa-lib-1.1.9-1

alsa-plugins-1.1.9-1

alsa-tools-1.1.7-1

alsa-utils-1.1.9-1

cairo-1.16.0-1

evince-3.30.3-1

expat-2.2.9-1

file-roller-3.30.1-1

gtk-doc-1.32-2

libplist-2.0.0-1

libsndfile-1.0.28-1

ncurses-6.1-2

openssh-8.1p1-1

python-2.7.16-5

python3-3.5.7-4

rsync-3.1.3-1

samba-4.10.9-1

sudo-1.8.28-1

sysstat-12.1.7-1

tix-8.4.3-5

zabbix-4.0.13-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A library to handle various audio file formats.
4Summary(ja):    さまざまなフォーマットの音声ファイルを扱うライブラリ
5Name:           libsndfile
6Version:        1.0.28
7Release:        1%{?_dist_release}
8
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        LGPLv2+ and GPLv2+ and BSD
13Group:          System Environment/Libraries
14URL:            http://www.mega-nerd.com/libsndfile/
15
16Source0:        http://www.mega-nerd.com/libsndfile/files/%{name}-%{version}.tar.gz
17
18Patch0:         %{name}-1.0.25-system-gsm.patch
19Patch1:         libsndfile-1.0.25-zerodivfix.patch
20
21# security fix
22Patch100:       CVE-2017-8365.patch
23Patch101:       CVE-2017-8363.patch
24Patch102:       CVE-2017-8362.patch
25Patch103:       CVE-2017-6892.patch
26Patch104:       CVE-2019-3832.patch
27Patch105:       binheader-heapoverflow.patch
28Patch106:       fix_rf64_arm.patch
29Patch107:       fix_typos.patch
30Patch108:       a-ulaw-fix-multiple-buffer-overflows-432.patch
31Patch109:       double64_init-Check-psf-sf.channels-against-upper-bo.patch
32Patch110:       src-wav.c-Fix-heap-read-overflow.patch
33Patch111:       Check-MAX_CHANNELS-in-sndfile-deinterleave.patch
34
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37BuildRequires:  alsa-lib-devel
38BuildRequires:  flac-devel
39BuildRequires:  libogg-devel
40BuildRequires:  libvorbis-devel
41BuildRequires:  pkgconfig
42BuildRequires:  sqlite3-devel
43BuildRequires:  gsm-devel
44
45
46%description
47libsndfile is a C library for reading and writing sound files such as
48AIFF, AU and WAV files through one standard interface. It can currently
49read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
50point WAV files and a number of compressed formats.
51
52
53%package devel
54Summary: Libraries, includes, etc to develop libsndfile applications
55Summary(ja): libsndfile アプリケーションを開発するためのファイル集
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58Requires: pkgconfig
59
60%description devel
61Libraries, include files, etc you can use to develop libsndfile applications.
62
63
64# compat32
65%package -n compat32-%{name}
66Summary: A library to handle various audio file formats.
67Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
68Group: System Environment/Libraries
69
70%description -n compat32-%{name}
71libsndfile is a C library for reading and writing sound files such as
72AIFF, AU and WAV files through one standard interface. It can currently
73read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
74point WAV files and a number of compressed formats.
75
76
77%package -n compat32-%{name}-devel
78Summary: Libraries, includes, etc to develop libsndfile applications
79Summary(ja): libsndfile アプリケーションを開発するためのファイル集
80Group: Development/Libraries
81Requires: compat32-%{name} = %{version}-%{release}
82Requires: compat32-pkgconfig
83Requires: %{name}-devel = %{version}-%{release}
84
85%description -n compat32-%{name}-devel
86Libraries, include files, etc you can use to develop libsndfile applications.
87
88
89%prep
90%autosetup -p1
91
92rm -r src/GSM610 ; autoreconf -I M4 -fiv # for system-gsm patch
93
94%build
95%configure \
96        --disable-dependency-tracking \
97        --enable-sqlite \
98        --enable-alsa \
99        --enable-largefile \
100        --disable-static
101
102# Get rid of rpath
103sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
104sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
105
106make %{?_smp_mflags}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110make install DESTDIR=$RPM_BUILD_ROOT
111
112rm -rf html
113cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile html
114rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile
115
116rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
117
118
119# fix multilib issues
120%if %{__isa_bits} == 64
121%define wordsize 64
122%else
123%define wordsize 32
124%endif
125
126mv $RPM_BUILD_ROOT%{_includedir}/sndfile.h \
127   $RPM_BUILD_ROOT%{_includedir}/sndfile-%{wordsize}.h
128
129cat > $RPM_BUILD_ROOT%{_includedir}/sndfile.h <<EOF
130#include <bits/wordsize.h>
131
132#if __WORDSIZE == 32
133# include "sndfile-32.h"
134#elif __WORDSIZE == 64
135# include "sndfile-64.h"
136#else
137# error "unexpected value for __WORDSIZE macro"
138#endif
139EOF
140
141%check
142LD_LIBRARY_PATH=$PWD/src/.libs make check
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post -p /sbin/ldconfig
148
149%postun -p /sbin/ldconfig
150
151# compat32
152%if %{build_compat32}
153%post -n compat32-%{name} -p /sbin/ldconfig
154
155%postun -n compat32-%{name} -p /sbin/ldconfig
156%endif
157
158%files
159%defattr(-,root,root)
160%license COPYING
161%doc AUTHORS ChangeLog NEWS README*
162%{_libdir}/libsndfile.so.*
163%{_bindir}/*
164%{_mandir}/man1/*
165
166%files devel
167%defattr(-,root,root)
168%doc html/*
169%{_libdir}/libsndfile.so
170%{_includedir}/sndfile.h
171%{_includedir}/sndfile.hh
172%{_includedir}/sndfile-%{wordsize}.h
173%{_libdir}/pkgconfig/sndfile.pc
174
175# compat32
176%if %{build_compat32}
177%files -n compat32-%{name}
178%defattr(-,root,root)
179%{_libdir}/libsndfile.so.*
180
181%files -n compat32-%{name}-devel
182%defattr(-,root,root)
183%{_includedir}/sndfile-%{wordsize}.h
184%{_libdir}/libsndfile.so
185%{_libdir}/pkgconfig/sndfile.pc
186%endif
187
188
189%changelog
190* Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.28-1
191- new upstream release.
192- dropped Patch100-101.
193- imported Patch100-111 from debian.
194
195* Wed Feb 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.25-2
196- added Patch0, 1 and 101 from Fedora
197  * Tue Jan 13 2015 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-14
198  - fix CVE-2014-9496: 2 buffer overruns in sd2_parse_rsrc_fork (#1178840)
199  - division by zero leading to denial of service in psf_fwrite (#1177254)
200  * Sat Nov 12 2011 Ville Skyttä <ville.skytta@iki.fi> - 1.0.25-2
201  - Patch to use system libgsm instead of a bundled copy.
202- added BR: flac-devel, libogg-devel, libvorbis-devel, pkgconfig,
203  sqlite3-devel and gsm-devel
204
205* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.25-1
206- new upstream release
207
208* Sun Jul 31 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-3
209- change spec filename (-vl)
210
211* Sat Jul 30 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-2
212- add patch100 for fix CVE-2011-2696 (IOF) from debian, thanks.
213
214* Wed Sep 22 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.21-1
215- new upstream release
216- built with rpm-4.8.1-1
217
218* Mon Jun  1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.20-1vl5
219- new upstream release with security fix (CVE-2009-1788, 1791)
220- add patch110 to fix devide by 0 issues
221- drop patch100 (is included in new release)
222- change configure option to fix new release
223- revome "TODO" file from file list
224
225* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.17-3
226- added compat32 package for x86_64 arch support
227
228* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.17-2
229- spec in utf-8
230- remove static lib
231
232* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.17-1vl5
233- applied new versioning policy
234- removed lib*.la file from devel package
235
236* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl2
237- rebuild for VineSeed
238
239* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl1
240- new upstream release
241
242* Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.16-0vl3.1
243- add patch100 for fix CVE-2007-4974 (PCM Data Handling Buffer Overflow)
244- built for VinePlus 4.x
245
246* Fri Nov 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.16-0vl3
247- add BuildRequires: alsa-lib-devel
248- add '--disable-sqlite --disable-flac' options to %%configure
249
250* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl2
251- rebuilt for VineSeed Plus
252
253* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl1
254- new upstream release
255- fixed Japanese summary
256
257* Wed Feb 08 2006 Atsushi SHICHI <ats7@a.email.ne.jp> 1.0.13-1vl1
258- initial build for VinePlus/3.0
259- modified spec file
260
261* Sun May 15 2005 Erik de Castro Lopo <erikd@mega-nerd.com>
262- Add html files to the files section.
263
264* Tue Sep 16 2003 Erik de Castro Lopo <erikd@mega-nerd.com>
265- Apply corrections from Andrew Schultz.
266
267* Mon Oct 21 2002 Erik de Castro Lopo <erikd@mega-nerd.com>
268- Force installation of sndfile.pc file.
269
270* Thu Jul 6 2000 Josh Green <jgreen@users.sourceforge.net>
271- Created libsndfile.spec.in
272
273
274# end of file
Note: See TracBrowser for help on using the repository browser.