source: projects/specs/trunk/lib/libs/libsmbios/libsmbios-vl.spec @ 12371

Revision 12371, 7.9 KB checked in by tomop, 4 years ago (diff)

updated 11 packages

dbus-glib-0.110-1

dstat-0.7.4-1

firefox-68.7.0-1

iso-codes-4.4-1

kbd-2.2.0-1

libdb-5.3.28-12

libsmbios-2.4.3-1

par2cmdline-0.8.1-1

sgml-common-0.6.3-42

smem-1.5-1

thunderbird-68.7.0-1

Line 
1Name: libsmbios
2Version: 2.4.3
3Release: 1%{?_dist_release}
4Summary: Libsmbios C/C++ shared libraries
5Summary(ja): Libsmbios C/C++ 共有ライブラリ
6Group: System Environment/Libraries
7Vendor: Project Vine
8Distribution: Vine Linux
9Packager: shaolin, daisuke
10
11License: GPLv2+ or OSL 2.1
12URL: https://github.com/dell/libsmbios
13Source: https://github.com/dell/libsmbios/archive/v%{version}.tar.gz#/libsmbios-%{version}.tar.gz
14Source100: ChangeLog.fedora
15Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: strace libxml2-devel gcc-c++ gettext doxygen cppunit-devel pkgconfig python-devel
17Obsoletes: python-smbios < %{version}-%{release}
18
19# libsmbios only ever makes sense on intel compatible arches
20# no DMI tables on ppc, s390, etc.
21ExclusiveArch: x86_64 ia64 %{ix86}
22
23# these are all substituted by autoconf
24%define pot_file  libsmbios
25%define lang_dom  libsmbios-2.4-x86_64
26
27%define major %(echo %{version} | sed -e 's/^\\([0-9]*\\)\..*$/\\1/')
28%define minor %(echo %{version} | sed -e 's/^[0-9]*\\.\\([0-9]*\\).*$/\\1/')
29%define micro %(echo %{version} | sed -e 's/^[0-9]*\\.[0-9]*\\.\\([0-9]*\\).*$/\\1/')
30%define extra %{nil}
31
32%description
33Libsmbios is a library and utilities that can be used by client programs to get
34information from standard BIOS tables, such as the SMBIOS table.
35
36This package provides the C-based libsmbios library, with a C interface.
37
38This package also has a C++-based library, with a C++ interface. It is not
39actively maintained, but provided for backwards compatibility. New programs
40should use the libsmbios C interface.
41
42
43%package -n python3-smbios
44Summary: Python interface to Libsmbios C library
45Summary(ja): libsmbios C ライブラリへの Python インターフェース
46Group: System Environment/Libraries
47BuildRequires: python3-devel python3-setuptools python3-rpm-macros
48Requires: %{name} = %{version}-%{release}
49Requires: python3
50
51
52%description -n python3-smbios
53This package provides a Python interface to libsmbios
54
55%package -n smbios-utils
56Summary: Meta-package that pulls in all smbios binaries and python scripts
57Summary(ja): すべての smbios プログラムと python スクリプトをインストールするための仮想パッケージ
58Group: Applications/System
59Requires: smbios-utils-bin = %{version}-%{release}
60Requires: smbios-utils-python3 = %{version}-%{release}
61
62%description -n smbios-utils
63This is a meta-package that pulls in the binary libsmbios executables as well
64as the python executables.
65
66%package -n smbios-utils-bin
67Summary: Binary utilities that use libsmbios
68Summary(ja): libsmbios を用いたユーティリティ集
69Group: Applications/System
70Requires: %{name} = %{version}-%{release}
71
72%description -n smbios-utils-bin
73Get BIOS information, such as System product name, product id, service tag and
74asset tag.
75
76%package -n smbios-utils-python3
77Summary: Python executables that use libsmbios
78Summary(ja): libsmbios を用いた Python スクリプト集
79Group: Applications/System
80Requires: python3-smbios = %{version}-%{release}
81Obsoletes: smbios-utils-python < %{version}-%{release}
82Provides: smbios-utils-python = %{version}-%{release}
83
84%description -n smbios-utils-python3
85Get BIOS information, such as System product name, product id, service tag and
86asset tag. Set service and asset tags on Dell machines. Manipulate wireless
87cards/bluetooth on Dell laptops. Set BIOS password on select Dell systems.
88Update BIOS on select Dell systems. Set LCD brightness on select Dell laptops.
89
90# name the devel package libsmbios-devel regardless of package name, per suse/fedora convention
91%package -n libsmbios-devel
92Summary: Development headers and archives
93Summary(ja): libsmbios の開発用ヘッダファイルとライブラリ
94Group: Development/Libraries
95Requires: %{name} = %{version}-%{release}
96
97%description -n libsmbios-devel
98Libsmbios is a library and utilities that can be used by client programs to get
99information from standard BIOS tables, such as the SMBIOS table.
100
101This package contains the headers and .a files necessary to compile new client
102programs against libsmbios.
103
104%prep
105%setup -q -n libsmbios-%{version}
106find . -type d -exec chmod -f 755 {} \;
107find doc src -type f -exec chmod -f 644 {} \;
108chmod 755 src/cppunit/*.sh
109
110
111%build
112# this line lets us build an RPM directly from a git tarball
113# and retains any customized version information we might have
114[ -e ./configure ] || ./autogen.sh --no-configure
115
116mkdir _build
117cd _build
118echo '../configure "$@"' > configure
119chmod +x ./configure
120
121export PYTHON=%{__python3}
122%configure
123
124mkdir -p out/libsmbios_c
125mkdir -p out/libsmbios_c++
126make %{?_smp_mflags} 2>&1 | tee build-%{_arch}.log
127
128echo \%doc _build/build-%{_arch}.log > buildlogs.txt
129
130
131%install
132rm -rf %{buildroot}
133mkdir %{buildroot}
134
135cd _build
136TOPDIR=..
137make install DESTDIR=%{buildroot} INSTALL="%{__install} -p"
138mkdir -p %{buildroot}/%{_includedir}
139mkdir -p %{buildroot}/%{_bindir}
140cp -a $TOPDIR/src/include/*  %{buildroot}/%{_includedir}/
141cp -a out/public-include/*  %{buildroot}/%{_includedir}/
142rm -f %{buildroot}/%{_libdir}/lib*.{la,a}
143rm -f %{buildroot}/%{_includedir}/Makefile.am
144find %{buildroot}/%{_includedir} out/libsmbios_c++ out/libsmbios_c -exec touch -r $TOPDIR/configure.ac {} \;
145
146mv out/libsmbios_c++  out/libsmbios_c++-%{_arch}
147mv out/libsmbios_c    out/libsmbios_c-%{_arch}
148
149rename %{pot_file}.mo %{lang_dom}.mo $(find %{buildroot}/%{_datadir} -name %{pot_file}.mo)
150%find_lang %{lang_dom}
151
152touch files-yum-dellsysid
153touch files-smbios-utils-python3
154touch files-python3-smbios
155
156cat > files-python3-smbios <<-EOF
157        %{python3_sitearch}/*
158EOF
159
160cat > files-smbios-utils-python3 <<-EOF
161        %dir %{_sysconfdir}/libsmbios
162        %config(noreplace) %{_sysconfdir}/libsmbios/*
163       
164        # python utilities
165        %{_sbindir}/smbios-sys-info
166        %{_sbindir}/smbios-token-ctl
167        %{_sbindir}/smbios-passwd
168        %{_sbindir}/smbios-wakeup-ctl
169        %{_sbindir}/smbios-wireless-ctl
170        %{_sbindir}/smbios-lcd-brightness
171        %{_sbindir}/smbios-keyboard-ctl
172        %{_sbindir}/smbios-thermal-ctl
173        %{_sbindir}/smbios-battery-ctl
174
175        # data files
176        %{_datadir}/smbios-utils
177EOF
178
179%clean
180rm -rf %{buildroot}
181
182%post   -p /sbin/ldconfig
183%postun -p /sbin/ldconfig
184
185%files -f _build/%{lang_dom}.lang
186%defattr(-,root,root,-)
187%license COPYING* src/bin/getopts_LICENSE.txt src/include/smbios_c/config/boost_LICENSE_1_0_txt
188%doc README*
189%{_libdir}/libsmbios_c.so.*
190
191%files -n libsmbios-devel -f _build/buildlogs.txt
192%defattr(-,root,root,-)
193%{_includedir}/smbios
194%{_includedir}/smbios_c
195%{_libdir}/libsmbios_c.so
196%{_libdir}/pkgconfig/*.pc
197%doc _build/out/libsmbios_c++-%{_arch}
198%doc _build/out/libsmbios_c-%{_arch}
199
200%files -n smbios-utils
201# opensuse 11.1 enforces non-empty file list :(
202%defattr(-,root,root,-)
203%license COPYING-GPL COPYING-OSL
204%doc README*
205# no other files.
206
207%files -n smbios-utils-bin
208%defattr(-,root,root,-)
209%license COPYING-GPL COPYING-OSL
210%license src/bin/getopts_LICENSE.txt src/include/smbios_c/config/boost_LICENSE_1_0_txt
211%doc README*
212#
213# new C utilities
214%{_sbindir}/smbios-state-byte-ctl
215%{_sbindir}/smbios-get-ut-data
216%{_sbindir}/smbios-upflag-ctl
217%{_sbindir}/smbios-sys-info-lite
218
219%files -n python3-smbios -f _build/files-python3-smbios
220%defattr(-,root,root,-)
221%license COPYING-GPL COPYING-OSL
222%doc README*
223
224%files -n smbios-utils-python3 -f _build/files-smbios-utils-python3
225%defattr(-,root,root,-)
226%license COPYING-GPL COPYING-OSL
227%license src/bin/getopts_LICENSE.txt src/include/smbios_c/config/boost_LICENSE_1_0_txt
228%doc README*
229
230
231%changelog
232* Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.3-1
233- new upstream release.
234- dropped python2 support.
235- added python3 support.
236- truncated %%changelog: old logs are ChangeLog.fedora.
237
238* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-1
239- new upstream release.
240
241* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.28-2
242- rebuilt on current VineSeed
243- added Japanese summary
244
245* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.28-1
246- update to 2.2.28
247
248* Sun Apr 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.26-1
249- merged with upstream package
250  * Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-3
251  - initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.