source: projects/specs/trunk/lib/libs/libsmbios/libsmbios-vl.spec @ 10512

Revision 10512, 14.6 KB checked in by tomop, 8 years ago (diff)

libsmbios-2.3.0-1

Line 
1# pkg/libsmbios.spec.  Generated from libsmbios.spec.in by configure.
2# required by suse build system
3# norootforbuild
4
5# these are all substituted by autoconf
6%define major 2
7%define minor 3
8%define micro 0
9%define extra %{nil}
10%define pot_file  libsmbios
11%define lang_dom  libsmbios-2.3-x86_64
12%define release_version 2.3.0
13
14%define release_name libsmbios
15
16Name: %{release_name}
17Version: %{release_version}
18Release: 1%{?_dist_release}
19Summary: Libsmbios C/C++ shared libraries
20Summary(ja): Libsmbios C/C++ 共有ライブラリ
21
22License: GPLv2+ or OSL 2.1
23Group: System Environment/Libraries
24URL: http://linux.dell.com/libsmbios/main
25
26Source: http://linux.dell.com/libsmbios/download/libsmbios/libsmbios-%{version}/libsmbios-%{version}.tar.xz
27Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: strace libxml2-devel gcc-c++ gettext doxygen cppunit-devel pkgconfig python-devel
29
30# libsmbios only ever makes sense on intel compatible arches
31# no DMI tables on ppc, s390, etc.
32ExclusiveArch: x86_64 ia64 %{ix86}
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: shaolin, daisuke
37
38
39%description
40Libsmbios is a library and utilities that can be used by client programs to get
41information from standard BIOS tables, such as the SMBIOS table.
42
43This package provides the C-based libsmbios library, with a C interface.
44
45This package also has a C++-based library, with a C++ interface. It is not
46actively maintained, but provided for backwards compatibility. New programs
47should use the libsmbios C interface.
48
49
50%package -n python-smbios
51Summary: Python interface to Libsmbios C library
52Summary(ja): libsmbios C ライブラリへの Python インターフェース
53Group: System Environment/Libraries
54Requires: %{release_name} = %{version}-%{release}
55Requires: python
56
57%description -n python-smbios
58This package provides a Python interface to libsmbios
59
60%package -n smbios-utils
61Summary: Meta-package that pulls in all smbios binaries and python scripts
62Summary(ja): すべての smbios プログラムと python スクリプトをインストールするための仮想パッケージ
63Group: Applications/System
64Requires: smbios-utils-bin
65Requires: smbios-utils-python
66
67%description -n smbios-utils
68This is a meta-package that pulls in the binary libsmbios executables as well
69as the python executables.
70
71%package -n smbios-utils-bin
72Summary: Binary utilities that use libsmbios
73Summary(ja): libsmbios を用いたユーティリティ集
74Group: Applications/System
75Requires: %{release_name} = %{version}-%{release}
76
77%description -n smbios-utils-bin
78Get BIOS information, such as System product name, product id, service tag and
79asset tag.
80
81%package -n smbios-utils-python
82Summary: Python executables that use libsmbios
83Summary(ja): libsmbios を用いた Python スクリプト集
84Group: Applications/System
85Requires: python-smbios = %{version}-%{release}
86
87%description -n smbios-utils-python
88Get BIOS information, such as System product name, product id, service tag and
89asset tag. Set service and asset tags on Dell machines. Manipulate wireless
90cards/bluetooth on Dell laptops. Set BIOS password on select Dell systems.
91Update BIOS on select Dell systems. Set LCD brightness on select Dell laptops.
92
93# name the devel package libsmbios-devel regardless of package name, per suse/fedora convention
94%package -n libsmbios-devel
95Summary: Development headers and archives
96Summary(ja): libsmbios の開発用ヘッダファイルとライブラリ
97Group: Development/Libraries
98Requires: %{release_name} = %{version}-%{release}
99
100%description -n libsmbios-devel
101Libsmbios is a library and utilities that can be used by client programs to get
102information from standard BIOS tables, such as the SMBIOS table.
103
104This package contains the headers and .a files necessary to compile new client
105programs against libsmbios.
106
107%prep
108
109%setup -q -n libsmbios-%{version}
110find . -type d -exec chmod -f 755 {} \;
111find doc src -type f -exec chmod -f 644 {} \;
112chmod 755 src/cppunit/*.sh
113
114%build
115# this line lets us build an RPM directly from a git tarball
116# and retains any customized version information we might have
117[ -e ./configure ] || ./autogen.sh --no-configure
118
119mkdir _build
120cd _build
121echo '../configure "$@"' > configure
122chmod +x ./configure
123
124%configure
125
126mkdir -p out/libsmbios_c
127mkdir -p out/libsmbios_c++
128make %{?_smp_mflags} 2>&1 | tee build-%{_arch}.log
129
130echo \%doc _build/build-%{_arch}.log > buildlogs.txt
131
132%install
133rm -rf %{buildroot}
134mkdir %{buildroot}
135
136cd _build
137TOPDIR=..
138make install DESTDIR=%{buildroot} INSTALL="%{__install} -p"
139mkdir -p %{buildroot}/%{_includedir}
140mkdir -p %{buildroot}/%{_bindir}
141cp -a $TOPDIR/src/include/*  %{buildroot}/%{_includedir}/
142cp -a out/public-include/*  %{buildroot}/%{_includedir}/
143rm -f %{buildroot}/%{_libdir}/lib*.{la,a}
144find %{buildroot}/%{_includedir} out/libsmbios_c++ out/libsmbios_c -exec touch -r $TOPDIR/configure.ac {} \;
145
146mv out/libsmbios_c++  out/libsmbios_c++-%{_arch}
147mv out/libsmbios_c    out/libsmbios_c-%{_arch}
148
149rename %{pot_file}.mo %{lang_dom}.mo $(find %{buildroot}/%{_datadir} -name %{pot_file}.mo)
150%find_lang %{lang_dom}
151
152touch files-yum-dellsysid
153touch files-smbios-utils-python
154touch files-python-smbios
155
156# backwards compatible:
157ln -s %{_sbindir}/dellWirelessCtl %{buildroot}/%{_bindir}/dellWirelessCtl
158ln -s smbios-sys-info %{buildroot}/%{_sbindir}/getSystemId
159ln -s smbios-wireless-ctl %{buildroot}/%{_sbindir}/dellWirelessCtl
160ln -s smbios-lcd-brightness %{buildroot}/%{_sbindir}/dellLcdBrightness
161ln -s smbios-rbu-bios-update %{buildroot}/%{_sbindir}/dellBiosUpdate
162
163cat > files-python-smbios <<-EOF
164        %doc COPYING-GPL COPYING-OSL README
165        %{python_sitelib}/*
166EOF
167
168cat > files-smbios-utils-python <<-EOF
169        %doc COPYING-GPL COPYING-OSL README
170        %doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
171        %doc doc/pkgheader.sh
172        %dir %{_sysconfdir}/libsmbios
173        %config(noreplace) %{_sysconfdir}/libsmbios/*
174       
175        # python utilities
176        %{_sbindir}/smbios-sys-info
177        %{_sbindir}/smbios-token-ctl
178        %{_sbindir}/smbios-passwd
179        %{_sbindir}/smbios-wakeup-ctl
180        %{_sbindir}/smbios-wireless-ctl
181        %{_sbindir}/smbios-rbu-bios-update
182        %{_sbindir}/smbios-lcd-brightness
183        %{_sbindir}/smbios-keyboard-ctl
184        %{_sbindir}/smbios-thermal-ctl
185
186        # symlinks: backwards compat
187        %{_sbindir}/dellLcdBrightness
188        %{_sbindir}/getSystemId
189        %{_sbindir}/dellWirelessCtl
190        %{_sbindir}/dellBiosUpdate
191        # used by HAL in old location, so keep it around until HAL is updated.
192        %{_bindir}/dellWirelessCtl
193
194        # data files
195        %{_datadir}/smbios-utils
196EOF
197
198%clean
199rm -rf %{buildroot}
200
201%post   -n %{release_name}   -p /sbin/ldconfig
202%postun -n %{release_name}   -p /sbin/ldconfig
203
204%files -f _build/%{lang_dom}.lang
205%defattr(-,root,root,-)
206%{_libdir}/libsmbios_c.so.*
207%{_libdir}/libsmbios.so.*
208
209%files -n libsmbios-devel -f _build/buildlogs.txt
210%defattr(-,root,root,-)
211%doc COPYING-GPL COPYING-OSL README src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
212%{_includedir}/smbios
213%{_includedir}/smbios_c
214%{_libdir}/libsmbios.so
215%{_libdir}/libsmbios_c.so
216%{_libdir}/pkgconfig/*.pc
217%doc _build/out/libsmbios_c++-%{_arch}
218%doc _build/out/libsmbios_c-%{_arch}
219
220%files -n smbios-utils
221# opensuse 11.1 enforces non-empty file list :(
222%defattr(-,root,root,-)
223%doc COPYING-GPL COPYING-OSL README
224# no other files.
225
226%files -n smbios-utils-bin
227%defattr(-,root,root,-)
228%doc COPYING-GPL COPYING-OSL README
229%doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
230%doc doc/pkgheader.sh
231#
232# legacy C++
233%{_sbindir}/dellBiosUpdate-compat
234%{_sbindir}/dellLEDCtl
235%ifnarch ia64
236%{_sbindir}/dellMediaDirectCtl
237%endif
238#
239# new C utilities
240%{_sbindir}/smbios-state-byte-ctl
241%{_sbindir}/smbios-get-ut-data
242%{_sbindir}/smbios-upflag-ctl
243%{_sbindir}/smbios-sys-info-lite
244
245%files -n python-smbios -f _build/files-python-smbios
246%defattr(-,root,root,-)
247
248%files -n smbios-utils-python -f _build/files-smbios-utils-python
249%defattr(-,root,root,-)
250
251
252%changelog
253* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-1
254- new upstream release.
255
256* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.28-2
257- rebuilt on current VineSeed
258- added Japanese summary
259
260* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.28-1
261- update to 2.2.28
262
263* Sun Apr 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.26-1
264- merged with upstream package
265  * Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-3
266  - initial build for Vine Linux
267
268* Mon Sep 27 2010 Matt Domsch <mdomsch@fedoraproject.org> - 2.2.26-3
269- build for Fedora 15
270
271* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.2.19-2
272- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
273
274* Fri Jul 06 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.26-1
275- implement CSV export of token settings from smbios-token-ctl
276
277* Fri Jul 06 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.25-1
278- Fix breakage resulting from improperly fixing up constructors for MemoryAccess/CmosAccess. Fixes CLI utilities.
279
280* Fri Jun 11 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.23-1
281- Fixup ABI break where a couple functions that should have been exported were not marked.
282
283* Thu Jun 10 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.22-1
284- Fixup bug in reading asset and service tag where it A) read checksum from wrong location and B) used wrong comparison check to validate it
285- enable service tag SET for machines that still set service tag in CMOS
286- ABI/API - change to -fvisibility=hidden for libsmbios_c.so.*, mark public api's. This removes all non-public symbols that were not formerly part of the ABI from the dynamic link table.
287
288* Mon May 18 2009 Matt Domsch <Matt_Domsch@dell.com> - 2.2.16-3
289- split yum plugin into yum-dellsysid package
290
291* Mon Mar 24 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.16-1
292- add gcc 4.4 support
293
294* Mon Mar 24 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.15-1
295- update to lastest upstream.
296- fixes bug in bios update on systems with versions like x.y.z.
297
298* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.13-2
299- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
300
301* Tue Feb 3 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.12-1
302- Add feature to turn on debugging printf()'s without recompiling by setting
303  certain environment variables:
304    LIBSMBIOS_C_DEBUG_OUTPUT_ALL    -- all debugging output
305        or, per module:
306    LIBSMBIOS_C_DEBUG_CONSTRUCTOR_C
307    LIBSMBIOS_C_DEBUG_SYSINFO_C
308    LIBSMBIOS_C_DEBUG_SMBIOS_C
309    LIBSMBIOS_C_DEBUG_TOKEN_C
310    LIBSMBIOS_C_DEBUG_MEMORY_C
311    LIBSMBIOS_C_DEBUG_CMOS_C
312    LIBSMBIOS_C_DEBUG_SMI_C
313
314* Mon Feb 2 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.12-1
315- Add pkgconfig files to -devel
316- fixup yum plugin to not parse certain data that causes a crash on some machines (Optiplex 755, others may be affected)
317
318* Thu Jan 15 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.8-1
319- revert change in upstream renaming rpm to libsmbios2
320
321* Thu Jan 15 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.7-1
322- change source to bz2 format
323- Update to latest upstream release. Many changes in the new release:
324  - python interface
325  - libsmbios_c interface almost fully implemented
326  - libsmbios c++ interface deprecated
327
328* Tue Oct 28 2008 Michael E Brown <michael_e_brown at dell.com> - 2.2.0-1
329- Spec updates
330
331* Mon Apr 21 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2.1
332- obsolete libsmbios-libs as well
333
334* Mon Mar 3 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2
335- properly obsolete older versions
336
337* Wed Feb 13 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1
338- Fixup GCC 4.3 compile issues.
339
340* Wed Jan 9 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.0
341- ABI incompatible, minor API changes
342- sync up libsmbios soname with version #
343- move binaries to /usr/sbin as they are only runnable by root
344- drop libsmbiosxml lib as it was mostly unused.
345- drop autotools generated files out of git and add autogen.sh
346- drop tokenCtl binary-- pysmbios has a *much* improved version
347
348* Wed Aug 22 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.9
349- Fix a couple of failure-to-check-return on fopen. most were unit-test code
350  only, but two or three were in regular code.
351- Add hinting to the memory class, so that it can intelligently close /dev/mem
352  file handle when it is not needed (which is most of the time). it only
353  leaves it open when it is scanning, so speed is not impacted.
354
355* Tue Aug 6 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.8
356- new upstream
357
358* Tue Apr 3 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.6
359- critical bugfix for dellBiosUpdate utility for packet mode
360- autoconf/automake support for automatically building docs
361- more readable 'make' lines by splitting out env vars
362- remove run_cppunit option... always run unit tests.
363- update autoconf/automake utilities to latest version
364- fix LDFLAGS to not overwrite user entered LDFLAGS
365- add automatic doxygen build of docs
366- fix urls of public repos
367- remove yum repo page in favor of official page from docs
368- split dmi table entry point from smbios table entry point
369- support legacy _DMI_ tables
370- fix support for EFI-based imacs without proper _SM_ anchor
371
372* Tue Mar 20 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.5
373- rpmlint cleanups
374- Add dellLEDCtl binary
375- update AUTHORS file to add credit for dellLEDCtl
376- update doc/DellToken.txt to add a few more useful tokens.
377- updated build system to create documentation
378- skip cppunit dep on .elX builds (not in EPEL yet)
379
380* Mon Mar 12 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.4-1
381- Added dellWirelessCtl binary
382- Added 'static' makefile target to build static binaries and clean them as well
383- fix for signed/unsigned bug in probes binary. CPU temp misreported
384- simplify interface for DELL_CALLING_INTERFACE_SMI, autodetect Port/Magic
385- document all of the tokens for controlling wireless on dell notebooks
386- enums for SMI args/res to make code match docs better (cbRES1 = res[0], which
387  was confusing.
388- helper functions isTokenActive() and activateToken() to simplify token API.
389- Added missing windows .cpp files to the dist tarball for those who compile
390  windows from dist tarball vs source control
391- Add support for EFI based machines without backwards compatible smbios table
392  entry point in 0xF0000 block.
393- Added wirelessSwitchControl() and wirelessRadioControl() API for newer
394  laptops.
395- fixed bug in TokenDA activate() code where it wasnt properly using SMI
396  (never worked, but apparently wasnt used until now.)
397
398* Tue Oct 3 2006 Michael E Brown <Michael_E_Brown@Dell.com> - 0.13.0-1
399- autotools conversion
400- add Changelog
401
402* Tue Sep 26 2006 Michael E Brown <michael_e_brown at dell.com> - 0.12.4-1
403- Changes per Fedora Packaging Guidelines to prepare to submit to Extras.
404- Add in a changelog entry per Fedora Packaging Guidelines...
405
Note: See TracBrowser for help on using the repository browser.