source: projects/specs/trunk/lib/libs/libskk/libskk-vl.spec @ 11267

Revision 11267, 1.8 KB checked in by ara_t, 6 years ago (diff)

libskk: initial commit

Line 
1%define pkg_name    libskk
2%define pkg_version 1.0.3
3%define pkg_release 1%{?_dist_release}
4
5Summary: A library to deal with Japanese kana-to-kanji conversion method
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPLv3+
11Group:   System Environment/Libraries
12URL:     https://github.com/ueno/libskk
13
14Source0: https://github.com/ueno/libskk/releases/download/1.0.2/%{name}-%{version}.tar.xz
15
16# unable stick-shift using "Henkan" key
17Patch1: rules_Makefile.am.patch
18Patch2: rules_Makefile.in.patch
19Patch3: libskk_key-event.c.patch
20Patch4: test-sticky-hiragana.json.patch
21
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
24BuildRequires: libgee-devel
25BuildRequires: json-glib-devel
26
27Vendor:       Project Vine
28Distribution: Vine Linux
29
30
31%description
32libskk -- a library to deal with Japanese kana-to-kanji conversion method
33
34
35%package devel
36Summary: files for development of libskk
37Group:   Development/Libraries
38Requires: libskk = %{version}-%{release}
39
40%description devel
41Development tools for libskk
42
43
44%prep
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%setup -q
47
48%patch1
49%patch2
50%patch3
51%patch4
52%{__cp} -a tests/rules/test-sticky rules
53
54%build
55%configure
56%{__make} %{?_smp_mflags}
57
58%install
59%{__rm} -rf ${RPM_BUILD_ROOT}
60%{make_install}
61%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66%post -p %{_syssbindir}/ldconfig
67
68%postun -p %{_syssbindir}/ldconfig
69
70
71%files
72%defattr(-, root, root)
73%doc AUTHORS ChangeLog COPYING NEWS README
74%{_bindir}/skk
75%{_libdir}/libskk.so.*
76%{_libdir}/girepository-1.0
77%{_datadir}/gir-1.0/
78%{_datadir}/libskk/
79%{_datadir}/locale/
80%{_datadir}/vala/
81%{_mandir}/man1/
82
83%files devel
84%defattr(-, root, root)
85%{_includedir}/libskk/*.h
86%{_libdir}/pkgconfig/*.pc
87%{_libdir}/libskk.so
88
89
90%changelog
91* Fri Dec 15 2017 Toshiaki Ara <ara_t@384.jp> 1.0.3-1
92- Initial release
93
Note: See TracBrowser for help on using the repository browser.