source: projects/specs/trunk/lib/libs/libskk/libskk-vl.spec @ 11741

Revision 11741, 1.9 KB checked in by ara_t, 6 years ago (diff)

libskk: enable to input some Zenkaku characters

Line 
1%define pkg_name    libskk
2%define pkg_version 1.0.3
3%define pkg_release 2%{?_dist_release}
4
5Summary: A library to deal with Japanese kana-to-kanji conversion method
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPLv3+
11Group:   System Environment/Libraries
12URL:     https://github.com/ueno/libskk
13
14Source0: https://github.com/ueno/libskk/releases/download/1.0.2/%{name}-%{version}.tar.xz
15
16# unable stick-shift using "Henkan" key
17Patch1: rules_Makefile.am.patch
18Patch2: rules_Makefile.in.patch
19Patch3: libskk_key-event.c.patch
20Patch4: test-sticky-hiragana.json.patch
21Patch5: libskk-add-keymap.patch
22
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
25BuildRequires: libgee-devel
26BuildRequires: json-glib-devel
27
28Vendor:       Project Vine
29Distribution: Vine Linux
30
31
32%description
33libskk -- a library to deal with Japanese kana-to-kanji conversion method
34
35
36%package devel
37Summary: files for development of libskk
38Group:   Development/Libraries
39Requires: libskk = %{version}-%{release}
40
41%description devel
42Development tools for libskk
43
44
45%prep
46%{__rm} -rf ${RPM_BUILD_ROOT}
47%setup -q
48
49%patch1
50%patch2
51%patch3
52%patch4
53%patch5
54%{__cp} -a tests/rules/test-sticky rules
55
56%build
57%configure
58%{__make} %{?_smp_mflags}
59
60%install
61%{__rm} -rf ${RPM_BUILD_ROOT}
62%{make_install}
63%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
64
65%clean
66%{__rm} -rf ${RPM_BUILD_ROOT}
67
68%post -p %{_syssbindir}/ldconfig
69
70%postun -p %{_syssbindir}/ldconfig
71
72
73%files
74%defattr(-, root, root)
75%doc AUTHORS ChangeLog COPYING NEWS README
76%{_bindir}/skk
77%{_libdir}/libskk.so.*
78%{_libdir}/girepository-1.0
79%{_datadir}/gir-1.0/
80%{_datadir}/libskk/
81%{_datadir}/locale/
82%{_datadir}/vala/
83%{_mandir}/man1/
84
85%files devel
86%defattr(-, root, root)
87%{_includedir}/libskk/*.h
88%{_libdir}/pkgconfig/*.pc
89%{_libdir}/libskk.so
90
91
92%changelog
93* Thu Jul 19 2018 Toshiaki Ara <ara_t@384.jp> 1.0.3-2
94- add Patch5 to input some Zenkaku characters
95
96* Fri Dec 15 2017 Toshiaki Ara <ara_t@384.jp> 1.0.3-1
97- Initial release
98
Note: See TracBrowser for help on using the repository browser.