source: projects/specs/trunk/lib/libs/libsigc++/libsigc++-vl.spec @ 900

Revision 900, 7.0 KB checked in by inagaki, 14 years ago (diff)

updated: libmal, libmcrypt, libsigc++

Line 
1%define name libsigc++
2%define version 2.2.6
3%define release 1%{?_dist_release}
4
5%define lib_name sigc++-2.0
6
7Summary: The Typesafe Signal Framework for C++
8Summary(ja): C++ 用の型安全なシグナルフレームワーク
9Name: %{name}
10Version: %{version}
11Release: %{release}
12Source: ftp://download.sourceforge.net/pub/sourceforge/libsigc/%{name}-%{version}.tar.bz2
13License: LGPL
14Group: System Environment/Libraries
15URL: http://libsigc.sourceforge.net/
16
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gcc-c++
19BuildRequires: m4
20
21%description
22This library implements a full callback system for use in widget libraries,
23abstract interfaces, and general programming. Originally part of the Gtk--
24widget set, %{name} is now a seperate library to provide for more general
25use. It is the most complete library of its kind with the ablity to connect
26an abstract callback to a class method, function, or function object. It
27contains adaptor classes for connection of dissimilar callbacks and has an
28ease of use unmatched by other C++ callback libraries.
29
30Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
31
32
33%package devel
34Summary: development tools for the Typesafe Signal Framework for C++
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: pkgconfig
38
39%description devel
40The %{name}-devel package contains the static libraries and header files
41needed for development with %{name}.
42
43%package examples
44Summary: examples and tests for the Typesafe Signal Framework for C++
45Group: Development/Libraries
46Requires: %{name}-devel = %{version}-%{release}
47
48%description examples
49The %{name}-devel package contains source code of example and test
50programs for %{name}.
51
52%prep
53%setup -q
54
55%build
56%configure --disable-static --enable-silent-rules
57make %{_smp_mflags}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61make install DESTDIR=$RPM_BUILD_ROOT
62
63# removed unpackage files
64rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
65
66mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
67cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
68find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
69find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
70find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
71        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
72
73for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
74        rm -f $i.*
75done
76
77rm -rf docs-toinstall
78mkdir -p docs-to-install
79cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
80rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
81
82# devhelp path fix
83sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
84#sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
85
86%post -p /sbin/ldconfig
87
88%postun -p /sbin/ldconfig
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(-,root,root,755)
95%doc AUTHORS COPYING README NEWS ChangeLog TODO
96%attr(755,root,root) %{_libdir}/lib*.so.*
97
98%files devel
99%defattr(-,root,root,755)
100%{_includedir}/*
101%{_libdir}/%{lib_name}/include
102%{_libdir}/pkgconfig/*.pc
103#{_libdir}/lib*.la
104%{_libdir}/lib*.so
105%{_datadir}/devhelp/books/%{name}-2.0/*
106%doc docs-to-install/index.html docs-to-install/images
107%doc docs-to-install/reference docs-to-install/tutorial
108
109%files examples
110%defattr(-,root,root,755)
111%{_libdir}/%{lib_name}/examples
112%{_libdir}/%{lib_name}/tests
113
114%changelog
115* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
116- new upstream release
117- built with new toolchain
118
119* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
120- new upstream release
121- remove static libraries from devel package
122
123* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
124- new upstream release
125- spec in UTF-8
126
127* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
128- removed .la files from devel package
129
130* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
131- new upstream release
132
133* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
134- rebuild with new environment/toolchain
135
136* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
137- new upstream release
138
139* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
140- rebuild with new libtool
141
142* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
143- new upstream release
144
145* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
146- new upstream release
147
148* Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
149- new upstream release
150
151* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
152- new upstream release
153- added tutorial to devel package
154
155* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
156- update to 2.0.6
157
158* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
159- update to 1.2.5
160- add Requires: pkgconfig
161
162* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
163- rebuild to remove dependance <5371>
164- add Japanese summary
165- use better macros
166- s/Copyright/License/
167
168* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
169- rebuild with new toolchain
170
171* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
172- 1.0.4-0vl1
173- Build for Vine Linux 2.5
174
175* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
176- packaged for Vine Linux 2.1
177
178* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
179- updated Url and Source fileds
180- 1.0.0 stable release
181
182* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
183- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
184- minor install section cleanup
185
186* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
187- autogen just creates configure, not runs it, so cleaned that up too.
188
189* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
190- minor attr fix
191- removed unnecessary curly braces
192- fixed Herbert's adjustement
193
194* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
195- minor package dependence fix
196
197* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
198- fixed typo of mine
199- added traditional CUSTOM_RELEASE stuff
200- added SMP support
201
202* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
203- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
204
205* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
206- split into three packages: %name, %name-devel and %name-examples
207
208* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
209- updated source field and merged conflicts between revisions.
210
211* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
212- updated Prefix and BuildRoot fields
213
214* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
215- made sure configure works on all alphas
216
217* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
218- Added autoconf macro for sigc.
219
220* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
221- Made into a .in to keep version field up to date
222- Still need to do release by hand
223
224* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
225- added Vendor and Packager fields
226
227* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
228- updated to 0.8.0
229
230* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
231- initial revision
Note: See TracBrowser for help on using the repository browser.