source: projects/specs/trunk/lib/libs/libsigc++/libsigc++-vl.spec @ 1793

Revision 1793, 7.1 KB checked in by inagaki, 14 years ago (diff)

update: libsigc++
NEW: libxml++

Line 
1%define name libsigc++
2%define version 2.2.8
3%define release 1%{?_dist_release}
4
5%define lib_name sigc++-2.0
6
7Summary: The Typesafe Signal Framework for C++
8Summary(ja): C++ 用の型安全なシグナルフレームワーク
9Name: %{name}
10Version: %{version}
11Release: %{release}
12
13Group: System Environment/Libraries
14License: LGPLv2
15URL: http://libsigc.sourceforge.net/
16
17Source: ftp://download.sourceforge.net/pub/sourceforge/libsigc/%{name}-%{version}.tar.bz2
18
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: gcc-c++
21BuildRequires: m4
22
23%description
24This library implements a full callback system for use in widget libraries,
25abstract interfaces, and general programming. Originally part of the Gtk--
26widget set, %{name} is now a seperate library to provide for more general
27use. It is the most complete library of its kind with the ablity to connect
28an abstract callback to a class method, function, or function object. It
29contains adaptor classes for connection of dissimilar callbacks and has an
30ease of use unmatched by other C++ callback libraries.
31
32Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
33
34
35%package devel
36Summary: development tools for the Typesafe Signal Framework for C++
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: pkgconfig
40
41%description devel
42The %{name}-devel package contains the static libraries and header files
43needed for development with %{name}.
44
45%package examples
46Summary: examples and tests for the Typesafe Signal Framework for C++
47Group: Development/Libraries
48Requires: %{name}-devel = %{version}-%{release}
49
50%description examples
51The %{name}-devel package contains source code of example and test
52programs for %{name}.
53
54%prep
55%setup -q
56
57%build
58%configure --disable-static --enable-silent-rules
59make %{_smp_mflags}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63make install DESTDIR=$RPM_BUILD_ROOT
64
65# removed unpackage files
66rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
67
68mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
69cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
70find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
71find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
72find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
73        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
74
75for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
76        rm -f $i.*
77done
78
79rm -rf docs-toinstall
80mkdir -p docs-to-install
81cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
82rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
83
84# devhelp path fix
85sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
86#sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files
96%defattr(-,root,root,755)
97%doc AUTHORS COPYING README NEWS ChangeLog TODO
98%attr(755,root,root) %{_libdir}/lib*.so.*
99
100%files devel
101%defattr(-,root,root,755)
102%{_includedir}/*
103%{_libdir}/%{lib_name}/include
104%{_libdir}/pkgconfig/*.pc
105#{_libdir}/lib*.la
106%{_libdir}/lib*.so
107%{_datadir}/devhelp/books/%{name}-2.0/*
108%doc docs-to-install/index.html docs-to-install/images
109%doc docs-to-install/reference docs-to-install/tutorial
110
111%files examples
112%defattr(-,root,root,755)
113%{_libdir}/%{lib_name}/examples
114%{_libdir}/%{lib_name}/tests
115
116%changelog
117* Thu Sep  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
118- new upstream release
119
120* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
121- new upstream release
122- built with new toolchain
123
124* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
125- new upstream release
126- remove static libraries from devel package
127
128* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
129- new upstream release
130- spec in UTF-8
131
132* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
133- removed .la files from devel package
134
135* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
136- new upstream release
137
138* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
139- rebuild with new environment/toolchain
140
141* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
142- new upstream release
143
144* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
145- rebuild with new libtool
146
147* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
148- new upstream release
149
150* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
151- new upstream release
152
153* Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
154- new upstream release
155
156* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
157- new upstream release
158- added tutorial to devel package
159
160* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
161- update to 2.0.6
162
163* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
164- update to 1.2.5
165- add Requires: pkgconfig
166
167* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
168- rebuild to remove dependance <5371>
169- add Japanese summary
170- use better macros
171- s/Copyright/License/
172
173* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
174- rebuild with new toolchain
175
176* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
177- 1.0.4-0vl1
178- Build for Vine Linux 2.5
179
180* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
181- packaged for Vine Linux 2.1
182
183* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
184- updated Url and Source fileds
185- 1.0.0 stable release
186
187* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
188- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
189- minor install section cleanup
190
191* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
192- autogen just creates configure, not runs it, so cleaned that up too.
193
194* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
195- minor attr fix
196- removed unnecessary curly braces
197- fixed Herbert's adjustement
198
199* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
200- minor package dependence fix
201
202* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
203- fixed typo of mine
204- added traditional CUSTOM_RELEASE stuff
205- added SMP support
206
207* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
208- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
209
210* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
211- split into three packages: %name, %name-devel and %name-examples
212
213* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
214- updated source field and merged conflicts between revisions.
215
216* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
217- updated Prefix and BuildRoot fields
218
219* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
220- made sure configure works on all alphas
221
222* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
223- Added autoconf macro for sigc.
224
225* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
226- Made into a .in to keep version field up to date
227- Still need to do release by hand
228
229* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
230- added Vendor and Packager fields
231
232* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
233- updated to 0.8.0
234
235* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
236- initial revision
Note: See TracBrowser for help on using the repository browser.