source: projects/specs/trunk/lib/libs/libsigc++/libsigc++-vl.spec @ 521

Revision 521, 6.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name libsigc++
2%define version 2.2.4.2
3%define release 1%{?_dist_release}
4
5%define lib_name sigc++-2.0
6
7Summary: The Typesafe Signal Framework for C++
8Summary(ja): C++ 用の型安全なシグナルフレームワーク
9Name: %{name}
10Version: %{version}
11Release: %{release}
12Source: ftp://download.sourceforge.net/pub/sourceforge/libsigc/%{name}-%{version}.tar.bz2
13License: LGPL
14Group: System Environment/Libraries
15URL: http://libsigc.sourceforge.net/
16
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gcc-c++ m4
19
20%description
21This library implements a full callback system for use in widget libraries,
22abstract interfaces, and general programming. Originally part of the Gtk--
23widget set, %{name} is now a seperate library to provide for more general
24use. It is the most complete library of its kind with the ablity to connect
25an abstract callback to a class method, function, or function object. It
26contains adaptor classes for connection of dissimilar callbacks and has an
27ease of use unmatched by other C++ callback libraries.
28
29Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
30
31
32%package devel
33Summary: development tools for the Typesafe Signal Framework for C++
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: pkgconfig
37
38%description devel
39The %{name}-devel package contains the static libraries and header files
40needed for development with %{name}.
41
42%package examples
43Summary: examples and tests for the Typesafe Signal Framework for C++
44Group: Development/Libraries
45Requires: %{name}-devel = %{version}-%{release}
46
47%description examples
48The %{name}-devel package contains source code of example and test
49programs for %{name}.
50
51%prep
52%setup -q
53
54%build
55%configure --disable-static
56make %{_smp_mflags}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60make install DESTDIR=$RPM_BUILD_ROOT
61
62# removed unpackage files
63rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
64
65mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
66cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
67find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
68find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
69find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
70        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
71
72for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
73        rm -f $i.*
74#       cp -p scripts/examples.Makefile $i
75done
76
77rm -rf docs-toinstall
78mkdir -p docs-to-install
79cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
80rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
81
82# devhelp path fix
83sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
84#sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
85
86%post -p /sbin/ldconfig
87
88%postun -p /sbin/ldconfig
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(-,root,root,755)
95%doc AUTHORS COPYING README NEWS ChangeLog TODO
96%attr(755,root,root) %{_libdir}/lib*.so.*
97
98%files devel
99%defattr(-,root,root,755)
100%{_includedir}/*
101%{_libdir}/%{lib_name}/include
102%{_libdir}/pkgconfig/*.pc
103#{_libdir}/lib*.la
104%{_libdir}/lib*.so
105%{_datadir}/devhelp/books/%{name}-2.0/*
106%doc docs-to-install/index.html docs-to-install/images
107%doc docs-to-install/reference docs-to-install/tutorial
108
109%files examples
110%defattr(-,root,root,755)
111%{_libdir}/%{lib_name}/examples
112%{_libdir}/%{lib_name}/tests
113
114%changelog
115* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
116- new upstream release
117- remove static libraries from devel package
118
119* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
120- new upstream release
121- spec in UTF-8
122
123* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
124- removed .la files from devel package
125
126* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
127- new upstream release
128
129* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
130- rebuild with new environment/toolchain
131
132* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
133- new upstream release
134
135* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
136- rebuild with new libtool
137
138* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
139- new upstream release
140
141* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
142- new upstream release
143
144* Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
145- new upstream release
146
147* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
148- new upstream release
149- added tutorial to devel package
150
151* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
152- update to 2.0.6
153
154* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
155- update to 1.2.5
156- add Requires: pkgconfig
157
158* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
159- rebuild to remove dependance <5371>
160- add Japanese summary
161- use better macros
162- s/Copyright/License/
163
164* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
165- rebuild with new toolchain
166
167* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
168- 1.0.4-0vl1
169- Build for Vine Linux 2.5
170
171* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
172- packaged for Vine Linux 2.1
173
174* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
175- updated Url and Source fileds
176- 1.0.0 stable release
177
178* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
179- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
180- minor install section cleanup
181
182* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
183- autogen just creates configure, not runs it, so cleaned that up too.
184
185* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
186- minor attr fix
187- removed unnecessary curly braces
188- fixed Herbert's adjustement
189
190* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
191- minor package dependence fix
192
193* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
194- fixed typo of mine
195- added traditional CUSTOM_RELEASE stuff
196- added SMP support
197
198* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
199- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
200
201* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
202- split into three packages: %name, %name-devel and %name-examples
203
204* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
205- updated source field and merged conflicts between revisions.
206
207* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
208- updated Prefix and BuildRoot fields
209
210* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
211- made sure configure works on all alphas
212
213* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
214- Added autoconf macro for sigc.
215
216* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
217- Made into a .in to keep version field up to date
218- Still need to do release by hand
219
220* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
221- added Vendor and Packager fields
222
223* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
224- updated to 0.8.0
225
226* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
227- initial revision
Note: See TracBrowser for help on using the repository browser.