source: projects/specs/trunk/lib/libs/libsigc++/libsigc++-vl.spec @ 12444

Revision 12444, 8.1 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

at-spi2-atk-2.34.2-1

at-spi2-core-2.36.0-1

atk-2.36.0-1

atkmm-2.28.0-1

cairomm-1.12.0-3

glibmm-2.64.2-1

gtkmm3-3.24.2-1

libsigc++-2.10.3-1

pangomm-2.42.1-1

Line 
1%define lib_name sigc++-2.0
2
3Summary: The Typesafe Signal Framework for C++
4Summary(ja): C++ 用の型安全なシグナルフレームワーク
5Name: libsigc++
6Version: 2.10.3
7Release: 1%{?_dist_release}
8Vendor: Project Vine
9Distribution: Vine Linux
10
11License: LGPLv2
12URL: https://github.com/libsigcplusplus/libsigcplusplus
13%global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
14Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: gcc-c++
18BuildRequires: m4
19
20%description
21This library implements a full callback system for use in widget libraries,
22abstract interfaces, and general programming. Originally part of the Gtk--
23widget set, %{name} is now a seperate library to provide for more general
24use. It is the most complete library of its kind with the ablity to connect
25an abstract callback to a class method, function, or function object. It
26contains adaptor classes for connection of dissimilar callbacks and has an
27ease of use unmatched by other C++ callback libraries.
28
29Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
30
31
32%package devel
33Summary: development tools for the Typesafe Signal Framework for C++
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: pkgconfig
37
38%description devel
39The %{name}-devel package contains the static libraries and header files
40needed for development with %{name}.
41
42
43%package examples
44Summary: examples and tests for the Typesafe Signal Framework for C++
45Group: Development/Libraries
46Requires: %{name}-devel = %{version}-%{release}
47
48%description examples
49The %{name}-devel package contains source code of example and test
50programs for %{name}.
51
52
53%prep
54%setup -q
55
56
57%build
58%configure --disable-static --enable-silent-rules
59make %{_smp_mflags}
60
61
62%install
63rm -rf $RPM_BUILD_ROOT
64make install DESTDIR=$RPM_BUILD_ROOT
65
66# removed unpackage files
67rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
68
69mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
70cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
71find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
72find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
73find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
74        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
75
76for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
77        rm -f $i.*
78done
79
80rm -rf docs-toinstall
81mkdir -p docs-to-install
82cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
83rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
84
85# devhelp path fix
86sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
87#sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
88
89
90%post -p /sbin/ldconfig
91
92%postun -p /sbin/ldconfig
93
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98
99%files
100%defattr(-,root,root,755)
101%license COPYING
102%doc AUTHORS README NEWS ChangeLog TODO
103%attr(755,root,root) %{_libdir}/lib*.so.*
104
105%files devel
106%defattr(-,root,root,755)
107%{_includedir}/*
108%{_libdir}/%{lib_name}/include
109%{_libdir}/pkgconfig/*.pc
110#{_libdir}/lib*.la
111%{_libdir}/lib*.so
112%{_datadir}/devhelp/books/%{name}-2.0/*
113%doc docs-to-install/index.html docs-to-install/images
114%doc docs-to-install/reference docs-to-install/tutorial
115
116%files examples
117%defattr(-,root,root,755)
118%{_libdir}/%{lib_name}/examples
119%{_libdir}/%{lib_name}/tests
120
121%changelog
122* Sat Aug 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.3-1
123- new upstream release.
124
125* Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.2-1
126- new upstream release.
127
128* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.0-1
129- new upstream release.
130
131* Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
132- new upstream release
133
134* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-2
135- rebuild with gcc-5.4.0
136
137* Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
138- new upstream release
139
140* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
141- new upstream release
142
143* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-1
144- new upstream release
145
146* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.10-1
147- new upstream release
148
149* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.8-2
150- build with rpm-4.8.1-1 for pkg-config file
151
152* Thu Sep  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
153- new upstream release
154
155* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
156- new upstream release
157- built with new toolchain
158
159* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
160- new upstream release
161- remove static libraries from devel package
162
163* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
164- new upstream release
165- spec in UTF-8
166
167* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
168- removed .la files from devel package
169
170* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
171- new upstream release
172
173* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
174- rebuild with new environment/toolchain
175
176* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
177- new upstream release
178
179* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
180- rebuild with new libtool
181
182* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
183- new upstream release
184
185* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
186- new upstream release
187
188* Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
189- new upstream release
190
191* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
192- new upstream release
193- added tutorial to devel package
194
195* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
196- update to 2.0.6
197
198* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
199- update to 1.2.5
200- add Requires: pkgconfig
201
202* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
203- rebuild to remove dependance <5371>
204- add Japanese summary
205- use better macros
206- s/Copyright/License/
207
208* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
209- rebuild with new toolchain
210
211* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
212- 1.0.4-0vl1
213- Build for Vine Linux 2.5
214
215* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
216- packaged for Vine Linux 2.1
217
218* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
219- updated Url and Source fileds
220- 1.0.0 stable release
221
222* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
223- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
224- minor install section cleanup
225
226* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
227- autogen just creates configure, not runs it, so cleaned that up too.
228
229* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
230- minor attr fix
231- removed unnecessary curly braces
232- fixed Herbert's adjustement
233
234* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
235- minor package dependence fix
236
237* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
238- fixed typo of mine
239- added traditional CUSTOM_RELEASE stuff
240- added SMP support
241
242* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
243- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
244
245* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
246- split into three packages: %name, %name-devel and %name-examples
247
248* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
249- updated source field and merged conflicts between revisions.
250
251* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
252- updated Prefix and BuildRoot fields
253
254* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
255- made sure configure works on all alphas
256
257* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
258- Added autoconf macro for sigc.
259
260* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
261- Made into a .in to keep version field up to date
262- Still need to do release by hand
263
264* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
265- added Vendor and Packager fields
266
267* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
268- updated to 0.8.0
269
270* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
271- initial revision
Note: See TracBrowser for help on using the repository browser.