source: projects/specs/trunk/lib/libs/libsigc++/libsigc++-vl.spec @ 12352

Revision 12352, 8.1 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

gnome-font-viewer-3.30.0-2

libsigc++-2.10.2-1

Line 
1%define name libsigc++
2%define version 2.10.2
3%define release 1%{?_dist_release}
4
5%define lib_name sigc++-2.0
6
7%define _unpackaged_files_terminate_build 1
8
9Summary: The Typesafe Signal Framework for C++
10Summary(ja): C++ 用の型安全なシグナルフレームワーク
11Name: %{name}
12Version: %{version}
13Release: %{release}
14Group: System Environment/Libraries
15Vendor: Project Vine
16Distribution: Vine Linux
17
18License: LGPLv2
19URL: https://github.com/libsigcplusplus/libsigcplusplus
20%global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
21Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
22
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: gcc-c++
25BuildRequires: m4
26
27
28%description
29This library implements a full callback system for use in widget libraries,
30abstract interfaces, and general programming. Originally part of the Gtk--
31widget set, %{name} is now a seperate library to provide for more general
32use. It is the most complete library of its kind with the ablity to connect
33an abstract callback to a class method, function, or function object. It
34contains adaptor classes for connection of dissimilar callbacks and has an
35ease of use unmatched by other C++ callback libraries.
36
37Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
38
39
40%package devel
41Summary: development tools for the Typesafe Signal Framework for C++
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Requires: pkgconfig
45
46%description devel
47The %{name}-devel package contains the static libraries and header files
48needed for development with %{name}.
49
50%package examples
51Summary: examples and tests for the Typesafe Signal Framework for C++
52Group: Development/Libraries
53Requires: %{name}-devel = %{version}-%{release}
54
55%description examples
56The %{name}-devel package contains source code of example and test
57programs for %{name}.
58
59%prep
60%setup -q
61
62%build
63%configure --disable-static --enable-silent-rules
64make %{_smp_mflags}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make install DESTDIR=$RPM_BUILD_ROOT
69
70# removed unpackage files
71rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
72
73mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
74cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
75find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
76find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
77find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
78        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
79
80for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
81        rm -f $i.*
82done
83
84rm -rf docs-toinstall
85mkdir -p docs-to-install
86cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
87rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
88
89# devhelp path fix
90sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
91#sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
92
93%post -p /sbin/ldconfig
94
95%postun -p /sbin/ldconfig
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%files
101%defattr(-,root,root,755)
102%license COPYING
103%doc AUTHORS README NEWS ChangeLog TODO
104%attr(755,root,root) %{_libdir}/lib*.so.*
105
106%files devel
107%defattr(-,root,root,755)
108%{_includedir}/*
109%{_libdir}/%{lib_name}/include
110%{_libdir}/pkgconfig/*.pc
111#{_libdir}/lib*.la
112%{_libdir}/lib*.so
113%{_datadir}/devhelp/books/%{name}-2.0/*
114%doc docs-to-install/index.html docs-to-install/images
115%doc docs-to-install/reference docs-to-install/tutorial
116
117%files examples
118%defattr(-,root,root,755)
119%{_libdir}/%{lib_name}/examples
120%{_libdir}/%{lib_name}/tests
121
122%changelog
123* Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.2-1
124- new upstream release.
125
126* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.0-1
127- new upstream release.
128
129* Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
130- new upstream release
131
132* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-2
133- rebuild with gcc-5.4.0
134
135* Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
136- new upstream release
137
138* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
139- new upstream release
140
141* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-1
142- new upstream release
143
144* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.10-1
145- new upstream release
146
147* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.8-2
148- build with rpm-4.8.1-1 for pkg-config file
149
150* Thu Sep  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
151- new upstream release
152
153* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
154- new upstream release
155- built with new toolchain
156
157* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
158- new upstream release
159- remove static libraries from devel package
160
161* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
162- new upstream release
163- spec in UTF-8
164
165* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
166- removed .la files from devel package
167
168* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
169- new upstream release
170
171* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
172- rebuild with new environment/toolchain
173
174* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
175- new upstream release
176
177* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
178- rebuild with new libtool
179
180* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
181- new upstream release
182
183* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
184- new upstream release
185
186* Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
187- new upstream release
188
189* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
190- new upstream release
191- added tutorial to devel package
192
193* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
194- update to 2.0.6
195
196* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
197- update to 1.2.5
198- add Requires: pkgconfig
199
200* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
201- rebuild to remove dependance <5371>
202- add Japanese summary
203- use better macros
204- s/Copyright/License/
205
206* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
207- rebuild with new toolchain
208
209* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
210- 1.0.4-0vl1
211- Build for Vine Linux 2.5
212
213* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
214- packaged for Vine Linux 2.1
215
216* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
217- updated Url and Source fileds
218- 1.0.0 stable release
219
220* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
221- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
222- minor install section cleanup
223
224* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
225- autogen just creates configure, not runs it, so cleaned that up too.
226
227* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
228- minor attr fix
229- removed unnecessary curly braces
230- fixed Herbert's adjustement
231
232* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
233- minor package dependence fix
234
235* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
236- fixed typo of mine
237- added traditional CUSTOM_RELEASE stuff
238- added SMP support
239
240* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
241- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
242
243* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
244- split into three packages: %name, %name-devel and %name-examples
245
246* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
247- updated source field and merged conflicts between revisions.
248
249* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
250- updated Prefix and BuildRoot fields
251
252* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
253- made sure configure works on all alphas
254
255* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
256- Added autoconf macro for sigc.
257
258* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
259- Made into a .in to keep version field up to date
260- Still need to do release by hand
261
262* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
263- added Vendor and Packager fields
264
265* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
266- updated to 0.8.0
267
268* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
269- initial revision
Note: See TracBrowser for help on using the repository browser.