source: projects/specs/trunk/lib/libs/libsigc++/libsigc++-vl.spec @ 11336

Revision 11336, 7.9 KB checked in by tomop, 6 years ago (diff)

libsigc++-2.10.0-1

Line 
1%define name libsigc++
2%define version 2.10.0
3%define release 1%{?_dist_release}
4
5%define lib_name sigc++-2.0
6
7%define _unpackaged_files_terminate_build 1
8
9Summary: The Typesafe Signal Framework for C++
10Summary(ja): C++ 用の型安全なシグナルフレームワーク
11Name: %{name}
12Version: %{version}
13Release: %{release}
14
15Group: System Environment/Libraries
16License: LGPLv2
17URL: http://libsigc.sourceforge.net/
18
19Source: http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.10/%{name}-%{version}.tar.xz
20
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: gcc-c++
23BuildRequires: m4
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28
29%description
30This library implements a full callback system for use in widget libraries,
31abstract interfaces, and general programming. Originally part of the Gtk--
32widget set, %{name} is now a seperate library to provide for more general
33use. It is the most complete library of its kind with the ablity to connect
34an abstract callback to a class method, function, or function object. It
35contains adaptor classes for connection of dissimilar callbacks and has an
36ease of use unmatched by other C++ callback libraries.
37
38Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
39
40
41%package devel
42Summary: development tools for the Typesafe Signal Framework for C++
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: pkgconfig
46
47%description devel
48The %{name}-devel package contains the static libraries and header files
49needed for development with %{name}.
50
51%package examples
52Summary: examples and tests for the Typesafe Signal Framework for C++
53Group: Development/Libraries
54Requires: %{name}-devel = %{version}-%{release}
55
56%description examples
57The %{name}-devel package contains source code of example and test
58programs for %{name}.
59
60%prep
61%setup -q
62
63%build
64%configure --disable-static --enable-silent-rules
65make %{_smp_mflags}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69make install DESTDIR=$RPM_BUILD_ROOT
70
71# removed unpackage files
72rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
73
74mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
75cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
76find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
77find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
78find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
79        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
80
81for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
82        rm -f $i.*
83done
84
85rm -rf docs-toinstall
86mkdir -p docs-to-install
87cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
88rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
89
90# devhelp path fix
91sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
92#sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(-,root,root,755)
103%doc AUTHORS COPYING README NEWS ChangeLog TODO
104%attr(755,root,root) %{_libdir}/lib*.so.*
105
106%files devel
107%defattr(-,root,root,755)
108%{_includedir}/*
109%{_libdir}/%{lib_name}/include
110%{_libdir}/pkgconfig/*.pc
111#{_libdir}/lib*.la
112%{_libdir}/lib*.so
113%{_datadir}/devhelp/books/%{name}-2.0/*
114%doc docs-to-install/index.html docs-to-install/images
115%doc docs-to-install/reference docs-to-install/tutorial
116
117%files examples
118%defattr(-,root,root,755)
119%{_libdir}/%{lib_name}/examples
120%{_libdir}/%{lib_name}/tests
121
122%changelog
123* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.0-1
124- new upstream release.
125
126* Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
127- new upstream release
128
129* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-2
130- rebuild with gcc-5.4.0
131
132* Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
133- new upstream release
134
135* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
136- new upstream release
137
138* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-1
139- new upstream release
140
141* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.10-1
142- new upstream release
143
144* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.8-2
145- build with rpm-4.8.1-1 for pkg-config file
146
147* Thu Sep  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
148- new upstream release
149
150* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
151- new upstream release
152- built with new toolchain
153
154* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
155- new upstream release
156- remove static libraries from devel package
157
158* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
159- new upstream release
160- spec in UTF-8
161
162* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
163- removed .la files from devel package
164
165* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
166- new upstream release
167
168* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
169- rebuild with new environment/toolchain
170
171* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
172- new upstream release
173
174* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
175- rebuild with new libtool
176
177* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
178- new upstream release
179
180* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
181- new upstream release
182
183* Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
184- new upstream release
185
186* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
187- new upstream release
188- added tutorial to devel package
189
190* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
191- update to 2.0.6
192
193* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
194- update to 1.2.5
195- add Requires: pkgconfig
196
197* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
198- rebuild to remove dependance <5371>
199- add Japanese summary
200- use better macros
201- s/Copyright/License/
202
203* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
204- rebuild with new toolchain
205
206* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
207- 1.0.4-0vl1
208- Build for Vine Linux 2.5
209
210* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
211- packaged for Vine Linux 2.1
212
213* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
214- updated Url and Source fileds
215- 1.0.0 stable release
216
217* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
218- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
219- minor install section cleanup
220
221* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
222- autogen just creates configure, not runs it, so cleaned that up too.
223
224* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
225- minor attr fix
226- removed unnecessary curly braces
227- fixed Herbert's adjustement
228
229* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
230- minor package dependence fix
231
232* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
233- fixed typo of mine
234- added traditional CUSTOM_RELEASE stuff
235- added SMP support
236
237* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
238- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
239
240* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
241- split into three packages: %name, %name-devel and %name-examples
242
243* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
244- updated source field and merged conflicts between revisions.
245
246* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
247- updated Prefix and BuildRoot fields
248
249* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
250- made sure configure works on all alphas
251
252* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
253- Added autoconf macro for sigc.
254
255* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
256- Made into a .in to keep version field up to date
257- Still need to do release by hand
258
259* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
260- added Vendor and Packager fields
261
262* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
263- updated to 0.8.0
264
265* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
266- initial revision
Note: See TracBrowser for help on using the repository browser.