source: projects/specs/trunk/lib/libr/librsvg2/librsvg2-vl.spec @ 9724

Revision 9724, 12.1 KB checked in by Takemikaduchi, 9 years ago (diff)

NEW: vine-sleep-helper
mate-session-manager,mate-power-manager: add R: vine-sleep-helper
others: new upstream release

Line 
1%define __libtoolize :
2
3%define libxml2_version 2.7.8
4%define gdk_pixbuf2 2.26.1
5%define gtk3_version 3.4.1
6%define freetype_version 2.4.2
7%define popt_version 1.14
8%define libart_version 2.3.21
9%define cairo_version 1.12.0
10%define dbus_version 1.4.0
11%define dbus_glib_version 0.88
12%define avahi_glib_version 0.6.23
13%define libcroco_version 0.6.2
14%define libgsf_version 1.14.19
15
16Name:    librsvg2
17Summary: An SVG library based on libart.
18Summary(ja): libart ベースの SVG ライブラリ
19Version: 2.40.10
20Release: 1%{?_dist_release}
21License: LGPL
22Group: System Environment/Libraries
23Source: librsvg-%{version}.tar.xz
24
25Patch0:  librsvg-2.40.10-git20150811.patch
26
27Requires(post,postun): gtk3 >= %{gtk3_version}
28Requires(post): dbus-glib >= %{dbus_glib_version}
29Requires(post): avahi-glib >= %{avahi_glib_version}
30Requires(post): libgsf, libcroco
31Requires: gtk3 >= %{gtk3_version}
32Requires: libxml2 >= %{libxml2_version}
33Requires: popt >= %{popt_version}
34Requires: freetype2 >= %{freetype_version}
35Requires: libpng
36BuildRequires: libpng-devel
37BuildRequires: gtk3-devel >= %{gtk3_version}
38BuildRequires: gobject-introspection-devel
39BuildRequires: libxml2-devel >= %{libxml2_version}
40BuildRequires: freetype2-devel >= %{freetype_version}
41BuildRequires: cairo-devel >= %{cairo_version}
42BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
43BuildRequires: avahi-glib-devel >= %{avahi_glib_version}
44BuildRequires: libcroco-devel >= %{libcroco_version}
45BuildRequires: libgsf-devel >= %{libgsf_version}
46BuildRequires: autoconf
47BuildRequires: gtk-doc
48BuildRequires: vala-devel
49BuildRequires: vala-tools
50
51BuildRoot: %{_tmppath}/%{name}-%{version}-root
52
53Vendor: Project Vine
54Distribution: Vine Linux
55
56%description
57An SVG library based on libart.
58
59%description -l ja
60libart ベースの SVG ライブラリです
61
62
63%package devel
64Summary: Libraries and include files for developing with librsvg.
65Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
66Group: Development/Libraries
67Requires: %{name} = %{version}
68Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
69Requires: cairo-devel >= %{cairo_version}
70
71%description devel
72This package provides the necessary development libraries and include
73files to allow you to develop with librsvg.
74
75
76%package        docs
77Summary:        Documentation for %{name}
78Summary(ja):    %{name} 用のドキュメント
79Group:          Documentation
80Requires:       %{name} = %{version}-%{release}
81BuildArch:      noarch
82
83%description    docs
84This package contains documentation for %{name}.
85
86
87%package        vala
88Summary:        Vala bindings for %{name}
89Summary(ja):    %{name} の Vala バインディング
90Group:          Development/Libraries
91Requires:       %{name} = %{version}-%{release}
92Requires:       vala
93
94%description    vala
95Vala bindings for %{name}.
96
97
98%prep
99%setup -q -n librsvg-%{version}
100%patch0 -p1
101
102%build
103%configure --enable-gtk-doc \
104           --enable-introspection=yes \
105           --enable-vala=yes \
106           --with-svgz \
107           --enable-gtk-theme \
108           --with-croco \
109           --disable-static
110%__make %{?_smp_mflags}
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make install DESTDIR=$RPM_BUILD_ROOT
115
116rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
117rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
118rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post
124/sbin/ldconfig
125if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
126  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
127fi ||:
128
129%postun
130/sbin/ldconfig
131if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
132  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
133fi ||:
134
135%files
136%defattr(-,root,root,-)
137%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
138%{_bindir}/rsvg-convert
139%{_bindir}/rsvg-view-3
140%{_libdir}/librsvg-2.so.*
141%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
142%{_libdir}/girepository-1.0/Rsvg-2.0.typelib
143%{_mandir}/man1/rsvg-convert.1.gz
144
145%files devel
146%defattr(-,root,root,-)
147%{_libdir}/librsvg-2.so
148%{_includedir}/librsvg-2.0/librsvg
149%{_libdir}/pkgconfig/librsvg-2.0.pc
150%{_datadir}/gir-1.0/Rsvg-2.0.gir
151
152%files docs
153%defattr(-,root,root,-)
154%{_datadir}/gtk-doc/html/rsvg-2.0
155
156%files vala
157%defattr(-,root,root,-)
158%{_datadir}/vala/vapi/librsvg-2.0.vapi
159
160
161%changelog
162* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.10-1
163- new upstream release
164- add Patch0 (librsvg-2.40.10-git20150811.patch)
165
166* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.9-1
167- new upstream release
168
169* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.8-1
170- new upstream release
171
172* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.7-1
173- new upstream release
174
175* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.6-1
176- new upstream release
177
178* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.5-1
179- new upstream release
180
181* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
182- new upstream release
183
184* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-2
185- rebuild with libpng-1.6.12
186
187* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
188- new upstream release
189
190* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
191- fix typo
192
193* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
194- new upstream release
195- remove BuildRequires: gtk2-devel
196
197* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
198- add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
199- create %%{name}-docs and %%{name}-vala subpackages
200
201* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
202- new upstream release
203
204* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
205- new upstream release
206
207* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
208- new upstream release
209
210* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
211- new upstream release
212- add BuildRequires: gobject-introspection-devel
213
214* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
215- new upstream release
216- remove Patch0
217
218* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
219- new upstream release
220- add Patch0 (librsvg2-2.34.0-git20110728.patch)
221
222* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
223- new upstream release
224
225* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
226- new upstream release
227- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
228- remove Requires: libart_lgpl
229- add configure option (--disable-static)
230- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
231- fix %install, %files, %post and %postun
232
233* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
234- build with rpm-4.8.1-1 for pkg-config file
235
236* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
237- new upstream release
238
239* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
240- new upstream release
241- remove static libs
242
243* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
244- new upstream release
245- spec in UTF-8
246
247* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
248- new upstream release
249
250* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
251- rebuilt with libgsf-1.14.8
252
253* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
254- new upstream release
255
256* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
257- new upstream release
258- add BuildRequires: dbus-glib-devel, avahi-glib-devel
259- add BuildRequires: libgsf-devel, libcroco-devel
260- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
261- add Requires(post,postun): glib2
262
263* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
264- rebuild with gtk+-2.10
265
266* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
267- rebuilt without libgsf-devel
268
269* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
270- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
271  for biarch support. (TODO: add compat32)
272
273* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
274- rebuild
275
276* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
277- new upstream release
278
279* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
280- new upstream release
281
282* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
283- new upstream release
284
285* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
286- new upstream release
287- added --disable-gtk-doc option
288
289* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
290- new upstream release
291- added gtk-doc to devel package
292
293* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
294- new upstream release
295- added Japanese description
296- added --without-svgz option (because it requires libgsf)
297
298* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
299- new upstream release
300
301* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
302- new upstream release
303
304* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
305- rebuilt to avoid unwanted dependency (libgsf)
306
307* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
308- add gdk-pixbuf-query-loaders to post/postun script.
309
310* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
311- rebuild with gtk+-2.4.0
312
313* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
314- new upstream release
315
316* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
317- fix kanji code of spec file
318- fix file entry, add missing files
319
320* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
321- new upstream release
322
323* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
324- added --without-svgz and --without-gimp to %configure
325
326* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
327- new upstream release
328- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
329- added %{_libdir}/gtk-2.0/* to devel package
330
331* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
332- new upstream release
333
334* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
335- new upstream release
336
337* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
338- new upstream release
339
340* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
341- build for Vine Linux
342- new upstream release from gnome-2.1.4
343
344* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
345- 2.0.1
346
347* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
348- automated rebuild
349
350* Sun May 26 2002 Tim Powers <timp@redhat.com>
351- automated rebuild
352
353* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
354- rebuild in different environment
355
356* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
357- rebuild in different environment
358
359* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
360- 1.1.6
361
362* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
363- Update to 1.1.3
364
365* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
366- automated rebuild
367
368* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
369- new CVS snap 1.1.0.91
370- remove automake/autoconf calls
371
372* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
373- convert to librsvg2 RPM
374
375* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
376- 1.0.2
377
378* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
379- Add a patch that moves the includes to librsvg-1/librsvg
380- in preparation for a later librsvg 2 library.
381
382* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
383- build requires gnome-libs-devel, #49509
384
385* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
386- own /usr/include/librsvg
387
388* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
389- fixed the linefeed problem in multibyte environment. (Bug#49310)
390
391* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
392- put .la file back in package
393
394* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
395- Put changelog at the end
396- Move .so files to devel subpackage
397- Don't mess with ld.so.conf
398- Don't use %%{prefix}, this isn't a relocatable package
399- Don't define a bad docdir
400- Add BuildRequires
401- Use %%{_tmppath}
402- Don't define name, version etc. on top of the file (why do so many do that?)
403- s/Copyright/License/
404
405* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
406- Put into Red Hat Build system
407
408* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
409- removed obsoletes from sub packages and added mozilla and trilobite
410subpackages
411
412* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
413- created this thing
414
Note: See TracBrowser for help on using the repository browser.