source: projects/specs/trunk/lib/libr/librsvg2/librsvg2-vl.spec @ 9791

Revision 9791, 12.1 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define __libtoolize :
2
3%define libxml2_version 2.7.8
4%define gdk_pixbuf2 2.26.1
5%define gtk3_version 3.4.1
6%define freetype_version 2.4.2
7%define popt_version 1.14
8%define libart_version 2.3.21
9%define cairo_version 1.12.0
10%define dbus_version 1.4.0
11%define dbus_glib_version 0.88
12%define avahi_glib_version 0.6.23
13%define libcroco_version 0.6.2
14%define libgsf_version 1.14.19
15
16Name:    librsvg2
17Summary: An SVG library based on libart.
18Summary(ja): libart ベースの SVG ライブラリ
19Version: 2.40.11
20Release: 1%{?_dist_release}
21License: LGPL
22Group: System Environment/Libraries
23Source: librsvg-%{version}.tar.xz
24
25Requires(post,postun): gtk3 >= %{gtk3_version}
26Requires(post): dbus-glib >= %{dbus_glib_version}
27Requires(post): avahi-glib >= %{avahi_glib_version}
28Requires(post): libgsf, libcroco
29Requires: gtk3 >= %{gtk3_version}
30Requires: libxml2 >= %{libxml2_version}
31Requires: popt >= %{popt_version}
32Requires: freetype2 >= %{freetype_version}
33Requires: libpng
34BuildRequires: libpng-devel
35BuildRequires: gtk3-devel >= %{gtk3_version}
36BuildRequires: gobject-introspection-devel
37BuildRequires: libxml2-devel >= %{libxml2_version}
38BuildRequires: freetype2-devel >= %{freetype_version}
39BuildRequires: cairo-devel >= %{cairo_version}
40BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
41BuildRequires: avahi-glib-devel >= %{avahi_glib_version}
42BuildRequires: libcroco-devel >= %{libcroco_version}
43BuildRequires: libgsf-devel >= %{libgsf_version}
44BuildRequires: autoconf
45BuildRequires: gtk-doc
46BuildRequires: vala-devel
47BuildRequires: vala-tools
48
49BuildRoot: %{_tmppath}/%{name}-%{version}-root
50
51Vendor: Project Vine
52Distribution: Vine Linux
53
54%description
55An SVG library based on libart.
56
57%description -l ja
58libart ベースの SVG ライブラリです
59
60
61%package devel
62Summary: Libraries and include files for developing with librsvg.
63Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
64Group: Development/Libraries
65Requires: %{name} = %{version}
66Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
67Requires: cairo-devel >= %{cairo_version}
68
69%description devel
70This package provides the necessary development libraries and include
71files to allow you to develop with librsvg.
72
73
74%package        docs
75Summary:        Documentation for %{name}
76Summary(ja):    %{name} 用のドキュメント
77Group:          Documentation
78Requires:       %{name} = %{version}-%{release}
79BuildArch:      noarch
80
81%description    docs
82This package contains documentation for %{name}.
83
84
85%package        vala
86Summary:        Vala bindings for %{name}
87Summary(ja):    %{name} の Vala バインディング
88Group:          Development/Libraries
89Requires:       %{name} = %{version}-%{release}
90Requires:       vala
91
92%description    vala
93Vala bindings for %{name}.
94
95
96%prep
97%setup -q -n librsvg-%{version}
98
99%build
100%configure --enable-gtk-doc \
101           --enable-introspection=yes \
102           --enable-vala=yes \
103           --with-svgz \
104           --enable-gtk-theme \
105           --with-croco \
106           --disable-static
107%__make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111make install DESTDIR=$RPM_BUILD_ROOT
112
113rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
114rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
115rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post
121/sbin/ldconfig
122if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
123  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
124fi ||:
125
126%postun
127/sbin/ldconfig
128if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
129  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
130fi ||:
131
132%files
133%defattr(-,root,root,-)
134%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
135%{_bindir}/rsvg-convert
136%{_bindir}/rsvg-view-3
137%{_libdir}/librsvg-2.so.*
138%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
139%{_libdir}/girepository-1.0/Rsvg-2.0.typelib
140%{_mandir}/man1/rsvg-convert.1.gz
141
142%files devel
143%defattr(-,root,root,-)
144%{_libdir}/librsvg-2.so
145%{_includedir}/librsvg-2.0/librsvg
146%{_libdir}/pkgconfig/librsvg-2.0.pc
147%{_datadir}/gir-1.0/Rsvg-2.0.gir
148
149%files docs
150%defattr(-,root,root,-)
151%{_datadir}/gtk-doc/html/rsvg-2.0
152
153%files vala
154%defattr(-,root,root,-)
155%{_datadir}/vala/vapi/librsvg-2.0.vapi
156
157
158%changelog
159* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.11-1
160- new upstream release
161- remove Patch0
162
163* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.10-1
164- new upstream release
165- add Patch0 (librsvg-2.40.10-git20150811.patch)
166
167* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.9-1
168- new upstream release
169
170* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.8-1
171- new upstream release
172
173* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.7-1
174- new upstream release
175
176* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.6-1
177- new upstream release
178
179* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.5-1
180- new upstream release
181
182* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
183- new upstream release
184
185* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-2
186- rebuild with libpng-1.6.12
187
188* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
189- new upstream release
190
191* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
192- fix typo
193
194* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
195- new upstream release
196- remove BuildRequires: gtk2-devel
197
198* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
199- add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
200- create %%{name}-docs and %%{name}-vala subpackages
201
202* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
203- new upstream release
204
205* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
206- new upstream release
207
208* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
209- new upstream release
210
211* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
212- new upstream release
213- add BuildRequires: gobject-introspection-devel
214
215* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
216- new upstream release
217- remove Patch0
218
219* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
220- new upstream release
221- add Patch0 (librsvg2-2.34.0-git20110728.patch)
222
223* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
224- new upstream release
225
226* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
227- new upstream release
228- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
229- remove Requires: libart_lgpl
230- add configure option (--disable-static)
231- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
232- fix %install, %files, %post and %postun
233
234* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
235- build with rpm-4.8.1-1 for pkg-config file
236
237* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
238- new upstream release
239
240* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
241- new upstream release
242- remove static libs
243
244* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
245- new upstream release
246- spec in UTF-8
247
248* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
249- new upstream release
250
251* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
252- rebuilt with libgsf-1.14.8
253
254* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
255- new upstream release
256
257* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
258- new upstream release
259- add BuildRequires: dbus-glib-devel, avahi-glib-devel
260- add BuildRequires: libgsf-devel, libcroco-devel
261- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
262- add Requires(post,postun): glib2
263
264* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
265- rebuild with gtk+-2.10
266
267* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
268- rebuilt without libgsf-devel
269
270* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
271- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
272  for biarch support. (TODO: add compat32)
273
274* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
275- rebuild
276
277* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
278- new upstream release
279
280* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
281- new upstream release
282
283* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
284- new upstream release
285
286* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
287- new upstream release
288- added --disable-gtk-doc option
289
290* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
291- new upstream release
292- added gtk-doc to devel package
293
294* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
295- new upstream release
296- added Japanese description
297- added --without-svgz option (because it requires libgsf)
298
299* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
300- new upstream release
301
302* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
303- new upstream release
304
305* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
306- rebuilt to avoid unwanted dependency (libgsf)
307
308* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
309- add gdk-pixbuf-query-loaders to post/postun script.
310
311* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
312- rebuild with gtk+-2.4.0
313
314* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
315- new upstream release
316
317* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
318- fix kanji code of spec file
319- fix file entry, add missing files
320
321* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
322- new upstream release
323
324* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
325- added --without-svgz and --without-gimp to %configure
326
327* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
328- new upstream release
329- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
330- added %{_libdir}/gtk-2.0/* to devel package
331
332* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
333- new upstream release
334
335* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
336- new upstream release
337
338* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
339- new upstream release
340
341* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
342- build for Vine Linux
343- new upstream release from gnome-2.1.4
344
345* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
346- 2.0.1
347
348* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
349- automated rebuild
350
351* Sun May 26 2002 Tim Powers <timp@redhat.com>
352- automated rebuild
353
354* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
355- rebuild in different environment
356
357* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
358- rebuild in different environment
359
360* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
361- 1.1.6
362
363* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
364- Update to 1.1.3
365
366* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
367- automated rebuild
368
369* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
370- new CVS snap 1.1.0.91
371- remove automake/autoconf calls
372
373* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
374- convert to librsvg2 RPM
375
376* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
377- 1.0.2
378
379* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
380- Add a patch that moves the includes to librsvg-1/librsvg
381- in preparation for a later librsvg 2 library.
382
383* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
384- build requires gnome-libs-devel, #49509
385
386* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
387- own /usr/include/librsvg
388
389* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
390- fixed the linefeed problem in multibyte environment. (Bug#49310)
391
392* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
393- put .la file back in package
394
395* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
396- Put changelog at the end
397- Move .so files to devel subpackage
398- Don't mess with ld.so.conf
399- Don't use %%{prefix}, this isn't a relocatable package
400- Don't define a bad docdir
401- Add BuildRequires
402- Use %%{_tmppath}
403- Don't define name, version etc. on top of the file (why do so many do that?)
404- s/Copyright/License/
405
406* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
407- Put into Red Hat Build system
408
409* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
410- removed obsoletes from sub packages and added mozilla and trilobite
411subpackages
412
413* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
414- created this thing
415
Note: See TracBrowser for help on using the repository browser.