source: projects/specs/trunk/lib/libq/libqzeitgeist/libqzeitgeist-vl.spec @ 5383

Revision 5383, 2.5 KB checked in by inagaki, 12 years ago (diff)

update: akonadi, automoc4, herqq, ibus-qt, kdebase-runtime, libqzeitgeist, phonon, PyQt4, qca2, qca-ossl, qt4, qt-assistant-adp, qscintilla, qtsoap, uim

Line 
1%define qt4_ver 4.8.0
2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
5%define _qt4_import %(pkg-config --variable importdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/imports)
6
7Name:    libqzeitgeist
8Summary: Qt Zeitgeist Library
9Version: 0.8.0
10Release: 1%{?_dist_release}
11
12License: LGPLv2+
13Group:   System Environment/Libraries
14URL:     http://projects.kde.org/projects/kdesupport/libqzeitgeist
15
16Source0: http://ftp.kde.org/pub/kde/stable/%{name}/0.8.0/src/%{name}-%{version}.tar.bz2
17
18## upstreamable patches
19# reduce linking in libqzeitgeist
20Patch50: libqzeitgeist-0.8.0-reduced_linking.patch
21
22## upstream patches
23# fix linking (don't link the Qt world, including QtWebkit, only use QT_DECLARATIVE_LIBRARIES)
24# consistently use QT_IMPORTS_DIR
25Patch100: libqzeitgeist-0.8.0-declarative.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: automoc4
29BuildRequires: cmake
30BuildRequires: qt4-devel >= 4.7.0
31BuildRequires: zeitgeist
32
33%description
34%{summary}.
35
36%package devel
37Summary: Development files for %{name}
38Group:   Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Requires: qt4-devel
41
42%description devel
43%{summary}
44
45
46%prep
47%setup -q
48
49%patch50 -p1 -b .reduced_linking
50%patch100 -p1 -b .declarative
51
52%build
53mkdir -p %{_target_platform}
54pushd %{_target_platform}
55%cmake ..
56popd
57
58make %{?_smp_mflags} -C %{_target_platform}
59
60
61%install
62rm -rf $RPM_BUILD_ROOT
63make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
64
65
66%check
67export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_datadir}/pkgconfig:$RPM_BUILD_ROOT%{_libdir}/pkgconfig
68test "$(pkg-config --modversion QZeitgeist)" = "%{version}"
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%post -p /sbin/ldconfig
75
76%postun -p /sbin/ldconfig
77
78
79%files
80%doc COPYING README
81%{_libdir}/libqzeitgeist.so.*
82%dir %{_qt4_import}/org
83%dir %{_qt4_import}/org/gnome
84%dir %{_qt4_import}/org/gnome/zeitgeist
85%{_qt4_import}/org/gnome/zeitgeist/*
86
87%files devel
88%{_includedir}/QZeitgeist/
89%{_libdir}/libqzeitgeist.so
90%dir %{_libdir}/cmake/QZeitgeist
91%{_libdir}/cmake/QZeitgeist/*
92%{_libdir}/pkgconfig/QZeitgeist.pc
93
94
95%changelog
96* Sun Jan  8 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.0-1
97- new upstream release
98- added BR: automoc4
99
100* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.0-2
101- Initial build for Vine Linux
102
103* Fri May 20 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.0-1
104- first try
105
Note: See TracBrowser for help on using the repository browser.