source: projects/specs/trunk/lib/libq/libqzeitgeist/libqzeitgeist-vl.spec @ 10454

Revision 10454, 2.6 KB checked in by tomop, 8 years ago (diff)

libqzeitgeist-0.8.0-2

Line 
1%define qt4_ver 4.8.0
2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
5%define _qt4_import %(pkg-config --variable importdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/imports)
6
7Name:    libqzeitgeist
8Summary: Qt Zeitgeist Library
9Version: 0.8.0
10Release: 2%{?_dist_release}
11
12License: LGPLv2+
13Group:   System Environment/Libraries
14URL:     http://projects.kde.org/projects/kdesupport/libqzeitgeist
15
16Vendor:  Project Vine
17Distribution: Vine Linux
18
19Source0: http://ftp.kde.org/pub/kde/stable/%{name}/0.8.0/src/%{name}-%{version}.tar.bz2
20
21## upstreamable patches
22# reduce linking in libqzeitgeist
23Patch50: libqzeitgeist-0.8.0-reduced_linking.patch
24
25## upstream patches
26# fix linking (don't link the Qt world, including QtWebkit, only use QT_DECLARATIVE_LIBRARIES)
27# consistently use QT_IMPORTS_DIR
28Patch100: libqzeitgeist-0.8.0-declarative.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: automoc4
32BuildRequires: cmake
33BuildRequires: qt4-devel >= 4.7.0
34BuildRequires: zeitgeist
35
36%description
37%{summary}.
38
39%package devel
40Summary: Development files for %{name}
41Group:   Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: qt4-devel
44
45%description devel
46%{summary}
47
48
49%prep
50%setup -q
51
52%patch50 -p1 -b .reduced_linking
53%patch100 -p1 -b .declarative
54
55%build
56mkdir -p %{_target_platform}
57pushd %{_target_platform}
58%cmake ..
59popd
60
61make %{?_smp_mflags} -C %{_target_platform}
62
63
64%install
65rm -rf $RPM_BUILD_ROOT
66make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
67
68
69%check
70export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_datadir}/pkgconfig:$RPM_BUILD_ROOT%{_libdir}/pkgconfig
71test "$(pkg-config --modversion QZeitgeist)" = "%{version}"
72
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%post -p /sbin/ldconfig
78
79%postun -p /sbin/ldconfig
80
81
82%files
83%doc COPYING README
84%{_libdir}/libqzeitgeist.so.*
85%dir %{_qt4_import}/org
86%dir %{_qt4_import}/org/gnome
87%dir %{_qt4_import}/org/gnome/zeitgeist
88%{_qt4_import}/org/gnome/zeitgeist/*
89
90%files devel
91%{_includedir}/QZeitgeist/
92%{_libdir}/libqzeitgeist.so
93%dir %{_libdir}/cmake/QZeitgeist
94%{_libdir}/cmake/QZeitgeist/*
95%{_libdir}/pkgconfig/QZeitgeist.pc
96
97
98%changelog
99* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.0-2
100- rebuilt with new toolchain.
101
102* Sun Jan  8 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.0-1
103- new upstream release
104- added BR: automoc4
105
106* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.0-2
107- Initial build for Vine Linux
108
109* Fri May 20 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.0-1
110- first try
111
Note: See TracBrowser for help on using the repository browser.