source: projects/specs/trunk/lib/libp/libpwquality/libpwquality-vl.spec @ 11942

Revision 11942, 5.8 KB checked in by tomop, 6 years ago (diff)

libpwquality-1.4.0-1

RevLine 
[6890]1Summary: A library for password generation and password quality checking
2Name: libpwquality
[11942]3Version: 1.4.0
[9073]4Release: 1%{?_dist_release}
[6890]5# The package is BSD licensed with option to relicense as GPLv2+
6# - this option is redundant as the BSD license allows that anyway.
7License: BSD or GPLv2+
8Group: System Environment/Base
[11942]9Source0: https://github.com/libpwquality/libpwquality/releases/download/libpwquality-%{version}/libpwquality-%{version}.tar.bz2
10Patch1: libpwquality-1.4.0-covscan.patch
[6890]11
12%global _moduledir /%{_lib}/security
13%global _secconfdir %{_sysconfdir}/security
14
15Requires: cracklib-dicts >= 2.8
[7938]16Requires: pam
[6890]17BuildRequires: cracklib
18BuildRequires: gettext
19BuildRequires: pam-devel
20BuildRequires: python-devel
[11942]21BuildRequires: python-rpm-macros
22BuildRequires: python3-devel
23BuildRequires: python3-rpm-macros
[6890]24
[9791]25URL: https://fedorahosted.org/libpwquality/
[6890]26
27# we don't want to provide private python extension libs
[11942]28%define __provides_exclude_from ^(%{python_sitearch}|%{python3_sitearch})/.*\.so$.
[6890]29
[8119]30Vendor: Project Vine
31Distribution: Vine Linux
32
[6890]33%description
34This is a library for password quality checks and generation
35of random passwords that pass the checks.
36This library uses the cracklib and cracklib dictionaries
37to perform some of the checks.
38
39%package devel
40Group: Development/Libraries
41Summary: Files needed for developing PAM-aware applications and modules for PAM
[7938]42Requires: libpwquality = %{version}-%{release}
[6890]43Requires: pkgconfig
44
45%description devel
46Files needed for development of applications using the libpwquality
47library.
48See the pwquality.h header file for the API.
49
50%package -n python-pwquality
51Group: Development/Libraries
52Summary: Python bindings for the libpwquality library
[7938]53Requires: libpwquality = %{version}-%{release}
[6890]54
55%description -n python-pwquality
56This is pwquality Python module that provides Python bindings
57for the libpwquality library. These bindings can be used
58for easy password quality checking and generation of random
59pronounceable passwords from Python applications.
60
[11942]61%package -n python3-pwquality
62Group: Development/Libraries
63Summary: Python bindings for the libpwquality library
64Requires: libpwquality = %{version}-%{release}
65
66%description -n python3-pwquality
67This is pwquality Python module that provides Python bindings
68for the libpwquality library. These bindings can be used
69for easy password quality checking and generation of random
70pronounceable passwords from Python applications.
71
[6890]72%prep
73%setup -q
[11942]74%patch1 -p1 -b .covscan
[6890]75
[11942]76rm -rf %{py3dir}
77cp -a . %{py3dir}
78
[6890]79%build
80%configure \
[11942]81        --with-securedir=%{_moduledir} \
[6890]82        --with-pythonsitedir=%{python_sitearch} \
[11942]83        --with-python-binary=%{__python} \
[6890]84        --disable-static
85
86make %{?_smp_mflags}
87
[11942]88pushd %{py3dir}
89%configure \
90        --with-securedir=%{_moduledir} \
91        --with-pythonsitedir=%{python3_sitearch} \
92        --with-python-binary=%{__python3} \
93        --disable-static
94
95make %{?_smp_mflags}
96popd
97
[6890]98%install
99make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
100
[11942]101pushd %{py3dir}
102make -C python install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
103popd
104
[6890]105pushd $RPM_BUILD_ROOT%{_libdir}
106mv libpwquality.so.* $RPM_BUILD_ROOT/%{_lib}/
107ln -sf ../../%{_lib}/libpwquality.so.*.* libpwquality.so
108popd
109rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
110rm -f $RPM_BUILD_ROOT%{_moduledir}/*.la
111
[11942]112mkdir $RPM_BUILD_ROOT%{_secconfdir}/pwquality.conf.d
113
[6890]114%find_lang libpwquality
115
116%check
117# Nothing yet
118
119%post -p /sbin/ldconfig
120
121%postun -p /sbin/ldconfig
122
123%files -f libpwquality.lang
124%defattr(-,root,root,-)
[11942]125%{!?_licensedir:%global license %%doc}
126%license COPYING
127%doc README NEWS AUTHORS
[6890]128%{_bindir}/pwmake
129%{_bindir}/pwscore
130%{_moduledir}/pam_pwquality.so
131/%{_lib}/libpwquality.so.*
132%config(noreplace) %{_secconfdir}/pwquality.conf
133%{_mandir}/man1/*
134%{_mandir}/man5/*
135%{_mandir}/man8/*
136
137%files devel
138%defattr(-,root,root,-)
139%{_includedir}/pwquality.h
140%{_libdir}/libpwquality.so
141%{_libdir}/pkgconfig/*.pc
[11942]142%{_mandir}/man3/*
[6890]143
144%files -n python-pwquality
145%defattr(-,root,root,-)
146%{python_sitearch}/pwquality.so
[11942]147%{python_sitearch}/*.egg-info
[6890]148
[11942]149%files -n python3-pwquality
150%defattr(-,root,root,-)
151%{python3_sitearch}/*.so
152%{python3_sitearch}/*.egg-info
153
[6890]154%changelog
[11942]155* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.0-1
156- new upstream release.
157- added python3 support.
158
[9791]159* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
160- new upstream release
161
[9073]162* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
163- new upstream release
164
[8119]165* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-2
166- rebuild with VineSeed environment
167
[7938]168* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
169- new upstream release
170
[6890]171* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
172- initial build for Vine Linux
173
174
175* Thu Aug 16 2012 Tomas Mraz <tmraz@redhat.com> 1.2.0-1
176- add maxsequence check for too long monotonic character sequence.
177- clarified alternative licensing to GPLv2+.
178- add local_users_only option to skip the pwquality checks for
179  non-locals. (thanks to Stef Walter)
180
181* Wed Jun 13 2012 Tomas Mraz <tmraz@redhat.com> 1.1.1-1
182- use rpm built-in filtering of provides (rhbz#830153)
183- remove strain debug fprintf() (rhbz#831567)
184
185* Thu May 24 2012 Tomas Mraz <tmraz@redhat.com> 1.1.0-1
186- fix leak when throwing PWQError exception
187- added pkgconfig file
188- call the simplicity checks before the cracklib check
189- add enforce_for_root option to the PAM module
190- updated translations from Transifex
191
192* Thu Dec  8 2011 Tomas Mraz <tmraz@redhat.com> 1.0.0-1
193- added a few additional password quality checks
194- bugfix in configuration file parsing
195
196* Fri Nov 11 2011 Tomas Mraz <tmraz@redhat.com> 0.9.9-1
197- added python bindings and documentation
198
199* Mon Oct 10 2011 Tomas Mraz <tmraz@redhat.com> 0.9-2
200- fixes for problems found in review (missing BR on pam-devel,
201  License field, Source URL, Require pam, other cleanups)
202
203* Mon Oct  3 2011 Tomas Mraz <tmraz@redhat.com> 0.9-1
204- first spec file for libpwquality
Note: See TracBrowser for help on using the repository browser.