source: projects/specs/trunk/lib/libp/libpwquality/libpwquality-vl.spec @ 12372

Revision 12372, 5.8 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

acpica-tools-20190509-1

ethtool-5.4-1

flac-1.3.3-1

iproute-5.6.0-1

libcap-ng-0.7.10-1

libestr-0.1.11-2

libfastjson-0.99.8-4

libproxy-0.4.15-2

libpwquality-1.4.2-1

libunistring-0.9.10-2

mdadm-4.1-1

python-six-1.14.0-1

rsyslog-8.2002.0-1

speexdsp-1.2-0.16.rc3

Line 
1Summary: A library for password generation and password quality checking
2Name: libpwquality
3Version: 1.4.2
4Release: 1%{?_dist_release}
5Group: System Environment/Base
6Vendor: Project Vine
7Distribution: Vine Linux
8# The package is BSD licensed with option to relicense as GPLv2+
9# - this option is redundant as the BSD license allows that anyway.
10License: BSD or GPLv2+
11Source0: https://github.com/libpwquality/libpwquality/releases/download/libpwquality-%{version}/libpwquality-%{version}.tar.bz2
12
13%global _moduledir /%{_lib}/security
14%global _secconfdir %{_sysconfdir}/security
15
16Requires: cracklib-dicts >= 2.8
17Requires: pam
18BuildRequires: cracklib
19BuildRequires: gettext
20BuildRequires: pam-devel
21BuildRequires: python-devel
22BuildRequires: python-rpm-macros
23BuildRequires: python3-devel
24BuildRequires: python3-rpm-macros
25
26URL: https://fedorahosted.org/libpwquality/
27
28# we don't want to provide private python extension libs
29%define __provides_exclude_from ^(%{python_sitearch}|%{python3_sitearch})/.*\.so$.
30
31%description
32This is a library for password quality checks and generation
33of random passwords that pass the checks.
34This library uses the cracklib and cracklib dictionaries
35to perform some of the checks.
36
37%package devel
38Group: Development/Libraries
39Summary: Files needed for developing PAM-aware applications and modules for PAM
40Requires: libpwquality = %{version}-%{release}
41Requires: pkgconfig
42
43%description devel
44Files needed for development of applications using the libpwquality
45library.
46See the pwquality.h header file for the API.
47
48%package -n python-pwquality
49Group: Development/Libraries
50Summary: Python bindings for the libpwquality library
51Requires: libpwquality = %{version}-%{release}
52
53%description -n python-pwquality
54This is pwquality Python module that provides Python bindings
55for the libpwquality library. These bindings can be used
56for easy password quality checking and generation of random
57pronounceable passwords from Python applications.
58
59%package -n python3-pwquality
60Group: Development/Libraries
61Summary: Python bindings for the libpwquality library
62Requires: libpwquality = %{version}-%{release}
63
64%description -n python3-pwquality
65This is pwquality Python module that provides Python bindings
66for the libpwquality library. These bindings can be used
67for easy password quality checking and generation of random
68pronounceable passwords from Python applications.
69
70%prep
71%setup -q
72
73rm -rf %{py3dir}
74cp -a . %{py3dir}
75
76%build
77%configure \
78        --with-securedir=%{_moduledir} \
79        --with-pythonsitedir=%{python_sitearch} \
80        --with-python-binary=%{__python} \
81        --disable-static
82
83make %{?_smp_mflags}
84
85pushd %{py3dir}
86%configure \
87        --with-securedir=%{_moduledir} \
88        --with-pythonsitedir=%{python3_sitearch} \
89        --with-python-binary=%{__python3} \
90        --disable-static
91
92make %{?_smp_mflags}
93popd
94
95%install
96make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
97
98pushd %{py3dir}
99make -C python install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
100popd
101
102pushd $RPM_BUILD_ROOT%{_libdir}
103mv libpwquality.so.* $RPM_BUILD_ROOT/%{_lib}/
104ln -sf ../../%{_lib}/libpwquality.so.*.* libpwquality.so
105popd
106rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
107rm -f $RPM_BUILD_ROOT%{_moduledir}/*.la
108
109mkdir $RPM_BUILD_ROOT%{_secconfdir}/pwquality.conf.d
110
111%find_lang libpwquality
112
113%check
114# Nothing yet
115
116%post -p /sbin/ldconfig
117
118%postun -p /sbin/ldconfig
119
120%files -f libpwquality.lang
121%defattr(-,root,root,-)
122%{!?_licensedir:%global license %%doc}
123%license COPYING
124%doc README NEWS AUTHORS
125%{_bindir}/pwmake
126%{_bindir}/pwscore
127%{_moduledir}/pam_pwquality.so
128/%{_lib}/libpwquality.so.*
129%config(noreplace) %{_secconfdir}/pwquality.conf
130%{_mandir}/man1/*
131%{_mandir}/man5/*
132%{_mandir}/man8/*
133
134%files devel
135%defattr(-,root,root,-)
136%{_includedir}/pwquality.h
137%{_libdir}/libpwquality.so
138%{_libdir}/pkgconfig/*.pc
139%{_mandir}/man3/*
140
141%files -n python-pwquality
142%defattr(-,root,root,-)
143%{python_sitearch}/pwquality.so
144%{python_sitearch}/*.egg-info
145
146%files -n python3-pwquality
147%defattr(-,root,root,-)
148%{python3_sitearch}/*.so
149%{python3_sitearch}/*.egg-info
150
151%changelog
152* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.2-1
153- new upstream release.
154- dropped Patch1: fixed in upstream.
155
156* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.0-1
157- new upstream release.
158- added python3 support.
159
160* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
161- new upstream release
162
163* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
164- new upstream release
165
166* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-2
167- rebuild with VineSeed environment
168
169* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
170- new upstream release
171
172* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
173- initial build for Vine Linux
174
175
176* Thu Aug 16 2012 Tomas Mraz <tmraz@redhat.com> 1.2.0-1
177- add maxsequence check for too long monotonic character sequence.
178- clarified alternative licensing to GPLv2+.
179- add local_users_only option to skip the pwquality checks for
180  non-locals. (thanks to Stef Walter)
181
182* Wed Jun 13 2012 Tomas Mraz <tmraz@redhat.com> 1.1.1-1
183- use rpm built-in filtering of provides (rhbz#830153)
184- remove strain debug fprintf() (rhbz#831567)
185
186* Thu May 24 2012 Tomas Mraz <tmraz@redhat.com> 1.1.0-1
187- fix leak when throwing PWQError exception
188- added pkgconfig file
189- call the simplicity checks before the cracklib check
190- add enforce_for_root option to the PAM module
191- updated translations from Transifex
192
193* Thu Dec  8 2011 Tomas Mraz <tmraz@redhat.com> 1.0.0-1
194- added a few additional password quality checks
195- bugfix in configuration file parsing
196
197* Fri Nov 11 2011 Tomas Mraz <tmraz@redhat.com> 0.9.9-1
198- added python bindings and documentation
199
200* Mon Oct 10 2011 Tomas Mraz <tmraz@redhat.com> 0.9-2
201- fixes for problems found in review (missing BR on pam-devel,
202  License field, Source URL, Require pam, other cleanups)
203
204* Mon Oct  3 2011 Tomas Mraz <tmraz@redhat.com> 0.9-1
205- first spec file for libpwquality
Note: See TracBrowser for help on using the repository browser.