source: projects/specs/trunk/lib/libp/libproxy/libproxy-vl.spec @ 11377

Revision 11377, 9.0 KB checked in by tomop, 6 years ago (diff)

libproxy-0.4.15-1

Line 
1%bcond_with mozjs
2
3%define _unpackaged_files_terminate_build 1
4
5Summary:        A library handling all the details of proxy configuration
6Name:           libproxy
7Version:        0.4.15
8Release:        1%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://libproxy.github.io/libproxy
13Source0:        https://github.com/libproxy/libproxy/releases/download/%{version}/libproxy-%{version}.tar.xz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15
16BuildRequires:  python-devel
17BuildRequires:  python3-devel
18#Virtual Provides - We need either mozjs or WebKit
19%if %{with mozjs}
20Requires: %{name}-pac >= %{version}
21%endif
22#
23Requires: libproxy-python = %{version}-%{release}
24Requires: libproxy-bin = %{version}-%{release}
25
26Obsoletes: %{name}-mozjs < 1.4.15
27Obsoletes: %{name}-webkitgtk3 < 1.4.15
28
29BuildRequires:  cmake
30# gnome
31BuildRequires:  GConf2-devel
32%if %{with mozjs}
33# mozjs
34BuildRequires:  mozjs >= 38
35%endif
36# NetworkManager
37BuildRequires:  NetworkManager-devel
38BuildRequires:  dbus-devel
39BuildRequires:  glib2
40# webkit (gtk)
41BuildRequires:  webkitgtk4-devel
42# kde
43BuildRequires:  kdelibs-devel
44BuildRequires:  libXmu-devel
45BuildRequires:  libX11-devel
46
47BuildRequires:  python-rpm-macros
48BuildRequires:  python3-rpm-macros
49
50Provides: %{name}-webkit = %{version}-%{release}
51Obsoletes: %{name}-webkit < %{version}-%{release}
52
53Vendor: Project Vine
54Distribution: Vine Linux
55
56%description
57libproxy offers the following features:
58
59    * extremely small core footprint (< 35K)
60    * no external dependencies within libproxy core
61      (libproxy plugins may have dependencies)
62    * only 3 functions in the stable external API
63    * dynamic adjustment to changing network topology
64    * a standard way of dealing with proxy settings across all scenarios
65    * a sublime sense of joy and accomplishment
66
67Non-default rpmbuild options:
68--with webkit:           Enable WebKit-gtk support
69
70
71%package        bin
72Summary:        Binary to test %{name}
73Group:          Applications/System
74Requires:       %{name} = %{version}-%{release}
75
76%description    bin
77The %{name}-bin package contains the proxy binary for %{name}
78
79%package        python
80Summary:        Binding for %{name} and python
81Group:          System Environment/Libraries
82Requires:       %{name} = %{version}-%{release}
83
84%description    python
85The %{name}-python package contains the python binding for %{name}
86
87%package        python3
88Summary:        Binding for %{name} and python
89Group:          System Environment/Libraries
90Requires:       %{name} = %{version}-%{release}
91
92%description    python3
93The %{name}-python package contains the python binding for %{name}
94
95%package        gnome
96Summary:        Plugin for %{name} and gnome
97Group:          System Environment/Libraries
98Requires:       %{name} = %{version}-%{release}
99
100%description    gnome
101The %{name}-gnome package contains the %{name} plugin for gnome.
102
103%package        kde
104Summary:        Plugin for %{name} and kde
105Group:          System Environment/Libraries
106Requires:       %{name} = %{version}-%{release}
107
108%description    kde
109The %{name}-kde package contains the %{name} plugin for kde.
110
111%if %{with mozjs}
112%package        mozjs
113Summary:        Plugin for %{name} and mozjs
114Group:          System Environment/Libraries
115Requires:       %{name} = %{version}
116#Tweak this according to the current gecko-libs version
117Requires:       js
118Provides:       %{name}-pac = %{version}-%{release}
119
120%description    mozjs
121The %{name}-mozjs package contains the %{name} plugin for mozjs.
122
123%package        webkitgtk4
124Summary:        Plugin for %{name} and webkitgtk4
125Group:          System Environment/Libraries
126Requires:       %{name} = %{version}
127Provides:       %{name}-pac = %{version}-%{release}
128
129%description    webkitgtk4
130The %{name}-webkitgtk3 package contains the %{name} plugin for
131webkitgtk3.
132
133%endif
134
135%package        devel
136Summary:        Development files for %{name}
137Group:          Development/Libraries
138Requires:       %{name} = %{version}-%{release}
139Requires:       pkgconfig
140
141%description    devel
142The %{name}-devel package contains libraries and header files for
143developing applications that use %{name}.
144
145
146%prep
147%setup -q
148#sed -i "s|mozjs185>=1.8.5|mozjs185|" libproxy/cmake/modules/pacrunner_mozjs.cmk
149
150%build
151%cmake \
152        -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
153        -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
154        -DWITH_PERL=OFF \
155        -DWITH_WEBKIT3=ON \
156        -DWITH_KDE=ON \
157   .
158make VERBOSE=1 %{?_smp_mflags}
159
160
161%install
162rm -rf $RPM_BUILD_ROOT
163make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
164find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
165
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
170
171%post -p /sbin/ldconfig
172
173%postun -p /sbin/ldconfig
174
175
176%files
177%defattr(-,root,root,-)
178%doc AUTHORS COPYING README
179%{_libdir}/*.so.*
180%dir %{_libdir}/%{name}
181%dir %{_libdir}/%{name}/%{version}
182%dir %{_libdir}/%{name}/%{version}/modules
183%{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
184
185%files bin
186%defattr(-,root,root,-)
187%{_bindir}/proxy
188
189%files python
190%defattr(-,root,root,-)
191%{python_sitelib}/libproxy.py
192
193%files python3
194%defattr(-,root,root,-)
195%{python3_sitelib}/libproxy.py
196
197%files gnome
198%defattr(-,root,root,-)
199%{_libdir}/%{name}/%{version}/modules/config_gnome3.so
200%{_libexecdir}/pxgsettings
201
202%files kde
203%defattr(-,root,root,-)
204%{_libdir}/%{name}/%{version}/modules/config_kde.so
205
206# Build the pacrunner into libproxy unless we are building for multiple engines
207%if %{with mozjs}
208%files mozjs
209%defattr(-,root,root,-)
210%{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
211
212%files webkitgtk4
213%defattr(-,root,root,-)
214%{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
215%endif
216
217%files devel
218%defattr(-,root,root,-)
219%{_includedir}/proxy.h
220%{_libdir}/*.so
221%{_libdir}/pkgconfig/libproxy-1.0.pc
222%{_datadir}/cmake/Modules/Findlibproxy.cmake
223
224
225%changelog
226* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-1
227- updated to 0.4.15.
228- enabled python3 support.
229- disabled mozjs as default.
230- switched to webkitgtk4.
231
232* Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-2
233- rebuild with gcc-5.4.0
234
235* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
236- update to 0.4.11
237- remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
238
239* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
240- rebuild with python-2.7.2
241
242* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
243- new upstream release
244- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
245- change BuildRequires: js-devel instead of gecko-devel
246- replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
247- detele -webkit sub package
248- create -webkitgtk3 sub package
249
250* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
251- new upstream release
252- drop Patch0
253- add BuildRequires: cmake, kdelibs-devel
254- fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
255
256* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
257- rebuild with rpm-4.8.1 for pkg-config file
258
259* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
260- rebuild with python-2.6
261
262* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
263- rebuild with gecko-1.9.1
264
265* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
266- rebuild with WebKit-gtk-1.0.0-8.svn41944
267
268* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
269- initial build for Vine Linux
270
271* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
272- Rebuild for webkit
273- Raise requirement for xulrunner to 1.9.1
274
275* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
276- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
277
278* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
279- Merge NetworkManager module into the main libproxy package
280- Main Requires the -python and -bin subpackage
281 (splitted for multilibs compliance).
282
283* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
284- Disable Gnome/KDE default support via builtin modules.
285 (it needs to be integrated via Gconf2/neon instead).
286
287* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
288- Disable Obsoletes.
289- Requires ev instead of evr for optionnals sub-packages.
290
291* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
292- Use conditionals build.
293
294* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
295- Remove plugin- in the name of the packages
296
297* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
298- Move proxy.h to libproxy/proxy.h
299  This will prevent it to be included in the default include path
300- Split main to libs and util and use libproxy to install all
301
302* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
303- Rename binding-python to python
304- Add Requires: gecko-libs >= %%{gecko_version}
305- Fix some descriptions
306- Add plugin-webkit package
307 
308* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
309- Convert to Fedora spec
310
311* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
312- Updated to version 0.2.3
313* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
314- Extended spec file to build all available plugins
315* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
316- Initial spec file for Version 0.2.2
317
Note: See TracBrowser for help on using the repository browser.