source: projects/specs/trunk/lib/libp/libproxy/libproxy-vl.spec @ 10549

Revision 10549, 8.2 KB checked in by Takemikaduchi, 8 years ago (diff)

systemtap: new upstream release
others: rebuild with gcc-5.4.0

Line 
1%{!?python_sitelib: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:        A library handling all the details of proxy configuration
4Name:           libproxy
5Version:        0.4.11
6Release:        2%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://code.google.com/p/libproxy/
11Source0:        http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14BuildRequires:  python-devel
15#Virtual Provides - We need either mozjs or WebKit
16Requires: %{name}-pac >= %{version}
17#
18Requires: libproxy-python = %{version}-%{release}
19Requires: libproxy-bin = %{version}-%{release}
20
21BuildRequires:  cmake
22# gnome
23BuildRequires:  GConf2-devel
24# mozjs
25BuildRequires:  js-devel
26# NetworkManager
27BuildRequires:  NetworkManager-devel
28BuildRequires:  dbus-devel
29# webkit (gtk)
30BuildRequires:  WebKit3-gtk-devel
31# kde
32BuildRequires:  kdelibs-devel
33BuildRequires:  libXmu-devel
34BuildRequires:  libX11-devel
35
36
37Provides: %{name}-webkit = %{version}-%{release}
38Obsoletes: %{name}-webkit < %{version}-%{release}
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44libproxy offers the following features:
45
46    * extremely small core footprint (< 35K)
47    * no external dependencies within libproxy core
48      (libproxy plugins may have dependencies)
49    * only 3 functions in the stable external API
50    * dynamic adjustment to changing network topology
51    * a standard way of dealing with proxy settings across all scenarios
52    * a sublime sense of joy and accomplishment
53
54Non-default rpmbuild options:
55--with webkit:           Enable WebKit-gtk support
56
57
58%package        bin
59Summary:        Binary to test %{name}
60Group:          Applications/System
61Requires:       %{name} = %{version}-%{release}
62
63%description    bin
64The %{name}-bin package contains the proxy binary for %{name}
65
66%package        python
67Summary:        Binding for %{name} and python
68Group:          System Environment/Libraries
69Requires:       %{name} = %{version}-%{release}
70
71%description    python
72The %{name}-python package contains the python binding for %{name}
73
74%package        gnome
75Summary:        Plugin for %{name} and gnome
76Group:          System Environment/Libraries
77Requires:       %{name} = %{version}-%{release}
78
79%description    gnome
80The %{name}-gnome package contains the %{name} plugin for gnome.
81
82%package        kde
83Summary:        Plugin for %{name} and kde
84Group:          System Environment/Libraries
85Requires:       %{name} = %{version}-%{release}
86
87%description    kde
88The %{name}-kde package contains the %{name} plugin for kde.
89
90%package        mozjs
91Summary:        Plugin for %{name} and mozjs
92Group:          System Environment/Libraries
93Requires:       %{name} = %{version}
94#Tweak this according to the current gecko-libs version
95Requires:       js
96Provides:       %{name}-pac = %{version}-%{release}
97
98%description    mozjs
99The %{name}-mozjs package contains the %{name} plugin for mozjs.
100
101%package        webkitgtk3
102Summary:        Plugin for %{name} and webkitgtk3
103Group:          System Environment/Libraries
104Requires:       %{name} = %{version}
105Provides:       %{name}-pac = %{version}-%{release}
106
107%description    webkitgtk3
108The %{name}-webkitgtk3 package contains the %{name} plugin for
109webkitgtk3.
110
111%package        devel
112Summary:        Development files for %{name}
113Group:          Development/Libraries
114Requires:       %{name} = %{version}-%{release}
115Requires:       pkgconfig
116
117%description    devel
118The %{name}-devel package contains libraries and header files for
119developing applications that use %{name}.
120
121
122%prep
123%setup -q
124sed -i "s|mozjs185>=1.8.5|mozjs185|" libproxy/cmake/modules/pacrunner_mozjs.cmk
125
126%build
127%cmake \
128        -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
129        -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
130        -DWITH_PERL=OFF \
131        -DWITH_WEBKIT3=ON \
132   .
133make VERBOSE=1 %{?_smp_mflags}
134
135
136%install
137rm -rf $RPM_BUILD_ROOT
138make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
139find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
140
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145
146%post -p /sbin/ldconfig
147
148%postun -p /sbin/ldconfig
149
150
151%files
152%defattr(-,root,root,-)
153%doc AUTHORS COPYING README
154%{_libdir}/*.so.*
155%dir %{_libdir}/%{name}
156%dir %{_libdir}/%{name}/%{version}
157%dir %{_libdir}/%{name}/%{version}/modules
158%{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
159
160%files bin
161%defattr(-,root,root,-)
162%{_bindir}/proxy
163
164%files python
165%defattr(-,root,root,-)
166%{python_sitelib}/libproxy.py
167
168%files gnome
169%defattr(-,root,root,-)
170%{_libdir}/%{name}/%{version}/modules/config_gnome3.so
171%{_libexecdir}/pxgsettings
172
173%files kde
174%defattr(-,root,root,-)
175%{_libdir}/%{name}/%{version}/modules/config_kde4.so
176
177%files mozjs
178%defattr(-,root,root,-)
179%{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
180
181%files webkitgtk3
182%defattr(-,root,root,-)
183%{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
184
185%files devel
186%defattr(-,root,root,-)
187%{_includedir}/proxy.h
188%{_libdir}/*.so
189%{_libdir}/pkgconfig/libproxy-1.0.pc
190%{_datadir}/cmake/Modules/Findlibproxy.cmake
191
192
193%changelog
194* Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-2
195- rebuild with gcc-5.4.0
196
197* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
198- update to 0.4.11
199- remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
200
201* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
202- rebuild with python-2.7.2
203
204* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
205- new upstream release
206- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
207- change BuildRequires: js-devel instead of gecko-devel
208- replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
209- detele -webkit sub package
210- create -webkitgtk3 sub package
211
212* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
213- new upstream release
214- drop Patch0
215- add BuildRequires: cmake, kdelibs-devel
216- fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
217
218* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
219- rebuild with rpm-4.8.1 for pkg-config file
220
221* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
222- rebuild with python-2.6
223
224* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
225- rebuild with gecko-1.9.1
226
227* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
228- rebuild with WebKit-gtk-1.0.0-8.svn41944
229
230* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
231- initial build for Vine Linux
232
233* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
234- Rebuild for webkit
235- Raise requirement for xulrunner to 1.9.1
236
237* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
239
240* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
241- Merge NetworkManager module into the main libproxy package
242- Main Requires the -python and -bin subpackage
243 (splitted for multilibs compliance).
244
245* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
246- Disable Gnome/KDE default support via builtin modules.
247 (it needs to be integrated via Gconf2/neon instead).
248
249* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
250- Disable Obsoletes.
251- Requires ev instead of evr for optionnals sub-packages.
252
253* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
254- Use conditionals build.
255
256* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
257- Remove plugin- in the name of the packages
258
259* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
260- Move proxy.h to libproxy/proxy.h
261  This will prevent it to be included in the default include path
262- Split main to libs and util and use libproxy to install all
263
264* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
265- Rename binding-python to python
266- Add Requires: gecko-libs >= %%{gecko_version}
267- Fix some descriptions
268- Add plugin-webkit package
269 
270* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
271- Convert to Fedora spec
272
273* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
274- Updated to version 0.2.3
275* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
276- Extended spec file to build all available plugins
277* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
278- Initial spec file for Version 0.2.2
279
Note: See TracBrowser for help on using the repository browser.