source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 8776

Revision 8776, 26.9 KB checked in by tomop, 10 years ago (diff)

libpq-9.3.4-4

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 9.3
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.4
19Release: 4%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source3: postgresql.init
23Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
24Source6: README.rpm-dist
25Source15: postgresql-bashprofile
26Patch2: postgresql-8.3.3-nls.patch
27Patch3: postgresql-7.4-ecpg-patch
28Buildrequires: perl build-essential
29Buildrequires: readline-devel
30Buildrequires: zlib-devel >= 1.0.4
31BuildRequires: bison, flex, pam-devel
32%if %ssl
33Buildrequires: openssl-devel
34%endif
35%if %kerberos
36Buildrequires: krb5-devel
37%endif
38%if %nls
39Buildrequires: gettext >= 0.10.35
40%endif
41
42%if %pam
43Buildrequires: pam-devel
44%endif
45
46Url: http://www.postgresql.org/
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53The %{name} package provides the essential shared libraries for any
54PostgreSQL client program or interface. You will need to install this package
55to use any other PostgreSQL package or any clients that need to connect to a
56PostgreSQL server.
57
58%description -l ja
59%{name} パッケージは、すべての PostgreSQL クライアントプログラ
60ムやインターフェースのための中核的な共有ライブラリを提供します。
61PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
62ントを使う場合には、このパッケージをインストールする必要があります。
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: System Environment/Libraries
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87%package devel
88Summary: PostgreSQL development header files and libraries.
89Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
90Group: Development/Libraries
91Requires: libpq%{pq_soname} = %{version}
92Obsoletes: postgresql7-devel
93Obsoletes: postgresql8-devel
94Obsoletes: postgresql-devel < 9.3.0
95
96%description devel
97The %{name}-devel package contains the header files and libraries
98needed to compile C or C++ applications which will directly interact
99with a PostgreSQL database management server and the ecpg Embedded C
100Postgres preprocessor. You need to install this package if you want to
101develop applications which will interact with a PostgreSQL server.
102
103%description -l ja devel
104%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
105するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
106ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
107が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
108したい場合にはこのパッケージをインストールしてください。
109
110
111%prep
112%setup -q -n postgresql-%{version}
113
114
115%build
116CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
117CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
118
119# Strip out -ffast-math from CFLAGS....
120
121CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
122
123./configure \
124        --prefix=%{_prefix} \
125        --libdir=%{_libdir} \
126        --disable-rpath \
127%if %beta
128        --enable-debug \
129        --enable-cassert \
130%endif
131%if %ssl
132        --with-openssl \
133%endif
134%if %pam
135        --with-pam \
136%endif
137%if %kerberos
138        --with-krb5=/usr/kerberos \
139%endif
140%if %nls
141        --enable-nls \
142%endif
143        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
144        --mandir=%{_mandir} \
145        --with-docdir=%{_docdir} \
146        --includedir=%{_includedir}/pgsql \
147        --datadir=%{_datadir}/pgsql
148
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
152make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
159make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
160cp -f ./src/backend/utils/fmgroids.h ./src/include/utils/
161make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
162
163# copy over Makefile.global to the include dir....
164install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
165install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
166
167# install missing header
168mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
169install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
171install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
172install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
176
177# Fix some more documentation
178##gzip doc/internals.ps
179cp %{SOURCE6} README.rpm-dist
180##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
181##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
182
183mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
184install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
185
186
187%find_lang libpq5-%{pgver}
188%find_lang ecpg-%{pgver}
189%find_lang ecpglib%{ecpg_soname}-%{pgver}
190#%find_lang pg_config-%{pgver}
191
192cat libpq5-%{pgver}.lang > libpq.lst
193cat ecpg-%{pgver}.lang >> libpq.lst
194cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
195#cat pg_config-%{pgver}.lang > devel.lst
196
197rm -rf %{buildroot}%{_libdir}/lib*.a
198rm -rf %{buildroot}%{_datadir}/pgsql
199find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
200
201rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
202find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
203
204%post
205/sbin/ldconfig
206
207%postun
208/sbin/ldconfig
209
210
211%clean
212rm -rf $RPM_BUILD_ROOT
213
214
215%files -n libpq%{pq_soname} -f libpq.lst
216%defattr(-,root,root)
217%doc COPYRIGHT HISTORY INSTALL README*
218%{_libdir}/libecpg.so.*
219%{_libdir}/libecpg_compat.so.*
220%{_libdir}/libpgtypes.so.*
221%{_libdir}/libpq.so.*
222
223%files devel -f devel.lst
224%defattr(-,root,root)
225%{_bindir}/ecpg
226%{_bindir}/pg_config
227%{_libdir}/libecpg.so
228%{_libdir}/libecpg_compat.so
229%{_libdir}/libpgtypes.so
230%{_libdir}/libpq.so
231%{_libdir}/pkgconfig/*
232%{_datadir}/locale/*/LC_MESSAGES/*.mo
233%{_mandir}/man1/ecpg.*
234#%{_mandir}/man1/pg_config.*
235
236
237%changelog
238* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
239- added all headers for a strange client.
240
241* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
242- add pgconfig
243- add pg_config*.h and libpq/libpq-fs.h
244
245* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
246- add postgres_ext.h and pg_config_ext.h
247
248* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
249- new upstream release
250
251* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
252- made to build client libraries only.
253
254* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
255- new upstream release
256
257* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
258- new upstream release
259- add Vendor and Distribution tags
260
261* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
262- build with Tcl/Tk 8.5.7-1
263- fix init script (Source3): fix su(1) paramaters.
264
265* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
266- new upstream release
267- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
268- remove *_and_*.so from -contrib (included in -server)
269
270* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
271- updated postgresql to 9.0.4
272
273* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
274- updated postgresql to 9.0.3
275- separated postgresql-jdbc package
276
277* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
278- updated postgresql to 8.4.7 (contains a variety of fixes)
279
280* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
281- updated postgresql to 8.4.6
282- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
283- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
284- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
285
286* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
287- rebuilt with openssl-1.0.0c
288
289* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
290- updated postgresql to 8.4.5
291
292* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
293- updated postgresql to 8.4.4
294
295* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
296- updated postgresql to 8.4.3
297- s/BuildPrereq/Buildrequires/
298
299* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
300- updated postgresql to 8.4.2
301- rebuilt with new environment
302
303* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
304- updated postgresql to 8.4.1
305
306* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
307- moved dict_snowball.so from conrib to server
308
309* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
310- updated postgresql to 8.4.0
311- updated jdbc3,4 to 701
312- dropt postgresql-8.3.3-nls.patch (fixed)
313- dropt postgresql-7.4-ecpg-patch (no effect)
314
315* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
316- changed libs Group to System Environment/Libraries
317
318* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
319- updated postgresql to 8.3.7
320
321* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
322- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
323
324* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
325- new upstream release (postgresql to 8.3.5, jdbc to 604)
326
327* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
328- applied new versioning policy, and spec in utf-8
329- updated postgresql to 8.3.3
330- updated jdbcver to 603
331- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
332- added a script to replace PGVERSION in postgresql.init
333
334* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
335- rebuild with tcl/tk-8.4.18
336
337* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
338- updated postgresql to 8.2.6
339- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
340
341* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
342- updated PGVERSION to 8.2 in postgresql.init (sorry;)
343
344* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
345- rebuild with tcl/tk-8.4.16
346
347* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
348- updated postgresql to 8.2.5
349- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
350- updated nls-patch to 8-2-0
351- dropt postgresql-8.1.4-Pg.patch.gz
352
353* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
354- for VineSeed
355- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
356- JDBC driver updated to 410
357
358* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
359- rebuilt for VineSeed
360- fixed install script
361
362* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
363- upstream release
364- fix missing %defattr in %files server
365
366* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
367- fix version number in postgresql.init
368
369* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
370- upstream release
371- drop rpm-pgsql-8.0.0.patch
372- add Requires: perl-DBD-Pg for contrib
373- add postgresql-8.1.4-Pg.patch.gz
374- update nls patches
375- new JDBC driver
376
377* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
378- added build options --without perl, --without python
379- rebuilt for x86_64 architecture support
380
381* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
382- drop Provides: on postgresql-libs
383- drop Requires: libpq.so on postgresql-server
384
385* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
386- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
387
388* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
389- upstream release
390- update nls patches
391
392* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
393- upstream release
394- update nls patches
395
396* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
397- rebuilded with python-2.4.1-0vl1
398
399* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
400- Dropped PyGreSQL-3.4.tgz.
401- Dropped PyGreSQL-3.4-setup-2.patch.
402- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
403- Dropped pyver and pynextver macros.
404- Changed macro name "python" to "plpython" like plperl.
405- Added "Obsoletes: postgresql-python"
406
407* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
408- Major version up
409- Obsoletes: postgresql7
410- update nls patch(es)
411- modify %postun not to delete postgres account on upgrade
412
413* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
414- upstream release (release as a new package)
415- Conflicts: postgresql
416- update nls patch(es)
417- (this package revision was rejected by Vine Project)
418
419* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
420- upstream release
421- new JDBC driver
422- add BuildRequires: bison, flex, pam-devel
423- drop postgresql-7.4.5-tempfile.patch (repaired)
424
425* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
426- Added a security fix patch postgresql-7.4.5-tempfile.patch
427  from Gentoo Linux (CAN-2004-0977).
428- Changed Patch4:
429  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
430  It is possible to compile this package without pre-installed postgresql.
431- Removed Patch5 because Patch4 was changed.
432
433* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
434- upstream release
435
436* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
437- upstream release
438- new jdbc driver
439
440* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
441- rebuild with python-2.3.3-0vl1
442
443* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
444- changed mode to 644 at Makefile.global, Makefile.shlib
445
446* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
447- updated python install section
448
449* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
450- added PyGreSQL-3.4.tgz and set python flag
451- added PyGreSQL-3.4-setup.patch
452- added PyGreSQL-3.4-pgmodule.patch
453- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
454
455* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
456- rebuild with new openssl
457
458* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
459- upstream release
460- change all of %{?foo:%define foo 0} -like descriptions to simple
461  %define format for latest rpm to build.
462
463* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
464- rebuild on latest tcl package environment.
465
466* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
467- fixed lacking files at server's %files
468
469* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
470- include JDBC driver for 7.4
471- fix typo in postgresql-7.4-psql-patch
472
473* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
474- upstream release
475- change '--includedir=' option to avoid conflicting with unixODBC
476- add postgresql-7.4-ecpg-patch
477
478* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
479- upstream release
480
481* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
482- drop previous version of libpq's trash
483
484* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
485- upstream release with new nls patch
486- fix postgresql-bashprofile (value of PGDATA)
487- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
488
489* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
490- rebuild with tcltk8.4 and readline-4.3
491
492* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
493- upstream release
494
495* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
496- upstream release
497- remove garbage changelog
498
499* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
500- upstream release based on 7.3-2PGDG
501- add nls patch
502
503* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
504- 7.3-2PGDG
505- Fix typo in initscript.  Argh!!
506
507* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
508- 7.3-0.5PGDG
509- Jerk out all perl client stuff and kludgage
510- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
511- Eliminate locale and multibyte explicit enables -- they are both defaults now
512- Eliminate pgaccess code; it's not a part of the main tarball anymore
513- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
514- Eliminated separate tk client package -- rolled the tk client into the tcl client.
515- Moved pltcl into the pl subpackage.
516- Added plpython to the pl subpackage.
517- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
518
519* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
520- 7.3-0.1PGDG (not released)
521- Integrate 7.3 jar's courtesy Joe Conway
522- Integrate multi-postmaster initscript courtesy Karl DeBisschop
523- Some renames and restructures.
524- Stripped out the last dregs of the postgresql-dump migration script.
525- Conflicts with less than 7.3.
526
527- (See below for old changelogs from VineSeed)
528
529* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
530- updated to 7.2.3.
531
532* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
533- absorbed previous patch8 into original nlspatch
534- fixed configure options (--enable-nls and --enable-locale to be antinomy)
535
536* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
537- add patch8 (ja.po for psql was invalid)
538
539* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
540- updated to 7.2.2.
541- improved nlspatch to enable japanese SQL help in psql.
542
543* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
544- fixed garbage chars in description(ja).
545
546* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
547- imported & replaced changelog (following VineSeed's).
548  add some stuff to '%%files'.
549
550* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
551- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
552  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
553
554* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
555- replace nls patch.
556- add *.mo to '%%files'.
557
558* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
559- fix initscript
560
561* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
562- add /usr/bin/pg_id to the package (fix)
563
564* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
565- updated 7.2
566- added nls.patch
567- fixed spec file
568- added New JDBC
569-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
570
571* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
572- updated 7.1.3
573
574* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
575- 7.1.2-7vl3
576- merge 7.1.2-7vl2 and 7.1.2-7
577
578* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
579- 7.1.2-7vl2
580- fixed spec typo (%%{_includesir} -> %%{_includedir})
581
582* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
583- updated 7.1.2 (used postgresql-7.1.2-7)
584- used psqlj patch for 7.1.2
585- used jumbo-20010801.patch.gz
586
587* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
588- Add patches from 7.1-stable branch. This should fix #50799 and #50797
589- Enable kerberos authentication (#50644)
590- handle stop with stale pid file (#50499)
591- make the test subpackage (not built by default) own /usr/lib/pgsql/test
592
593* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
594- Make the -devel subpackage depend on -libs, not the main package
595
596* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
597- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
598
599* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
600- add changes for s390x
601
602* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
603- Many path fixes for contrib packages
604- Newer intarray
605- Don't use nested ifs for tkpkg/pgaccess
606- Turn off test package for Red Hat Linux - it makes most sense just to use
607  this during development
608- One "pgacess" -> "pgaccess"
609
610* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
611- -4PGDG
612- patchset update for pg_regress.sh
613- can the dot in the release -- confused too many people and some programs.
614- -3.PGDG
615- updated README.rpm-dist
616- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
617  was still being used where /usr/lib/pgsql was intended.
618- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
619
620* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
621- sync
622- Run chkconfig --add on server install
623- Move the prereqs on useradd on chkconfig to the server package
624- don't disable the %%clean section
625
626* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
627- Sync up with Trond Eivind's set.
628
629* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
630- Don't create postgres' .bashrc from the server post script: include it instead
631- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
632- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
633  libs
634- Source the i18n data from the .bashrc instead of in the initscript
635
636* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
637- Handle i18n for database startup - backend needs to have the same locale everytime,
638  but this certainly can't be hardcoded to C either
639- Fix stop, restart in initscript (#42217)
640- Make database init _much_ less verbose
641- other minor fixes to the initscript
642
643* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
644- 7.1.2
645
646* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
647- 7.1.2-0.1.1.PGDG PRERELEASE
648- Changed versioning and release numbering a little for better flexibility,
649-- particularly for distribution packagers.
650- Release numbering comment at top of spec, where it's more useful.
651- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
652  changlog, and the last 6.5.3's specfile for the changelog prior to
653  7.0.
654
655* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
656- 7.1.1-4.PGDG
657- _really_ got Python version agnosticism working.
658
659* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
660- 7.1.1-3.PGDG Release
661- Python version agnosticism.....
662
663* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
664- Use openssl
665- Make it obsolete subpackages if they aren't built
666
667* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
668- 7.1.1-2.PGDG Release.
669- Appended .PGDG to release string to differentiate our RPM set from the others.
670- /bin/sh fix in initscript
671- README.rpm-dist updates.
672
673* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
674- Rebuild with new readline
675
676* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
677- Initial 7.1.1
678
679* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
680- Specify shell when running commands through su in the initscript, to avoid problems
681  when people switch the postgres user to use tcsh
682
683* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
684- JDBC driver for Postgresql 7.1
685
686* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
687- slightly different versioning scheming, will go back to the official
688  later when I'm sure the package is ready to use
689
690* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
691- 7.1 RELEASE
692- 7.1-1 RPM RELEASE
693- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
694- Back to old versioning scheme, kept teg's other fixes.
695- README.rpm-dist updated.
696- PGVERSION updated all-around (hopefully!)
697- Couple of fixes from Peter E.
698- Rearrange dependencies -- only the -libs subpackage is required for most stuff
699- Removed broken and confusing logrotate script.
700
701* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
702- chown considered harmful - removed
703- fix dangling symlimks (pg_crc.c)
704- libpq.so changes for maximum compatiblity
705- different versioning scheme, to avoid trouble later
706- remove temporary perl file from the file list
707- fix spelling error in tcl description
708- mark odbcinst.ini as a config file
709- use %%defattr on packages which didn't have it
710
711* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
712- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
713- Packaging reorg: added contrib and docs subpackages.
714- Removed sgml source docs from main package --> docs subpackage.
715- Removed contrib tree from main package --> contrib subpackage.
716- Contrib tree is now prebuilt -- HOWEVER, very little install work is
717  currently done with this.
718
719* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
720- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
721
722* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
723- RC2
724- eliminate versioning information for ancilliary files in prep for CVS.
725- Fix docs mixup.
726
727* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
728- RC1 quickie.
729
730* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
731- Beta 6 initial build.
732- Use make install-all-headers instead of cpio hack for devel headers.
733- Split out the libs into the libs subpackage.
734- Updated initscript to use pg_ctl to stop
735- Updated initscript to initdb and start postmaster with LC_ALL=C to
736  prevent index corruption.
737
738
739* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
740- Beta4
741- Return to 'pgsql' directories instead of 'postgresql'
742- Better perl patches.
743
744* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
745- Edit patches to get rid of some cruft.
746- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
747- Moved pg_id to server
748- added Makefile.global and pg_config to devel
749- Corrected /usr/include/pgsql to /usr/include/postgresql
750- Fixed some configure options.  Will be trying the configure macro next release
751- Since it is terminally ill in this version pg_upgrade is _gone_.
752- Thanks to Peter E for a good review.
753
754* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
755- Running regression. 1 on the release-o-meter.
756- Minor patches to get regression running right. 
757- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
758
759* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
760- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
761- The 7.1 build is different from the 7.0 build -- see the configure line.
762- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
763- by request, conditional packages are now supported. See the top of the spec.
764- Fixed the server postinstall problems.
765
766* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
767- First 7.1 beta test-build
768
Note: See TracBrowser for help on using the repository browser.