source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 8554

Revision 8554, 26.2 KB checked in by daisuke, 10 years ago (diff)

libpq: add postgres_ext.h and pg_config_ext.h

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 9.3
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.4
19Release: 2%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source3: postgresql.init
23Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
24Source6: README.rpm-dist
25Source15: postgresql-bashprofile
26Patch2: postgresql-8.3.3-nls.patch
27Patch3: postgresql-7.4-ecpg-patch
28Buildrequires: perl build-essential
29Buildrequires: readline-devel
30Buildrequires: zlib-devel >= 1.0.4
31BuildRequires: bison, flex, pam-devel
32%if %ssl
33Buildrequires: openssl-devel
34%endif
35%if %kerberos
36Buildrequires: krb5-devel
37%endif
38%if %nls
39Buildrequires: gettext >= 0.10.35
40%endif
41
42%if %pam
43Buildrequires: pam-devel
44%endif
45
46Url: http://www.postgresql.org/
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53The %{name} package provides the essential shared libraries for any
54PostgreSQL client program or interface. You will need to install this package
55to use any other PostgreSQL package or any clients that need to connect to a
56PostgreSQL server.
57
58%description -l ja
59%{name} パッケージは、すべての PostgreSQL クライアントプログラ
60ムやインターフェースのための中核的な共有ライブラリを提供します。
61PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
62ントを使う場合には、このパッケージをインストールする必要があります。
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: System Environment/Libraries
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87%package devel
88Summary: PostgreSQL development header files and libraries.
89Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
90Group: Development/Libraries
91Requires: libpq%{pq_soname} = %{version}
92Obsoletes: postgresql7-devel
93Obsoletes: postgresql8-devel
94Obsoletes: postgresql-devel < 9.3.0
95
96%description devel
97The %{name}-devel package contains the header files and libraries
98needed to compile C or C++ applications which will directly interact
99with a PostgreSQL database management server and the ecpg Embedded C
100Postgres preprocessor. You need to install this package if you want to
101develop applications which will interact with a PostgreSQL server.
102
103%description -l ja devel
104%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
105するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
106ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
107が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
108したい場合にはこのパッケージをインストールしてください。
109
110
111%prep
112%setup -q -n postgresql-%{version}
113
114
115%build
116CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
117CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
118
119# Strip out -ffast-math from CFLAGS....
120
121CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
122
123./configure \
124        --prefix=%{_prefix} \
125        --libdir=%{_libdir} \
126        --disable-rpath \
127%if %beta
128        --enable-debug \
129        --enable-cassert \
130%endif
131%if %ssl
132        --with-openssl \
133%endif
134%if %pam
135        --with-pam \
136%endif
137%if %kerberos
138        --with-krb5=/usr/kerberos \
139%endif
140%if %nls
141        --enable-nls \
142%endif
143        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
144        --mandir=%{_mandir} \
145        --with-docdir=%{_docdir} \
146        --includedir=%{_includedir}/pgsql \
147        --datadir=%{_datadir}/pgsql
148
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151
152%install
153rm -rf $RPM_BUILD_ROOT
154
155make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
156#make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
157
158# copy over Makefile.global to the include dir....
159install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
160install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
161
162# install missing header
163install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
164install -m644 src/include/pg_config_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
165
166# Fix some more documentation
167##gzip doc/internals.ps
168cp %{SOURCE6} README.rpm-dist
169##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
170##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
171
172mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
173install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
174
175
176%find_lang libpq5-%{pgver}
177%find_lang ecpg-%{pgver}
178%find_lang ecpglib%{ecpg_soname}-%{pgver}
179#%find_lang pg_config-%{pgver}
180
181cat libpq5-%{pgver}.lang > libpq.lst
182cat ecpg-%{pgver}.lang >> libpq.lst
183cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
184#cat pg_config-%{pgver}.lang > devel.lst
185
186rm -rf %{buildroot}%{_libdir}/lib*.a
187rm -rf %{buildroot}%{_datadir}/pgsql
188find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
189
190rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
191find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
192
193%post
194/sbin/ldconfig
195
196%postun
197/sbin/ldconfig
198
199
200%clean
201rm -rf $RPM_BUILD_ROOT
202
203
204%files -n libpq%{pq_soname} -f libpq.lst
205%defattr(-,root,root)
206%doc COPYRIGHT HISTORY INSTALL README*
207%{_libdir}/libecpg.so.*
208%{_libdir}/libecpg_compat.so.*
209%{_libdir}/libpgtypes.so.*
210%{_libdir}/libpq.so.*
211
212%files devel -f devel.lst
213%defattr(-,root,root)
214%{_bindir}/ecpg
215#%{_bindir}/pg_config
216#%{_includedir}/pgsql/libpq-events.h
217#%{_includedir}/pgsql/libpq-fe.h
218#%{_includedir}/pgsql/postgres_ext.h
219%{_libdir}/libecpg.so
220%{_libdir}/libecpg_compat.so
221%{_libdir}/libpgtypes.so
222%{_libdir}/libpq.so
223%{_libdir}/pkgconfig/*
224%{_mandir}/man1/ecpg.*
225#%{_mandir}/man1/pg_config.*
226
227
228%changelog
229* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
230- add postgres_ext.h and pg_config_ext.h
231
232* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
233- new upstream release
234
235* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
236- made to build client libraries only.
237
238* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
239- new upstream release
240
241* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
242- new upstream release
243- add Vendor and Distribution tags
244
245* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
246- build with Tcl/Tk 8.5.7-1
247- fix init script (Source3): fix su(1) paramaters.
248
249* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
250- new upstream release
251- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
252- remove *_and_*.so from -contrib (included in -server)
253
254* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
255- updated postgresql to 9.0.4
256
257* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
258- updated postgresql to 9.0.3
259- separated postgresql-jdbc package
260
261* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
262- updated postgresql to 8.4.7 (contains a variety of fixes)
263
264* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
265- updated postgresql to 8.4.6
266- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
267- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
268- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
269
270* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
271- rebuilt with openssl-1.0.0c
272
273* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
274- updated postgresql to 8.4.5
275
276* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
277- updated postgresql to 8.4.4
278
279* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
280- updated postgresql to 8.4.3
281- s/BuildPrereq/Buildrequires/
282
283* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
284- updated postgresql to 8.4.2
285- rebuilt with new environment
286
287* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
288- updated postgresql to 8.4.1
289
290* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
291- moved dict_snowball.so from conrib to server
292
293* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
294- updated postgresql to 8.4.0
295- updated jdbc3,4 to 701
296- dropt postgresql-8.3.3-nls.patch (fixed)
297- dropt postgresql-7.4-ecpg-patch (no effect)
298
299* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
300- changed libs Group to System Environment/Libraries
301
302* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
303- updated postgresql to 8.3.7
304
305* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
306- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
307
308* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
309- new upstream release (postgresql to 8.3.5, jdbc to 604)
310
311* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
312- applied new versioning policy, and spec in utf-8
313- updated postgresql to 8.3.3
314- updated jdbcver to 603
315- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
316- added a script to replace PGVERSION in postgresql.init
317
318* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
319- rebuild with tcl/tk-8.4.18
320
321* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
322- updated postgresql to 8.2.6
323- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
324
325* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
326- updated PGVERSION to 8.2 in postgresql.init (sorry;)
327
328* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
329- rebuild with tcl/tk-8.4.16
330
331* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
332- updated postgresql to 8.2.5
333- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
334- updated nls-patch to 8-2-0
335- dropt postgresql-8.1.4-Pg.patch.gz
336
337* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
338- for VineSeed
339- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
340- JDBC driver updated to 410
341
342* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
343- rebuilt for VineSeed
344- fixed install script
345
346* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
347- upstream release
348- fix missing %defattr in %files server
349
350* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
351- fix version number in postgresql.init
352
353* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
354- upstream release
355- drop rpm-pgsql-8.0.0.patch
356- add Requires: perl-DBD-Pg for contrib
357- add postgresql-8.1.4-Pg.patch.gz
358- update nls patches
359- new JDBC driver
360
361* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
362- added build options --without perl, --without python
363- rebuilt for x86_64 architecture support
364
365* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
366- drop Provides: on postgresql-libs
367- drop Requires: libpq.so on postgresql-server
368
369* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
370- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
371
372* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
373- upstream release
374- update nls patches
375
376* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
377- upstream release
378- update nls patches
379
380* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
381- rebuilded with python-2.4.1-0vl1
382
383* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
384- Dropped PyGreSQL-3.4.tgz.
385- Dropped PyGreSQL-3.4-setup-2.patch.
386- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
387- Dropped pyver and pynextver macros.
388- Changed macro name "python" to "plpython" like plperl.
389- Added "Obsoletes: postgresql-python"
390
391* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
392- Major version up
393- Obsoletes: postgresql7
394- update nls patch(es)
395- modify %postun not to delete postgres account on upgrade
396
397* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
398- upstream release (release as a new package)
399- Conflicts: postgresql
400- update nls patch(es)
401- (this package revision was rejected by Vine Project)
402
403* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
404- upstream release
405- new JDBC driver
406- add BuildRequires: bison, flex, pam-devel
407- drop postgresql-7.4.5-tempfile.patch (repaired)
408
409* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
410- Added a security fix patch postgresql-7.4.5-tempfile.patch
411  from Gentoo Linux (CAN-2004-0977).
412- Changed Patch4:
413  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
414  It is possible to compile this package without pre-installed postgresql.
415- Removed Patch5 because Patch4 was changed.
416
417* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
418- upstream release
419
420* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
421- upstream release
422- new jdbc driver
423
424* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
425- rebuild with python-2.3.3-0vl1
426
427* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
428- changed mode to 644 at Makefile.global, Makefile.shlib
429
430* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
431- updated python install section
432
433* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
434- added PyGreSQL-3.4.tgz and set python flag
435- added PyGreSQL-3.4-setup.patch
436- added PyGreSQL-3.4-pgmodule.patch
437- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
438
439* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
440- rebuild with new openssl
441
442* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
443- upstream release
444- change all of %{?foo:%define foo 0} -like descriptions to simple
445  %define format for latest rpm to build.
446
447* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
448- rebuild on latest tcl package environment.
449
450* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
451- fixed lacking files at server's %files
452
453* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
454- include JDBC driver for 7.4
455- fix typo in postgresql-7.4-psql-patch
456
457* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
458- upstream release
459- change '--includedir=' option to avoid conflicting with unixODBC
460- add postgresql-7.4-ecpg-patch
461
462* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
463- upstream release
464
465* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
466- drop previous version of libpq's trash
467
468* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
469- upstream release with new nls patch
470- fix postgresql-bashprofile (value of PGDATA)
471- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
472
473* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
474- rebuild with tcltk8.4 and readline-4.3
475
476* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
477- upstream release
478
479* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
480- upstream release
481- remove garbage changelog
482
483* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
484- upstream release based on 7.3-2PGDG
485- add nls patch
486
487* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
488- 7.3-2PGDG
489- Fix typo in initscript.  Argh!!
490
491* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
492- 7.3-0.5PGDG
493- Jerk out all perl client stuff and kludgage
494- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
495- Eliminate locale and multibyte explicit enables -- they are both defaults now
496- Eliminate pgaccess code; it's not a part of the main tarball anymore
497- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
498- Eliminated separate tk client package -- rolled the tk client into the tcl client.
499- Moved pltcl into the pl subpackage.
500- Added plpython to the pl subpackage.
501- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
502
503* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
504- 7.3-0.1PGDG (not released)
505- Integrate 7.3 jar's courtesy Joe Conway
506- Integrate multi-postmaster initscript courtesy Karl DeBisschop
507- Some renames and restructures.
508- Stripped out the last dregs of the postgresql-dump migration script.
509- Conflicts with less than 7.3.
510
511- (See below for old changelogs from VineSeed)
512
513* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
514- updated to 7.2.3.
515
516* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
517- absorbed previous patch8 into original nlspatch
518- fixed configure options (--enable-nls and --enable-locale to be antinomy)
519
520* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
521- add patch8 (ja.po for psql was invalid)
522
523* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
524- updated to 7.2.2.
525- improved nlspatch to enable japanese SQL help in psql.
526
527* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
528- fixed garbage chars in description(ja).
529
530* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
531- imported & replaced changelog (following VineSeed's).
532  add some stuff to '%%files'.
533
534* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
535- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
536  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
537
538* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
539- replace nls patch.
540- add *.mo to '%%files'.
541
542* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
543- fix initscript
544
545* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
546- add /usr/bin/pg_id to the package (fix)
547
548* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
549- updated 7.2
550- added nls.patch
551- fixed spec file
552- added New JDBC
553-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
554
555* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
556- updated 7.1.3
557
558* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
559- 7.1.2-7vl3
560- merge 7.1.2-7vl2 and 7.1.2-7
561
562* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
563- 7.1.2-7vl2
564- fixed spec typo (%%{_includesir} -> %%{_includedir})
565
566* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
567- updated 7.1.2 (used postgresql-7.1.2-7)
568- used psqlj patch for 7.1.2
569- used jumbo-20010801.patch.gz
570
571* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
572- Add patches from 7.1-stable branch. This should fix #50799 and #50797
573- Enable kerberos authentication (#50644)
574- handle stop with stale pid file (#50499)
575- make the test subpackage (not built by default) own /usr/lib/pgsql/test
576
577* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
578- Make the -devel subpackage depend on -libs, not the main package
579
580* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
581- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
582
583* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
584- add changes for s390x
585
586* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
587- Many path fixes for contrib packages
588- Newer intarray
589- Don't use nested ifs for tkpkg/pgaccess
590- Turn off test package for Red Hat Linux - it makes most sense just to use
591  this during development
592- One "pgacess" -> "pgaccess"
593
594* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
595- -4PGDG
596- patchset update for pg_regress.sh
597- can the dot in the release -- confused too many people and some programs.
598- -3.PGDG
599- updated README.rpm-dist
600- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
601  was still being used where /usr/lib/pgsql was intended.
602- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
603
604* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
605- sync
606- Run chkconfig --add on server install
607- Move the prereqs on useradd on chkconfig to the server package
608- don't disable the %%clean section
609
610* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
611- Sync up with Trond Eivind's set.
612
613* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
614- Don't create postgres' .bashrc from the server post script: include it instead
615- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
616- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
617  libs
618- Source the i18n data from the .bashrc instead of in the initscript
619
620* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
621- Handle i18n for database startup - backend needs to have the same locale everytime,
622  but this certainly can't be hardcoded to C either
623- Fix stop, restart in initscript (#42217)
624- Make database init _much_ less verbose
625- other minor fixes to the initscript
626
627* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
628- 7.1.2
629
630* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
631- 7.1.2-0.1.1.PGDG PRERELEASE
632- Changed versioning and release numbering a little for better flexibility,
633-- particularly for distribution packagers.
634- Release numbering comment at top of spec, where it's more useful.
635- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
636  changlog, and the last 6.5.3's specfile for the changelog prior to
637  7.0.
638
639* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
640- 7.1.1-4.PGDG
641- _really_ got Python version agnosticism working.
642
643* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
644- 7.1.1-3.PGDG Release
645- Python version agnosticism.....
646
647* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
648- Use openssl
649- Make it obsolete subpackages if they aren't built
650
651* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
652- 7.1.1-2.PGDG Release.
653- Appended .PGDG to release string to differentiate our RPM set from the others.
654- /bin/sh fix in initscript
655- README.rpm-dist updates.
656
657* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
658- Rebuild with new readline
659
660* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
661- Initial 7.1.1
662
663* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
664- Specify shell when running commands through su in the initscript, to avoid problems
665  when people switch the postgres user to use tcsh
666
667* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
668- JDBC driver for Postgresql 7.1
669
670* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
671- slightly different versioning scheming, will go back to the official
672  later when I'm sure the package is ready to use
673
674* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
675- 7.1 RELEASE
676- 7.1-1 RPM RELEASE
677- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
678- Back to old versioning scheme, kept teg's other fixes.
679- README.rpm-dist updated.
680- PGVERSION updated all-around (hopefully!)
681- Couple of fixes from Peter E.
682- Rearrange dependencies -- only the -libs subpackage is required for most stuff
683- Removed broken and confusing logrotate script.
684
685* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
686- chown considered harmful - removed
687- fix dangling symlimks (pg_crc.c)
688- libpq.so changes for maximum compatiblity
689- different versioning scheme, to avoid trouble later
690- remove temporary perl file from the file list
691- fix spelling error in tcl description
692- mark odbcinst.ini as a config file
693- use %%defattr on packages which didn't have it
694
695* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
696- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
697- Packaging reorg: added contrib and docs subpackages.
698- Removed sgml source docs from main package --> docs subpackage.
699- Removed contrib tree from main package --> contrib subpackage.
700- Contrib tree is now prebuilt -- HOWEVER, very little install work is
701  currently done with this.
702
703* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
704- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
705
706* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
707- RC2
708- eliminate versioning information for ancilliary files in prep for CVS.
709- Fix docs mixup.
710
711* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
712- RC1 quickie.
713
714* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
715- Beta 6 initial build.
716- Use make install-all-headers instead of cpio hack for devel headers.
717- Split out the libs into the libs subpackage.
718- Updated initscript to use pg_ctl to stop
719- Updated initscript to initdb and start postmaster with LC_ALL=C to
720  prevent index corruption.
721
722
723* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
724- Beta4
725- Return to 'pgsql' directories instead of 'postgresql'
726- Better perl patches.
727
728* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
729- Edit patches to get rid of some cruft.
730- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
731- Moved pg_id to server
732- added Makefile.global and pg_config to devel
733- Corrected /usr/include/pgsql to /usr/include/postgresql
734- Fixed some configure options.  Will be trying the configure macro next release
735- Since it is terminally ill in this version pg_upgrade is _gone_.
736- Thanks to Peter E for a good review.
737
738* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
739- Running regression. 1 on the release-o-meter.
740- Minor patches to get regression running right. 
741- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
742
743* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
744- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
745- The 7.1 build is different from the 7.0 build -- see the configure line.
746- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
747- by request, conditional packages are now supported. See the top of the spec.
748- Fixed the server postinstall problems.
749
750* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
751- First 7.1 beta test-build
752
Note: See TracBrowser for help on using the repository browser.