source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 12321

Revision 12321, 27.9 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

bash-5.0.16-1

gtk-doc-1.32-3

libmariadb-3.1.7-1

libpq-12.2-1

librsvg2-2.46.4-1

postgresql-12.2-1

python-pygments-2.5.2-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 12
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.2
19Release: 1%{?_dist_release}
20License: BSD
21Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source5: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
23Source6: README.rpm-dist
24Patch2: postgresql-8.3.3-nls.patch
25Patch3: postgresql-7.4-ecpg-patch
26Buildrequires: perl build-essential
27Buildrequires: libedit-devel
28Buildrequires: zlib-devel >= 1.0.4
29BuildRequires: bison, flex, pam-devel
30%if %ssl
31Buildrequires: openssl-devel
32%endif
33%if %kerberos
34Buildrequires: krb5-devel
35%endif
36%if %nls
37Buildrequires: gettext >= 0.10.35
38%endif
39
40%if %pam
41Buildrequires: pam-devel
42%endif
43
44Url: https://www.postgresql.org/
45Buildroot: %{_tmppath}/%{name}-%{version}-root
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51The %{name} package provides the essential shared libraries for any
52PostgreSQL client program or interface. You will need to install this package
53to use any other PostgreSQL package or any clients that need to connect to a
54PostgreSQL server.
55
56%description -l ja
57%{name} パッケージは、すべての PostgreSQL クライアントプログラ
58ムやインターフェースのための中核的な共有ライブラリを提供します。
59PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
60ントを使う場合には、このパッケージをインストールする必要があります。
61
62%package -n libpq%{pq_soname}
63Summary: The shared libraries required for any PostgreSQL clients.
64Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
65Group: System Environment/Libraries
66Requires(post): /sbin/ldconfig
67Requires(postun): /sbin/ldconfig
68Obsoletes: postgresql7-libs
69Obsoletes: postgresql8-libs
70Obsoletes: postgresql-libs < 9.3.0
71Conflicts: postgresql-libs >= 9.3.0
72
73%description -n libpq%{pq_soname}
74The %{name} package provides the essential shared libraries for any
75PostgreSQL client program or interface. You will need to install this package
76to use any other PostgreSQL package or any clients that need to connect to a
77PostgreSQL server.
78
79%description -n libpq%{pq_soname} -l ja
80%{name} パッケージは、すべての PostgreSQL クライアントプログラ
81ムやインターフェースのための中核的な共有ライブラリを提供します。
82PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
83ントを使う場合には、このパッケージをインストールする必要があります。
84
85%package devel
86Summary: PostgreSQL development header files and libraries.
87Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
88Group: Development/Libraries
89Requires: libpq%{pq_soname} = %{version}
90Obsoletes: postgresql7-devel
91Obsoletes: postgresql8-devel
92Obsoletes: postgresql-devel < 9.3.0
93
94%description devel
95The %{name}-devel package contains the header files and libraries
96needed to compile C or C++ applications which will directly interact
97with a PostgreSQL database management server and the ecpg Embedded C
98Postgres preprocessor. You need to install this package if you want to
99develop applications which will interact with a PostgreSQL server.
100
101%description -l ja devel
102%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
103するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
104ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
105が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
106したい場合にはこのパッケージをインストールしてください。
107
108
109%prep
110%setup -q -n postgresql-%{version}
111
112
113%build
114CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
115CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
116
117# Strip out -ffast-math from CFLAGS....
118
119CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
120
121./configure \
122        --prefix=%{_prefix} \
123        --libdir=%{_libdir} \
124        --disable-rpath \
125%if %beta
126        --enable-debug \
127        --enable-cassert \
128%endif
129%if %ssl
130        --with-openssl \
131%endif
132%if %pam
133        --with-pam \
134%endif
135%if %kerberos
136        --with-krb5=/usr/kerberos \
137%endif
138%if %nls
139        --enable-nls \
140%endif
141        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
142        --mandir=%{_mandir} \
143        --with-docdir=%{_docdir} \
144        --includedir=%{_includedir}/pgsql \
145        --datadir=%{_datadir}/pgsql
146
147# workaround for bug with parallel build
148make %{?_smp_mflags} -C ./src/interfaces all ||:
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
152make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
159make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
160make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
161
162# copy over Makefile.global to the include dir....
163install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
164install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
165
166# install missing header
167mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
168install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
169install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
171install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
172install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175
176# Fix some more documentation
177##gzip doc/internals.ps
178cp %{SOURCE6} README.rpm-dist
179##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
180##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
181
182mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
183install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
184
185
186%find_lang libpq5-%{pgver}
187%find_lang ecpg-%{pgver}
188%find_lang ecpglib%{ecpg_soname}-%{pgver}
189#%find_lang pg_config-%{pgver}
190
191cat libpq5-%{pgver}.lang > libpq.lst
192cat ecpg-%{pgver}.lang >> libpq.lst
193cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
194#cat pg_config-%{pgver}.lang > devel.lst
195
196rm -rf %{buildroot}%{_libdir}/lib*.a
197rm -rf %{buildroot}%{_datadir}/pgsql
198find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
199
200rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
201find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
202
203%post
204/sbin/ldconfig
205
206%postun
207/sbin/ldconfig
208
209
210%clean
211rm -rf $RPM_BUILD_ROOT
212
213
214%files -n libpq%{pq_soname} -f libpq.lst
215%defattr(-,root,root)
216%license COPYRIGHT
217%doc HISTORY INSTALL README*
218%{_libdir}/libecpg.so.*
219%{_libdir}/libecpg_compat.so.*
220%{_libdir}/libpgtypes.so.*
221%{_libdir}/libpq.so.*
222
223%files devel -f devel.lst
224%defattr(-,root,root)
225%{_bindir}/ecpg
226%{_bindir}/pg_config
227%{_libdir}/libecpg.so
228%{_libdir}/libecpg_compat.so
229%{_libdir}/libpgtypes.so
230%{_libdir}/libpq.so
231%{_libdir}/pkgconfig/*
232%dir %{_includedir}/pgsql
233%{_datadir}/locale/*/LC_MESSAGES/*.mo
234%{_mandir}/man1/ecpg.*
235#%{_mandir}/man1/pg_config.*
236
237
238%changelog
239* Fri Feb 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.2-1
240- new upstream release.
241
242* Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0-1
243- new upstream release.
244
245* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.5-1
246- new upstream release.
247
248* Fri Mar 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.3-1
249- new upstream release.
250
251* Fri Apr  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.2-1
252- new upstream release.
253
254* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.1-1
255- new upstream release.
256
257* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.0-1
258- new upstream release.
259
260* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
261- new upstream release.
262
263* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
264- new upstream release.
265
266* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
267- new upstream release.
268
269* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
270- added all headers for a strange client.
271
272* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
273- add pgconfig
274- add pg_config*.h and libpq/libpq-fs.h
275
276* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
277- add postgres_ext.h and pg_config_ext.h
278
279* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
280- new upstream release
281
282* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
283- made to build client libraries only.
284
285* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
286- new upstream release
287
288* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
289- new upstream release
290- add Vendor and Distribution tags
291
292* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
293- build with Tcl/Tk 8.5.7-1
294- fix init script (Source3): fix su(1) paramaters.
295
296* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
297- new upstream release
298- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
299- remove *_and_*.so from -contrib (included in -server)
300
301* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
302- updated postgresql to 9.0.4
303
304* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
305- updated postgresql to 9.0.3
306- separated postgresql-jdbc package
307
308* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
309- updated postgresql to 8.4.7 (contains a variety of fixes)
310
311* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
312- updated postgresql to 8.4.6
313- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
314- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
315- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
316
317* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
318- rebuilt with openssl-1.0.0c
319
320* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
321- updated postgresql to 8.4.5
322
323* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
324- updated postgresql to 8.4.4
325
326* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
327- updated postgresql to 8.4.3
328- s/BuildPrereq/Buildrequires/
329
330* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
331- updated postgresql to 8.4.2
332- rebuilt with new environment
333
334* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
335- updated postgresql to 8.4.1
336
337* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
338- moved dict_snowball.so from conrib to server
339
340* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
341- updated postgresql to 8.4.0
342- updated jdbc3,4 to 701
343- dropt postgresql-8.3.3-nls.patch (fixed)
344- dropt postgresql-7.4-ecpg-patch (no effect)
345
346* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
347- changed libs Group to System Environment/Libraries
348
349* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
350- updated postgresql to 8.3.7
351
352* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
353- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
354
355* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
356- new upstream release (postgresql to 8.3.5, jdbc to 604)
357
358* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
359- applied new versioning policy, and spec in utf-8
360- updated postgresql to 8.3.3
361- updated jdbcver to 603
362- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
363- added a script to replace PGVERSION in postgresql.init
364
365* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
366- rebuild with tcl/tk-8.4.18
367
368* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
369- updated postgresql to 8.2.6
370- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
371
372* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
373- updated PGVERSION to 8.2 in postgresql.init (sorry;)
374
375* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
376- rebuild with tcl/tk-8.4.16
377
378* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
379- updated postgresql to 8.2.5
380- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
381- updated nls-patch to 8-2-0
382- dropt postgresql-8.1.4-Pg.patch.gz
383
384* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
385- for VineSeed
386- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
387- JDBC driver updated to 410
388
389* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
390- rebuilt for VineSeed
391- fixed install script
392
393* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
394- upstream release
395- fix missing %defattr in %files server
396
397* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
398- fix version number in postgresql.init
399
400* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
401- upstream release
402- drop rpm-pgsql-8.0.0.patch
403- add Requires: perl-DBD-Pg for contrib
404- add postgresql-8.1.4-Pg.patch.gz
405- update nls patches
406- new JDBC driver
407
408* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
409- added build options --without perl, --without python
410- rebuilt for x86_64 architecture support
411
412* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
413- drop Provides: on postgresql-libs
414- drop Requires: libpq.so on postgresql-server
415
416* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
417- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
418
419* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
420- upstream release
421- update nls patches
422
423* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
424- upstream release
425- update nls patches
426
427* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
428- rebuilded with python-2.4.1-0vl1
429
430* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
431- Dropped PyGreSQL-3.4.tgz.
432- Dropped PyGreSQL-3.4-setup-2.patch.
433- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
434- Dropped pyver and pynextver macros.
435- Changed macro name "python" to "plpython" like plperl.
436- Added "Obsoletes: postgresql-python"
437
438* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
439- Major version up
440- Obsoletes: postgresql7
441- update nls patch(es)
442- modify %postun not to delete postgres account on upgrade
443
444* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
445- upstream release (release as a new package)
446- Conflicts: postgresql
447- update nls patch(es)
448- (this package revision was rejected by Vine Project)
449
450* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
451- upstream release
452- new JDBC driver
453- add BuildRequires: bison, flex, pam-devel
454- drop postgresql-7.4.5-tempfile.patch (repaired)
455
456* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
457- Added a security fix patch postgresql-7.4.5-tempfile.patch
458  from Gentoo Linux (CAN-2004-0977).
459- Changed Patch4:
460  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
461  It is possible to compile this package without pre-installed postgresql.
462- Removed Patch5 because Patch4 was changed.
463
464* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
465- upstream release
466
467* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
468- upstream release
469- new jdbc driver
470
471* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
472- rebuild with python-2.3.3-0vl1
473
474* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
475- changed mode to 644 at Makefile.global, Makefile.shlib
476
477* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
478- updated python install section
479
480* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
481- added PyGreSQL-3.4.tgz and set python flag
482- added PyGreSQL-3.4-setup.patch
483- added PyGreSQL-3.4-pgmodule.patch
484- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
485
486* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
487- rebuild with new openssl
488
489* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
490- upstream release
491- change all of %{?foo:%define foo 0} -like descriptions to simple
492  %define format for latest rpm to build.
493
494* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
495- rebuild on latest tcl package environment.
496
497* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
498- fixed lacking files at server's %files
499
500* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
501- include JDBC driver for 7.4
502- fix typo in postgresql-7.4-psql-patch
503
504* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
505- upstream release
506- change '--includedir=' option to avoid conflicting with unixODBC
507- add postgresql-7.4-ecpg-patch
508
509* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
510- upstream release
511
512* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
513- drop previous version of libpq's trash
514
515* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
516- upstream release with new nls patch
517- fix postgresql-bashprofile (value of PGDATA)
518- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
519
520* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
521- rebuild with tcltk8.4 and readline-4.3
522
523* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
524- upstream release
525
526* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
527- upstream release
528- remove garbage changelog
529
530* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
531- upstream release based on 7.3-2PGDG
532- add nls patch
533
534* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
535- 7.3-2PGDG
536- Fix typo in initscript.  Argh!!
537
538* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
539- 7.3-0.5PGDG
540- Jerk out all perl client stuff and kludgage
541- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
542- Eliminate locale and multibyte explicit enables -- they are both defaults now
543- Eliminate pgaccess code; it's not a part of the main tarball anymore
544- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
545- Eliminated separate tk client package -- rolled the tk client into the tcl client.
546- Moved pltcl into the pl subpackage.
547- Added plpython to the pl subpackage.
548- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
549
550* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
551- 7.3-0.1PGDG (not released)
552- Integrate 7.3 jar's courtesy Joe Conway
553- Integrate multi-postmaster initscript courtesy Karl DeBisschop
554- Some renames and restructures.
555- Stripped out the last dregs of the postgresql-dump migration script.
556- Conflicts with less than 7.3.
557
558- (See below for old changelogs from VineSeed)
559
560* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
561- updated to 7.2.3.
562
563* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
564- absorbed previous patch8 into original nlspatch
565- fixed configure options (--enable-nls and --enable-locale to be antinomy)
566
567* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
568- add patch8 (ja.po for psql was invalid)
569
570* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
571- updated to 7.2.2.
572- improved nlspatch to enable japanese SQL help in psql.
573
574* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
575- fixed garbage chars in description(ja).
576
577* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
578- imported & replaced changelog (following VineSeed's).
579  add some stuff to '%%files'.
580
581* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
582- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
583  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
584
585* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
586- replace nls patch.
587- add *.mo to '%%files'.
588
589* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
590- fix initscript
591
592* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
593- add /usr/bin/pg_id to the package (fix)
594
595* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
596- updated 7.2
597- added nls.patch
598- fixed spec file
599- added New JDBC
600-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
601
602* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
603- updated 7.1.3
604
605* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
606- 7.1.2-7vl3
607- merge 7.1.2-7vl2 and 7.1.2-7
608
609* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
610- 7.1.2-7vl2
611- fixed spec typo (%%{_includesir} -> %%{_includedir})
612
613* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
614- updated 7.1.2 (used postgresql-7.1.2-7)
615- used psqlj patch for 7.1.2
616- used jumbo-20010801.patch.gz
617
618* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
619- Add patches from 7.1-stable branch. This should fix #50799 and #50797
620- Enable kerberos authentication (#50644)
621- handle stop with stale pid file (#50499)
622- make the test subpackage (not built by default) own /usr/lib/pgsql/test
623
624* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
625- Make the -devel subpackage depend on -libs, not the main package
626
627* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
628- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
629
630* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
631- add changes for s390x
632
633* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
634- Many path fixes for contrib packages
635- Newer intarray
636- Don't use nested ifs for tkpkg/pgaccess
637- Turn off test package for Red Hat Linux - it makes most sense just to use
638  this during development
639- One "pgacess" -> "pgaccess"
640
641* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
642- -4PGDG
643- patchset update for pg_regress.sh
644- can the dot in the release -- confused too many people and some programs.
645- -3.PGDG
646- updated README.rpm-dist
647- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
648  was still being used where /usr/lib/pgsql was intended.
649- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
650
651* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
652- sync
653- Run chkconfig --add on server install
654- Move the prereqs on useradd on chkconfig to the server package
655- don't disable the %%clean section
656
657* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
658- Sync up with Trond Eivind's set.
659
660* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
661- Don't create postgres' .bashrc from the server post script: include it instead
662- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
663- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
664  libs
665- Source the i18n data from the .bashrc instead of in the initscript
666
667* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
668- Handle i18n for database startup - backend needs to have the same locale everytime,
669  but this certainly can't be hardcoded to C either
670- Fix stop, restart in initscript (#42217)
671- Make database init _much_ less verbose
672- other minor fixes to the initscript
673
674* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
675- 7.1.2
676
677* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
678- 7.1.2-0.1.1.PGDG PRERELEASE
679- Changed versioning and release numbering a little for better flexibility,
680-- particularly for distribution packagers.
681- Release numbering comment at top of spec, where it's more useful.
682- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
683  changlog, and the last 6.5.3's specfile for the changelog prior to
684  7.0.
685
686* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
687- 7.1.1-4.PGDG
688- _really_ got Python version agnosticism working.
689
690* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
691- 7.1.1-3.PGDG Release
692- Python version agnosticism.....
693
694* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
695- Use openssl
696- Make it obsolete subpackages if they aren't built
697
698* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
699- 7.1.1-2.PGDG Release.
700- Appended .PGDG to release string to differentiate our RPM set from the others.
701- /bin/sh fix in initscript
702- README.rpm-dist updates.
703
704* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
705- Rebuild with new readline
706
707* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
708- Initial 7.1.1
709
710* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
711- Specify shell when running commands through su in the initscript, to avoid problems
712  when people switch the postgres user to use tcsh
713
714* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
715- JDBC driver for Postgresql 7.1
716
717* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
718- slightly different versioning scheming, will go back to the official
719  later when I'm sure the package is ready to use
720
721* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
722- 7.1 RELEASE
723- 7.1-1 RPM RELEASE
724- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
725- Back to old versioning scheme, kept teg's other fixes.
726- README.rpm-dist updated.
727- PGVERSION updated all-around (hopefully!)
728- Couple of fixes from Peter E.
729- Rearrange dependencies -- only the -libs subpackage is required for most stuff
730- Removed broken and confusing logrotate script.
731
732* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
733- chown considered harmful - removed
734- fix dangling symlimks (pg_crc.c)
735- libpq.so changes for maximum compatiblity
736- different versioning scheme, to avoid trouble later
737- remove temporary perl file from the file list
738- fix spelling error in tcl description
739- mark odbcinst.ini as a config file
740- use %%defattr on packages which didn't have it
741
742* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
743- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
744- Packaging reorg: added contrib and docs subpackages.
745- Removed sgml source docs from main package --> docs subpackage.
746- Removed contrib tree from main package --> contrib subpackage.
747- Contrib tree is now prebuilt -- HOWEVER, very little install work is
748  currently done with this.
749
750* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
751- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
752
753* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
754- RC2
755- eliminate versioning information for ancilliary files in prep for CVS.
756- Fix docs mixup.
757
758* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
759- RC1 quickie.
760
761* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
762- Beta 6 initial build.
763- Use make install-all-headers instead of cpio hack for devel headers.
764- Split out the libs into the libs subpackage.
765- Updated initscript to use pg_ctl to stop
766- Updated initscript to initdb and start postmaster with LC_ALL=C to
767  prevent index corruption.
768
769
770* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
771- Beta4
772- Return to 'pgsql' directories instead of 'postgresql'
773- Better perl patches.
774
775* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
776- Edit patches to get rid of some cruft.
777- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
778- Moved pg_id to server
779- added Makefile.global and pg_config to devel
780- Corrected /usr/include/pgsql to /usr/include/postgresql
781- Fixed some configure options.  Will be trying the configure macro next release
782- Since it is terminally ill in this version pg_upgrade is _gone_.
783- Thanks to Peter E for a good review.
784
785* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
786- Running regression. 1 on the release-o-meter.
787- Minor patches to get regression running right. 
788- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
789
790* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
791- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
792- The 7.1 build is different from the 7.0 build -- see the configure line.
793- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
794- by request, conditional packages are now supported. See the top of the spec.
795- Fixed the server postinstall problems.
796
797* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
798- First 7.1 beta test-build
799
Note: See TracBrowser for help on using the repository browser.