source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 12240

Revision 12240, 27.8 KB checked in by tomop, 5 years ago (diff)

libpq-12.0-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 12
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.0
19Release: 1%{?_dist_release}
20License: BSD
21Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source5: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
23Source6: README.rpm-dist
24Patch2: postgresql-8.3.3-nls.patch
25Patch3: postgresql-7.4-ecpg-patch
26Buildrequires: perl build-essential
27Buildrequires: libedit-devel
28Buildrequires: zlib-devel >= 1.0.4
29BuildRequires: bison, flex, pam-devel
30%if %ssl
31Buildrequires: openssl-devel
32%endif
33%if %kerberos
34Buildrequires: krb5-devel
35%endif
36%if %nls
37Buildrequires: gettext >= 0.10.35
38%endif
39
40%if %pam
41Buildrequires: pam-devel
42%endif
43
44Url: https://www.postgresql.org/
45Buildroot: %{_tmppath}/%{name}-%{version}-root
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51The %{name} package provides the essential shared libraries for any
52PostgreSQL client program or interface. You will need to install this package
53to use any other PostgreSQL package or any clients that need to connect to a
54PostgreSQL server.
55
56%description -l ja
57%{name} パッケージは、すべての PostgreSQL クライアントプログラ
58ムやインターフェースのための中核的な共有ライブラリを提供します。
59PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
60ントを使う場合には、このパッケージをインストールする必要があります。
61
62%package -n libpq%{pq_soname}
63Summary: The shared libraries required for any PostgreSQL clients.
64Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
65Group: System Environment/Libraries
66Requires(post): /sbin/ldconfig
67Requires(postun): /sbin/ldconfig
68Obsoletes: postgresql7-libs
69Obsoletes: postgresql8-libs
70Obsoletes: postgresql-libs < 9.3.0
71Conflicts: postgresql-libs >= 9.3.0
72
73%description -n libpq%{pq_soname}
74The %{name} package provides the essential shared libraries for any
75PostgreSQL client program or interface. You will need to install this package
76to use any other PostgreSQL package or any clients that need to connect to a
77PostgreSQL server.
78
79%description -n libpq%{pq_soname} -l ja
80%{name} パッケージは、すべての PostgreSQL クライアントプログラ
81ムやインターフェースのための中核的な共有ライブラリを提供します。
82PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
83ントを使う場合には、このパッケージをインストールする必要があります。
84
85%package devel
86Summary: PostgreSQL development header files and libraries.
87Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
88Group: Development/Libraries
89Requires: libpq%{pq_soname} = %{version}
90Obsoletes: postgresql7-devel
91Obsoletes: postgresql8-devel
92Obsoletes: postgresql-devel < 9.3.0
93
94%description devel
95The %{name}-devel package contains the header files and libraries
96needed to compile C or C++ applications which will directly interact
97with a PostgreSQL database management server and the ecpg Embedded C
98Postgres preprocessor. You need to install this package if you want to
99develop applications which will interact with a PostgreSQL server.
100
101%description -l ja devel
102%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
103するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
104ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
105が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
106したい場合にはこのパッケージをインストールしてください。
107
108
109%prep
110%setup -q -n postgresql-%{version}
111
112
113%build
114CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
115CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
116
117# Strip out -ffast-math from CFLAGS....
118
119CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
120
121./configure \
122        --prefix=%{_prefix} \
123        --libdir=%{_libdir} \
124        --disable-rpath \
125%if %beta
126        --enable-debug \
127        --enable-cassert \
128%endif
129%if %ssl
130        --with-openssl \
131%endif
132%if %pam
133        --with-pam \
134%endif
135%if %kerberos
136        --with-krb5=/usr/kerberos \
137%endif
138%if %nls
139        --enable-nls \
140%endif
141        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
142        --mandir=%{_mandir} \
143        --with-docdir=%{_docdir} \
144        --includedir=%{_includedir}/pgsql \
145        --datadir=%{_datadir}/pgsql
146
147# workaround for bug with parallel build
148make %{?_smp_mflags} -C ./src/interfaces all ||:
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
152make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
159make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
160make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
161
162# copy over Makefile.global to the include dir....
163install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
164install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
165
166# install missing header
167mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
168install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
169install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
171install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
172install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175
176# Fix some more documentation
177##gzip doc/internals.ps
178cp %{SOURCE6} README.rpm-dist
179##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
180##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
181
182mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
183install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
184
185
186%find_lang libpq5-%{pgver}
187%find_lang ecpg-%{pgver}
188%find_lang ecpglib%{ecpg_soname}-%{pgver}
189#%find_lang pg_config-%{pgver}
190
191cat libpq5-%{pgver}.lang > libpq.lst
192cat ecpg-%{pgver}.lang >> libpq.lst
193cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
194#cat pg_config-%{pgver}.lang > devel.lst
195
196rm -rf %{buildroot}%{_libdir}/lib*.a
197rm -rf %{buildroot}%{_datadir}/pgsql
198find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
199
200rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
201find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
202
203%post
204/sbin/ldconfig
205
206%postun
207/sbin/ldconfig
208
209
210%clean
211rm -rf $RPM_BUILD_ROOT
212
213
214%files -n libpq%{pq_soname} -f libpq.lst
215%defattr(-,root,root)
216%license COPYRIGHT
217%doc HISTORY INSTALL README*
218%{_libdir}/libecpg.so.*
219%{_libdir}/libecpg_compat.so.*
220%{_libdir}/libpgtypes.so.*
221%{_libdir}/libpq.so.*
222
223%files devel -f devel.lst
224%defattr(-,root,root)
225%{_bindir}/ecpg
226%{_bindir}/pg_config
227%{_libdir}/libecpg.so
228%{_libdir}/libecpg_compat.so
229%{_libdir}/libpgtypes.so
230%{_libdir}/libpq.so
231%{_libdir}/pkgconfig/*
232%dir %{_includedir}/pgsql
233%{_datadir}/locale/*/LC_MESSAGES/*.mo
234%{_mandir}/man1/ecpg.*
235#%{_mandir}/man1/pg_config.*
236
237
238%changelog
239* Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0-1
240- new upstream release.
241
242* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.5-1
243- new upstream release.
244
245* Fri Mar 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.3-1
246- new upstream release.
247
248* Fri Apr  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.2-1
249- new upstream release.
250
251* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.1-1
252- new upstream release.
253
254* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.0-1
255- new upstream release.
256
257* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
258- new upstream release.
259
260* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
261- new upstream release.
262
263* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
264- new upstream release.
265
266* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
267- added all headers for a strange client.
268
269* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
270- add pgconfig
271- add pg_config*.h and libpq/libpq-fs.h
272
273* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
274- add postgres_ext.h and pg_config_ext.h
275
276* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
277- new upstream release
278
279* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
280- made to build client libraries only.
281
282* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
283- new upstream release
284
285* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
286- new upstream release
287- add Vendor and Distribution tags
288
289* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
290- build with Tcl/Tk 8.5.7-1
291- fix init script (Source3): fix su(1) paramaters.
292
293* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
294- new upstream release
295- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
296- remove *_and_*.so from -contrib (included in -server)
297
298* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
299- updated postgresql to 9.0.4
300
301* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
302- updated postgresql to 9.0.3
303- separated postgresql-jdbc package
304
305* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
306- updated postgresql to 8.4.7 (contains a variety of fixes)
307
308* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
309- updated postgresql to 8.4.6
310- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
311- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
312- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
313
314* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
315- rebuilt with openssl-1.0.0c
316
317* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
318- updated postgresql to 8.4.5
319
320* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
321- updated postgresql to 8.4.4
322
323* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
324- updated postgresql to 8.4.3
325- s/BuildPrereq/Buildrequires/
326
327* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
328- updated postgresql to 8.4.2
329- rebuilt with new environment
330
331* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
332- updated postgresql to 8.4.1
333
334* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
335- moved dict_snowball.so from conrib to server
336
337* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
338- updated postgresql to 8.4.0
339- updated jdbc3,4 to 701
340- dropt postgresql-8.3.3-nls.patch (fixed)
341- dropt postgresql-7.4-ecpg-patch (no effect)
342
343* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
344- changed libs Group to System Environment/Libraries
345
346* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
347- updated postgresql to 8.3.7
348
349* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
350- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
351
352* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
353- new upstream release (postgresql to 8.3.5, jdbc to 604)
354
355* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
356- applied new versioning policy, and spec in utf-8
357- updated postgresql to 8.3.3
358- updated jdbcver to 603
359- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
360- added a script to replace PGVERSION in postgresql.init
361
362* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
363- rebuild with tcl/tk-8.4.18
364
365* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
366- updated postgresql to 8.2.6
367- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
368
369* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
370- updated PGVERSION to 8.2 in postgresql.init (sorry;)
371
372* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
373- rebuild with tcl/tk-8.4.16
374
375* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
376- updated postgresql to 8.2.5
377- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
378- updated nls-patch to 8-2-0
379- dropt postgresql-8.1.4-Pg.patch.gz
380
381* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
382- for VineSeed
383- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
384- JDBC driver updated to 410
385
386* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
387- rebuilt for VineSeed
388- fixed install script
389
390* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
391- upstream release
392- fix missing %defattr in %files server
393
394* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
395- fix version number in postgresql.init
396
397* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
398- upstream release
399- drop rpm-pgsql-8.0.0.patch
400- add Requires: perl-DBD-Pg for contrib
401- add postgresql-8.1.4-Pg.patch.gz
402- update nls patches
403- new JDBC driver
404
405* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
406- added build options --without perl, --without python
407- rebuilt for x86_64 architecture support
408
409* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
410- drop Provides: on postgresql-libs
411- drop Requires: libpq.so on postgresql-server
412
413* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
414- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
415
416* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
417- upstream release
418- update nls patches
419
420* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
421- upstream release
422- update nls patches
423
424* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
425- rebuilded with python-2.4.1-0vl1
426
427* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
428- Dropped PyGreSQL-3.4.tgz.
429- Dropped PyGreSQL-3.4-setup-2.patch.
430- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
431- Dropped pyver and pynextver macros.
432- Changed macro name "python" to "plpython" like plperl.
433- Added "Obsoletes: postgresql-python"
434
435* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
436- Major version up
437- Obsoletes: postgresql7
438- update nls patch(es)
439- modify %postun not to delete postgres account on upgrade
440
441* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
442- upstream release (release as a new package)
443- Conflicts: postgresql
444- update nls patch(es)
445- (this package revision was rejected by Vine Project)
446
447* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
448- upstream release
449- new JDBC driver
450- add BuildRequires: bison, flex, pam-devel
451- drop postgresql-7.4.5-tempfile.patch (repaired)
452
453* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
454- Added a security fix patch postgresql-7.4.5-tempfile.patch
455  from Gentoo Linux (CAN-2004-0977).
456- Changed Patch4:
457  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
458  It is possible to compile this package without pre-installed postgresql.
459- Removed Patch5 because Patch4 was changed.
460
461* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
462- upstream release
463
464* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
465- upstream release
466- new jdbc driver
467
468* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
469- rebuild with python-2.3.3-0vl1
470
471* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
472- changed mode to 644 at Makefile.global, Makefile.shlib
473
474* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
475- updated python install section
476
477* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
478- added PyGreSQL-3.4.tgz and set python flag
479- added PyGreSQL-3.4-setup.patch
480- added PyGreSQL-3.4-pgmodule.patch
481- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
482
483* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
484- rebuild with new openssl
485
486* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
487- upstream release
488- change all of %{?foo:%define foo 0} -like descriptions to simple
489  %define format for latest rpm to build.
490
491* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
492- rebuild on latest tcl package environment.
493
494* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
495- fixed lacking files at server's %files
496
497* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
498- include JDBC driver for 7.4
499- fix typo in postgresql-7.4-psql-patch
500
501* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
502- upstream release
503- change '--includedir=' option to avoid conflicting with unixODBC
504- add postgresql-7.4-ecpg-patch
505
506* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
507- upstream release
508
509* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
510- drop previous version of libpq's trash
511
512* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
513- upstream release with new nls patch
514- fix postgresql-bashprofile (value of PGDATA)
515- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
516
517* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
518- rebuild with tcltk8.4 and readline-4.3
519
520* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
521- upstream release
522
523* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
524- upstream release
525- remove garbage changelog
526
527* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
528- upstream release based on 7.3-2PGDG
529- add nls patch
530
531* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
532- 7.3-2PGDG
533- Fix typo in initscript.  Argh!!
534
535* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
536- 7.3-0.5PGDG
537- Jerk out all perl client stuff and kludgage
538- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
539- Eliminate locale and multibyte explicit enables -- they are both defaults now
540- Eliminate pgaccess code; it's not a part of the main tarball anymore
541- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
542- Eliminated separate tk client package -- rolled the tk client into the tcl client.
543- Moved pltcl into the pl subpackage.
544- Added plpython to the pl subpackage.
545- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
546
547* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
548- 7.3-0.1PGDG (not released)
549- Integrate 7.3 jar's courtesy Joe Conway
550- Integrate multi-postmaster initscript courtesy Karl DeBisschop
551- Some renames and restructures.
552- Stripped out the last dregs of the postgresql-dump migration script.
553- Conflicts with less than 7.3.
554
555- (See below for old changelogs from VineSeed)
556
557* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
558- updated to 7.2.3.
559
560* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
561- absorbed previous patch8 into original nlspatch
562- fixed configure options (--enable-nls and --enable-locale to be antinomy)
563
564* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
565- add patch8 (ja.po for psql was invalid)
566
567* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
568- updated to 7.2.2.
569- improved nlspatch to enable japanese SQL help in psql.
570
571* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
572- fixed garbage chars in description(ja).
573
574* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
575- imported & replaced changelog (following VineSeed's).
576  add some stuff to '%%files'.
577
578* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
579- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
580  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
581
582* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
583- replace nls patch.
584- add *.mo to '%%files'.
585
586* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
587- fix initscript
588
589* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
590- add /usr/bin/pg_id to the package (fix)
591
592* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
593- updated 7.2
594- added nls.patch
595- fixed spec file
596- added New JDBC
597-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
598
599* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
600- updated 7.1.3
601
602* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
603- 7.1.2-7vl3
604- merge 7.1.2-7vl2 and 7.1.2-7
605
606* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
607- 7.1.2-7vl2
608- fixed spec typo (%%{_includesir} -> %%{_includedir})
609
610* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
611- updated 7.1.2 (used postgresql-7.1.2-7)
612- used psqlj patch for 7.1.2
613- used jumbo-20010801.patch.gz
614
615* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
616- Add patches from 7.1-stable branch. This should fix #50799 and #50797
617- Enable kerberos authentication (#50644)
618- handle stop with stale pid file (#50499)
619- make the test subpackage (not built by default) own /usr/lib/pgsql/test
620
621* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
622- Make the -devel subpackage depend on -libs, not the main package
623
624* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
625- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
626
627* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
628- add changes for s390x
629
630* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
631- Many path fixes for contrib packages
632- Newer intarray
633- Don't use nested ifs for tkpkg/pgaccess
634- Turn off test package for Red Hat Linux - it makes most sense just to use
635  this during development
636- One "pgacess" -> "pgaccess"
637
638* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
639- -4PGDG
640- patchset update for pg_regress.sh
641- can the dot in the release -- confused too many people and some programs.
642- -3.PGDG
643- updated README.rpm-dist
644- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
645  was still being used where /usr/lib/pgsql was intended.
646- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
647
648* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
649- sync
650- Run chkconfig --add on server install
651- Move the prereqs on useradd on chkconfig to the server package
652- don't disable the %%clean section
653
654* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
655- Sync up with Trond Eivind's set.
656
657* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
658- Don't create postgres' .bashrc from the server post script: include it instead
659- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
660- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
661  libs
662- Source the i18n data from the .bashrc instead of in the initscript
663
664* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
665- Handle i18n for database startup - backend needs to have the same locale everytime,
666  but this certainly can't be hardcoded to C either
667- Fix stop, restart in initscript (#42217)
668- Make database init _much_ less verbose
669- other minor fixes to the initscript
670
671* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
672- 7.1.2
673
674* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
675- 7.1.2-0.1.1.PGDG PRERELEASE
676- Changed versioning and release numbering a little for better flexibility,
677-- particularly for distribution packagers.
678- Release numbering comment at top of spec, where it's more useful.
679- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
680  changlog, and the last 6.5.3's specfile for the changelog prior to
681  7.0.
682
683* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
684- 7.1.1-4.PGDG
685- _really_ got Python version agnosticism working.
686
687* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
688- 7.1.1-3.PGDG Release
689- Python version agnosticism.....
690
691* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
692- Use openssl
693- Make it obsolete subpackages if they aren't built
694
695* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
696- 7.1.1-2.PGDG Release.
697- Appended .PGDG to release string to differentiate our RPM set from the others.
698- /bin/sh fix in initscript
699- README.rpm-dist updates.
700
701* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
702- Rebuild with new readline
703
704* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
705- Initial 7.1.1
706
707* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
708- Specify shell when running commands through su in the initscript, to avoid problems
709  when people switch the postgres user to use tcsh
710
711* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
712- JDBC driver for Postgresql 7.1
713
714* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
715- slightly different versioning scheming, will go back to the official
716  later when I'm sure the package is ready to use
717
718* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
719- 7.1 RELEASE
720- 7.1-1 RPM RELEASE
721- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
722- Back to old versioning scheme, kept teg's other fixes.
723- README.rpm-dist updated.
724- PGVERSION updated all-around (hopefully!)
725- Couple of fixes from Peter E.
726- Rearrange dependencies -- only the -libs subpackage is required for most stuff
727- Removed broken and confusing logrotate script.
728
729* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
730- chown considered harmful - removed
731- fix dangling symlimks (pg_crc.c)
732- libpq.so changes for maximum compatiblity
733- different versioning scheme, to avoid trouble later
734- remove temporary perl file from the file list
735- fix spelling error in tcl description
736- mark odbcinst.ini as a config file
737- use %%defattr on packages which didn't have it
738
739* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
740- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
741- Packaging reorg: added contrib and docs subpackages.
742- Removed sgml source docs from main package --> docs subpackage.
743- Removed contrib tree from main package --> contrib subpackage.
744- Contrib tree is now prebuilt -- HOWEVER, very little install work is
745  currently done with this.
746
747* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
748- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
749
750* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
751- RC2
752- eliminate versioning information for ancilliary files in prep for CVS.
753- Fix docs mixup.
754
755* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
756- RC1 quickie.
757
758* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
759- Beta 6 initial build.
760- Use make install-all-headers instead of cpio hack for devel headers.
761- Split out the libs into the libs subpackage.
762- Updated initscript to use pg_ctl to stop
763- Updated initscript to initdb and start postmaster with LC_ALL=C to
764  prevent index corruption.
765
766
767* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
768- Beta4
769- Return to 'pgsql' directories instead of 'postgresql'
770- Better perl patches.
771
772* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
773- Edit patches to get rid of some cruft.
774- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
775- Moved pg_id to server
776- added Makefile.global and pg_config to devel
777- Corrected /usr/include/pgsql to /usr/include/postgresql
778- Fixed some configure options.  Will be trying the configure macro next release
779- Since it is terminally ill in this version pg_upgrade is _gone_.
780- Thanks to Peter E for a good review.
781
782* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
783- Running regression. 1 on the release-o-meter.
784- Minor patches to get regression running right. 
785- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
786
787* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
788- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
789- The 7.1 build is different from the 7.0 build -- see the configure line.
790- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
791- by request, conditional packages are now supported. See the top of the spec.
792- Fixed the server postinstall problems.
793
794* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
795- First 7.1 beta test-build
796
Note: See TracBrowser for help on using the repository browser.