source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 9598

Revision 9598, 27.1 KB checked in by tomop, 9 years ago (diff)

libpq-9.4.4-1, postgresql-9.4.4-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 9.4
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.4
19Release: 1%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source3: postgresql.init
23Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
24Source6: README.rpm-dist
25Source15: postgresql-bashprofile
26Patch2: postgresql-8.3.3-nls.patch
27Patch3: postgresql-7.4-ecpg-patch
28Buildrequires: perl build-essential
29Buildrequires: libedit-devel
30Buildrequires: zlib-devel >= 1.0.4
31BuildRequires: bison, flex, pam-devel
32%if %ssl
33Buildrequires: openssl-devel
34%endif
35%if %kerberos
36Buildrequires: krb5-devel
37%endif
38%if %nls
39Buildrequires: gettext >= 0.10.35
40%endif
41
42%if %pam
43Buildrequires: pam-devel
44%endif
45
46Url: http://www.postgresql.org/
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53The %{name} package provides the essential shared libraries for any
54PostgreSQL client program or interface. You will need to install this package
55to use any other PostgreSQL package or any clients that need to connect to a
56PostgreSQL server.
57
58%description -l ja
59%{name} パッケージは、すべての PostgreSQL クライアントプログラ
60ムやインターフェースのための中核的な共有ライブラリを提供します。
61PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
62ントを使う場合には、このパッケージをインストールする必要があります。
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: System Environment/Libraries
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87%package devel
88Summary: PostgreSQL development header files and libraries.
89Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
90Group: Development/Libraries
91Requires: libpq%{pq_soname} = %{version}
92Obsoletes: postgresql7-devel
93Obsoletes: postgresql8-devel
94Obsoletes: postgresql-devel < 9.3.0
95
96%description devel
97The %{name}-devel package contains the header files and libraries
98needed to compile C or C++ applications which will directly interact
99with a PostgreSQL database management server and the ecpg Embedded C
100Postgres preprocessor. You need to install this package if you want to
101develop applications which will interact with a PostgreSQL server.
102
103%description -l ja devel
104%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
105するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
106ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
107が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
108したい場合にはこのパッケージをインストールしてください。
109
110
111%prep
112%setup -q -n postgresql-%{version}
113
114
115%build
116CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
117CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
118
119# Strip out -ffast-math from CFLAGS....
120
121CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
122
123./configure \
124        --prefix=%{_prefix} \
125        --libdir=%{_libdir} \
126        --disable-rpath \
127%if %beta
128        --enable-debug \
129        --enable-cassert \
130%endif
131%if %ssl
132        --with-openssl \
133%endif
134%if %pam
135        --with-pam \
136%endif
137%if %kerberos
138        --with-krb5=/usr/kerberos \
139%endif
140%if %nls
141        --enable-nls \
142%endif
143        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
144        --mandir=%{_mandir} \
145        --with-docdir=%{_docdir} \
146        --includedir=%{_includedir}/pgsql \
147        --datadir=%{_datadir}/pgsql
148
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
152make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
159make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
160cp -f ./src/backend/utils/fmgroids.h ./src/include/utils/
161make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
162
163# copy over Makefile.global to the include dir....
164install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
165install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
166
167# install missing header
168mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
169install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
171install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
172install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
176
177# Fix some more documentation
178##gzip doc/internals.ps
179cp %{SOURCE6} README.rpm-dist
180##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
181##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
182
183mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
184install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
185
186
187%find_lang libpq5-%{pgver}
188%find_lang ecpg-%{pgver}
189%find_lang ecpglib%{ecpg_soname}-%{pgver}
190#%find_lang pg_config-%{pgver}
191
192cat libpq5-%{pgver}.lang > libpq.lst
193cat ecpg-%{pgver}.lang >> libpq.lst
194cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
195#cat pg_config-%{pgver}.lang > devel.lst
196
197rm -rf %{buildroot}%{_libdir}/lib*.a
198rm -rf %{buildroot}%{_datadir}/pgsql
199find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
200
201rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
202find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
203
204%post
205/sbin/ldconfig
206
207%postun
208/sbin/ldconfig
209
210
211%clean
212rm -rf $RPM_BUILD_ROOT
213
214
215%files -n libpq%{pq_soname} -f libpq.lst
216%defattr(-,root,root)
217%doc COPYRIGHT HISTORY INSTALL README*
218%{_libdir}/libecpg.so.*
219%{_libdir}/libecpg_compat.so.*
220%{_libdir}/libpgtypes.so.*
221%{_libdir}/libpq.so.*
222
223%files devel -f devel.lst
224%defattr(-,root,root)
225%{_bindir}/ecpg
226%{_bindir}/pg_config
227%{_libdir}/libecpg.so
228%{_libdir}/libecpg_compat.so
229%{_libdir}/libpgtypes.so
230%{_libdir}/libpq.so
231%{_libdir}/pkgconfig/*
232%{_datadir}/locale/*/LC_MESSAGES/*.mo
233%{_mandir}/man1/ecpg.*
234#%{_mandir}/man1/pg_config.*
235
236
237%changelog
238* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
239- new upstream release.
240
241* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
242- new upstream release.
243
244* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
245- added all headers for a strange client.
246
247* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
248- add pgconfig
249- add pg_config*.h and libpq/libpq-fs.h
250
251* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
252- add postgres_ext.h and pg_config_ext.h
253
254* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
255- new upstream release
256
257* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
258- made to build client libraries only.
259
260* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
261- new upstream release
262
263* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
264- new upstream release
265- add Vendor and Distribution tags
266
267* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
268- build with Tcl/Tk 8.5.7-1
269- fix init script (Source3): fix su(1) paramaters.
270
271* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
272- new upstream release
273- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
274- remove *_and_*.so from -contrib (included in -server)
275
276* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
277- updated postgresql to 9.0.4
278
279* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
280- updated postgresql to 9.0.3
281- separated postgresql-jdbc package
282
283* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
284- updated postgresql to 8.4.7 (contains a variety of fixes)
285
286* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
287- updated postgresql to 8.4.6
288- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
289- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
290- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
291
292* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
293- rebuilt with openssl-1.0.0c
294
295* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
296- updated postgresql to 8.4.5
297
298* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
299- updated postgresql to 8.4.4
300
301* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
302- updated postgresql to 8.4.3
303- s/BuildPrereq/Buildrequires/
304
305* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
306- updated postgresql to 8.4.2
307- rebuilt with new environment
308
309* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
310- updated postgresql to 8.4.1
311
312* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
313- moved dict_snowball.so from conrib to server
314
315* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
316- updated postgresql to 8.4.0
317- updated jdbc3,4 to 701
318- dropt postgresql-8.3.3-nls.patch (fixed)
319- dropt postgresql-7.4-ecpg-patch (no effect)
320
321* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
322- changed libs Group to System Environment/Libraries
323
324* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
325- updated postgresql to 8.3.7
326
327* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
328- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
329
330* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
331- new upstream release (postgresql to 8.3.5, jdbc to 604)
332
333* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
334- applied new versioning policy, and spec in utf-8
335- updated postgresql to 8.3.3
336- updated jdbcver to 603
337- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
338- added a script to replace PGVERSION in postgresql.init
339
340* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
341- rebuild with tcl/tk-8.4.18
342
343* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
344- updated postgresql to 8.2.6
345- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
346
347* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
348- updated PGVERSION to 8.2 in postgresql.init (sorry;)
349
350* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
351- rebuild with tcl/tk-8.4.16
352
353* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
354- updated postgresql to 8.2.5
355- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
356- updated nls-patch to 8-2-0
357- dropt postgresql-8.1.4-Pg.patch.gz
358
359* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
360- for VineSeed
361- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
362- JDBC driver updated to 410
363
364* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
365- rebuilt for VineSeed
366- fixed install script
367
368* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
369- upstream release
370- fix missing %defattr in %files server
371
372* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
373- fix version number in postgresql.init
374
375* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
376- upstream release
377- drop rpm-pgsql-8.0.0.patch
378- add Requires: perl-DBD-Pg for contrib
379- add postgresql-8.1.4-Pg.patch.gz
380- update nls patches
381- new JDBC driver
382
383* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
384- added build options --without perl, --without python
385- rebuilt for x86_64 architecture support
386
387* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
388- drop Provides: on postgresql-libs
389- drop Requires: libpq.so on postgresql-server
390
391* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
392- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
393
394* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
395- upstream release
396- update nls patches
397
398* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
399- upstream release
400- update nls patches
401
402* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
403- rebuilded with python-2.4.1-0vl1
404
405* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
406- Dropped PyGreSQL-3.4.tgz.
407- Dropped PyGreSQL-3.4-setup-2.patch.
408- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
409- Dropped pyver and pynextver macros.
410- Changed macro name "python" to "plpython" like plperl.
411- Added "Obsoletes: postgresql-python"
412
413* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
414- Major version up
415- Obsoletes: postgresql7
416- update nls patch(es)
417- modify %postun not to delete postgres account on upgrade
418
419* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
420- upstream release (release as a new package)
421- Conflicts: postgresql
422- update nls patch(es)
423- (this package revision was rejected by Vine Project)
424
425* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
426- upstream release
427- new JDBC driver
428- add BuildRequires: bison, flex, pam-devel
429- drop postgresql-7.4.5-tempfile.patch (repaired)
430
431* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
432- Added a security fix patch postgresql-7.4.5-tempfile.patch
433  from Gentoo Linux (CAN-2004-0977).
434- Changed Patch4:
435  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
436  It is possible to compile this package without pre-installed postgresql.
437- Removed Patch5 because Patch4 was changed.
438
439* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
440- upstream release
441
442* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
443- upstream release
444- new jdbc driver
445
446* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
447- rebuild with python-2.3.3-0vl1
448
449* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
450- changed mode to 644 at Makefile.global, Makefile.shlib
451
452* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
453- updated python install section
454
455* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
456- added PyGreSQL-3.4.tgz and set python flag
457- added PyGreSQL-3.4-setup.patch
458- added PyGreSQL-3.4-pgmodule.patch
459- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
460
461* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
462- rebuild with new openssl
463
464* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
465- upstream release
466- change all of %{?foo:%define foo 0} -like descriptions to simple
467  %define format for latest rpm to build.
468
469* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
470- rebuild on latest tcl package environment.
471
472* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
473- fixed lacking files at server's %files
474
475* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
476- include JDBC driver for 7.4
477- fix typo in postgresql-7.4-psql-patch
478
479* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
480- upstream release
481- change '--includedir=' option to avoid conflicting with unixODBC
482- add postgresql-7.4-ecpg-patch
483
484* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
485- upstream release
486
487* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
488- drop previous version of libpq's trash
489
490* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
491- upstream release with new nls patch
492- fix postgresql-bashprofile (value of PGDATA)
493- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
494
495* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
496- rebuild with tcltk8.4 and readline-4.3
497
498* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
499- upstream release
500
501* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
502- upstream release
503- remove garbage changelog
504
505* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
506- upstream release based on 7.3-2PGDG
507- add nls patch
508
509* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
510- 7.3-2PGDG
511- Fix typo in initscript.  Argh!!
512
513* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
514- 7.3-0.5PGDG
515- Jerk out all perl client stuff and kludgage
516- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
517- Eliminate locale and multibyte explicit enables -- they are both defaults now
518- Eliminate pgaccess code; it's not a part of the main tarball anymore
519- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
520- Eliminated separate tk client package -- rolled the tk client into the tcl client.
521- Moved pltcl into the pl subpackage.
522- Added plpython to the pl subpackage.
523- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
524
525* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
526- 7.3-0.1PGDG (not released)
527- Integrate 7.3 jar's courtesy Joe Conway
528- Integrate multi-postmaster initscript courtesy Karl DeBisschop
529- Some renames and restructures.
530- Stripped out the last dregs of the postgresql-dump migration script.
531- Conflicts with less than 7.3.
532
533- (See below for old changelogs from VineSeed)
534
535* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
536- updated to 7.2.3.
537
538* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
539- absorbed previous patch8 into original nlspatch
540- fixed configure options (--enable-nls and --enable-locale to be antinomy)
541
542* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
543- add patch8 (ja.po for psql was invalid)
544
545* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
546- updated to 7.2.2.
547- improved nlspatch to enable japanese SQL help in psql.
548
549* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
550- fixed garbage chars in description(ja).
551
552* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
553- imported & replaced changelog (following VineSeed's).
554  add some stuff to '%%files'.
555
556* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
557- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
558  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
559
560* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
561- replace nls patch.
562- add *.mo to '%%files'.
563
564* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
565- fix initscript
566
567* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
568- add /usr/bin/pg_id to the package (fix)
569
570* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
571- updated 7.2
572- added nls.patch
573- fixed spec file
574- added New JDBC
575-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
576
577* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
578- updated 7.1.3
579
580* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
581- 7.1.2-7vl3
582- merge 7.1.2-7vl2 and 7.1.2-7
583
584* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
585- 7.1.2-7vl2
586- fixed spec typo (%%{_includesir} -> %%{_includedir})
587
588* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
589- updated 7.1.2 (used postgresql-7.1.2-7)
590- used psqlj patch for 7.1.2
591- used jumbo-20010801.patch.gz
592
593* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
594- Add patches from 7.1-stable branch. This should fix #50799 and #50797
595- Enable kerberos authentication (#50644)
596- handle stop with stale pid file (#50499)
597- make the test subpackage (not built by default) own /usr/lib/pgsql/test
598
599* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
600- Make the -devel subpackage depend on -libs, not the main package
601
602* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
603- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
604
605* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
606- add changes for s390x
607
608* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
609- Many path fixes for contrib packages
610- Newer intarray
611- Don't use nested ifs for tkpkg/pgaccess
612- Turn off test package for Red Hat Linux - it makes most sense just to use
613  this during development
614- One "pgacess" -> "pgaccess"
615
616* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
617- -4PGDG
618- patchset update for pg_regress.sh
619- can the dot in the release -- confused too many people and some programs.
620- -3.PGDG
621- updated README.rpm-dist
622- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
623  was still being used where /usr/lib/pgsql was intended.
624- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
625
626* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
627- sync
628- Run chkconfig --add on server install
629- Move the prereqs on useradd on chkconfig to the server package
630- don't disable the %%clean section
631
632* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
633- Sync up with Trond Eivind's set.
634
635* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
636- Don't create postgres' .bashrc from the server post script: include it instead
637- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
638- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
639  libs
640- Source the i18n data from the .bashrc instead of in the initscript
641
642* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
643- Handle i18n for database startup - backend needs to have the same locale everytime,
644  but this certainly can't be hardcoded to C either
645- Fix stop, restart in initscript (#42217)
646- Make database init _much_ less verbose
647- other minor fixes to the initscript
648
649* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
650- 7.1.2
651
652* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
653- 7.1.2-0.1.1.PGDG PRERELEASE
654- Changed versioning and release numbering a little for better flexibility,
655-- particularly for distribution packagers.
656- Release numbering comment at top of spec, where it's more useful.
657- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
658  changlog, and the last 6.5.3's specfile for the changelog prior to
659  7.0.
660
661* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
662- 7.1.1-4.PGDG
663- _really_ got Python version agnosticism working.
664
665* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
666- 7.1.1-3.PGDG Release
667- Python version agnosticism.....
668
669* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
670- Use openssl
671- Make it obsolete subpackages if they aren't built
672
673* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
674- 7.1.1-2.PGDG Release.
675- Appended .PGDG to release string to differentiate our RPM set from the others.
676- /bin/sh fix in initscript
677- README.rpm-dist updates.
678
679* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
680- Rebuild with new readline
681
682* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
683- Initial 7.1.1
684
685* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
686- Specify shell when running commands through su in the initscript, to avoid problems
687  when people switch the postgres user to use tcsh
688
689* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
690- JDBC driver for Postgresql 7.1
691
692* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
693- slightly different versioning scheming, will go back to the official
694  later when I'm sure the package is ready to use
695
696* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
697- 7.1 RELEASE
698- 7.1-1 RPM RELEASE
699- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
700- Back to old versioning scheme, kept teg's other fixes.
701- README.rpm-dist updated.
702- PGVERSION updated all-around (hopefully!)
703- Couple of fixes from Peter E.
704- Rearrange dependencies -- only the -libs subpackage is required for most stuff
705- Removed broken and confusing logrotate script.
706
707* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
708- chown considered harmful - removed
709- fix dangling symlimks (pg_crc.c)
710- libpq.so changes for maximum compatiblity
711- different versioning scheme, to avoid trouble later
712- remove temporary perl file from the file list
713- fix spelling error in tcl description
714- mark odbcinst.ini as a config file
715- use %%defattr on packages which didn't have it
716
717* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
718- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
719- Packaging reorg: added contrib and docs subpackages.
720- Removed sgml source docs from main package --> docs subpackage.
721- Removed contrib tree from main package --> contrib subpackage.
722- Contrib tree is now prebuilt -- HOWEVER, very little install work is
723  currently done with this.
724
725* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
726- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
727
728* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
729- RC2
730- eliminate versioning information for ancilliary files in prep for CVS.
731- Fix docs mixup.
732
733* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
734- RC1 quickie.
735
736* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
737- Beta 6 initial build.
738- Use make install-all-headers instead of cpio hack for devel headers.
739- Split out the libs into the libs subpackage.
740- Updated initscript to use pg_ctl to stop
741- Updated initscript to initdb and start postmaster with LC_ALL=C to
742  prevent index corruption.
743
744
745* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
746- Beta4
747- Return to 'pgsql' directories instead of 'postgresql'
748- Better perl patches.
749
750* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
751- Edit patches to get rid of some cruft.
752- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
753- Moved pg_id to server
754- added Makefile.global and pg_config to devel
755- Corrected /usr/include/pgsql to /usr/include/postgresql
756- Fixed some configure options.  Will be trying the configure macro next release
757- Since it is terminally ill in this version pg_upgrade is _gone_.
758- Thanks to Peter E for a good review.
759
760* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
761- Running regression. 1 on the release-o-meter.
762- Minor patches to get regression running right. 
763- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
764
765* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
766- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
767- The 7.1 build is different from the 7.0 build -- see the configure line.
768- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
769- by request, conditional packages are now supported. See the top of the spec.
770- Fixed the server postinstall problems.
771
772* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
773- First 7.1 beta test-build
774
Note: See TracBrowser for help on using the repository browser.