source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 8604

Revision 8604, 26.6 KB checked in by daisuke, 10 years ago (diff)

libpq:

  • add pgconfig
  • add pg_config*.h and libpq/libpq-fs.h
Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 9.3
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.4
19Release: 3%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source3: postgresql.init
23Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
24Source6: README.rpm-dist
25Source15: postgresql-bashprofile
26Patch2: postgresql-8.3.3-nls.patch
27Patch3: postgresql-7.4-ecpg-patch
28Buildrequires: perl build-essential
29Buildrequires: readline-devel
30Buildrequires: zlib-devel >= 1.0.4
31BuildRequires: bison, flex, pam-devel
32%if %ssl
33Buildrequires: openssl-devel
34%endif
35%if %kerberos
36Buildrequires: krb5-devel
37%endif
38%if %nls
39Buildrequires: gettext >= 0.10.35
40%endif
41
42%if %pam
43Buildrequires: pam-devel
44%endif
45
46Url: http://www.postgresql.org/
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53The %{name} package provides the essential shared libraries for any
54PostgreSQL client program or interface. You will need to install this package
55to use any other PostgreSQL package or any clients that need to connect to a
56PostgreSQL server.
57
58%description -l ja
59%{name} パッケージは、すべての PostgreSQL クライアントプログラ
60ムやインターフェースのための中核的な共有ライブラリを提供します。
61PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
62ントを使う場合には、このパッケージをインストールする必要があります。
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: System Environment/Libraries
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87%package devel
88Summary: PostgreSQL development header files and libraries.
89Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
90Group: Development/Libraries
91Requires: libpq%{pq_soname} = %{version}
92Obsoletes: postgresql7-devel
93Obsoletes: postgresql8-devel
94Obsoletes: postgresql-devel < 9.3.0
95
96%description devel
97The %{name}-devel package contains the header files and libraries
98needed to compile C or C++ applications which will directly interact
99with a PostgreSQL database management server and the ecpg Embedded C
100Postgres preprocessor. You need to install this package if you want to
101develop applications which will interact with a PostgreSQL server.
102
103%description -l ja devel
104%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
105するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
106ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
107が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
108したい場合にはこのパッケージをインストールしてください。
109
110
111%prep
112%setup -q -n postgresql-%{version}
113
114
115%build
116CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
117CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
118
119# Strip out -ffast-math from CFLAGS....
120
121CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
122
123./configure \
124        --prefix=%{_prefix} \
125        --libdir=%{_libdir} \
126        --disable-rpath \
127%if %beta
128        --enable-debug \
129        --enable-cassert \
130%endif
131%if %ssl
132        --with-openssl \
133%endif
134%if %pam
135        --with-pam \
136%endif
137%if %kerberos
138        --with-krb5=/usr/kerberos \
139%endif
140%if %nls
141        --enable-nls \
142%endif
143        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
144        --mandir=%{_mandir} \
145        --with-docdir=%{_docdir} \
146        --includedir=%{_includedir}/pgsql \
147        --datadir=%{_datadir}/pgsql
148
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151
152%install
153rm -rf $RPM_BUILD_ROOT
154
155make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
156make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
157
158# copy over Makefile.global to the include dir....
159install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
160install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
161
162# install missing header
163mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
164install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
165install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
166install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
167install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
168install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
169install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
170install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
171
172# Fix some more documentation
173##gzip doc/internals.ps
174cp %{SOURCE6} README.rpm-dist
175##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
176##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
177
178mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
179install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
180
181
182%find_lang libpq5-%{pgver}
183%find_lang ecpg-%{pgver}
184%find_lang ecpglib%{ecpg_soname}-%{pgver}
185#%find_lang pg_config-%{pgver}
186
187cat libpq5-%{pgver}.lang > libpq.lst
188cat ecpg-%{pgver}.lang >> libpq.lst
189cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
190#cat pg_config-%{pgver}.lang > devel.lst
191
192rm -rf %{buildroot}%{_libdir}/lib*.a
193rm -rf %{buildroot}%{_datadir}/pgsql
194find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
195
196rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
197find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
198
199%post
200/sbin/ldconfig
201
202%postun
203/sbin/ldconfig
204
205
206%clean
207rm -rf $RPM_BUILD_ROOT
208
209
210%files -n libpq%{pq_soname} -f libpq.lst
211%defattr(-,root,root)
212%doc COPYRIGHT HISTORY INSTALL README*
213%{_libdir}/libecpg.so.*
214%{_libdir}/libecpg_compat.so.*
215%{_libdir}/libpgtypes.so.*
216%{_libdir}/libpq.so.*
217
218%files devel -f devel.lst
219%defattr(-,root,root)
220%{_bindir}/ecpg
221%{_bindir}/pg_config
222%{_libdir}/libecpg.so
223%{_libdir}/libecpg_compat.so
224%{_libdir}/libpgtypes.so
225%{_libdir}/libpq.so
226%{_libdir}/pkgconfig/*
227%{_datadir}/locale/*/LC_MESSAGES/*.mo
228%{_mandir}/man1/ecpg.*
229#%{_mandir}/man1/pg_config.*
230
231
232%changelog
233* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
234- add pgconfig
235- add pg_config*.h and libpq/libpq-fs.h
236
237* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
238- add postgres_ext.h and pg_config_ext.h
239
240* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
241- new upstream release
242
243* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
244- made to build client libraries only.
245
246* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
247- new upstream release
248
249* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
250- new upstream release
251- add Vendor and Distribution tags
252
253* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
254- build with Tcl/Tk 8.5.7-1
255- fix init script (Source3): fix su(1) paramaters.
256
257* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
258- new upstream release
259- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
260- remove *_and_*.so from -contrib (included in -server)
261
262* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
263- updated postgresql to 9.0.4
264
265* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
266- updated postgresql to 9.0.3
267- separated postgresql-jdbc package
268
269* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
270- updated postgresql to 8.4.7 (contains a variety of fixes)
271
272* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
273- updated postgresql to 8.4.6
274- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
275- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
276- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
277
278* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
279- rebuilt with openssl-1.0.0c
280
281* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
282- updated postgresql to 8.4.5
283
284* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
285- updated postgresql to 8.4.4
286
287* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
288- updated postgresql to 8.4.3
289- s/BuildPrereq/Buildrequires/
290
291* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
292- updated postgresql to 8.4.2
293- rebuilt with new environment
294
295* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
296- updated postgresql to 8.4.1
297
298* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
299- moved dict_snowball.so from conrib to server
300
301* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
302- updated postgresql to 8.4.0
303- updated jdbc3,4 to 701
304- dropt postgresql-8.3.3-nls.patch (fixed)
305- dropt postgresql-7.4-ecpg-patch (no effect)
306
307* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
308- changed libs Group to System Environment/Libraries
309
310* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
311- updated postgresql to 8.3.7
312
313* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
314- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
315
316* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
317- new upstream release (postgresql to 8.3.5, jdbc to 604)
318
319* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
320- applied new versioning policy, and spec in utf-8
321- updated postgresql to 8.3.3
322- updated jdbcver to 603
323- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
324- added a script to replace PGVERSION in postgresql.init
325
326* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
327- rebuild with tcl/tk-8.4.18
328
329* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
330- updated postgresql to 8.2.6
331- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
332
333* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
334- updated PGVERSION to 8.2 in postgresql.init (sorry;)
335
336* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
337- rebuild with tcl/tk-8.4.16
338
339* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
340- updated postgresql to 8.2.5
341- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
342- updated nls-patch to 8-2-0
343- dropt postgresql-8.1.4-Pg.patch.gz
344
345* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
346- for VineSeed
347- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
348- JDBC driver updated to 410
349
350* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
351- rebuilt for VineSeed
352- fixed install script
353
354* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
355- upstream release
356- fix missing %defattr in %files server
357
358* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
359- fix version number in postgresql.init
360
361* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
362- upstream release
363- drop rpm-pgsql-8.0.0.patch
364- add Requires: perl-DBD-Pg for contrib
365- add postgresql-8.1.4-Pg.patch.gz
366- update nls patches
367- new JDBC driver
368
369* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
370- added build options --without perl, --without python
371- rebuilt for x86_64 architecture support
372
373* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
374- drop Provides: on postgresql-libs
375- drop Requires: libpq.so on postgresql-server
376
377* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
378- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
379
380* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
381- upstream release
382- update nls patches
383
384* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
385- upstream release
386- update nls patches
387
388* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
389- rebuilded with python-2.4.1-0vl1
390
391* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
392- Dropped PyGreSQL-3.4.tgz.
393- Dropped PyGreSQL-3.4-setup-2.patch.
394- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
395- Dropped pyver and pynextver macros.
396- Changed macro name "python" to "plpython" like plperl.
397- Added "Obsoletes: postgresql-python"
398
399* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
400- Major version up
401- Obsoletes: postgresql7
402- update nls patch(es)
403- modify %postun not to delete postgres account on upgrade
404
405* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
406- upstream release (release as a new package)
407- Conflicts: postgresql
408- update nls patch(es)
409- (this package revision was rejected by Vine Project)
410
411* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
412- upstream release
413- new JDBC driver
414- add BuildRequires: bison, flex, pam-devel
415- drop postgresql-7.4.5-tempfile.patch (repaired)
416
417* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
418- Added a security fix patch postgresql-7.4.5-tempfile.patch
419  from Gentoo Linux (CAN-2004-0977).
420- Changed Patch4:
421  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
422  It is possible to compile this package without pre-installed postgresql.
423- Removed Patch5 because Patch4 was changed.
424
425* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
426- upstream release
427
428* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
429- upstream release
430- new jdbc driver
431
432* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
433- rebuild with python-2.3.3-0vl1
434
435* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
436- changed mode to 644 at Makefile.global, Makefile.shlib
437
438* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
439- updated python install section
440
441* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
442- added PyGreSQL-3.4.tgz and set python flag
443- added PyGreSQL-3.4-setup.patch
444- added PyGreSQL-3.4-pgmodule.patch
445- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
446
447* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
448- rebuild with new openssl
449
450* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
451- upstream release
452- change all of %{?foo:%define foo 0} -like descriptions to simple
453  %define format for latest rpm to build.
454
455* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
456- rebuild on latest tcl package environment.
457
458* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
459- fixed lacking files at server's %files
460
461* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
462- include JDBC driver for 7.4
463- fix typo in postgresql-7.4-psql-patch
464
465* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
466- upstream release
467- change '--includedir=' option to avoid conflicting with unixODBC
468- add postgresql-7.4-ecpg-patch
469
470* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
471- upstream release
472
473* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
474- drop previous version of libpq's trash
475
476* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
477- upstream release with new nls patch
478- fix postgresql-bashprofile (value of PGDATA)
479- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
480
481* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
482- rebuild with tcltk8.4 and readline-4.3
483
484* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
485- upstream release
486
487* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
488- upstream release
489- remove garbage changelog
490
491* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
492- upstream release based on 7.3-2PGDG
493- add nls patch
494
495* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
496- 7.3-2PGDG
497- Fix typo in initscript.  Argh!!
498
499* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
500- 7.3-0.5PGDG
501- Jerk out all perl client stuff and kludgage
502- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
503- Eliminate locale and multibyte explicit enables -- they are both defaults now
504- Eliminate pgaccess code; it's not a part of the main tarball anymore
505- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
506- Eliminated separate tk client package -- rolled the tk client into the tcl client.
507- Moved pltcl into the pl subpackage.
508- Added plpython to the pl subpackage.
509- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
510
511* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
512- 7.3-0.1PGDG (not released)
513- Integrate 7.3 jar's courtesy Joe Conway
514- Integrate multi-postmaster initscript courtesy Karl DeBisschop
515- Some renames and restructures.
516- Stripped out the last dregs of the postgresql-dump migration script.
517- Conflicts with less than 7.3.
518
519- (See below for old changelogs from VineSeed)
520
521* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
522- updated to 7.2.3.
523
524* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
525- absorbed previous patch8 into original nlspatch
526- fixed configure options (--enable-nls and --enable-locale to be antinomy)
527
528* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
529- add patch8 (ja.po for psql was invalid)
530
531* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
532- updated to 7.2.2.
533- improved nlspatch to enable japanese SQL help in psql.
534
535* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
536- fixed garbage chars in description(ja).
537
538* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
539- imported & replaced changelog (following VineSeed's).
540  add some stuff to '%%files'.
541
542* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
543- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
544  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
545
546* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
547- replace nls patch.
548- add *.mo to '%%files'.
549
550* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
551- fix initscript
552
553* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
554- add /usr/bin/pg_id to the package (fix)
555
556* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
557- updated 7.2
558- added nls.patch
559- fixed spec file
560- added New JDBC
561-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
562
563* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
564- updated 7.1.3
565
566* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
567- 7.1.2-7vl3
568- merge 7.1.2-7vl2 and 7.1.2-7
569
570* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
571- 7.1.2-7vl2
572- fixed spec typo (%%{_includesir} -> %%{_includedir})
573
574* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
575- updated 7.1.2 (used postgresql-7.1.2-7)
576- used psqlj patch for 7.1.2
577- used jumbo-20010801.patch.gz
578
579* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
580- Add patches from 7.1-stable branch. This should fix #50799 and #50797
581- Enable kerberos authentication (#50644)
582- handle stop with stale pid file (#50499)
583- make the test subpackage (not built by default) own /usr/lib/pgsql/test
584
585* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
586- Make the -devel subpackage depend on -libs, not the main package
587
588* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
589- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
590
591* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
592- add changes for s390x
593
594* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
595- Many path fixes for contrib packages
596- Newer intarray
597- Don't use nested ifs for tkpkg/pgaccess
598- Turn off test package for Red Hat Linux - it makes most sense just to use
599  this during development
600- One "pgacess" -> "pgaccess"
601
602* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
603- -4PGDG
604- patchset update for pg_regress.sh
605- can the dot in the release -- confused too many people and some programs.
606- -3.PGDG
607- updated README.rpm-dist
608- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
609  was still being used where /usr/lib/pgsql was intended.
610- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
611
612* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
613- sync
614- Run chkconfig --add on server install
615- Move the prereqs on useradd on chkconfig to the server package
616- don't disable the %%clean section
617
618* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
619- Sync up with Trond Eivind's set.
620
621* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
622- Don't create postgres' .bashrc from the server post script: include it instead
623- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
624- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
625  libs
626- Source the i18n data from the .bashrc instead of in the initscript
627
628* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
629- Handle i18n for database startup - backend needs to have the same locale everytime,
630  but this certainly can't be hardcoded to C either
631- Fix stop, restart in initscript (#42217)
632- Make database init _much_ less verbose
633- other minor fixes to the initscript
634
635* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
636- 7.1.2
637
638* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
639- 7.1.2-0.1.1.PGDG PRERELEASE
640- Changed versioning and release numbering a little for better flexibility,
641-- particularly for distribution packagers.
642- Release numbering comment at top of spec, where it's more useful.
643- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
644  changlog, and the last 6.5.3's specfile for the changelog prior to
645  7.0.
646
647* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
648- 7.1.1-4.PGDG
649- _really_ got Python version agnosticism working.
650
651* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
652- 7.1.1-3.PGDG Release
653- Python version agnosticism.....
654
655* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
656- Use openssl
657- Make it obsolete subpackages if they aren't built
658
659* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
660- 7.1.1-2.PGDG Release.
661- Appended .PGDG to release string to differentiate our RPM set from the others.
662- /bin/sh fix in initscript
663- README.rpm-dist updates.
664
665* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
666- Rebuild with new readline
667
668* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
669- Initial 7.1.1
670
671* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
672- Specify shell when running commands through su in the initscript, to avoid problems
673  when people switch the postgres user to use tcsh
674
675* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
676- JDBC driver for Postgresql 7.1
677
678* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
679- slightly different versioning scheming, will go back to the official
680  later when I'm sure the package is ready to use
681
682* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
683- 7.1 RELEASE
684- 7.1-1 RPM RELEASE
685- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
686- Back to old versioning scheme, kept teg's other fixes.
687- README.rpm-dist updated.
688- PGVERSION updated all-around (hopefully!)
689- Couple of fixes from Peter E.
690- Rearrange dependencies -- only the -libs subpackage is required for most stuff
691- Removed broken and confusing logrotate script.
692
693* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
694- chown considered harmful - removed
695- fix dangling symlimks (pg_crc.c)
696- libpq.so changes for maximum compatiblity
697- different versioning scheme, to avoid trouble later
698- remove temporary perl file from the file list
699- fix spelling error in tcl description
700- mark odbcinst.ini as a config file
701- use %%defattr on packages which didn't have it
702
703* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
704- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
705- Packaging reorg: added contrib and docs subpackages.
706- Removed sgml source docs from main package --> docs subpackage.
707- Removed contrib tree from main package --> contrib subpackage.
708- Contrib tree is now prebuilt -- HOWEVER, very little install work is
709  currently done with this.
710
711* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
712- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
713
714* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
715- RC2
716- eliminate versioning information for ancilliary files in prep for CVS.
717- Fix docs mixup.
718
719* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
720- RC1 quickie.
721
722* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
723- Beta 6 initial build.
724- Use make install-all-headers instead of cpio hack for devel headers.
725- Split out the libs into the libs subpackage.
726- Updated initscript to use pg_ctl to stop
727- Updated initscript to initdb and start postmaster with LC_ALL=C to
728  prevent index corruption.
729
730
731* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
732- Beta4
733- Return to 'pgsql' directories instead of 'postgresql'
734- Better perl patches.
735
736* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
737- Edit patches to get rid of some cruft.
738- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
739- Moved pg_id to server
740- added Makefile.global and pg_config to devel
741- Corrected /usr/include/pgsql to /usr/include/postgresql
742- Fixed some configure options.  Will be trying the configure macro next release
743- Since it is terminally ill in this version pg_upgrade is _gone_.
744- Thanks to Peter E for a good review.
745
746* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
747- Running regression. 1 on the release-o-meter.
748- Minor patches to get regression running right. 
749- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
750
751* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
752- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
753- The 7.1 build is different from the 7.0 build -- see the configure line.
754- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
755- by request, conditional packages are now supported. See the top of the spec.
756- Fixed the server postinstall problems.
757
758* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
759- First 7.1 beta test-build
760
Note: See TracBrowser for help on using the repository browser.