source: projects/specs/trunk/lib/libp/libpng/libpng-vl.spec @ 8586

Revision 8586, 13.3 KB checked in by daisuke, 10 years ago (diff)

libpng:

  • update to 1.6.12
  • add tools subpackage
  • remove unneeded Obsoletes
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating PNG image format files.
4Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
5Name: libpng
6Version: 1.6.12
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source: ftp://ftp.simplesystems.org/pub/libpng/png/src/%{name}-%{version}.tar.xz
11
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: zlib-devel
14Requires: zlib
15URL: http://www.libpng.org/pub/png/
16%define LIBVER 3.%{version}
17Epoch: 2
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23The libpng package contains a library of functions for creating and
24manipulating PNG (Portable Network Graphics) image format files.  PNG
25is a bit-mapped graphics format similar to the GIF format.  PNG was
26created to replace the GIF format, since GIF uses a patented data
27compression algorithm.
28
29Libpng should be installed if you need to manipulate PNG format image
30files.
31
32%description -l ja
33libpng パッケージには PNG (Portable Network Graphics) 形式の
34画像ファイルを作成/操作する為のライブラリが収められています.
35PNG はビットマップの画像形式で,GIF によく似ています.
36GIF が 特許保護された LZW データ圧縮アルゴリズムを利用している為,
37PNG は GIF の代替画像形式として生まれました.
38
39PNG 形式の画像ファイルを扱う場合は libpng をインストールして下さい.
40
41%package devel
42Summary: Development tools for programs to manipulate PNG image format files.
43Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
44Group: Development/Libraries
45Requires: libpng = %{epoch}:%{version}-%{release}
46Requires: zlib-devel
47
48%description devel
49The libpng-devel package contains the header files necessary for
50developing programs using the PNG (Portable Network Graphics) library.
51
52%description devel -l ja
53libpng-devel パッケージには,PNG (Portable Network Graphics) ライブラリを
54使ったプログラムを開発するのに必要なヘッダファイルが収められています.
55
56%package static
57Summary: Static library for %{name}
58Summary(ja): %{name} のスタティックライブラリ
59Group: Development/Libraries
60Requires: libpng-devel = %{epoch}:%{version}-%{release}
61
62%description static
63The libpng-static package contains the static library for libpng.
64
65%package tools
66Summary: Tools for PNG image format file library
67Summary(ja): %{name} 用のツール
68Group: Development/Libraries
69Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
70
71%description tools
72The libpng-tools package contains tools used by the authors of libpng.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: A library of functions for manipulating PNG image format files.
77Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
78Group: System Environment/Libraries
79
80%description -n compat32-%{name}
81The libpng package contains a library of functions for creating and
82manipulating PNG (Portable Network Graphics) image format files.  PNG
83is a bit-mapped graphics format similar to the GIF format.  PNG was
84created to replace the GIF format, since GIF uses a patented data
85compression algorithm.
86
87Libpng should be installed if you need to manipulate PNG format image
88files.
89
90%package -n compat32-%{name}-devel
91Summary: Development tools for programs to manipulate PNG image format files.
92Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
93Group: Development/Libraries
94Requires: libpng = %{epoch}:%{version}-%{release}, libpng-devel = %{epoch}:%{version}-%{release}
95Requires: zlib-devel
96
97%description -n compat32-%{name}-devel
98The libpng-devel package contains the header files and static
99libraries necessary for developing programs using the PNG (Portable
100Network Graphics) library.
101
102If you want to develop programs which will manipulate PNG image format
103files, you should install libpng-devel.  You'll also need to install
104the libpng package.
105
106#'
107%prep
108%setup -q
109
110%build
111#./autogen.sh
112%configure
113%__make %{?_smp_mflags}
114
115%install
116[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
117%makeinstall
118
119# remove unneeded files
120%__rm -f %{buildroot}%{_libdir}/libpng*.la
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126%post -n compat32-%{name} -p /sbin/ldconfig
127
128%postun -n compat32-%{name} -p /sbin/ldconfig
129
130%clean
131[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
132
133%files
134%defattr(-,root,root)
135%doc *.txt example.c README TODO CHANGES
136%{_libdir}/libpng*.so.*
137%{_mandir}/man5/*
138
139%files devel
140%defattr(-,root,root)
141%{_bindir}/libpng-config
142%{_bindir}/libpng16-config
143%{_includedir}/*
144%{_libdir}/libpng*.so
145%{_libdir}/pkgconfig/*
146%{_mandir}/man3/*
147
148%files static
149%defattr(-,root,root)
150%{_libdir}/libpng*.a
151
152%files tools
153%defattr(-,root,root)
154%{_bindir}/pngfix
155%{_bindir}/png-fix-itxt
156
157
158## to build compat32 for x86_64 architecture support
159%if %{build_compat32}
160%files -n compat32-%{name}
161%defattr(-,root,root)
162%{_libdir}/libpng*.so.*
163
164%files -n compat32-%{name}-devel
165%defattr(-,root,root)
166%{_libdir}/libpng*.a
167%{_libdir}/libpng*.so
168%{_libdir}/pkgconfig/*
169%endif
170
171%changelog
172* Sat Jun 21 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2:1.6.12-1
173- update to 1.6.12
174- add tools subpackage
175
176* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.50-1
177- new upstream release
178- drop old patches (are included in new release)
179
180* Sat Apr 28 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-3vl6
181- add patch110 for fix CVE-2011-3045
182- add patch120 for fix CVE-2011-3048 (png_set_text2())
183
184* Sat Feb 18 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-2
185- add patch100 for fix CVE-2011-3026
186
187* Wed Jul 13 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-1
188- new upstream release with security fix (VU#819894)
189- add Vendor/Distri tags
190
191* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2:1.2.44-3
192- build with rpm-4.8.1-1 for pkg-config file
193
194* Sun Jul 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.44-2
195- sync with Vine Linux 5 updates release
196  * Tue Jun 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.44-1
197  - new upstream release with security fix (CVE-2010-1205)
198
199* Thu Apr 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.43-2
200- sync with Vine Linux 5 updates release
201  * Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.43-1
202  - new upstream release with security fix (CVE-2010-0205)
203
204* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.42-1
205- new upstream release with security fix
206
207* Tue Jun  9 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.37-1
208- new upstream release with security fix
209
210* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:1.2.35-2
211- split static library to libpng-static
212  - needed by tuxonice-userui
213
214* Wed Feb 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.35-1
215- new upstream release with security fix (CVE-2009-0040)
216
217* Mon Nov 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.33-1
218- new upstream release
219
220* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-2
221- spec file in UTF-8
222
223* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-1
224- new upstream release with security fix (CVE-2008-3964)
225
226* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.28-1
227- new upstream release with security fix (CVE-2008-1382)
228- added running autogen.sh before configure
229- new versioning policy
230
231* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.25-0vl1
232- new upstream release
233
234* Thu Jan 24 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2:1.2.24-0vl2
235- removed %%if !%%{build_compat32} case condition
236
237* Mon Jan 21 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 2:1.2.24-0vl1
238- new upstream release
239
240* Wed Oct 10 2007 Shu KONNO <owa@bg.wakwak.com> 2:1.2.21-0vl1
241- new upstream release
242
243* Fri May 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2:1.2.18-0vl1
244- new upstream release (CVE-2007-2445)
245
246* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2:1.2.14-0vl1
247- new upstream release
248- drop obsolete patch100
249
250* Fri Nov 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-0vl1.1
251- add Patch100 for fix CVE-2006-5793.patch
252
253* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.12-0vl1
254- [SECURITY] new upstream release
255  - potential buffer overrun in chunk error processing (CVE-2006-3334)
256- use %%configure, %%makeinstall
257- drop unneeded patch10
258
259* Sun Jun 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl7
260- rebuilt with glibc-2.3.3-3vl14
261
262* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl6
263- fixed libdir path in libpng.pc
264
265* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl5
266- fixed %postun (missing to build as scriptlet by invalid comment)
267
268* Thu Feb 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl4
269- added compat32-* packages for x86_64 architecture support
270- added CC='gcc -m32' to make when build_compat32
271- added LIBPATH=%{_libdir} to make
272
273* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.8-0vl3
274- rebuild
275
276* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl2
277- rebuild for VineSeed
278
279* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
280- new upstream release (bug fix)
281
282* Mon Sep 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
283- new upstream release
284
285* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc3
286- update to 1.2.6rc3
287- add Requires: zlib-devel to libpng-devel.
288
289* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc2
290- update to 1.2.6rc2
291
292* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc1
293- update to 1.2.6rc1
294- add patch10 to correct directory name in libpng.pc
295- clean spec file
296
297* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl4
298- added Patch4 from Redhat WS updates
299  * Mon Jun 14 2004 Matthias Clasen <mclasen@redhat.com> 1.2.2-23
300  - Reinstate and improve the transfix patch which got lost sometime ago,
301    but is still needed for CAN-2002-1363 (#125934)
302
303* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl3
304- rebuild with new toolchain
305- use License tag
306- change URL
307
308* Tue Apr 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl2
309- added Obsoletes: libpng12-devel for libpng-devel
310
311* Mon Apr 14 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
312- change package name from libpng12 to libpng
313- revised install and files section
314- remove all patches
315- define LIBVER 3.%{version}
316- add Obsoletes: libpng12
317
318* Sat Mar  1 2003 Kazuhisa TAKEI <takei@vinelinux.org> 1.2.25-0vl5
319- new upstream version
320- change package name to libpng12
321- conflicts libpng-devel(1.0.5) and libpng12-devel
322
323* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl3
324- added Patch200 for linking libz shared lib
325- include libpng*-config
326
327* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl2
328- added missing libraries in the file list
329
330* Tue Nov 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
331- update to 1.0.15
332- now, security patch were merged source.
333
334* Wed Aug 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl3
335- added another security patch to preserve libpng from processing too wide
336  image files (a patch itself extracted from DSA 140-2)
337
338* Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl2
339- added a patch to fix buffer overflow (Patch100)
340
341* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
342- 1.0.12-0vl1
343- updated 1.0.12
344
345* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
346- 1.0.7-0vl3
347- use better macros
348- added Japanese summary and description
349
350* Tue Jul 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
351- 1.0.7-0vl2
352- oops, spec was in Shift-JIS... Fixed it.
353
354* Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
355- update to 1.0.7
356
357* Tue Mar 21 2000 Nalin Dahyabhai <nalin@redhat.com>
358- update to 1.0.6
359
360* Mon Mar 13 2000 Nalin Dahyabhai <nalin@redhat.com>
361- change serial to Epoch to get dependencies working correctly
362
363* Fri Feb 11 2000 Nalin Dahyabhai <nalin@redhat.com>
364- move buildroot and add URL
365
366* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
367- strip library
368- rebuild to compress man pages
369
370* Sun Nov 21 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
371- 1.0.5
372- some tweaks to spec file to make updating easier
373- handle RPM_OPT_FLAGS
374
375* Mon Sep 20 1999 Matt Wilson <msw@redhat.com>
376- changed requires in libpng-devel to include serial
377- corrected typo
378
379* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
380- auto rebuild in the new build environment (release 2)
381
382* Sun Feb 07 1999 Michael Johnson <johnsonm@redhat.com>
383- rev to 1.0.3
384
385* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
386- build for 6.0
387
388* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
389- we are Serial: 1 now because we are reverting the 1.0.2 version from 5.2
390  beta to this prior one
391- install man pages; set defattr defaults
392
393* Thu May 07 1998 Prospector System <bugs@redhat.com>
394- translations modified for de, fr, tr
395
396* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
397- devel subpackage moved to Development/Libraries
398
399* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
400- upgraded to 1.0.1
401- added buildroot
402
403* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
404- updated to new version
405- spec file cleanups
406
407* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
408- built against glibc
409
Note: See TracBrowser for help on using the repository browser.