source: projects/specs/trunk/lib/libp/libpng/libpng-vl.spec @ 6953

Revision 6953, 12.8 KB checked in by iwamoto, 12 years ago (diff)

update: zlib, libpng, xz, proftpd

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating PNG image format files.
4Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
5Name: libpng
6Version: 1.2.50
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source: ftp://ftp.simplesystems.org/pub/libpng/png/src/%{name}-%{version}.tar.xz
11
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: zlib-devel
14Requires: zlib
15URL: http://www.libpng.org/pub/png/
16%define LIBVER 3.%{version}
17Epoch: 2
18Obsoletes: libpng12
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24The libpng package contains a library of functions for creating and
25manipulating PNG (Portable Network Graphics) image format files.  PNG
26is a bit-mapped graphics format similar to the GIF format.  PNG was
27created to replace the GIF format, since GIF uses a patented data
28compression algorithm.
29
30Libpng should be installed if you need to manipulate PNG format image
31files.
32
33%description -l ja
34libpng パッケージには PNG (Portable Network Graphics) 形式の
35画像ファイルを作成/操作する為のライブラリが収められています.
36PNG はビットマップの画像形式で,GIF によく似ています.
37GIF が 特許保護された LZW データ圧縮アルゴリズムを利用している為,
38PNG は GIF の代替画像形式として生まれました.
39
40PNG 形式の画像ファイルを扱う場合は libpng をインストールして下さい.
41
42%package devel
43Summary: Development tools for programs to manipulate PNG image format files.
44Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
45Group: Development/Libraries
46Requires: libpng = %{epoch}:%{version}-%{release}
47Requires: zlib-devel
48Obsoletes: libpng12-devel
49
50%description devel
51The libpng-devel package contains the header files necessary for
52developing programs using the PNG (Portable Network Graphics) library.
53
54%description devel -l ja
55libpng-devel パッケージには,PNG (Portable Network Graphics) ライブラリを
56使ったプログラムを開発するのに必要なヘッダファイルが収められています.
57
58%package static
59Summary: Static library for %{name}
60Summary(ja): %{name} のスタティックライブラリ
61Group: Development/Libraries
62Requires: libpng-devel = %{epoch}:%{version}-%{release}
63
64%description static
65The libpng-static package contains the static library for libpng.
66
67
68## to build compat32 for x86_64 architecture support
69%package -n compat32-%{name}
70Summary: A library of functions for manipulating PNG image format files.
71Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
72Group: System Environment/Libraries
73
74%description -n compat32-%{name}
75The libpng package contains a library of functions for creating and
76manipulating PNG (Portable Network Graphics) image format files.  PNG
77is a bit-mapped graphics format similar to the GIF format.  PNG was
78created to replace the GIF format, since GIF uses a patented data
79compression algorithm.
80
81Libpng should be installed if you need to manipulate PNG format image
82files.
83
84%package -n compat32-%{name}-devel
85Summary: Development tools for programs to manipulate PNG image format files.
86Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
87Group: Development/Libraries
88Requires: libpng = %{epoch}:%{version}-%{release}, libpng-devel = %{epoch}:%{version}-%{release}
89Requires: zlib-devel
90
91%description -n compat32-%{name}-devel
92The libpng-devel package contains the header files and static
93libraries necessary for developing programs using the PNG (Portable
94Network Graphics) library.
95
96If you want to develop programs which will manipulate PNG image format
97files, you should install libpng-devel.  You'll also need to install
98the libpng package.
99
100#'
101%prep
102%setup -q
103
104%build
105#./autogen.sh
106%configure
107%__make %{?_smp_mflags}
108
109%install
110[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
111%makeinstall
112
113# remove unneeded files
114%__rm -f %{buildroot}%{_libdir}/libpng*.la
115
116%post -p /sbin/ldconfig
117
118%postun -p /sbin/ldconfig
119
120%post -n compat32-%{name} -p /sbin/ldconfig
121
122%postun -n compat32-%{name} -p /sbin/ldconfig
123
124%clean
125[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
126
127%files
128%defattr(-,root,root)
129%doc *.txt example.c README TODO CHANGES
130%{_libdir}/libpng*.so.*
131%{_mandir}/man5/*
132
133%files devel
134%defattr(-,root,root)
135%{_bindir}/libpng-config
136%{_bindir}/libpng12-config
137%{_includedir}/*
138%{_libdir}/libpng*.so
139%{_libdir}/pkgconfig/*
140%{_mandir}/man3/*
141
142%files static
143%defattr(-,root,root)
144%{_libdir}/libpng*.a
145
146## to build compat32 for x86_64 architecture support
147%if %{build_compat32}
148%files -n compat32-%{name}
149%defattr(-,root,root)
150%{_libdir}/libpng*.so.*
151
152%files -n compat32-%{name}-devel
153%defattr(-,root,root)
154%{_libdir}/libpng*.a
155%{_libdir}/libpng*.so
156%{_libdir}/pkgconfig/*
157%endif
158
159%changelog
160* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.50-1
161- new upstream release
162- drop old patches (are included in new release)
163
164* Sat Apr 28 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-3vl6
165- add patch110 for fix CVE-2011-3045
166- add patch120 for fix CVE-2011-3048 (png_set_text2())
167
168* Sat Feb 18 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-2
169- add patch100 for fix CVE-2011-3026
170
171* Wed Jul 13 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-1
172- new upstream release with security fix (VU#819894)
173- add Vendor/Distri tags
174
175* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2:1.2.44-3
176- build with rpm-4.8.1-1 for pkg-config file
177
178* Sun Jul 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.44-2
179- sync with Vine Linux 5 updates release
180  * Tue Jun 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.44-1
181  - new upstream release with security fix (CVE-2010-1205)
182
183* Thu Apr 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.43-2
184- sync with Vine Linux 5 updates release
185  * Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.43-1
186  - new upstream release with security fix (CVE-2010-0205)
187
188* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.42-1
189- new upstream release with security fix
190
191* Tue Jun  9 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.37-1
192- new upstream release with security fix
193
194* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:1.2.35-2
195- split static library to libpng-static
196  - needed by tuxonice-userui
197
198* Wed Feb 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.35-1
199- new upstream release with security fix (CVE-2009-0040)
200
201* Mon Nov 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.33-1
202- new upstream release
203
204* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-2
205- spec file in UTF-8
206
207* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-1
208- new upstream release with security fix (CVE-2008-3964)
209
210* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.28-1
211- new upstream release with security fix (CVE-2008-1382)
212- added running autogen.sh before configure
213- new versioning policy
214
215* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.25-0vl1
216- new upstream release
217
218* Thu Jan 24 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2:1.2.24-0vl2
219- removed %%if !%%{build_compat32} case condition
220
221* Mon Jan 21 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 2:1.2.24-0vl1
222- new upstream release
223
224* Wed Oct 10 2007 Shu KONNO <owa@bg.wakwak.com> 2:1.2.21-0vl1
225- new upstream release
226
227* Fri May 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2:1.2.18-0vl1
228- new upstream release (CVE-2007-2445)
229
230* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2:1.2.14-0vl1
231- new upstream release
232- drop obsolete patch100
233
234* Fri Nov 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-0vl1.1
235- add Patch100 for fix CVE-2006-5793.patch
236
237* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.12-0vl1
238- [SECURITY] new upstream release
239  - potential buffer overrun in chunk error processing (CVE-2006-3334)
240- use %%configure, %%makeinstall
241- drop unneeded patch10
242
243* Sun Jun 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl7
244- rebuilt with glibc-2.3.3-3vl14
245
246* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl6
247- fixed libdir path in libpng.pc
248
249* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl5
250- fixed %postun (missing to build as scriptlet by invalid comment)
251
252* Thu Feb 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl4
253- added compat32-* packages for x86_64 architecture support
254- added CC='gcc -m32' to make when build_compat32
255- added LIBPATH=%{_libdir} to make
256
257* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.8-0vl3
258- rebuild
259
260* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl2
261- rebuild for VineSeed
262
263* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
264- new upstream release (bug fix)
265
266* Mon Sep 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
267- new upstream release
268
269* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc3
270- update to 1.2.6rc3
271- add Requires: zlib-devel to libpng-devel.
272
273* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc2
274- update to 1.2.6rc2
275
276* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc1
277- update to 1.2.6rc1
278- add patch10 to correct directory name in libpng.pc
279- clean spec file
280
281* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl4
282- added Patch4 from Redhat WS updates
283  * Mon Jun 14 2004 Matthias Clasen <mclasen@redhat.com> 1.2.2-23
284  - Reinstate and improve the transfix patch which got lost sometime ago,
285    but is still needed for CAN-2002-1363 (#125934)
286
287* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl3
288- rebuild with new toolchain
289- use License tag
290- change URL
291
292* Tue Apr 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl2
293- added Obsoletes: libpng12-devel for libpng-devel
294
295* Mon Apr 14 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
296- change package name from libpng12 to libpng
297- revised install and files section
298- remove all patches
299- define LIBVER 3.%{version}
300- add Obsoletes: libpng12
301
302* Sat Mar  1 2003 Kazuhisa TAKEI <takei@vinelinux.org> 1.2.25-0vl5
303- new upstream version
304- change package name to libpng12
305- conflicts libpng-devel(1.0.5) and libpng12-devel
306
307* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl3
308- added Patch200 for linking libz shared lib
309- include libpng*-config
310
311* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl2
312- added missing libraries in the file list
313
314* Thu Nov 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
315- update to 1.0.15
316- now, security patch were merged source.
317
318* Wed Aug 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl3
319- added another security patch to preserve libpng from processing too wide
320  image files (a patch itself extracted from DSA 140-2)
321
322* Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl2
323- added a patch to fix buffer overflow (Patch100)
324
325* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
326- 1.0.12-0vl1
327- updated 1.0.12
328
329* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
330- 1.0.7-0vl3
331- use better macros
332- added Japanese summary and description
333
334* Tue Jul 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
335- 1.0.7-0vl2
336- oops, spec was in Shift-JIS... Fixed it.
337
338* Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
339- update to 1.0.7
340
341* Tue Mar 21 2000 Nalin Dahyabhai <nalin@redhat.com>
342- update to 1.0.6
343
344* Mon Mar 13 2000 Nalin Dahyabhai <nalin@redhat.com>
345- change serial to Epoch to get dependencies working correctly
346
347* Fri Feb 11 2000 Nalin Dahyabhai <nalin@redhat.com>
348- move buildroot and add URL
349
350* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
351- strip library
352- rebuild to compress man pages
353
354* Sun Nov 21 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
355- 1.0.5
356- some tweaks to spec file to make updating easier
357- handle RPM_OPT_FLAGS
358
359* Mon Sep 20 1999 Matt Wilson <msw@redhat.com>
360- changed requires in libpng-devel to include serial
361- corrected typo
362
363* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
364- auto rebuild in the new build environment (release 2)
365
366* Sun Feb 07 1999 Michael Johnson <johnsonm@redhat.com>
367- rev to 1.0.3
368
369* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
370- build for 6.0
371
372* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
373- we are Serial: 1 now because we are reverting the 1.0.2 version from 5.2
374  beta to this prior one
375- install man pages; set defattr defaults
376
377* Thu May 07 1998 Prospector System <bugs@redhat.com>
378- translations modified for de, fr, tr
379
380* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
381- devel subpackage moved to Development/Libraries
382
383* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
384- upgraded to 1.0.1
385- added buildroot
386
387* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
388- updated to new version
389- spec file cleanups
390
391* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
392- built against glibc
393
Note: See TracBrowser for help on using the repository browser.