source: projects/specs/trunk/lib/libp/libpcap/libpcap-vl.spec @ 521

Revision 521, 14.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pcap_major 1
2%define pcap_minor 0
3%define pcap_subminor 0
4%define libpcap_ver %{pcap_major}.%{pcap_minor}.%{pcap_subminor}
5
6Summary: A system-independent interface for user-level packet capture.
7Summary(ja): ユーザレベルでパケットをキャプチャするインターフェイス
8Name: libpcap
9Version: %{libpcap_ver}
10Release: 2%{?_dist_release}
11Epoch: 1
12# XXX epoch is necessary to obsolete tcpdump-3.4a5
13License: BSD
14Group: System Environment/Libraries
15Source0: http://www.tcpdump.org/release/libpcap-%{libpcap_ver}.tar.gz
16
17Patch50: libpcap-1.0.0-shared.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: kernel-headers >= 2.2.0
21BuildRequires: flex >= 2.4
22BuildRequires: bison
23BuildRequires: openssl-devel
24Requires: kernel >= 2.2.0
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30Libpcap provides a portable framework for low-level network
31monitoring. Libpcap can provide network statistics collection,
32security monitoring and network debugging. Since almost every system
33vendor provides a different interface for packet capture, the libpcap
34authors created this system-independent API to ease in porting and to
35alleviate the need for several system-dependent packet capture modules
36in each application.
37
38Install libpcap if you need to do low-level network traffic monitoring
39on your network.
40
41%description -l ja
42Libpcap は低レベルでネットワークをモニタするためのポータブルなフレーム
43ワークを提供します。Libpcap はネットワークの統計を収集したり、セキュリ
44ティの為のモニタリングやネットワークのデバッグなどの用途に使用できます。
45ほぼ全てのシステムベンダがパケットのキャプチャに異なるインターフェイス
46を提供していたので、libpcap の作者は 移植性を良くして 各々のアプリケー
47ションにおける数々のシステムに依存したパケットキャプチャモジュールを
48可能にするために、このシステムに依存しない API を作成しました。
49
50ネットワークの低レベルのトラフィックを監視する必要がある場合、libpcap
51をインストールして下さい。
52
53%package devel
54Summary:  Development package for %{name}
55Group:    Development/Libraries
56Requires: %{name} = %{epoch}:%{version}-%{release}
57
58%description devel
59The %{name}-devel package contains the files needed for development
60with %{name}.
61
62%prep
63%setup -q
64%patch50 -p1 -b .shared
65
66%build
67%configure --enable-ipv6
68DEFS="-g -D_U_=\"\" -fPIC -DHAVE_CONFIG_H"
69%ifarch alpha sparc sparc64
70DEFS="$DEFS -DHAVE_ETHER_HOSTTON=1 -DLBL_ALIGN=1"
71%endif
72make DEFS="$DEFS" \
73     LIBMAJOR="%{pcap_major}" \
74     LIBMINOR="%{pcap_minor}" \
75     LIBSUBMINOR="%{pcap_subminor}"
76                       
77
78%install
79rm -rf $RPM_BUILD_ROOT
80mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
81mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
82
83make DESTDIR=${RPM_BUILD_ROOT} \
84     includedir=%{_includedir}/pcap \
85     LIBMAJOR="%{pcap_major}" \
86     LIBMINOR="%{pcap_minor}" \
87     LIBSUBMINOR="%{pcap_subminor}" \
88     install
89#chmod +x ${RPM_BUILD_ROOT}%{_libdir}/libpcap.so.*
90
91%clean
92rm -rf ${RPM_BUILD_ROOT}
93
94%post -p /sbin/ldconfig
95 
96%postun -p /sbin/ldconfig
97
98%files
99%defattr(-,root,root)
100%doc README CHANGES
101%{_libdir}/libpcap.so.*
102
103%files devel
104%defattr(-,root,root)
105%{_bindir}/pcap-config
106%{_includedir}/pcap
107%{_libdir}/libpcap.so
108%{_libdir}/libpcap.a
109%{_mandir}/man1/*
110%{_mandir}/man3/*
111%{_mandir}/man5/*
112%{_mandir}/man7/*
113
114%changelog
115* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:1.0.0-2vl5
116- split devel package
117
118* Wed Oct 29 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:1.0.0-1vl5
119- new upstream release
120- update Patch50 to fit 1.0.0
121
122* Mon Apr 14 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:0.9.8-2vl5
123- add BuildRequires: flex >= 2.4, bison
124
125* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.8-1vl5
126- new upstream release
127
128* Sat Sep  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.7-0vl1
129- new upstream release
130
131* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.6-0vl1
132- new upstream release
133
134* Sun Aug 21 2005 Satoshi MACHINO <machino@vinelinux.org> 1:0.9.3-0vl1
135- new upstream release
136
137* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.8.3-0vl1
138- new upstream release
139
140* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.7.2-0vl1
141- updated to 0.7.2
142- dropped patch52
143- s/Copyright/License/
144
145* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.7.1-0vl1
146- libpcap standalone package splitted from tcpdump
147
148* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
149- update to new upstream release tcpdump 3.7.1
150- drop unneeded patches
151- use autoconf213, automake14
152- split arpwatch
153
154* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
155- add patch16 to fix  print_bgp security bug
156  - errata 20030221-3
157
158* Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
159- merged with 3.6.2-13
160- fix buffer overflow for errata
161  * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
162  - added official 3.6.3 fix
163  - fixed 6.2 compat #63113
164  * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
165  - tcpdump-3.6.2-snaplen.patch added to fix #55145
166  * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
167  - took old purge patch for filters
168  - fixed #54225,#58346
169  - drop root by default #49635
170  - fixed #54593
171  - fixed #57711
172
173* Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
174- 3.6.2-9vl1
175- used PRM macros
176- changed File Name to Package Name in Prereq tag
177- marged 3.6.2-9 (RedHat7.2)
178
179  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
180  - 3.4-19vl2
181  - use better macros
182 
183  * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
184  - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
185  - add Japanese summarys and descriptions
186  - modify spec file to build as a normal user
187 
188  * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
189  - Compile shared libpcap with -fPIC (Bug #6342)
190 
191  * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
192  - fix descriptions
193  - man pages are compressed
194 
195  * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
196  - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
197  - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
198  - add getprotobyname lookup (#6725).
199  - getservbyname port lookup appears functional (#7569).
200  - remove uid 2090 backdoor (sorry Dave) (#7116).
201 
202  * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
203  - fox the pcap.h header
204 
205  * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
206  - prevent segfault on obscure spoofed ip header (#4634).
207 
208  * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
209  - add defattr to arpwatch (#4591).
210 
211  * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
212  - initscript munging
213
214  * Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
215  - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
216 
217  * Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
218  - include A. Kuznetsov's patches to libpcap/tcpdump.
219  - added arpsnmp to package (#3258).
220  - arp2ethers written for different of awk (#4326).
221
222  * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
223  - auto rebuild in the new build environment (release 10)
224
225  * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
226  - strip binaries.
227 
228  * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
229  - autoconf fixes for arm
230
231  * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
232  - libpcap description typo.
233
234  * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
235  - fix arpwatch summary line.
236 
237  * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
238  - enable arpwatch
239 
240  * Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
241  - separate package for libpcap.
242  - update tcpdump to 3.4, libpcap to 0.4.
243  - added arpwatch (but disabled for now)
244 
245  * Thu May 07 1998 Prospector System <bugs@redhat.com>
246  - translations modified for de, fr, tr
247 
248  * Sat May  2 1998 Alan Cox <alan@rehat.com>
249  - Added the SACK printing fix so you can dump Linux 2.1+.
250 
251  * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
252  - updated to release 3.4a5
253  - uses a buildroot and %attr
254 
255  * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
256  - built against glibc
257
258* Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
259- took better fix for #52654 from tcpdump cvs
260
261* Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
262- fixed #52654
263
264* Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
265- added shared library to libpcap (#47174)
266- afs printing security patch (#49294)
267
268* Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
269- use initgroups, instead of setgroups
270
271* Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
272- added dropgroup patches (#44563)
273
274* Mon May 07 2001 Harald Hoyer <harald@redhat.de>
275- switched to Pekka's tcpdump-3.6.2 package
276- incremented epoch
277
278* Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
279- fix building of tcpslice on glibc 2.2.2 (time.h)
280- disable /etc/init.d requirement and fix %post scripts in arpwatch
281
282* Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
283- glibc sys/time -> time include patch
284
285* Wed Feb  7 2001 Trond Eivind Glomsr <teg@redhat.com>
286- Add space to this check
287
288* Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
289- added check for presence of /etc/sysconfig/arpwatch (#23172)
290
291* Wed Feb  7 2001 Pekka Savola <pekkas@netcore.fi>
292- update to 3.6.2, 0.6.2 and new CVS of tcpslice.
293- i18n'ize arpwatch init script
294
295* Fri Feb  2 2001 Trond Eivind Glomsr <teg@redhat.com>
296- i18nize initscript
297
298* Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
299- fixed EINTR stopping for e.g. SIGSTOP. (#22008)
300- added -u option for tcpdump (#20231)
301- new arpwatch version (#23172)
302- added "all" and "one" interface for -i (#20907)
303- added arpwatch sysconfig (#23172)
304
305* Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
306- more (potential) overflows in libpcap. #21373
307- documentation fix for #20906
308
309* Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
310- use --enable-ipv6
311- Add two patches from CVS to enhance 802.2 printing, and more importantly,
312  to be able to specify 'no stp'
313
314* Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
315- Make SMB printing output a lot more quiet unless in verbose mode.
316- Make -n resolve port/protocol numbers but not hostnames, -nn for no
317  resolving at all
318- Separate droproot patch from a more generic man/usage fix one
319- Add non-promiscuous mode -by default patch, but don't apply it by default
320
321* Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
322- Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
323
324* Mon Jan  8 2001 Pekka Savola <pekkas@netcore.fi>
325- Update to 20010108 CVS, disable some upstreamed patches.
326- Change some additional .1 pages to .8.
327- Add droproot patch, some --usage and man page fixes.
328
329* Mon Jan  1 2001 Pekka Savola <pekkas@netcore.fi>
330- Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
331- add earlier print-domain.c, the latest is segfaulting
332- don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
333- don't use savestr, require openssl, tweak tweak tweak
334- add tcpslice, patch it a bit for egcs detection
335
336* Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
337- tcpdump: spice up the manpage about interfaces
338- tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
339- upgrade arpwatch to 2.1a10
340
341* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
342- more (potential) overflows in libpcap.
343
344* Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
345- eliminate still more buffer overflows (from FreeBSD) (#20069).
346
347* Thu Nov  2 2000 Jeff Johnson <jbj@redhat.com>
348- eliminate more buffer overflows (from FreeBSD) (#20069).
349- 802.1q ether type incorrect (#19850).
350- add -u flag to drop arpwatch privs (#19696).
351
352* Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
353- updated ethercodes.dat
354
355* Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
356- fix arpwatch tmp race (#18943).
357
358* Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
359- fix condrestart
360
361* Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
362- correct arpsnmp man pages (#15442).
363- don't print harmless ENOPROTOOPT message (#13518).
364
365* Fri Aug  4 2000 Jeff Johnson <jbj@redhat.com>
366- rebuild with final kernel headers (#13518).
367
368* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
369- add STP patch (#14112).
370
371* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
372- source /etc/init.d/functions
373- back out /etc/init.d/arpwatch, place file in /etc/rc.d
374- move initscript to /etc/init.d
375- changed initscript to use start() and stop() functions
376- added condrestart to init script
377- added %%post %%preun %%postun scripts to register arpwatch script
378- added Prereq: for all things needed in post/preun/postun
379
380* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
381- automatic rebuild
382
383* Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
384- updated man page and help (pekkas@netcore.fi) (#10739 et al).
385
386* Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
387- FHS packaging.
388
389* Tue May  9 2000 Bill Nottingham <notting@redhat.com>
390- minor tweaks for ia64 (prototypes)
391
392* Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
393- Compile shared libpcap with -fPIC (Bug #6342)
394
395* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
396- fix descriptions
397- man pages are compressed
398
399* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
400- remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
401- upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
402- add getprotobyname lookup (#6725).
403- getservbyname port lookup appears functional (#7569).
404- remove uid 2090 backdoor (sorry Dave) (#7116).
405
406* Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
407- fox the pcap.h header
408
409* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
410- prevent segfault on obscure spoofed ip header (#4634).
411
412* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
413- add defattr to arpwatch (#4591).
414
415* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
416- initscript munging
417
418* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
419- add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
420
421* Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
422- include A. Kuznetsov's patches to libpcap/tcpdump.
423- added arpsnmp to package (#3258).
424- arp2ethers written for different of awk (#4326).
425
426* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
427- auto rebuild in the new build environment (release 10)
428
429* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
430- strip binaries.
431
432* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
433- autoconf fixes for arm
434
435* Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
436- libpcap description typo.
437
438* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
439- fix arpwatch summary line.
440
441* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
442- enable arpwatch
443
444* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
445- separate package for libpcap.
446- update tcpdump to 3.4, libpcap to 0.4.
447- added arpwatch (but disabled for now)
448
449* Thu May 07 1998 Prospector System <bugs@redhat.com>
450- translations modified for de, fr, tr
451
452* Sat May  2 1998 Alan Cox <alan@rehat.com>
453- Added the SACK printing fix so you can dump Linux 2.1+.
454
455* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
456- updated to release 3.4a5
457- uses a buildroot and %attr
458
459* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
460- built against glibc
Note: See TracBrowser for help on using the repository browser.