source: projects/specs/trunk/lib/libp/libpcap/libpcap-vl.spec @ 1070

Revision 1070, 14.8 KB checked in by inagaki, 14 years ago (diff)

updated: libpcap, tcpdump

Line 
1%define pcap_major 1
2%define pcap_minor 1
3%define pcap_subminor 1
4%define libpcap_ver %{pcap_major}.%{pcap_minor}.%{pcap_subminor}
5
6Summary: A system-independent interface for user-level packet capture.
7Summary(ja): ユーザレベルでパケットをキャプチャするインターフェイス
8Name: libpcap
9Version: %{libpcap_ver}
10Release: 1%{?_dist_release}
11Epoch: 1
12# XXX epoch is necessary to obsolete tcpdump-3.4a5
13License: BSD
14Group: System Environment/Libraries
15Source0: http://www.tcpdump.org/release/libpcap-%{libpcap_ver}.tar.gz
16
17Patch50: libpcap-1.0.0-shared.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: kernel-headers >= 2.2.0
21BuildRequires: flex >= 2.4
22BuildRequires: bison
23BuildRequires: openssl-devel
24BuildRequires: libnl-devel
25Requires: kernel >= 2.2.0
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31Libpcap provides a portable framework for low-level network
32monitoring. Libpcap can provide network statistics collection,
33security monitoring and network debugging. Since almost every system
34vendor provides a different interface for packet capture, the libpcap
35authors created this system-independent API to ease in porting and to
36alleviate the need for several system-dependent packet capture modules
37in each application.
38
39Install libpcap if you need to do low-level network traffic monitoring
40on your network.
41
42%description -l ja
43Libpcap は低レベルでネットワークをモニタするためのポータブルなフレーム
44ワークを提供します。Libpcap はネットワークの統計を収集したり、セキュリ
45ティの為のモニタリングやネットワークのデバッグなどの用途に使用できます。
46ほぼ全てのシステムベンダがパケットのキャプチャに異なるインターフェイス
47を提供していたので、libpcap の作者は 移植性を良くして 各々のアプリケー
48ションにおける数々のシステムに依存したパケットキャプチャモジュールを
49可能にするために、このシステムに依存しない API を作成しました。
50
51ネットワークの低レベルのトラフィックを監視する必要がある場合、libpcap
52をインストールして下さい。
53
54%package devel
55Summary:  Development package for %{name}
56Group:    Development/Libraries
57Requires: %{name} = %{epoch}:%{version}-%{release}
58
59%description devel
60The %{name}-devel package contains the files needed for development
61with %{name}.
62
63%prep
64%setup -q
65#patch50 -p1 -b .shared
66
67%build
68%configure --enable-ipv6
69DEFS="-g -D_U_=\"\" -fPIC -DHAVE_CONFIG_H"
70%ifarch alpha sparc sparc64
71DEFS="$DEFS -DHAVE_ETHER_HOSTTON=1 -DLBL_ALIGN=1"
72%endif
73make DEFS="$DEFS"
74
75%install
76rm -rf $RPM_BUILD_ROOT
77mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
78mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
79
80make DESTDIR=${RPM_BUILD_ROOT} \
81     includedir=%{_includedir}/pcap \
82     install
83
84%clean
85rm -rf ${RPM_BUILD_ROOT}
86
87%post -p /sbin/ldconfig
88 
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(-,root,root)
93%doc README CHANGES
94%{_libdir}/libpcap.so.*
95
96%files devel
97%defattr(-,root,root)
98%{_bindir}/pcap-config
99%{_includedir}/pcap
100%{_libdir}/libpcap.so
101%{_libdir}/libpcap.a
102%{_mandir}/man1/*
103%{_mandir}/man3/*
104%{_mandir}/man5/*
105%{_mandir}/man7/*
106
107%changelog
108* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:1.1.1-1
109- new upstream release
110- dropt Patch50
111- built with new toolchain
112- added BR: libnl-devel
113
114* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:1.0.0-2vl5
115- split devel package
116
117* Wed Oct 29 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:1.0.0-1vl5
118- new upstream release
119- update Patch50 to fit 1.0.0
120
121* Mon Apr 14 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:0.9.8-2vl5
122- add BuildRequires: flex >= 2.4, bison
123
124* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.8-1vl5
125- new upstream release
126
127* Sat Sep  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.7-0vl1
128- new upstream release
129
130* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.6-0vl1
131- new upstream release
132
133* Sun Aug 21 2005 Satoshi MACHINO <machino@vinelinux.org> 1:0.9.3-0vl1
134- new upstream release
135
136* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.8.3-0vl1
137- new upstream release
138
139* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.7.2-0vl1
140- updated to 0.7.2
141- dropped patch52
142- s/Copyright/License/
143
144* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.7.1-0vl1
145- libpcap standalone package splitted from tcpdump
146
147* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
148- update to new upstream release tcpdump 3.7.1
149- drop unneeded patches
150- use autoconf213, automake14
151- split arpwatch
152
153* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
154- add patch16 to fix  print_bgp security bug
155  - errata 20030221-3
156
157* Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
158- merged with 3.6.2-13
159- fix buffer overflow for errata
160  * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
161  - added official 3.6.3 fix
162  - fixed 6.2 compat #63113
163  * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
164  - tcpdump-3.6.2-snaplen.patch added to fix #55145
165  * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
166  - took old purge patch for filters
167  - fixed #54225,#58346
168  - drop root by default #49635
169  - fixed #54593
170  - fixed #57711
171
172* Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
173- 3.6.2-9vl1
174- used PRM macros
175- changed File Name to Package Name in Prereq tag
176- marged 3.6.2-9 (RedHat7.2)
177
178  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
179  - 3.4-19vl2
180  - use better macros
181 
182  * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
183  - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
184  - add Japanese summarys and descriptions
185  - modify spec file to build as a normal user
186 
187  * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
188  - Compile shared libpcap with -fPIC (Bug #6342)
189 
190  * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
191  - fix descriptions
192  - man pages are compressed
193 
194  * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
195  - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
196  - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
197  - add getprotobyname lookup (#6725).
198  - getservbyname port lookup appears functional (#7569).
199  - remove uid 2090 backdoor (sorry Dave) (#7116).
200 
201  * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
202  - fox the pcap.h header
203 
204  * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
205  - prevent segfault on obscure spoofed ip header (#4634).
206 
207  * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
208  - add defattr to arpwatch (#4591).
209 
210  * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
211  - initscript munging
212
213  * Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
214  - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
215 
216  * Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
217  - include A. Kuznetsov's patches to libpcap/tcpdump.
218  - added arpsnmp to package (#3258).
219  - arp2ethers written for different of awk (#4326).
220
221  * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
222  - auto rebuild in the new build environment (release 10)
223
224  * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
225  - strip binaries.
226 
227  * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
228  - autoconf fixes for arm
229
230  * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
231  - libpcap description typo.
232
233  * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
234  - fix arpwatch summary line.
235 
236  * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
237  - enable arpwatch
238 
239  * Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
240  - separate package for libpcap.
241  - update tcpdump to 3.4, libpcap to 0.4.
242  - added arpwatch (but disabled for now)
243 
244  * Thu May 07 1998 Prospector System <bugs@redhat.com>
245  - translations modified for de, fr, tr
246 
247  * Sat May  2 1998 Alan Cox <alan@rehat.com>
248  - Added the SACK printing fix so you can dump Linux 2.1+.
249 
250  * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
251  - updated to release 3.4a5
252  - uses a buildroot and %attr
253 
254  * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
255  - built against glibc
256
257* Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
258- took better fix for #52654 from tcpdump cvs
259
260* Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
261- fixed #52654
262
263* Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
264- added shared library to libpcap (#47174)
265- afs printing security patch (#49294)
266
267* Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
268- use initgroups, instead of setgroups
269
270* Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
271- added dropgroup patches (#44563)
272
273* Mon May 07 2001 Harald Hoyer <harald@redhat.de>
274- switched to Pekka's tcpdump-3.6.2 package
275- incremented epoch
276
277* Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
278- fix building of tcpslice on glibc 2.2.2 (time.h)
279- disable /etc/init.d requirement and fix %post scripts in arpwatch
280
281* Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
282- glibc sys/time -> time include patch
283
284* Wed Feb  7 2001 Trond Eivind Glomsr <teg@redhat.com>
285- Add space to this check
286
287* Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
288- added check for presence of /etc/sysconfig/arpwatch (#23172)
289
290* Wed Feb  7 2001 Pekka Savola <pekkas@netcore.fi>
291- update to 3.6.2, 0.6.2 and new CVS of tcpslice.
292- i18n'ize arpwatch init script
293
294* Fri Feb  2 2001 Trond Eivind Glomsr <teg@redhat.com>
295- i18nize initscript
296
297* Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
298- fixed EINTR stopping for e.g. SIGSTOP. (#22008)
299- added -u option for tcpdump (#20231)
300- new arpwatch version (#23172)
301- added "all" and "one" interface for -i (#20907)
302- added arpwatch sysconfig (#23172)
303
304* Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
305- more (potential) overflows in libpcap. #21373
306- documentation fix for #20906
307
308* Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
309- use --enable-ipv6
310- Add two patches from CVS to enhance 802.2 printing, and more importantly,
311  to be able to specify 'no stp'
312
313* Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
314- Make SMB printing output a lot more quiet unless in verbose mode.
315- Make -n resolve port/protocol numbers but not hostnames, -nn for no
316  resolving at all
317- Separate droproot patch from a more generic man/usage fix one
318- Add non-promiscuous mode -by default patch, but don't apply it by default
319
320* Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
321- Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
322
323* Mon Jan  8 2001 Pekka Savola <pekkas@netcore.fi>
324- Update to 20010108 CVS, disable some upstreamed patches.
325- Change some additional .1 pages to .8.
326- Add droproot patch, some --usage and man page fixes.
327
328* Mon Jan  1 2001 Pekka Savola <pekkas@netcore.fi>
329- Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
330- add earlier print-domain.c, the latest is segfaulting
331- don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
332- don't use savestr, require openssl, tweak tweak tweak
333- add tcpslice, patch it a bit for egcs detection
334
335* Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
336- tcpdump: spice up the manpage about interfaces
337- tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
338- upgrade arpwatch to 2.1a10
339
340* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
341- more (potential) overflows in libpcap.
342
343* Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
344- eliminate still more buffer overflows (from FreeBSD) (#20069).
345
346* Thu Nov  2 2000 Jeff Johnson <jbj@redhat.com>
347- eliminate more buffer overflows (from FreeBSD) (#20069).
348- 802.1q ether type incorrect (#19850).
349- add -u flag to drop arpwatch privs (#19696).
350
351* Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
352- updated ethercodes.dat
353
354* Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
355- fix arpwatch tmp race (#18943).
356
357* Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
358- fix condrestart
359
360* Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
361- correct arpsnmp man pages (#15442).
362- don't print harmless ENOPROTOOPT message (#13518).
363
364* Fri Aug  4 2000 Jeff Johnson <jbj@redhat.com>
365- rebuild with final kernel headers (#13518).
366
367* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
368- add STP patch (#14112).
369
370* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
371- source /etc/init.d/functions
372- back out /etc/init.d/arpwatch, place file in /etc/rc.d
373- move initscript to /etc/init.d
374- changed initscript to use start() and stop() functions
375- added condrestart to init script
376- added %%post %%preun %%postun scripts to register arpwatch script
377- added Prereq: for all things needed in post/preun/postun
378
379* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
380- automatic rebuild
381
382* Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
383- updated man page and help (pekkas@netcore.fi) (#10739 et al).
384
385* Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
386- FHS packaging.
387
388* Tue May  9 2000 Bill Nottingham <notting@redhat.com>
389- minor tweaks for ia64 (prototypes)
390
391* Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
392- Compile shared libpcap with -fPIC (Bug #6342)
393
394* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
395- fix descriptions
396- man pages are compressed
397
398* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
399- remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
400- upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
401- add getprotobyname lookup (#6725).
402- getservbyname port lookup appears functional (#7569).
403- remove uid 2090 backdoor (sorry Dave) (#7116).
404
405* Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
406- fox the pcap.h header
407
408* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
409- prevent segfault on obscure spoofed ip header (#4634).
410
411* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
412- add defattr to arpwatch (#4591).
413
414* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
415- initscript munging
416
417* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
418- add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
419
420* Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
421- include A. Kuznetsov's patches to libpcap/tcpdump.
422- added arpsnmp to package (#3258).
423- arp2ethers written for different of awk (#4326).
424
425* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
426- auto rebuild in the new build environment (release 10)
427
428* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
429- strip binaries.
430
431* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
432- autoconf fixes for arm
433
434* Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
435- libpcap description typo.
436
437* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
438- fix arpwatch summary line.
439
440* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
441- enable arpwatch
442
443* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
444- separate package for libpcap.
445- update tcpdump to 3.4, libpcap to 0.4.
446- added arpwatch (but disabled for now)
447
448* Thu May 07 1998 Prospector System <bugs@redhat.com>
449- translations modified for de, fr, tr
450
451* Sat May  2 1998 Alan Cox <alan@rehat.com>
452- Added the SACK printing fix so you can dump Linux 2.1+.
453
454* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
455- updated to release 3.4a5
456- uses a buildroot and %attr
457
458* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
459- built against glibc
Note: See TracBrowser for help on using the repository browser.