source: projects/specs/trunk/lib/libm/libmysqlclient/libmysqlclient-vl.spec @ 10087

Revision 10087, 5.9 KB checked in by tomop, 8 years ago (diff)

libmysqlclient-10.1.12-1

RevLine 
[521]1
[6103]2Vendor: Project Vine
3Distribution: Vine Linux
[8348]4Packager: tomop
[6103]5
[8348]6%define soversion 18
7
8Name:           libmysqlclient
9Summary:        libraries and headers of MariaDB.
[10087]10Version:        10.1.12
[8526]11Release:        1%{_dist_release}
[2087]12
[521]13Group:          Applications/Databases
[8348]14License:        GPLv2
15URL:            http://www.mariadb.org/
[2087]16
[8348]17Source:         mariadb-%{version}.tar.gz
[2087]18
[8348]19#Patch0:                mysql-5.5.15-jp-all.patch
[2151]20# lib64 patch for vine
[8348]21#Patch200:      pysql-5.1.44-lib64.patch
[2151]22
[8348]23BuildRoot:              %{_tmppath}/%{name}-%{version}-root
24BuildRequires:  perl, readline-devel, libaio-devel, libevent-devel
25BuildRequires:  gcc-c++, ncurses-devel, zlib-devel, openssl-devel
26BuildRequires:  groff, cmake, bison
27Requires:               fileutils sh-utils
[521]28
29%description
[8348]30 build client libraries and headers of MariaDB.
[521]31
32
[8348]33%package -n mariadb-common
34Summary: The configuration file of MariaDB server and clients
35Group: Applications/System
[521]36
[8348]37%description -n mariadb-common
38 This package contains the configuration file for MariaDB server and
39clients.
[521]40
41
[8348]42%package -n libmysqlclient%{soversion}
43Summary: The shared libraries required for MariaDB/MySQL clients
44Group: System Environment/Libraries
45Requires: mariadb-common
46Obsoletes: MySQL-shared < 5.5.0
[521]47
[8348]48%description -n libmysqlclient%{soversion}
49 This package contains the shared libraries which certain languages
50and applications need to dynamically load and use MariaDB/MySQL.
[521]51
52
53%package devel
[8348]54Summary: libraries and headers for MariaDB/MySQL clients
[2087]55Group: Development/Libraries
[8348]56Requires: libmysqlclient%{soversion} = %{version}-%{release}
[3541]57Requires: openssl-devel, zlib-devel
[8460]58Provides: MySQL-devel mysql-devel MySQL5-devel
59Obsoletes: MySQL-devel mysql-devel MySQL5-devel
60Conflicts: mariadb-devel
[521]61
62%description devel
[8348]63 This package contains the development header files and libraries
64necessary to develop MariaDB/MySQL client applications.
[521]65
66
67%prep
[8348]68%setup -q -n mariadb-%{version}
[521]69
[8348]70#%patch0 -p1 -b .jp
[521]71
72
73%build
74
[4643]75# Be strict about variables, bail at earliest opportunity, etc.
76set -eu
[521]77
[4643]78# Optional package files
79touch optional-files-devel
[521]80
[4643]81export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
82export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
83export LDFLAGS=${MYSQL_BUILD_LDFLAGS:-${LDFLAGS:-}}
84export CMAKE=${MYSQL_BUILD_CMAKE:-${CMAKE:-cmake}}
85export MAKE_JFLAG=${MYSQL_BUILD_MAKE_JFLAG:-}
[521]86
[4643]87# Build full release
88mkdir release
[521]89(
[4643]90  cd release
91  # XXX: MYSQL_UNIX_ADDR should be in cmake/* but mysql_version is included before
92  # XXX: install_layout so we can't just set it based on INSTALL_LAYOUT=RPM
[8348]93  ${CMAKE} ../ \
94      -DINSTALL_LAYOUT=RPM \
95      -DCMAKE_BUILD_TYPE=Release \
96      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
97      -DMANUFACTURER="Vine Linux MariaDB RPM" \
98      -DWITH_PIC="ON" \
99      -DWITHOUT_SERVER="yes" \
100      -DWITH_ZLIB="system" \
101      -DWITH_LIBEVENT="system" \
102      -DWITH_LOCALES="yes" \
103      -DWITH_UNIT_TESTS="no"
104
105#      -DWITH_PCRE="system"
106
[4643]107  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
[8348]108  make %{?_smp_mflags}
109#  make %{?_smp_mflags} -C libmysql
110#  make %{?_smp_mflags} -C include
[521]111)
112
113
[4643]114##############################################################################
[521]115%install
[8348]116rm -rf %{buildroot}
[521]117
118# Install all binaries
[4643]119# Install all binaries
120(
[8348]121  cd release
122  make DESTDIR=%{buildroot} install
[4643]123)
[521]124
[8348]125mv -f  %{buildroot}%{_datadir}/doc ./
[521]126
[8348]127rm -rf %{buildroot}%{_sysconfdir}/{init.d,logrotate.d}
[9840]128rm -rf %{buildroot}%{_sysconfdir}/my.cnf.d/{mysql-clients.cnf,server.cnf,enable_encryption.preset}
[8348]129rm -rf %{buildroot}%{_datadir}/{man/man8,mysql}
130rm -f %{buildroot}%{_libdir}/*.a
131find %{buildroot}%{_bindir} -type f | grep -v -e mysql_config | xargs rm -f
132find %{buildroot}%{_mandir} -type f | grep -v -e mysql_config | xargs rm -f
[521]133
[4643]134##############################################################################
135
136
[8348]137%post -n libmysqlclient%{soversion}
[532]138/sbin/ldconfig
139
[8348]140%postun -n libmysqlclient%{soversion}
[532]141/sbin/ldconfig
142
[521]143%clean
[8348]144rm -rf %{buildroot}
[521]145
[8348]146%files -n mariadb-common
147%defattr(-, root, root)
148%config(noreplace) %{_sysconfdir}/my.cnf
149%dir %{_sysconfdir}/my.cnf.d
150%config(noreplace) %{_sysconfdir}/my.cnf.d/client.cnf
[521]151
[8348]152%files -n libmysqlclient%{soversion}
153%defattr(-, root, root)
154%doc doc/*
155%{_libdir}/libmysql*.so.*
[521]156
[8348]157%files devel
158%defattr(-, root, root)
159%doc %{_mandir}/man1/mysql_config.1*
160%{_bindir}/mysql_config
[9840]161%{_datadir}/pkgconfig/mariadb.pc
[8348]162%{_includedir}/mysql
[521]163%{_datadir}/aclocal/mysql.m4
[4643]164%{_libdir}/*.so
[521]165
166
167%changelog
[10087]168* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.12-1
169- new upstream release.
170
171* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.10-1
172- new upstream release.
173
[9840]174* Mon Nov 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-1
175- new upstream release.
176
[9707]177* Fri Aug  7 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-1
178- new upstream release.
179
[9612]180* Fri Jun 19 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-1
181- new upstream release.
182
[9557]183* Sun May 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.19-1
184- new upstream release.
185
[9556]186* Fri May  8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.18-1
[9406]187- new upstream release.
188
[9556]189* Tue Mar  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
190- new upstream release.
191
[9361]192* Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
193- new upstream release.
194
[9132]195* Thu Nov 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
196- new upstream release.
197
[8526]198* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
199- new upstream release.
200
[8460]201* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
202- fixed Conflicts: and Obsoletes:.
203
[8348]204* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
[7513]205- new upstream release.
206
[8348]207* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
[7159]208- new upstream release.
209
[8348]210* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
[6810]211- new upstream release.
212
[8348]213* Tue Dec 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
214- initial build.
Note: See TracBrowser for help on using the repository browser.