source: projects/specs/trunk/lib/libm/libmysqlclient/libmysqlclient-vl.spec @ 10087

Revision 10087, 5.9 KB checked in by tomop, 8 years ago (diff)

libmysqlclient-10.1.12-1

Line 
1
2Vendor: Project Vine
3Distribution: Vine Linux
4Packager: tomop
5
6%define soversion 18
7
8Name:           libmysqlclient
9Summary:        libraries and headers of MariaDB.
10Version:        10.1.12
11Release:        1%{_dist_release}
12
13Group:          Applications/Databases
14License:        GPLv2
15URL:            http://www.mariadb.org/
16
17Source:         mariadb-%{version}.tar.gz
18
19#Patch0:                mysql-5.5.15-jp-all.patch
20# lib64 patch for vine
21#Patch200:      pysql-5.1.44-lib64.patch
22
23BuildRoot:              %{_tmppath}/%{name}-%{version}-root
24BuildRequires:  perl, readline-devel, libaio-devel, libevent-devel
25BuildRequires:  gcc-c++, ncurses-devel, zlib-devel, openssl-devel
26BuildRequires:  groff, cmake, bison
27Requires:               fileutils sh-utils
28
29%description
30 build client libraries and headers of MariaDB.
31
32
33%package -n mariadb-common
34Summary: The configuration file of MariaDB server and clients
35Group: Applications/System
36
37%description -n mariadb-common
38 This package contains the configuration file for MariaDB server and
39clients.
40
41
42%package -n libmysqlclient%{soversion}
43Summary: The shared libraries required for MariaDB/MySQL clients
44Group: System Environment/Libraries
45Requires: mariadb-common
46Obsoletes: MySQL-shared < 5.5.0
47
48%description -n libmysqlclient%{soversion}
49 This package contains the shared libraries which certain languages
50and applications need to dynamically load and use MariaDB/MySQL.
51
52
53%package devel
54Summary: libraries and headers for MariaDB/MySQL clients
55Group: Development/Libraries
56Requires: libmysqlclient%{soversion} = %{version}-%{release}
57Requires: openssl-devel, zlib-devel
58Provides: MySQL-devel mysql-devel MySQL5-devel
59Obsoletes: MySQL-devel mysql-devel MySQL5-devel
60Conflicts: mariadb-devel
61
62%description devel
63 This package contains the development header files and libraries
64necessary to develop MariaDB/MySQL client applications.
65
66
67%prep
68%setup -q -n mariadb-%{version}
69
70#%patch0 -p1 -b .jp
71
72
73%build
74
75# Be strict about variables, bail at earliest opportunity, etc.
76set -eu
77
78# Optional package files
79touch optional-files-devel
80
81export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
82export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
83export LDFLAGS=${MYSQL_BUILD_LDFLAGS:-${LDFLAGS:-}}
84export CMAKE=${MYSQL_BUILD_CMAKE:-${CMAKE:-cmake}}
85export MAKE_JFLAG=${MYSQL_BUILD_MAKE_JFLAG:-}
86
87# Build full release
88mkdir release
89(
90  cd release
91  # XXX: MYSQL_UNIX_ADDR should be in cmake/* but mysql_version is included before
92  # XXX: install_layout so we can't just set it based on INSTALL_LAYOUT=RPM
93  ${CMAKE} ../ \
94      -DINSTALL_LAYOUT=RPM \
95      -DCMAKE_BUILD_TYPE=Release \
96      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
97      -DMANUFACTURER="Vine Linux MariaDB RPM" \
98      -DWITH_PIC="ON" \
99      -DWITHOUT_SERVER="yes" \
100      -DWITH_ZLIB="system" \
101      -DWITH_LIBEVENT="system" \
102      -DWITH_LOCALES="yes" \
103      -DWITH_UNIT_TESTS="no"
104
105#      -DWITH_PCRE="system"
106
107  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
108  make %{?_smp_mflags}
109#  make %{?_smp_mflags} -C libmysql
110#  make %{?_smp_mflags} -C include
111)
112
113
114##############################################################################
115%install
116rm -rf %{buildroot}
117
118# Install all binaries
119# Install all binaries
120(
121  cd release
122  make DESTDIR=%{buildroot} install
123)
124
125mv -f  %{buildroot}%{_datadir}/doc ./
126
127rm -rf %{buildroot}%{_sysconfdir}/{init.d,logrotate.d}
128rm -rf %{buildroot}%{_sysconfdir}/my.cnf.d/{mysql-clients.cnf,server.cnf,enable_encryption.preset}
129rm -rf %{buildroot}%{_datadir}/{man/man8,mysql}
130rm -f %{buildroot}%{_libdir}/*.a
131find %{buildroot}%{_bindir} -type f | grep -v -e mysql_config | xargs rm -f
132find %{buildroot}%{_mandir} -type f | grep -v -e mysql_config | xargs rm -f
133
134##############################################################################
135
136
137%post -n libmysqlclient%{soversion}
138/sbin/ldconfig
139
140%postun -n libmysqlclient%{soversion}
141/sbin/ldconfig
142
143%clean
144rm -rf %{buildroot}
145
146%files -n mariadb-common
147%defattr(-, root, root)
148%config(noreplace) %{_sysconfdir}/my.cnf
149%dir %{_sysconfdir}/my.cnf.d
150%config(noreplace) %{_sysconfdir}/my.cnf.d/client.cnf
151
152%files -n libmysqlclient%{soversion}
153%defattr(-, root, root)
154%doc doc/*
155%{_libdir}/libmysql*.so.*
156
157%files devel
158%defattr(-, root, root)
159%doc %{_mandir}/man1/mysql_config.1*
160%{_bindir}/mysql_config
161%{_datadir}/pkgconfig/mariadb.pc
162%{_includedir}/mysql
163%{_datadir}/aclocal/mysql.m4
164%{_libdir}/*.so
165
166
167%changelog
168* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.12-1
169- new upstream release.
170
171* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.10-1
172- new upstream release.
173
174* Mon Nov 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1.9-1
175- new upstream release.
176
177* Fri Aug  7 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.21-1
178- new upstream release.
179
180* Fri Jun 19 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.20-1
181- new upstream release.
182
183* Sun May 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.19-1
184- new upstream release.
185
186* Fri May  8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.18-1
187- new upstream release.
188
189* Tue Mar  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.17-1
190- new upstream release.
191
192* Wed Jan 28 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.16-1
193- new upstream release.
194
195* Thu Nov 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
196- new upstream release.
197
198* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
199- new upstream release.
200
201* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
202- fixed Conflicts: and Obsoletes:.
203
204* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
205- new upstream release.
206
207* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
208- new upstream release.
209
210* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
211- new upstream release.
212
213* Tue Dec 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
214- initial build.
Note: See TracBrowser for help on using the repository browser.