source: projects/specs/trunk/lib/libl/libldb/libldb-vl.spec @ 9136

Revision 9136, 7.5 KB checked in by tomop, 9 years ago (diff)

samba-4.1.14-1

Line 
1%define talloc_version 2.1.1
2%define tdb_version 1.3.3
3%define tevent_version 0.9.22
4
5Name: libldb
6Summary: A schema-less, ldap like, API and database
7Version: 1.1.18
8Release: 1%{?_dist_release}
9
10Group: System Environment/Libraries
11License: LGPLv3+
12URL: http://ldb.samba.org/
13
14Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
15# Patches
16Patch1001: FED01-fix-tevent-check.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: libtalloc-devel >= %{talloc_version}
20BuildRequires: libtdb-devel >= %{tdb_version}
21BuildRequires: libtevent-devel >= %{tevent_version}
22BuildRequires: popt-devel
23BuildRequires: autoconf
24BuildRequires: libxslt
25BuildRequires: docbook-style-xsl
26BuildRequires: python-devel
27BuildRequires: python-tdb
28BuildRequires: pytalloc-devel
29BuildRequires: python-tevent
30BuildRequires: doxygen
31Requires: libtalloc >= %{talloc_version}
32Requires: libtdb >= %{tdb_version}
33Requires: libtevent >= %{tevent_version}
34
35Provides: bundled(libreplace)
36Provides: bundled(libtdb_compat)
37Provides: bundled(libccan)
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: tomop
42
43%description
44An extensible library that implements an LDAP like API to access remote LDAP
45servers, or use local tdb databases.
46
47%package -n ldb-tools
48Group: Applications/System
49Summary: Tools to manage LDB files
50Requires: libldb = %{version}-%{release}
51
52%description -n ldb-tools
53Tools to manage LDB files
54
55%package devel
56Group: Development/Libraries
57Summary: Developer tools for the LDB library
58Requires: libldb = %{version}-%{release}
59Requires: libtdb-devel >= %{tdb_version}
60Requires: libtalloc-devel >= %{talloc_version}
61Requires: libtevent-devel >= %{tevent_version}
62Requires: pkgconfig
63
64%description devel
65Header files needed to develop programs that link against the LDB library.
66
67%package -n pyldb
68Group: System Environment/Libraries
69Summary: Python bindings for the LDB library
70Requires: libldb = %{version}-%{release}
71Requires: python-tdb >= %{tdb_version}
72
73%description -n pyldb
74Python bindings for the LDB library
75
76%package -n pyldb-devel
77Group: Development/Libraries
78Summary: Development files for the Python bindings for the LDB library
79Requires: pyldb = %{version}-%{release}
80
81%description -n pyldb-devel
82Development files for the Python bindings for the LDB library
83
84%prep
85%setup -q -n ldb-%{version}
86
87%patch1001 -p1
88
89%build
90
91# tdb_compat and ccan have no upstream releases to link against yet and their
92# API is in flux. It is unsafe to make them public and shared at this time.
93%configure --disable-rpath \
94           --disable-rpath-install \
95           --bundled-libraries=NONE \
96           --builtin-libraries=tdb_compat,ccan,replace \
97           --with-modulesdir=%{_libdir}/ldb/modules \
98           --with-privatelibdir=%{_libdir}/ldb
99
100make V=1 %{?_smp_mflags}
101doxygen Doxyfile
102
103%install
104make install DESTDIR=%{buildroot}
105
106rm -f %{buildroot}%{_libdir}/libldb.a
107
108# Remove _tevent.so (it's managed by python-tevent)
109#rm -f %{buildroot}/%{python_sitearch}/_tevent.so
110
111# Shared libraries need to be marked executable for
112# rpmbuild to strip them and include them in debuginfo
113find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
114
115# Install API docs
116cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
117
118%clean
119rm -rf %{buildroot}
120
121%post -p /sbin/ldconfig
122
123%postun -p /sbin/ldconfig
124
125%files
126%defattr(-,root,root,-)
127%dir %{_libdir}/ldb
128%{_libdir}/libldb.so.*
129%dir %{_libdir}/ldb/modules
130%dir %{_libdir}/ldb/modules/ldb
131%{_libdir}/ldb/libldb-cmdline.so
132%{_libdir}/ldb/modules/ldb/*.so
133
134%files -n ldb-tools
135%defattr(-,root,root,-)
136%{_bindir}/ldbadd
137%{_bindir}/ldbdel
138%{_bindir}/ldbedit
139%{_bindir}/ldbmodify
140%{_bindir}/ldbrename
141%{_bindir}/ldbsearch
142%{_mandir}/man1/ldbadd.1.*
143%{_mandir}/man1/ldbdel.1.*
144%{_mandir}/man1/ldbedit.1.*
145%{_mandir}/man1/ldbmodify.1.*
146%{_mandir}/man1/ldbrename.1.*
147%{_mandir}/man1/ldbsearch.1.*
148
149%files devel
150%defattr(-,root,root,-)
151%{_includedir}/ldb_module.h
152%{_includedir}/ldb_handlers.h
153%{_includedir}/ldb_errors.h
154%{_includedir}/ldb_version.h
155%{_includedir}/ldb.h
156%{_libdir}/libldb.so
157
158%{_libdir}/pkgconfig/ldb.pc
159%{_mandir}/man3/ldb*.gz
160
161%files -n pyldb
162%defattr(-,root,root,-)
163%{python_sitearch}/ldb.so
164%{_libdir}/libpyldb-util.so.1*
165
166%files -n pyldb-devel
167%defattr(-,root,root,-)
168%{_includedir}/pyldb.h
169%{_libdir}/libpyldb-util.so
170%{_libdir}/pkgconfig/pyldb-util.pc
171%{_mandir}/man*/Py*.gz
172
173%post -n pyldb
174/sbin/ldconfig
175
176%postun -n pyldb
177/sbin/ldconfig
178
179%changelog
180* Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
181- new upstream release.
182
183* Fri Oct  3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
184- moved libldb and pyldb to System Environment/Libraries Group
185- moved ldb-tool to Applications/System Group
186
187* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
188- new upstream release.
189
190* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
191- rebuilt with current environment.
192
193* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
194- new upstream release.
195
196* Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
197- new upstream release.
198
199* Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
200- moved libldb-cmdline.so to main package.
201
202* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
203- fixed dependency.
204
205* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
206- new upstream release.
207- initial build for Vine Linux.
208
209* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
210- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
211
212* Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
213- New upstream release
214- Add ldb_module_error() routine
215- Fedora: work around unreliable configure check for pytevent
216- Drop patch to ignore --disable-silent-rules (included in tarball)
217
218* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
219- Add patch to ignore --disable-silent-rules
220
221* Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
222- Add explicit mention of the bundled libreplace
223- https://fedorahosted.org/fpc/ticket/120
224- Add explicit mention of bundled libtdb_compat and libccan
225- https://fedorahosted.org/fpc/ticket/119
226
227* Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
228- Build and install API documentation
229- Build tdb_compat and ccan statically. They have no upstream releases to
230  link against yet and their API is in flux. It is unsafe to make them
231  public and shared at this time.
232
233* Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
234- New upstream release
235- Required for building newer samba4 packages
236
237* Tue Aug  2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
238- Update to 1.1.0
239  (dependency for samba4 alpha16 snapshot)
240
241* Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
242- Update to 1.0.2
243  (dependency for samba4 alpha15 snapshot)
244
245* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
246- Disable rpath
247
248* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
249- New upstream release 1.0.0
250- SOname bump to account for module loading changes
251- Rename libldb-tools to ldb-tools to make upgrades easier
252
253* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
254- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
255
256* Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
257- Fixes from package review
258- Change Requires: on tools subpackage to be the exact version/release
259- Remove unnecessary BuildRoot directive
260
261* Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
262- Update to 0.9.22 (first independent release of libldb upstream)
263
Note: See TracBrowser for help on using the repository browser.