source: projects/specs/trunk/lib/libl/libldb/libldb-vl.spec @ 8130

Revision 8130, 7.1 KB checked in by tomop, 10 years ago (diff)

update samba-libraries

Line 
1%define talloc_version 2.1.0
2%define tdb_version 1.2.12
3%define tevent_version 0.9.19
4
5Name: libldb
6Version: 1.1.16
7Release: 2%{?_dist_release}
8Group: Development/Libraries
9Summary: A schema-less, ldap like, API and database
10Requires: libtalloc >= %{talloc_version}
11Requires: libtdb >= %{tdb_version}
12Requires: libtevent >= %{tevent_version}
13License: LGPLv3+
14URL: http://ldb.samba.org/
15Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
16
17BuildRequires: libtalloc-devel >= %{talloc_version}
18BuildRequires: libtdb-devel >= %{tdb_version}
19BuildRequires: libtevent-devel >= %{tevent_version}
20BuildRequires: popt-devel
21BuildRequires: autoconf
22BuildRequires: libxslt
23BuildRequires: docbook-style-xsl
24BuildRequires: python-devel
25BuildRequires: python-tdb
26BuildRequires: pytalloc-devel
27BuildRequires: python-tevent
28BuildRequires: doxygen
29
30Provides: bundled(libreplace)
31Provides: bundled(libtdb_compat)
32Provides: bundled(libccan)
33
34# Patches
35
36Patch1001: FED01-fix-tevent-check.patch
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: tomop
41
42%description
43An extensible library that implements an LDAP like API to access remote LDAP
44servers, or use local tdb databases.
45
46%package -n ldb-tools
47Group: Development/Libraries
48Summary: Tools to manage LDB files
49Requires: libldb = %{version}-%{release}
50
51%description -n ldb-tools
52Tools to manage LDB files
53
54%package devel
55Group: Development/Libraries
56Summary: Developer tools for the LDB library
57Requires: libldb = %{version}-%{release}
58Requires: libtdb-devel >= %{tdb_version}
59Requires: libtalloc-devel >= %{talloc_version}
60Requires: libtevent-devel >= %{tevent_version}
61Requires: pkgconfig
62
63%description devel
64Header files needed to develop programs that link against the LDB library.
65
66%package -n pyldb
67Group: Development/Libraries
68Summary: Python bindings for the LDB library
69Requires: libldb = %{version}-%{release}
70Requires: python-tdb >= %{tdb_version}
71
72%description -n pyldb
73Python bindings for the LDB library
74
75%package -n pyldb-devel
76Group: Development/Libraries
77Summary: Development files for the Python bindings for the LDB library
78Requires: pyldb = %{version}-%{release}
79
80%description -n pyldb-devel
81Development files for the Python bindings for the LDB library
82
83%prep
84%setup -q -n ldb-%{version}
85
86%patch1001 -p1
87
88%build
89
90# tdb_compat and ccan have no upstream releases to link against yet and their
91# API is in flux. It is unsafe to make them public and shared at this time.
92%configure --disable-rpath \
93           --disable-rpath-install \
94           --bundled-libraries=NONE \
95           --builtin-libraries=tdb_compat,ccan,replace \
96           --with-modulesdir=%{_libdir}/ldb/modules \
97           --with-privatelibdir=%{_libdir}/ldb
98
99make V=1 %{?_smp_mflags}
100doxygen Doxyfile
101
102%install
103make install DESTDIR=%{buildroot}
104
105rm -f %{buildroot}%{_libdir}/libldb.a
106
107# Remove _tevent.so (it's managed by python-tevent)
108#rm -f %{buildroot}/%{python_sitearch}/_tevent.so
109
110# Shared libraries need to be marked executable for
111# rpmbuild to strip them and include them in debuginfo
112find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
113
114# Install API docs
115cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
116
117%clean
118rm -rf %{buildroot}
119
120%post -p /sbin/ldconfig
121
122%postun -p /sbin/ldconfig
123
124%files
125%defattr(-,root,root,-)
126%dir %{_libdir}/ldb
127%{_libdir}/libldb.so.*
128%dir %{_libdir}/ldb/modules
129%dir %{_libdir}/ldb/modules/ldb
130%{_libdir}/ldb/libldb-cmdline.so
131%{_libdir}/ldb/modules/ldb/*.so
132
133%files -n ldb-tools
134%defattr(-,root,root,-)
135%{_bindir}/ldbadd
136%{_bindir}/ldbdel
137%{_bindir}/ldbedit
138%{_bindir}/ldbmodify
139%{_bindir}/ldbrename
140%{_bindir}/ldbsearch
141%{_mandir}/man1/ldbadd.1.*
142%{_mandir}/man1/ldbdel.1.*
143%{_mandir}/man1/ldbedit.1.*
144%{_mandir}/man1/ldbmodify.1.*
145%{_mandir}/man1/ldbrename.1.*
146%{_mandir}/man1/ldbsearch.1.*
147
148%files devel
149%defattr(-,root,root,-)
150%{_includedir}/ldb_module.h
151%{_includedir}/ldb_handlers.h
152%{_includedir}/ldb_errors.h
153%{_includedir}/ldb_version.h
154%{_includedir}/ldb.h
155%{_libdir}/libldb.so
156
157%{_libdir}/pkgconfig/ldb.pc
158%{_mandir}/man3/ldb*.gz
159
160%files -n pyldb
161%defattr(-,root,root,-)
162%{python_sitearch}/ldb.so
163%{_libdir}/libpyldb-util.so.1*
164
165%files -n pyldb-devel
166%defattr(-,root,root,-)
167%{_includedir}/pyldb.h
168%{_libdir}/libpyldb-util.so
169%{_libdir}/pkgconfig/pyldb-util.pc
170%{_mandir}/man*/Py*.gz
171
172%post -n pyldb
173/sbin/ldconfig
174
175%postun -n pyldb
176/sbin/ldconfig
177
178%changelog
179* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
180- rebuilt with current environment.
181
182* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
183- new upstream release.
184
185* Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
186- new upstream release.
187
188* Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
189- moved libldb-cmdline.so to main package.
190
191* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
192- fixed dependency.
193
194* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
195- new upstream release.
196- initial build for Vine Linux.
197
198* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
200
201* Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
202- New upstream release
203- Add ldb_module_error() routine
204- Fedora: work around unreliable configure check for pytevent
205- Drop patch to ignore --disable-silent-rules (included in tarball)
206
207* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
208- Add patch to ignore --disable-silent-rules
209
210* Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
211- Add explicit mention of the bundled libreplace
212- https://fedorahosted.org/fpc/ticket/120
213- Add explicit mention of bundled libtdb_compat and libccan
214- https://fedorahosted.org/fpc/ticket/119
215
216* Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
217- Build and install API documentation
218- Build tdb_compat and ccan statically. They have no upstream releases to
219  link against yet and their API is in flux. It is unsafe to make them
220  public and shared at this time.
221
222* Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
223- New upstream release
224- Required for building newer samba4 packages
225
226* Tue Aug  2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
227- Update to 1.1.0
228  (dependency for samba4 alpha16 snapshot)
229
230* Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
231- Update to 1.0.2
232  (dependency for samba4 alpha15 snapshot)
233
234* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
235- Disable rpath
236
237* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
238- New upstream release 1.0.0
239- SOname bump to account for module loading changes
240- Rename libldb-tools to ldb-tools to make upgrades easier
241
242* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
244
245* Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
246- Fixes from package review
247- Change Requires: on tools subpackage to be the exact version/release
248- Remove unnecessary BuildRoot directive
249
250* Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
251- Update to 0.9.22 (first independent release of libldb upstream)
252
Note: See TracBrowser for help on using the repository browser.