source: projects/specs/trunk/lib/libl/libldb/libldb-vl.spec @ 9673

Revision 9673, 8.6 KB checked in by tomop, 9 years ago (diff)

samba-4.2.3, etc.

RevLine 
[9517]1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
[8910]3%define talloc_version 2.1.1
[9254]4%define tdb_version 1.3.4
[9411]5%define tevent_version 0.9.24
[7255]6
7Name: libldb
[8998]8Summary: A schema-less, ldap like, API and database
[9673]9Version: 1.1.21
10Release: 1%{?_dist_release}
[8998]11
12Group: System Environment/Libraries
[7255]13License: LGPLv3+
14URL: http://ldb.samba.org/
[8998]15
[7255]16Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
[8998]17# Patches
18Patch1001: FED01-fix-tevent-check.patch
[7255]19
[8998]20BuildRoot: %{_tmppath}/%{name}-%{version}-root
[7255]21BuildRequires: libtalloc-devel >= %{talloc_version}
22BuildRequires: libtdb-devel >= %{tdb_version}
23BuildRequires: libtevent-devel >= %{tevent_version}
24BuildRequires: popt-devel
25BuildRequires: autoconf
26BuildRequires: libxslt
27BuildRequires: docbook-style-xsl
28BuildRequires: python-devel
29BuildRequires: python-tdb
30BuildRequires: pytalloc-devel
31BuildRequires: python-tevent
32BuildRequires: doxygen
[8998]33Requires: libtalloc >= %{talloc_version}
34Requires: libtdb >= %{tdb_version}
35Requires: libtevent >= %{tevent_version}
[7255]36
37Provides: bundled(libreplace)
38Provides: bundled(libtdb_compat)
39Provides: bundled(libccan)
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: tomop
44
45%description
46An extensible library that implements an LDAP like API to access remote LDAP
47servers, or use local tdb databases.
48
49%package -n ldb-tools
[8998]50Group: Applications/System
[7255]51Summary: Tools to manage LDB files
52Requires: libldb = %{version}-%{release}
53
54%description -n ldb-tools
55Tools to manage LDB files
56
57%package devel
58Group: Development/Libraries
59Summary: Developer tools for the LDB library
60Requires: libldb = %{version}-%{release}
61Requires: libtdb-devel >= %{tdb_version}
62Requires: libtalloc-devel >= %{talloc_version}
63Requires: libtevent-devel >= %{tevent_version}
64Requires: pkgconfig
65
66%description devel
67Header files needed to develop programs that link against the LDB library.
68
69%package -n pyldb
[8998]70Group: System Environment/Libraries
[7255]71Summary: Python bindings for the LDB library
72Requires: libldb = %{version}-%{release}
73Requires: python-tdb >= %{tdb_version}
74
75%description -n pyldb
76Python bindings for the LDB library
77
78%package -n pyldb-devel
79Group: Development/Libraries
80Summary: Development files for the Python bindings for the LDB library
81Requires: pyldb = %{version}-%{release}
82
83%description -n pyldb-devel
84Development files for the Python bindings for the LDB library
85
[9517]86%if %build_compat32
87
88%package -n compat32-%{name}
89Summary: A schema-less, ldap like, API and database
90Group: System Environment/Libraries
91
92%description -n compat32-%{name}
93An extensible library that implements an LDAP like API to access remote LDAP
94servers, or use local tdb databases.
95
96%endif
97
[7255]98%prep
99%setup -q -n ldb-%{version}
100
101%patch1001 -p1
102
103%build
104
105# tdb_compat and ccan have no upstream releases to link against yet and their
106# API is in flux. It is unsafe to make them public and shared at this time.
107%configure --disable-rpath \
108           --disable-rpath-install \
109           --bundled-libraries=NONE \
110           --builtin-libraries=tdb_compat,ccan,replace \
111           --with-modulesdir=%{_libdir}/ldb/modules \
112           --with-privatelibdir=%{_libdir}/ldb
113
114make V=1 %{?_smp_mflags}
115doxygen Doxyfile
116
117%install
118make install DESTDIR=%{buildroot}
119
120rm -f %{buildroot}%{_libdir}/libldb.a
121
122# Remove _tevent.so (it's managed by python-tevent)
123#rm -f %{buildroot}/%{python_sitearch}/_tevent.so
124
125# Shared libraries need to be marked executable for
126# rpmbuild to strip them and include them in debuginfo
127find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
128
129# Install API docs
130cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
131
132%clean
133rm -rf %{buildroot}
134
[9517]135%post
136/sbin/ldconfig
[7255]137
[9517]138%postun
139/sbin/ldconfig
[7255]140
[9517]141%post -n pyldb
142/sbin/ldconfig
143
144%postun -n pyldb
145/sbin/ldconfig
146
147%if %build_compat32
148
149%post -n compat32-%{name}
150/sbin/ldconfig
151
152%postun -n compat32-%{name}
153/sbin/ldconfig
154
155%endif
156
[7255]157%files
158%defattr(-,root,root,-)
159%dir %{_libdir}/ldb
160%{_libdir}/libldb.so.*
161%dir %{_libdir}/ldb/modules
162%dir %{_libdir}/ldb/modules/ldb
[7261]163%{_libdir}/ldb/libldb-cmdline.so
[7255]164%{_libdir}/ldb/modules/ldb/*.so
165
166%files -n ldb-tools
167%defattr(-,root,root,-)
168%{_bindir}/ldbadd
169%{_bindir}/ldbdel
170%{_bindir}/ldbedit
171%{_bindir}/ldbmodify
172%{_bindir}/ldbrename
173%{_bindir}/ldbsearch
174%{_mandir}/man1/ldbadd.1.*
175%{_mandir}/man1/ldbdel.1.*
176%{_mandir}/man1/ldbedit.1.*
177%{_mandir}/man1/ldbmodify.1.*
178%{_mandir}/man1/ldbrename.1.*
179%{_mandir}/man1/ldbsearch.1.*
180
181%files devel
182%defattr(-,root,root,-)
183%{_includedir}/ldb_module.h
184%{_includedir}/ldb_handlers.h
185%{_includedir}/ldb_errors.h
186%{_includedir}/ldb_version.h
187%{_includedir}/ldb.h
188%{_libdir}/libldb.so
189
190%{_libdir}/pkgconfig/ldb.pc
191%{_mandir}/man3/ldb*.gz
192
193%files -n pyldb
194%defattr(-,root,root,-)
195%{python_sitearch}/ldb.so
196%{_libdir}/libpyldb-util.so.1*
197
198%files -n pyldb-devel
199%defattr(-,root,root,-)
200%{_includedir}/pyldb.h
201%{_libdir}/libpyldb-util.so
202%{_libdir}/pkgconfig/pyldb-util.pc
203%{_mandir}/man*/Py*.gz
204
[9517]205%if %build_compat32
[7255]206
[9517]207%files -n compat32-%{name}
208%defattr(-,root,root,-)
209%dir %{_libdir}/ldb
210%{_libdir}/libldb.so.*
211%dir %{_libdir}/ldb/modules
212%dir %{_libdir}/ldb/modules/ldb
213%{_libdir}/ldb/libldb-cmdline.so
214%{_libdir}/ldb/modules/ldb/*.so
[7512]215
[9517]216%endif
217
218
[7255]219%changelog
[9673]220* Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.21-1
221- new upstream release.
222
[9517]223* Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-2
224- added compat32 package.
225
[9411]226* Fri Mar 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-1
227- new upstream release.
228
[9254]229* Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.19-1
230- new upstream release.
231
[9136]232* Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
233- new upstream release.
234
[8998]235* Fri Oct  3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
236- moved libldb and pyldb to System Environment/Libraries Group
237- moved ldb-tool to Applications/System Group
238
[8910]239* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
240- new upstream release.
241
[8130]242* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
243- rebuilt with current environment.
244
[7885]245* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
246- new upstream release.
247
[7512]248* Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
249- new upstream release.
250
[7261]251* Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
252- moved libldb-cmdline.so to main package.
253
[7255]254* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
255- fixed dependency.
256
257* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
258- new upstream release.
259- initial build for Vine Linux.
260
261* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
262- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
263
264* Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
265- New upstream release
266- Add ldb_module_error() routine
267- Fedora: work around unreliable configure check for pytevent
268- Drop patch to ignore --disable-silent-rules (included in tarball)
269
270* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
271- Add patch to ignore --disable-silent-rules
272
273* Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
274- Add explicit mention of the bundled libreplace
275- https://fedorahosted.org/fpc/ticket/120
276- Add explicit mention of bundled libtdb_compat and libccan
277- https://fedorahosted.org/fpc/ticket/119
278
279* Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
280- Build and install API documentation
281- Build tdb_compat and ccan statically. They have no upstream releases to
282  link against yet and their API is in flux. It is unsafe to make them
283  public and shared at this time.
284
285* Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
286- New upstream release
287- Required for building newer samba4 packages
288
289* Tue Aug  2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
290- Update to 1.1.0
291  (dependency for samba4 alpha16 snapshot)
292
293* Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
294- Update to 1.0.2
295  (dependency for samba4 alpha15 snapshot)
296
297* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
298- Disable rpath
299
300* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
301- New upstream release 1.0.0
302- SOname bump to account for module loading changes
303- Rename libldb-tools to ldb-tools to make upgrades easier
304
305* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
306- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
307
308* Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
309- Fixes from package review
310- Change Requires: on tools subpackage to be the exact version/release
311- Remove unnecessary BuildRoot directive
312
313* Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
314- Update to 0.9.22 (first independent release of libldb upstream)
315
Note: See TracBrowser for help on using the repository browser.