source: projects/specs/trunk/lib/libk/libkkc/libkkc-vl.spec @ 8051

Revision 8051, 6.2 KB checked in by iwaim, 10 years ago (diff)

libkkc 0.3.2-1

Line 
1%define ver 0.3.2
2%define rel 1
3%define dataver 0.2.7
4%define datarel 2
5
6%define from_git 0
7%if %{from_git}
8%define githash ccfd5c6d
9%endif
10
11%if "%{?_dist_release}" == "vl6"
12%define with_vala 0
13%else
14%define with_vala 1
15%endif
16
17Summary: Japanese Kana Kanji conversion library (libkkc)
18Name: libkkc
19Version: %{ver}
20%if %{from_git}
21Release: %{rel}.git%{githash}%{_dist_release}
22%else
23Release: %{rel}%{_dist_release}
24%endif
25License: GPLv3+
26Group: System Environment/Libraries
27URL: https://bitbucket.org/libkkc/libkkc/
28%if %{from_git}
29Source0: libkkc-%{githash}.tar.gz
30%else
31Source0: https://bitbucket.org/libkkc/libkkc/downloads/%{name}-%{version}.tar.gz
32%endif
33Source1: https://bitbucket.org/libkkc/libkkc-data/downloads/%{name}-data-%{dataver}.tar.xz
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
35%if "%{?_dist_release}" == "vl6"
36BuildRequires: libgee-devel
37%else
38BuildRequires: libgee06-devel
39%endif
40BuildRequires: json-glib-devel
41BuildRequires: marisa-trie-devel
42# for libkkc-data
43BuildRequires: marisa-trie-python
44%if %{with_vala}
45BuildRequires: vala-devel
46BuildRequires: vala-tools
47%endif
48
49Requires: libkkc-data = %{dataver}-%{datarel}%{_dist_release}
50Requires: libkkc-common = %{version}-%{release}
51
52Vendor: Project Vine
53Distribution: Vine Linux
54Packager: iwaim
55
56%description
57libkkc provides a converter from Kana-string to
58Kana-Kanji-mixed-string.  It was named after kkc.el in GNU Emacs, a
59simple Kana Kanji converter, while libkkc tries to convert sentences
60in a bit more complex way using N-gram language models.
61
62%package devel
63Summary: Header files and libraries for developing apps which will use libkkc
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description devel
68The libkkc-devel package contains the header files and libraries.
69
70%package tools
71Summary: Tools for %{name}
72Group: Applications/Accessories
73Requires: %{name} = %{version}-%{release}
74
75%description tools
76The %{name}-tools package contains tools for developing applications
77that use %{name}.
78
79%package common
80Summary: Common data files for %{name}
81
82%description common
83The %{name}-common package contains the arch-independent data that
84%{name} uses at run time.
85
86%package data
87Summary: Data files for %{name}
88Version: %{dataver}
89Release: %{datarel}%{_dist_release}
90
91%description data
92The %{name}-data package contains the language model data that %{name}
93uses at run time.
94
95%prep
96%if %{from_git}
97%setup -q -n %{name}-%{githash}
98%else
99%setup -q
100%endif
101
102# for libkkc-data
103tar xf %{SOURCE1}
104
105%build
106%if %{from_git}
107./autogen.sh
108%endif
109%configure --enable-shared \
110           --disable-silent-rules \
111%if %{with_vala}
112           --enable-vala=yes \
113%else
114           --enable-vala=no \
115%endif
116
117%__make
118
119# for libkkc-data
120pushd %{name}-data-%{dataver}
121%configure
122%__make
123popd
124
125%install
126%__rm -rf $RPM_BUILD_ROOT
127%makeinstall
128
129# for libkkc-data
130pushd %{name}-data-%{dataver}
131%makeinstall
132popd
133
134%find_lang %{name}
135
136# remove files
137%__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
138
139%clean
140%__rm -rf $RPM_BUILD_ROOT
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%files -f %{name}.lang
147%defattr(-,root,root,-)
148%doc README ChangeLog COPYING AUTHORS NEWS
149%doc data/rules/README.rules
150%{_libdir}/libkkc.so.*
151%{_libdir}/girepository-1.0/Kkc-1.0.typelib
152%dir %{_datadir}/libkkc
153%{_datadir}/libkkc/rules
154
155%files devel
156%defattr(-,root,root,-)
157%doc COPYING AUTHORS
158%dir %{_includedir}/libkkc
159%{_includedir}/libkkc/libkkc.h
160%{_libdir}/libkkc.so
161%{_libdir}/pkgconfig/kkc-1.0.pc
162%{_datadir}/gir-1.0/Kkc-1.0.gir
163%{_datadir}/vala/vapi/kkc-1.0.deps
164%{_datadir}/vala/vapi/kkc-1.0.vapi
165
166%files tools
167%defattr(-,root,root,-)
168%doc COPYING AUTHORS
169%{_bindir}/kkc
170%{_bindir}/kkc-package-data
171
172%files common
173%defattr(-,root,root,-)
174%doc COPYING AUTHORS
175%dir %{_datadir}/libkkc
176%dir %{_datadir}/libkkc/templates
177%{_datadir}/libkkc/templates/libkkc-data
178
179%files data
180%defattr(-,root,root,-)
181%doc COPYING AUTHORS
182%dir %{_libdir}/libkkc
183%dir %{_libdir}/libkkc/models
184%{_libdir}/libkkc/models/sorted3
185
186%changelog
187* Wed Dec 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.2-1
188- update to libkkc 0.3.2
189
190* Thu Nov  7 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.1-1
191- update to libkkc 0.3.1
192- update to libkkc-data 0.2.7
193- fix changelog for 0.2.6-1
194
195* Sat Jul 27 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.6-1
196- update to libkkc 0.2.6
197- update to libkkc-data 0.2.5
198
199* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-1
200- update to libkkc 0.2.4
201- update to libkkc-data 0.2.0
202- add Version tag for libkkc-data sub package
203
204* Tue Mar 26 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.10-1
205- update to libkkc 0.1.10
206
207* Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.9-1
208- update to libkkc 0.1.9
209
210* Sun Mar  3 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.8-1
211- update to libkkc 0.1.8
212
213* Sat Feb 23 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.7-1
214- update to libkkc 0.1.7
215
216* Fri Feb 15 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.6-1
217- update to libkkc 0.1.6
218- update to libkkc-data 0.1.6
219
220* Mon Feb 11 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.5-1
221- update to libkkc 0.1.5
222
223* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.3-1
224- update to 0.1.3
225- update License value: GPLv3 -> GPLv3+
226- add BuildRequires: marisa-trie-python for libkkc-data
227- sync upstream spec: http://ueno.fedorapeople.org/libkkc/libkkc.spec 0.1.3-2
228 - create tools sub package
229  - move %%{_bindir}/kkc
230  - add %%{_bindir}/kkc-package-data
231 - create common sub package
232  - add template for generating libkkc-data
233 - merge libkkc-data SRPM file
234  - add libkkc-data source file (Source1)
235  - create data sub package
236 - add '--disable-silent-rules' option for configure
237 - add Requires libkkc-data and libkkc-common
238 - add document: data/rules/README.rules
239
240* Wed Feb  6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
241- update to 0.1.2
242
243* Tue Feb  5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
244- update to 0.1.1
245
246* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
247- update to 0.1.0
248- rename libkkc.pc to kkc-1.0.pc by upstream
249
250* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
251- update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
252- add post and postun script
253- add translate file
254
255* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
256- support Vine Linux 6
257 - without Vala
258 - BR: libgee-devel
259
260* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
261- initial build for Vine Linux
262
Note: See TracBrowser for help on using the repository browser.