source: projects/specs/trunk/lib/libk/libkkc/libkkc-vl.spec @ 8047

Revision 8047, 6.0 KB checked in by iwaim, 11 years ago (diff)

libkkc 0.3.1-1

Line 
1%define ver 0.3.1
2%define rel 1
3%define dataver 0.2.7
4
5%define from_git 0
6%if %{from_git}
7%define githash ccfd5c6d
8%endif
9
10%if "%{?_dist_release}" == "vl6"
11%define with_vala 0
12%else
13%define with_vala 1
14%endif
15
16Summary: Japanese Kana Kanji conversion library (libkkc)
17Name: libkkc
18Version: %{ver}
19%if %{from_git}
20Release: %{rel}.git%{githash}%{_dist_release}
21%else
22Release: %{rel}%{_dist_release}
23%endif
24License: GPLv3+
25Group: System Environment/Libraries
26URL: https://bitbucket.org/libkkc/libkkc/
27%if %{from_git}
28Source0: libkkc-%{githash}.tar.gz
29%else
30Source0: https://bitbucket.org/libkkc/libkkc/downloads/%{name}-%{version}.tar.gz
31%endif
32Source1: https://bitbucket.org/libkkc/libkkc-data/downloads/%{name}-data-%{dataver}.tar.xz
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
34%if "%{?_dist_release}" == "vl6"
35BuildRequires: libgee-devel
36%else
37BuildRequires: libgee06-devel
38%endif
39BuildRequires: json-glib-devel
40BuildRequires: marisa-trie-devel
41# for libkkc-data
42BuildRequires: marisa-trie-python
43%if %{with_vala}
44BuildRequires: vala-devel
45BuildRequires: vala-tools
46%endif
47
48Requires: libkkc-data = %{dataver}-%{release}
49Requires: libkkc-common = %{version}-%{release}
50
51Vendor: Project Vine
52Distribution: Vine Linux
53Packager: iwaim
54
55%description
56libkkc provides a converter from Kana-string to
57Kana-Kanji-mixed-string.  It was named after kkc.el in GNU Emacs, a
58simple Kana Kanji converter, while libkkc tries to convert sentences
59in a bit more complex way using N-gram language models.
60
61%package devel
62Summary: Header files and libraries for developing apps which will use libkkc
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description devel
67The libkkc-devel package contains the header files and libraries.
68
69%package tools
70Summary: Tools for %{name}
71Group: Applications/Accessories
72Requires: %{name} = %{version}-%{release}
73
74%description tools
75The %{name}-tools package contains tools for developing applications
76that use %{name}.
77
78%package common
79Summary: Common data files for %{name}
80
81%description common
82The %{name}-common package contains the arch-independent data that
83%{name} uses at run time.
84
85%package data
86Summary: Data files for %{name}
87Version: %{dataver}
88
89%description data
90The %{name}-data package contains the language model data that %{name}
91uses at run time.
92
93%prep
94%if %{from_git}
95%setup -q -n %{name}-%{githash}
96%else
97%setup -q
98%endif
99
100# for libkkc-data
101tar xf %{SOURCE1}
102
103%build
104%if %{from_git}
105./autogen.sh
106%endif
107%configure --enable-shared \
108           --disable-silent-rules \
109%if %{with_vala}
110           --enable-vala=yes \
111%else
112           --enable-vala=no \
113%endif
114
115%__make
116
117# for libkkc-data
118pushd %{name}-data-%{dataver}
119%configure
120%__make
121popd
122
123%install
124%__rm -rf $RPM_BUILD_ROOT
125%makeinstall
126
127# for libkkc-data
128pushd %{name}-data-%{dataver}
129%makeinstall
130popd
131
132%find_lang %{name}
133
134# remove files
135%__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
136
137%clean
138%__rm -rf $RPM_BUILD_ROOT
139
140%post -p /sbin/ldconfig
141
142%postun -p /sbin/ldconfig
143
144%files -f %{name}.lang
145%defattr(-,root,root,-)
146%doc README ChangeLog COPYING AUTHORS NEWS
147%doc data/rules/README.rules
148%{_libdir}/libkkc.so.*
149%{_libdir}/girepository-1.0/Kkc-1.0.typelib
150%dir %{_datadir}/libkkc
151%{_datadir}/libkkc/rules
152
153%files devel
154%defattr(-,root,root,-)
155%doc COPYING AUTHORS
156%dir %{_includedir}/libkkc
157%{_includedir}/libkkc/libkkc.h
158%{_libdir}/libkkc.so
159%{_libdir}/pkgconfig/kkc-1.0.pc
160%{_datadir}/gir-1.0/Kkc-1.0.gir
161%{_datadir}/vala/vapi/kkc-1.0.deps
162%{_datadir}/vala/vapi/kkc-1.0.vapi
163
164%files tools
165%defattr(-,root,root,-)
166%doc COPYING AUTHORS
167%{_bindir}/kkc
168%{_bindir}/kkc-package-data
169
170%files common
171%defattr(-,root,root,-)
172%doc COPYING AUTHORS
173%dir %{_datadir}/libkkc
174%dir %{_datadir}/libkkc/templates
175%{_datadir}/libkkc/templates/libkkc-data
176
177%files data
178%defattr(-,root,root,-)
179%doc COPYING AUTHORS
180%dir %{_libdir}/libkkc
181%dir %{_libdir}/libkkc/models
182%{_libdir}/libkkc/models/sorted3
183
184%changelog
185* Thu Nov  7 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.1-1
186- update to libkkc 0.3.1
187- update to libkkc-data 0.2.7
188- fix changelog for 0.2.6-1
189
190* Sat Jul 27 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.6-1
191- update to libkkc 0.2.6
192- update to libkkc-data 0.2.5
193
194* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.2.4-1
195- update to libkkc 0.2.4
196- update to libkkc-data 0.2.0
197- add Version tag for libkkc-data sub package
198
199* Tue Mar 26 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.10-1
200- update to libkkc 0.1.10
201
202* Sat Mar 16 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.9-1
203- update to libkkc 0.1.9
204
205* Sun Mar  3 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.8-1
206- update to libkkc 0.1.8
207
208* Sat Feb 23 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.7-1
209- update to libkkc 0.1.7
210
211* Fri Feb 15 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.6-1
212- update to libkkc 0.1.6
213- update to libkkc-data 0.1.6
214
215* Mon Feb 11 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.5-1
216- update to libkkc 0.1.5
217
218* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.3-1
219- update to 0.1.3
220- update License value: GPLv3 -> GPLv3+
221- add BuildRequires: marisa-trie-python for libkkc-data
222- sync upstream spec: http://ueno.fedorapeople.org/libkkc/libkkc.spec 0.1.3-2
223 - create tools sub package
224  - move %%{_bindir}/kkc
225  - add %%{_bindir}/kkc-package-data
226 - create common sub package
227  - add template for generating libkkc-data
228 - merge libkkc-data SRPM file
229  - add libkkc-data source file (Source1)
230  - create data sub package
231 - add '--disable-silent-rules' option for configure
232 - add Requires libkkc-data and libkkc-common
233 - add document: data/rules/README.rules
234
235* Wed Feb  6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
236- update to 0.1.2
237
238* Tue Feb  5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
239- update to 0.1.1
240
241* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
242- update to 0.1.0
243- rename libkkc.pc to kkc-1.0.pc by upstream
244
245* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
246- update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
247- add post and postun script
248- add translate file
249
250* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
251- support Vine Linux 6
252 - without Vala
253 - BR: libgee-devel
254
255* Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
256- initial build for Vine Linux
257
Note: See TracBrowser for help on using the repository browser.