source: projects/specs/trunk/lib/libi/libimobiledevice/libimobiledevice-vl.spec @ 8766

Revision 8766, 6.9 KB checked in by daisuke, 10 years ago (diff)

libimobiledevice: update to 1.1.6

Line 
1%bcond_with python
2
3Name:          libimobiledevice
4Version:       1.1.6
5Release:       1%{?_dist_release}
6Summary:       Library for connecting to mobile devices
7Summary(ja):   モバイルデバイスに接続するためのライブラリ
8
9Group:         System Environment/Libraries
10License:       LGPLv2+
11URL:           http://www.libimobiledevice.org/
12
13Source0:       http://cloud.github.com/downloads/MattColyer/libiphone/%{name}-%{version}.tar.bz2
14
15BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: libxml2-devel
17BuildRequires: libusb1-devel
18BuildRequires: libtasn1-devel
19BuildRequires: libplist-devel >= 1.11
20BuildRequires: libplist-python
21BuildRequires: glib2-devel
22BuildRequires: gnutls-devel
23BuildRequires: python-devel
24%if %{with python}
25BuildRequires: Cython
26%endif
27BuildRequires: swig
28BuildRequires: libusbmuxd-devel >= 1.0.9
29BuildRequires: libgcrypt-devel
30BuildRequires: readline-devel
31
32Provides: libiphone = %{version}
33Obsoletes: libiphone < 0.9.7
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: daisuke
38
39%description
40libimobiledevice is a library for connecting to mobile devices including phones
41and music players
42
43%package devel
44Summary: Development package for libimobiledevice
45Summary(ja): libimobiledevice の開発用パッケージ
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Provides: libiphone-devel = %{version}
49Obsoletes: libiphone-devel < 0.9.7
50
51%description devel
52Files for development with libimobiledevice.
53
54%package python
55Summary: Python bindings for libimobiledevice
56Summary(ja): libimobiledevice の Python バインディング
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Provides: libiphone-python = %{version}
60Obsoletes: libiphone-python < 0.9.7
61
62%description python
63Python bindings for libimobiledevice.
64
65%prep
66%setup -q
67
68# Fix dir permissions on html docs
69chmod +x docs/html
70
71%build
72%configure \
73  --disable-static \
74  --disable-openssl \
75%if %{with python}
76  --without-cython \
77  --without-python \
78%endif
79  --enable-dev-tools
80
81
82sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
83sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
84
85make %{?_smp_mflags} V=1
86
87%install
88rm -rf %{buildroot}
89make install DESTDIR=%{buildroot}
90
91#Remove libtool archives.
92find %{buildroot} -name '*.la' -exec rm -f {} ';'
93
94%clean
95rm -rf %{buildroot}
96
97%post -p /sbin/ldconfig
98
99%postun -p /sbin/ldconfig
100
101%files
102%defattr(-,root,root,-)
103%doc AUTHORS COPYING.LESSER README
104%doc %{_datadir}/man/man1/idevice*
105%{_bindir}/idevice*
106%{_libdir}/libimobiledevice.so.*
107
108%files devel
109%defattr(-,root,root,-)
110%doc docs/html/
111%{_libdir}/pkgconfig/libimobiledevice-1.0.pc
112%{_libdir}/libimobiledevice.so
113%{_includedir}/libimobiledevice/
114
115%if %{with python}
116%files python
117%defattr(-,root,root,-)
118%{python_sitearch}/imobiledevice.so
119%endif
120
121%changelog
122* Tue Jul 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.1.6-1
123- update to 1.1.6
124- add BR: libusbmuxd-devel >= 1.0.9, libgcrypt-devel, readline-devel
125- disable python
126- disable openssl
127
128* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.5-2
129- rebuild with VineSeed environment
130- add Patch2 (libimobiledevice-1.1.5-cython.patch)
131
132* Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.5-1
133- new upstream release
134
135* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
136- new upstream release
137- add BuildRequires: openssl-devel, Cython
138- add Patch1 (libimobiledevice-1.1.4-pkgconfig.patch)
139
140* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-2
141- rebuild with python-2.7.2
142
143* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
144- new upstream release
145
146* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
147- new upstream release
148
149* Tue Dec 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
150- new upstream release
151
152* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
153- rebuilt with rpm-4.8.1 for pkg-config
154
155* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
156- new upstream release
157
158* Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-2
159- updated devel package Requires
160
161* Thu Apr 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
162- initial build for Vine Linux
163
164* Sun Mar 21 2010 Peter Robinson <pbrobinson@gmail.com> 1.0.0-1
165- New upstream stable 1.0.0 release
166
167* Mon Feb 15 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-3
168- Add patch to fix DSO linking. Fixes bug 565084
169
170* Wed Feb  3 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-2
171- Package review updates, add developer docs
172
173* Wed Jan 27 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-1
174- New package for new library name. Update to 0.9.7
175
176* Sun Jan 24 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.6-1
177- Update to 0.9.6 release
178
179* Sat Jan  9 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.5-3
180- Updated to the new python sysarch spec file reqs
181
182* Tue Dec 15 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.5-2
183- Update python bindings
184
185* Sat Dec 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.5-1
186- Update to 0.9.5 release for new usbmuxd/libplist 1.0.0 final
187
188* Sat Dec 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-3
189- Rebuild for libplist .so bump
190
191* Wed Oct 28 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-2
192- Update from libusb to libusb1
193
194* Wed Oct 28 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-1
195- Update to 0.9.4 release for new usbmuxd 1.0.0-rc1
196
197* Mon Aug 10 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.3-1
198- Update to 0.9.3 release
199
200* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.1-3
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
202
203* Wed May 13 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.1-2
204- Add new build reqs
205
206* Tue May 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.1-1
207- Update to official 0.9.1 release
208
209* Fri Apr 03 2009 - Bastien Nocera <bnocera@redhat.com> - 0.1.0-11.20090325git443edc8
210- Update to latest master version
211
212* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-10.20090103git5cde554
213- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
214
215* Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-9.git5cde554
216- Add back gnutls version patch
217
218* Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-8.git5cde554
219- Upload bzipped source file
220
221* Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-7.git5cde554
222- New git snapshot
223
224* Fri Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-6.git8c3a01e
225- Fix devel dependency
226
227* Fri Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-5.git8c3a01e
228- Fix gnutls check for new rawhide version
229
230* Fri Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-4.git8c3a01e
231- Rebuild for pkgconfig
232
233* Tue Dec 2 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-3.git8c3a01e
234- Fix git file generation
235
236* Mon Dec 1 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-2.git8c3a01e
237- Updates for package review
238
239* Sat Nov 29 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-1
240- Initial package
Note: See TracBrowser for help on using the repository browser.